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Non-Inverting Amplifier Example

Obijective: Build a non-inverting amplifier using Cadence with a gain of 5 V/V.

Ay =142 R2=4kQ
R, R1=1kQ
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Setup Cadence Environment

‘You must do this before running Cadence, and you only need to do this once.

1. Loginto a CAEN Linux machine in one of the CAEN labs. To connect remotely from a Windows computer or personal
computer, login remotely to login.engin.umich.edu.

2. Authenticate using gettokens and your Kerberos password. Create a link from your home directory to your EECS 311 AFS
space. Replace <unigname> with your UMICH unigname. If your directory does not exist, contact the course staff.

>> gettokens
>>cd ~
>> |n -s /afs/umich.edu/class/eecs311/f09/students/<unigname> eecs311

3. All your Cadence files should be saved on the afs file server. You can easily access this space from your home directory
using the link you just created.

>> cd ~/eecs311
4. Copy all of the the setup files to your afs space.

>> cp /afs/umich.edu/class/eecs311/f09/cadence/setup_working_dir/* ~/eecs311
>> cp /afs/umich.edu/class/eecs311/f09/cadence/setup_working_dir/.* ~/eecs311

5. For those who have used Cadence in a class before, check your home directory for the following 2 files: ~/.cdsinit and
~/.cdsenv. If they exist, rename them to ~/.cdsinit.tmp and ~/.cdsenv.tmp. Also remove any Cadence-related modifications
you made to your ~/.cshrc file. The default .cshrc file can be found at /usr/caen/skel/std.cshrc.

Note: if you created these files for a class you are currently taking, you will have to undo these operations before launching
Cadence for this other class.
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Launch Cadence and Create a Library

o

1. Logintoa CAEN Linux machine in one of the CAEN labs. To connect remotely from a Windows
computer or personal computer, login remotely to login.engin.umich.edu.

2. Launch Cadence from your afs directory. The Command Interface Window (CIW) will pop up.

>> cd ~/eecs311
>> gettokens
>> icfb &

3. Next launch the library manager to create a new library by selecting Tools > Library Manager... from the
CIw.

cfb - Log: /afs/umich.edu/user/w/e/wentzlof/CDS.log

File Tools | Oplions
ILo=d1 Conversion Tool Box... =)

I Verilog Integration
moust YHDL Tool Box... i E
> Synopsys Integration...
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Launch Cadence and Create a Library

4. The EECS311Lib and EECS311Examples libraries should appear in the Library Manager. Select File >
New > Library... from the Library Manager to create a new library.

rary Manager: Directory .../eecs311/f08/students/wentzlof

File Edit View Design Manager

!NBW ls | Library

Sy " Cul i | ca View
Opss {Read- Oty 7y Crtetry...

Load Defaulls...

Save Defaults...
Open Shell Window  “p

Exit “x
(fonctional
rfExamples

cfLib

Log file is "/afa/unich. edu/class/escadll/£08/students /ventzlof /libManager . log”

[
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Launch Cadence and Create a Library

5. Enter tutorial for the Library Name and click OK.

-, New Library =

Lmrary 6. Select Don't need a techfile and click OK.
Hame tutoeial]

[rectary

Tachnology Fila for Bbrary “tutorial®

1T yomt will I reating ik, ol or
other physical data in this library, you
will e o bechnology fie. If you phen
10 e anly Schematic or HOL data, a

FeecsI11/E00/students Arentrlaf]

technalogy fila ks not required.
D Managger
_JUse HONE You can: - Compibe a mew lechiie
] - Altach 1o an existing techiie
_JUse Ha DM Sttt

OK | fpply| Comcell  Melp

7. The library tutorial will now appear in the Library
Manager
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Create a New Schematic

8. Click on the tutorial library in the Library Manager to select it, then go to File > New > Cell View...

brary Manager: Directory .../eecs311/f08/students/wentzlof

File | Edit  View Design Manager Help
sl Library... |

e 4 [Cell Miewr... | con e

Opess {Read- Oy 7y Category... =

Load Defaulis... [ L |

Save Defaults...

Open Shell Window  “p
Exit ~x
[functional )

|rfExamples

cfLib
|tutorial

Messages

ddCreateLib: Creating a new cds. 1ib file at ' /afs/umich edu/class/eecs31l/f08/students /wen
| Created new library "tutorial" at /afs/umich.edu/class/eecs31l/£08/students /wentzlof /tutori
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Create a New Schematic

9. Enter NonInvertOpAmp for the Cell Name, and choose Composer-Schematic for the Tool. The View
Name will automatically default to schematic. Click OK.

OF | Concel Detasits Holp
Ly Heams st

ol Harme: HmInvertipig
e e

- s Sofm
Library b I

VAT aben o il sl frabe 130

10. The new schematic will open up. To add a part to the schematic, go to Add > Instance... or by hitting the
“i” key.

rtuoso® Schematic Edit utorial sourcefollower schematic
Cmd: Sel: 0

Tools Design Window Edit Add Check Sheet Options Migrate
[ Instance...

B’ Wire (narrow)
| Wire (wide)
@ Wire Hame...
.2 | Pin...
& Block...

It

Net Expression...
Solder Dot

Note

Patchcord...

0]
Y

ARl
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Add Components

11. To find a part, click Browse from the Add Instance dialog box.

Hide Cancel | Defmdls Help.

View | syboll

ey Rows | 1 Colmns | &
12. The Library Browser will pop up.
Select EECS311Lib, lab1l_opamp, symbol. Click Close.

Rotate Sideways Upside Down

ibrary Browser - Add Imtance

¥ Show Catpgorins
Category il View

[Labl_opanp Toakal
1ebd_spang syl

cdaDefTockLab

functional

#{Exmnples

=fLib

tutosial

Oose Filers... Help
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Add Components

13. Place the opamp on the schematic. You may exit commands by pressing the Esc key.

Virtuoso® Schematic Editing: tutorial 741invertingamp schematic
Cmd: Sal: 0

Tools Design Window Edit Add Check Sheet Options Migrate

A

DN[EEp

mouse L M: R:

s

&

>
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Add Components

14. Using the Add > Instance... command, add a 1kOhm and 4kOhm resistor (analogLib > res), a sine wave input (analogLib >
vsin), and ground symbols (analogLib > gnd). Place them as shown in the figure below. You may copy a component by
going to Edit > Copy or by hitting the “c” key.

15. To edit the properties of a component, go to Edit > Properties or select the component and hit the “q” key to bring up the
properties menu. To move components you may simply click and drag, hit the “m” key or hit Shift+'m” to break the
components connections and move it.

16. Use the Add > Wire Name... command to name the vin and vout, nets as shown below. You may auto-zoom the
schematic by going to Window > Fit or pressing the “f” key.
(m Virtuoso® Schamatic Editing: Titorial NoninvartOpAmp schamatic - Virtuoso® Analog Dasign Envirar = 0 %
et o H Fbes 1oty
Tnols Nasigs Windws [t Add (hark Shast Optines Migrsis
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Edit Properties

17. Edit the properties of the sine wave input to have an AC magnitude of 1 V, a DC voltage of 1 V, an
Amplitude with a variable value of “amp” and a variable Frequency of “f" as shown below. You need only
enter/change these values. Units will be added on automatically.

- [Eckt OBject Propertias
UK Concel Fpply Detaultz I'vevious Mt
APy 10 oty cament nstance
how 3ystem W uzer W C1
Brawsn | Keset nstnee §abels eply
Trogserty Vile Dizpiay
Ny Foamm | #elingt 2 ull
ol Bame ErT ant
W HEmE bl ot
Iestance Niame 7T ort
il Delntn Macify
User Mty Masler Vakee Ll Vikre Dispiary
hesiguner K 1 att
CUR Faraneier vatwe Drsptany
AC magaitige e ant
AL nasa E wit
DU voitage Ty ull
Offza:l wmilliag: 3 aff
Aumpilars: aap ¥ aff
Frequency £ 1 ot
Delay tma £ att
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Analog Environment
18. Finally, click the Check and Save button in the upper left corner of the schematic window. Next open the
Analog Environment by going to Tools > Analog Environment. The Analog Environment window will
appear.
Virtuoso® Analog Design Environment (3)
Status: Ready 15
Session Setup Analyses Variables Outputs Simulation Results Tools Help
Design Analyses v—%
Library Tutorial #  Type Arguments Enable =
Cell NonInwer tOpimp 1 e & yes :B‘D ’
View  schematic I T I
Design Variahles Outputs [Ej
#  Name Value #  Nams/Signal/Expr Walue Plot Save March y
Plotting mode : Replace I&
MichiganEngineering
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Environment Variables

19. Load any variable names from the schematic by selecting Variables > Copy From Cellview.

20. Select Variables > Edit ... to edit the variable values or double click on them in the environment window.
Give the freq variable a value of 1k (Hz) and the amp variable a value of 1 (Vpk).

Editing Design Variables -- Virtuoso® Analog Desi
OK | Cancel Apply | Apply & Run Simulation Help
Selected Variable Tahle of Design Variables

Name £ #  Name value

2 amp 1

Add | Delete  Change  Hext| Clear| Find

Cellview Variables Copy From | Copy To
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Select Analyses

21. Go to Analyses > Choose... or click the Choose analysis button on the righthand side of the Analog
Environment Window. Select dc as the Analysis type, select Save DC Operating Point, and ensure that
enabled is selected at the bottom.

= Choosing Analyses -- Virtuoso® Analog De

OK | Cancel| Defaults| Apply Hep
Analysis ran  @dc ac noise
=f - sens dematch sth
hz sp ENVIp - pss
pac pnoise o prf ~ psp
- apss ~gpac apnoise - gpxf
apsp
DC Analysis

Save DC Operating Foint | |

Sweep Variable
Temperature
Design Variable
Component Parameter
Model Parameter

Enabled H Options...
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Select Analyses

22. Select ac as the Analysis type. Select the sweep variable as Frequency and sweep over a range from
1Hz to 20kHz. Select the sweep type as logarithmic over 100 points or so. Ensure that enabled is
selected at the bottom.

B Choouing Anslysss - Virtuoao® Analog Dws = 5 8

0% Cuncel| Duefimils| Ay L]
Fanttysts i L3 o s
u sens . domalch st
] o e 123
e ponisE =3
L L oo el
L=
A Fnalysis
Awerp Varabie
# Froguoncy
Design Varkai:
Trmparstura

Comgarnd [l
ot e

Enaica W Ot
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Select Analyses

23. Select tran as the Analysis type. Set the stop time to be 5m (s) and ensure that enabled is selected at
the bottom. Hit OK.

Choosing Analyse: Virtuoso® Analog D

OK | Cancel Defaults| Apply Help|
Analysis @ tran de - ac hoise
-xf Sens dcmatch . -sth
73 sp envip PSS
pac phoise - pxf ~psp
opss .~ gpac gpnoise qpxT
- apsp
Transient Analy sis

Accuracy Defaults (errpreset)
conservative moderate liberal

Enabled W Options...

P y | MichiganEngineering

Simulation

24. Select Simulation > Netlist and Run or the Netlist and Run icon on the righthand side of the Environment
window to run a all 3 simulations.

Virtuoso ® Analog Design Environment (3)
Status: Ready

Session Setup Analyses Varables Outputs Simulation Results Tools Help
Design Analyses "{{
# a e Enzhl
Library Tutorial e S nete e
.
Cell  NonDnwertopamp ||t 4C t yes
2 ac 1 20K 100  Loga.. yes 1]
View  schematic 3 tran 0 sn yes 1:]
Design Variables Outputs [Ej
#  Name Value # Name/Signal/Expc valuz Plot Sawe March f Netlist and Run
1t /
2 amp

Plotting mode: Replace
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Viewing Results

25. To see the DC voltage and current levels within the circuit, go to Results > Annotate > DC Node Voltages
and Results > Annotate > DC Operating Points.

W Virtuozo® Schematic Editing: Tutarial Noniny ertOpAmp schematic — Virtuoso® Analog Design Enviros = O
ez el: U tatus: Heady

Tooks Deshn Window Edit Add Check 3heel Optiens Higrate

As expected, the op-amp shows roughly equal DC voltage at its terminals with no DC current
going to either one. From the non-inverting architecture we also see that we obtain a gain of
roughly Av = 5 V/V which is expected from the aforementioned equation.

Py MichiganEngineering

Viewing Results

26. Select Results > Direct Plot > AC dB20 to view the small signal frequency response of the amplifier.
Next select the “vout” wire in the schematic window and press “Esc”. The following window should

appear.
m  utonal NominvartDpAmp cchematic : Sap 8 18567 200825 _ 8 K
Flle Edlt Frame Craph A«s Trame Marker Zoom Towiz Weip
S @ FEE S -= B BRESE =1 et
AL Tieg e "
— Vet
5.3

458550

RREEEES
’51 a9,

4 ]

REEERS

48357 “anp " P— e

10! wo# 1wl 0*
T ooy )
@ >

Here again we see that the non-inverting amp is giving us a gain of about Av = 5. Since this

is not an ideal op-amp we can see it starting to cut-off at higher frequencies. If you run a
wider frequency simulation, you will see where the amplifier cuts off.

10
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Viewing Results

27. Finally, select Results > Direct Plot > Transient Signal and select both “vout” and “vin” in the schematic
window and press “Esc”. This allows us to view the input as a function of time. The following window
should appear.

‘W Tutarial NoninvartOpAmp schamatle : Sap B LB!10:57 2000 37
Tl vih TR Cuaph AR ioae Ve fom Yo el
CFEFHSLGEE ST o E M o Label
el s 7
WICpawry  ICpa
1y
100
75 f
£cq { { i
s ! !
- - o o o=
ol 39 1L 29 L L
= T T T r
1 M H 1 5
| s.2mms|  1m0wv L
#a

Once again we see that the output of the amplifier exhibits a 5 V/V gain.
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Viewing Results

28. You may look at the input and output on separate graphs in the same window by selecting Axis > Strips
as shown below.

‘- Tutorial NoninvertOpAmp schematic : Sep 8 18:19:57 2009 27

File Edit Frame CGraph Awvis Trace Marker 7oom Tools Help

SrHElHEEE FOENORESE e

Transient Response .
12.54YT( fwout’) L

1603~ i = /
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e
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