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S&K Demo: Non-Inverting Amplifier

e Build a non-inverting amplifier in Cadence with a gain of 2 V/V
e Used the circuit in Fig. 1 in the S&K paper
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Setting-Up the Cadence Environment

You must do this setup before running Cadence for the first time, but only once.

1. Login to a Linux machine in one of the CAEN labs. To connect remotely from a
Windows computer or personal computer, login remotely to
login.engin.umich.edu.

2. Go to your home directory, then create a link from your home directory to your

class AFS space. Replace <unigname> with your UMICH unigname
>> cd ~
>> In -s /afs/umich.edu/class/eecs311/f10/students/<unigname> eecs311

3. Usevyour link to get to your class space on the AFS file server anytime
>> cd ~/eecs311

4. Copy all of the Cadence setup files to your AFS space
>> cp /afs/umich.edu/class/eecs311/f10/cadence/setup working dir/* ~/eecs311l
>> cp /afs/umich.edu/class/eecs311/f10/cadence/setup working dir/.* ~/eecs3ll
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Setting-Up the Cadence Environment

Aside: For those who have used Cadence in a class before, check your home directory
for the following two files:
~/.cdsinit

~/.cdsenv
If they exist, you may need to rename them to ~/.cdsinit.tmp and ~/.cdsenv.tmp
and remove any Cadence-related modifications you made to your ~/.cshrc file.

The default .cshrc file can be found at /usr/caen/skel/std.cshrc. It will need to be

renamed to .cshrc.
Note: If you created these files for a class you are currently taking, you will have to

undo these operations before launching Cadence for this other class.
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Launching Cadence & Creating a Library

Login to a Linux machine in one of the CAEN labs. To connect remotely from a

Windows computer or personal computer, login remotely to
login.engin.umich.edu.

Launch Cadence from your AFS directory. The Command Interface Window (CIW)

will pop up.
>> cd ~/eecs311
>> jicfb &

Launch the Library Manager by selecting Tools > Library Manager...

24 icfb - Log: /afs/umich.edu/user/w/e/wentzlof/CDS.log

File Tools | Options

L.oadi Conversion Tool Box...
e Lih Manager
R B Al LU

ILoadi Library Path Editor...
Loadi

— ¥PCHM
I Verilog Integration [
movse YHDL Tool Box... M: R:

2 Synopsys Integration...

Help 1
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Launching Cadence & Creating a Library

The EECS311Lib and EECS311Examples libraries should appear in the Library Manager.
4. Select File > New > Library... from the Library Manager to create a new library

_ EIE' Edit View Design Manager Help
ey | |
.. " Cott View .. | L
Gpens {Bead- Oy Y carenaey | il
! Load Defaulis... !

Save Defaults...

Open Shell Window  “p
Exit g
[functional '
| cfExamples

\cfLih

Messages
|Log file is "/afs/umich. edu/class/eecs311/E08 students wentzlof /libManager. log"
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Launching Cadence & Creating a Library

5. Enter tutorial for the Library Name 6. Select “Don't need a techfile” and
and click OK click OK

& New Library 24 Technology File for New Li... [= |[B]X]
iy oK | Can[:el.'l ;Helpj
Name . tutorial] . Technology File for library "tutorial”
Directory If you \_l.ri.ll he creating I'-I;Iask layout or

other physical data in this library, you
will need a technology file. If you plan
to use only schematic or HDL data, a
technology file is not required.

You can: . - Compile a new techfile
.~ Attach to an existing techfile

- feecs3ll/f08/students fwentzlof 4 Don't need a techfile

— Design Manager
) isn HOHE 7

The library tutorial should now
appear in the Library Manager.

L) iame Mo D

spply | Cancell  Help |
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Creating a New Schematic

8. Click on the tutorial library in the Library Manager to select it, then go to
File > New > Cell View...

B Library Manager: Directory .../eecs3 11/f08/students/wentzlof

IElE Edit View Design Manager Help
|New e Library...

Gyt 4 i Cell View... | cop [ View

dpm {Read-OElY: Y category...

Load Defaults... Il
Save Defaults...

Open Shell Window  “p

Exit
[Fonctional
|cfExamples
rfLib
|tutorial

2

— Messages

ddCreateLikh: Creating a new cds. lib file at ! fafs/mdich. edu/classfeecsd11£08students fwen =
[Lreated new library "tutorial® at /afs/umich. edu/class/feecs311/f08/students /wentzlof /tutori -J
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Creating a New Schematic

9. Type amplifier for the Cell Name, and  10. The new schematic will open. To add
choose Composer-Schematic for the a part to the schematic, go to
Tool. The View Name will default to Add > Instance... or by hit the ‘i’ key.
schematic, then click OK.

i . = s | L e .
X Create New File = 4% Virtuoso® Schematic Editing: tutorial sourcefollower schematic
oK Cancel | Defaults Help Cmid: Sel: 0

; tutorial Tools Design Window Edit Add | Check Sheet Options Migrate

Library Mame
anplified

Cell Hame Wire (n w)

View Hame | 3chematic Bl wire (wide)

o Composer-Schematic ; Wire Mame...

Library path file 3 _— R Fii...

10/students /kbrovn/cadence /ods. 1ik h . B Biock...

Het Expression...
Solder Dot

Hote

Patchcord...
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Adding Components

11. To find a part, click Browse from the 12. The Library Browser will pop up.
Add Instance dialog box Select EECS311Lib > labl_opamp >
symbol, then click Close.

274 Add Instance

%% Library Browser - Add Instance

| |
Hide | Cancel |Defaults‘ Help|

¥ Show Categories

- — bbrary —————— Category — Cell View
LRIy II |  Browse EECS3 1Lk Tabl opanp ||
Cell o EECS311Lib 1abl opamp symbol

7 Us_8ths
View | symbol; shdlLih

analogLib
hasic
cdsDefTechLihb
functional
rfExamples

: - ] rfLihb

Rotate | Sideways | Upside Down il tutorial

Hames |
i

[

Array Rows |l Columns |1

Close Filters... Help
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Adding Components

13. Place the lab1l_opamp on the schematic
14. Exit the current command by pressing the ‘Esc’ key

Cmd: 3el: 0 z

Tools Design Window Edit Add Check Sheet Options Migrate
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Adding Components

15. Add the remaining instances using Add > Instance...
Resistors (analoglib > res)
Capacitors (analogLib > cap)
Pulse generator (analogLib > vpulse)
Ground connections (analogLib > gnd)
16. Connect instances as shown in the figure on the next slide.
17. Go to Add > Wire Name... to name the Vin and Vout nets
Aside: To copy an instance, go to Edit > Copy or by hit the ‘c’ key.
Aside: To rotate an instance, go to Edit > Rotate or by hit the r’ key.

Aside: To edit the properties of an instance, select the component and either go to
Edit > Properties or press the ‘q’ key.

Aside: To move an instance, click and drag the component, press the ‘m’ key, or press
shift+'m’ to break wire connections then move it.

Aside: To auto-zoom the schematic, go to Window > Fit or press the ‘f’ key.
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Adding Components

Below is the final circuit schematic.

Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 2

r}( Virtuoso® Schematic Editing: tutorial amplifier schematic -- Virtuoso® Analog De

Tools Design Window Edit Add Check Sheet Options Migrate Help
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Editing Properties

18. Edit the properties of the pulse input to have the following properties:

AC magnitude=1V
DCvoltage=1V
Voltage 1=0V
Voltage 2 = Ampl V

Delay time = 100u s
Rise time =1ns
Falltime=1ns
Pulse width =2ms
Period =4m s

Aside: ‘Voltage 2’ is used for transient
simulations. By giving it a variable

name, it can be swept/changed later.

Note: Units are added automatically.

X Edit Object Propertie

OK | Cancel | Apply | Defaults| Previous | Next

Apply To only current instance
Show system |l user ll CDF
Browse Reset Instance Labels Display
Property Value

Library Hame | analoglLil

Cell Name vpulse
View Name symbol]

Instance Hame |V

Add Delete
User Property Master Value
Ivslgnore TRUE
CDF Parameter Value
AC magnitude 1%
AC phase
DC voltage 1%
Yoltage 1 0¥
Yoltage 2 anpl ¥
Delay time 1000 &
Rise time 1n =
Fall time In g
Pulse width an g,

Petiod dn =

Modify
Local Value

Display
off
off
off

off

Display
off

Display
off
off
off
off
off
off
off
off

off

off
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Setting Analog Environment

19. Click the ‘Check and Save’ button in the upper left corner of the schematic
window to save the schematic design

20. Go to Tools > Analog Environment to setup simulations

Status: Ready T=27 C Simulator: spectre 4

Session Setup Analyses Varables Outputs Simulation Results Tools Help

Design Analyses

Library tutorial

Cell amplifier 1 de £ yes

Yiews schematic

Design Variahles

#  Hame Value #  Name/Signal/Expr Value  Plot Sawe March

Plotting mode:  Replace . | |
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Setting Design Variables

21. Load variable names from the schematic by selecting Variables > Copy From

Cellview
22. Select Variables > Edit ... to edit the variable values or double-click on them in the

environment window.
23. Give the Ampl variable a value of 1 (Vpk)

"X Editing Design Variables - Vir
Ok | Cancel| Apply | Apply & Run Simulation Help

Selected Variahle Table of Design Variables

ampl #  Hame Yalue

Hame

Value (Expr) |1

Add | Delete | Change | Mext| Clear| Find

Cellview Variables Copy From | Copy To
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Setting Analyses

24. Go to Analyses > Choose... or click the “Choose analysis” button on the right-hand
side of the Analog Environment Window

25. Select dc as the Analysis type, then select “Save DC Operating Point” and ensure
that ‘Enabled’ is selected at the bottom

|'-- Choosing Analyses -- Virtuoso® Analog Des/— |0 X |

0K | Cancel | Defaults | Apply Help
Analysis tran # dc ac noise

=T Sens decmatch sth

pz sp envip pss

pac pnoise pxf psp

gqpss gpac gpnoise gp=f

qpsp

DC Analysis

Save DC Operating Point |

Sweep Variable

Temperature

Design Variable
Component Parameter
Model Parameter

Enabled H Options...
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Setting Analyses

26. Select ac as the Analysis type. Set the Sweep Variable to ‘Frequency’ and sweep
over a range from 1 Hz to 10k Hz. Set the Sweep Type to ‘Logarithmic’ with 100
Points Per Decade. Ensure that ‘Enabled’ is selected at the bottom.

0K | Cancel | Defaulls | Apply Help
Analysis tran dc & ac noise
#f Sens dematch sth
pz sp envip pss
pac psth pnoise pxf
psp gpss gpac gphoise
opxf qpsp
AC Analysis
Sweep Variable
4 Frequency

Design Variable
Temperaiure
Component Parameter
Model Parameter

Sweep Range

4 Start-Stop

start |1 swp 100
Center-Span
Sweep Type
P Typ # Points Per Decade 7
Logarithmic Humber of Steps

Add Specific Points

Specialized Analyses

Hone

Enabled W Options...
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Setting Analyses

27. Select tran as the Analysis type. Set the stop time to be 2m s and ensure that
‘Enabled’ is selected at the bottom

"X Choosing Analyses — Vir

0K | Cancel| Defaults| .prly|

Analysis 4 tran - dc .- ac -~ hoise
- X -~ 3ens - dcmatch - -sth
- Pz - Sp -~ envip B
-~ pac -~ hsth -~ pnoise . prf
- hsp - Opss -~ fpac -~ (pnoise
o gpxf . qpsp

Transient Analysis

Accuracy Defaults (enpreset)
_ | conservative | moderate | liberal

| Transient Noise

Enabled W
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Running Simulations

28. Select Simulation > Netlist and Run or hit the “Netlist and Run” icon on the right-
hand side of the Environment window to run all 3 simulations

k'{ Virtuos=o® Analog Design Environment (

Status: Ready T=27 C Simulator: spectre 3

Session Setup Analyses Varahles Outputs Simulation Results Tools Help

Design Analyses

Library tutorial

Cell amplifier

View schematic

Design Variahles

#  Mame Value Name /Signal /Expr Value Plot Sawe March - Netlist and Run

1 ampl 1

Plotting mode:  Replace . | |
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View Results

29. To see the DC voltages and currents within the circuit, select Results > Annotate >
DC Node Voltages & Results > Annotate > DC Operating Points

" 2
5"( Virtuoso® Schematic Editing: tutorial amplifier schematic -- Virtuoso® Analog Design Emmﬂ S

Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 2
Tools Design Window Edit Add Check Sheet Options Migrate Help

<% [

D
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n
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&k Imouse L: schSingleSelectPt() F:sevinnotateResults (' sevSessionl '

% | > Select instances for the OP output...

M: schHiMousePopUp ()

The opamp has roughly equal DC voltage at its terminals with no DC current going into
either input. The opamp also has a gain of roughly Av = 2 V/V as expected.
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Viewing Results

30. To view the small signal response, select Results > Direct Plot > AC Magnitude,
then select the Vout wire in the schematic window and press ‘Esc’. (left figure)

31. Select Results > Direct Plot > AC dB20, then select the Vout wire in the schematic
window and press ‘Esc’. (right figure)
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Once again, the opamp has a gain of roughly Av = 2 V/V as expected. Because it is non-
ideal, the opamp has a finite frequency response.
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Viewing Results

32. To see the transient response, select Results > Direct Plot > Transient Signal and
select both Vin and Vout in the schematic window and press ‘Esc’. (left figure)

33. Go to Zoom > X-Zoom or press ‘x’ to zoom-in the plot. (right figure)

File Edit Frame Graph Axis Trace Marker Zoom Tools Help
Gr#El FEED # D X4t v ]
Transient Response m
— WTNINY — VT ot
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2.0 P R R
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=
o 1.0 i
= |
e
]
(o
-5 T T T
4] 500 1o 1.5 2.0
100us| 384.36mV A ()
@ > graphl selected: double-click to bring up attribute dialog.

N tutorial amplifier schematic : Sep 19 15:29:59 2010
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Once again, the opamp has a gain of roughly Av = 2 V/V after the step response. By
zooming-in, we see that the delay is 135us, which matches the result from the class
demo.
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S&K Demo: Non-Inverting Amplifier v2

e Build a non-inverting amplifier in Cadence with a gain of 2 V/V
e Used the circuit in Fig. 1 in the S&K paper

— Used different resistors

5”{ Virtuoso® Schematic Editing: tutorial amplifier schematic - Virtuoso® Analog Design Emmﬂﬂz_

Cmd: Sel: 0 Status: Ready T=27 C Simulator: spectre 2

Tools Design Window Edit Add Check Sheet Options Migrate Help

mouse L: schSingleSelectPt() M: schHiMousePoplp() R:sevAnnotateResults('sevSessionl
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Viewing Results v2

34. To see the transient response, select Results > Direct Plot > Transient Signal and
select both Vin and Vout in the schematic window and press ‘Esc’.

tutorial amplifier schematic :

File Edit Frame Graph Axis Trace Marker Zoom Tools Help
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Once again, the opamp has a gain of roughly Av = 2 V/V after the step response, but
now we have oscillations like seen in the class demo.
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Saving Analog Environment Setup

35. In the Analog Environment window, go to Session > Save State .... Choose
‘Cellview’ for the Save State Option, then type a filename for the State.

Saving State -- Virtuoso® Analog Design Environment (1)
OK | Cancel| Apply Help

Save State Option Directory 4 Cellview

Shpciory Opbiong
Hists Save Dinolary Browese...
Save A

Exising Siates

Cellview Options

Library tutorial
Cell amplifieq Browse...
State spectre_statel
Description
Hone
What to Save
Select All Clear All
H Analyses M Variables M Outputs
H Model Setup M Simulation Files M Environment Options
M Simulator Options H Convergence Setup M Waveform Setup
M Graphical Stimuli M Conditions Setup M Results Display Setup

M Device Checking Setup M Cosimulation Options M Distributed Processing
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Saving Results

There are at least 3 ways to save your plots:

1.

2.

3.

Hit the ‘Print Screen’ key. In Linux, a window should pop-up that allows you
to save the entire screen.

In the plot window, go to File > Save as Image..., hit the ‘Browse...” button,
define the file name and path, click ‘Ok’, and click ‘Ok’ again. This will save
the plot as an image.

In the plot window, select each trace, then go to Tools > Table..., select
‘Value’, and click ‘Ok’. You should see a speadsheet window open with data.
To save the data points, go to File > Save as CSV..., define the file name and
path, and click ‘Save’. This will save the data, so that you can generate a
clean plot in Matlab.
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Using the Linux Terminal

e For those new to Linux, there are many commands to learn within the
terminal, which can make your life easier. Below are just a few.

>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>

cd

<any command> --help
<any command> ~/...
<any command> ./...
<any command> &

Is -a

ps —u <unignhame>
kill <process ID>

In -s

cp

mkdir

rm

rmdir

mv

gedit <filename> &

ps2pdf

%
%
%

% .

%
%
%
%
%
%
%
%
%
%
%
%

change directory

brings up help info on <any command>

~ starts a path from your home directory
starts a path from your current directory
& launches a process iIn the background

list all files & folders iIn a directory
lists yours processes & process IDs

kills a process (like Cadence 1f 1t freezes)
create a symbolic link

copy

make directory

remove files

remove directory

move or rename files or directory

opens a very Windows-like text editor
converts a postscript file to a pdf

e You can search the web and find more commands pretty easily

— ss64.com/bash/ has a pretty good list
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