EECS 452 Digital Signal Processing Design Laboratory Fall 2008

Xilinx ISE WebPACK Tutorial for VHDL Design on
Spartan-3 FPGA

The purpose of this tutorial is to guide you through the steps of creating a project
using Xilinx ISE WebPACK. It serves as a very simple way to get you start using
the tool. Details are not mentioned. You should read ISE 10.1 Quick Start Tutorial,
which can be downloaded from Xilinx website, for complete instructions and informa-
tion. The latest version of the Xilinx FPGA design solutions software is called ISE
Design Suite 10.1. ISE WebPACK is one of the Design Suite softwares and the latest
update is service pack 2. It is free and you can download a copy from the Xilinx
website. You need to register an account at the Xilinx website in order to download
the software.

Unlike Code Composer Studio, ISE does not require a hardware to run the soft-
ware. You can design and program your project and build up the programming file
that can be loaded to FPGA without having the hardware at hand. That means you
can work on your project with this software anywhere. You can compile your codes
and simulate the circuits in ISE. Once the programming file is generated, all you have
to do is to bring the whole project or programming file to the lab and loaded to the
hardware to see if it actually works. The FPGA chips supported by ISE WebPACK
and the full version are listed in Figure [
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Platforms
Virtex Series
Devices (FPGAs)
Spartan Series
CoolRunner™ XPLA3
. CoolRunner-II
D CPLD:
evices ( s) CoolRunner-llA
XC9500 Series

ISE WebPACK

Microsoft® Windows® XP Professional (32-bit)
Microsoft Vista Business (32-bit)

Red Hat Enterprise Linux 4 WS (32-bit)

Red hat Enterprise Linux Enterprise 5 (32-bit)
SUSE Linux Enterprise 10 (32 bit)

Virtex: XCV50 - XCV600
Virtex-E: XCV50E - XCV600E
Virtex-1I: XC2V40 - XC2V500
Virtex-1l Pro: XC2VP2 - XC2VP30
Virtex-4:
LX: XC4VLX15, XC4VLX25
SX: XCAVSX25
FX: XC4VFX12
Virtex-5:
LX: XC5VLX30, XC5VLX50
LXT: XC5VLX30T, XC5VLX50T
FXT: XC5VFX30T
Virtex Q: XQV100- XQV600
Virtex QR: XQVR300, XQVR600
Virtex-E Q: XQV600E

Spartan-II/IE: All

Spartan-3: XC3550 - XC351500
Spartan-3A: All

Spartan-3AN: All

Spartan-3A DSP: XC3SD1800A
Spartan-3E: All

Spartan-3L: XC351000L, XC351500L
XA (Xilinx Automotive) Spartan-3: All

All

ISE Foundation

Microsoft Windows XP Professional (32/64-bit)
Microsoft Vista Business (32/64-bit)

Red Hat Enterprise Linux 4 WS (32/64-bit)

Red Hat Enterprise Linux Desktop 5 (32/64-bit)
SUSE Linux Enterprise 10 (32 and 64 bit))

Virtex: All
Virtex-E: All
Virtex-1l/Pro: All
Virtex-4:

LX: All

SX: All

FX: All
Virtex-5:

LX: All

LXT: All

FXT: All
Virtex Q/QR: All
Virtex-E Q: All

Spartan-1I/IIE: All

Spartan-3: All

Spartan-3A: All

Spartan-3AN: All

Spartan-3A DSP: All

Spartan-3E: All

Spartan-3L: All

XA (Xilinx Automotive) Spartan-3: All

Figure 1: ISE features (from Xilinx ISE Product Brief).
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Start Xilinx ISE 10.1 by clicking the icon on the desktop. The following window
will show up (Figure [2]).

Fie Edt View Project Source Process Window Help

;aDBEﬂ\&mr@@xmmzz@ﬁxxp@\z;%s ull=FP T | R T
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Figure 2: ISE WebPACK starting window.

From the File menu, select New Project. The New Project Wizard window will show
up as shown in Figure [3
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EZ New Project Wizard - Create New Project

Enter a name and location for the project
Project location

Project name:
‘ [C:\Documents and Seﬁings\GSl\W Documents'\eecs

(-]

Select the type of topJevel source for the project
Top-evel source type:
HDL

Bk || Net>

Figure 3: New Project Wizard window.

In the Create New Project window, choose a Project Name and click Next.

ISE WebPACK Tutorial 4 September 19, 2008



EECS 452 Digital Signal Processing Design Laboratory Fall 2008

Then we need to specify the Device Properties. Follow the settings as shown below
in Figure @ The FPGA chip we use on the starter board is the Xilinx Spartan-3
FPGA XC351000. This chip has 1000K system gates with FT256 package (173 User
I/O). The speed is set to be —4. When you are done with the setting, click Next.

ES New Project Wizard - Device Properties

Select the device and design flow for the project

Property Name ‘ Value

Product Category Al v
Family Spartan3 v
Device XC351000 v
Package FT256 v
Speed -4 v
Top-Level Source Type HDL

Synthesis Tool XST (VHDL/Verilog) v
Simulator ISE Simulator (VHDL/Verilog) v
Preferred Language VHDL v
Enable Enhanced Design Summary

Enable Message Filtering O

Display Incremental Messages O

Figure 4: Set device properties.
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Next, we need to create a new source for the project. In the Create New Source
window as shown in Figure [ click on New Source.

EZ New Project Wizard - Create New Source @

Create a new source

Source File Type

1 Remove

Creating a new source to add to the project is optional. Only one new source can be created with the New Project Wizard.
Addtional sources can be created and added to the project by using the "Project->New Source" command.

Existing sources can be added on the next page.

[ <Bak |[ Net> | [ cancel |

Figure 5: Create new source window.
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Then the Select Source Type window will show up as in Figure Choose the

VHDL Module from the list and fill out the File Name. Check ”Add to project” and
click Next.

E= New Source Wizard - Select Source Type @

é IP (CORE Generator & Architecture Wizard)

Schematic

File name:
'SSD _test |
Location:

P | VHDL Package

% VHDL Test Bench [C:\Documents and Settings\GSI\My Documents\eec! Q
Add to project

ok |[ et ] [ Coes

Figure 6: Select source type.
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Then you need to define the 1/0 signals in the VHDL module you just created
in the Define Module window as shown in Figure [l Fill out the Port Name, Direction
(in, out, or inout), and specify the number of bits (Bus, MSB, LSB) and click Next.

E New Source Wizard - Define Module

Entity name [SSD_test I
Architecture name [Behavioral ‘
Port Name Direction Bus  MSB LSB o
mclk in v[]
an in v 3 0
ssg out v 7 0
[ in v
in v D
in v [:]
in v
in v |:] ]
in v D
in v 7
[ <Back |[ Net> | [ Cancel

Figure 7: Define module window.
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When you are done, check out the Summary as shown in Figure [§ and click Finish.
You should see the source file you just created in the file list as in Figure @ Click

Next.

E= New Source Wizard - Summary @

Project Navigator will create a new skeleton source with the following specffications:

Add to Project: Yes

Source Directory: C:\Documents and Settings\GSI\My Documents\eecs452\452F08\Lecture 8 (0S_15_08)\VHDL
example\SSD_test

Source Type: VHDL Module

Source Name: SSD_test.vhd

Entity name: SSD_test
Architecture name: Behavioral

Port Definttions:
mck Pin in
an Bus: 3.0 in
ssg Bus: 70 out

[ <Back

I

Finish

] [ Cancel

ISE WebPACK Tutorial

Figure 8: New source file summary.
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EE New Project Wizard - Create New Source

Create a new source

New Source...

Source File Type

s s Lo

Creating a new source to add to the project is optional. Only one new source can be created with the New Project Wizard.
Addtional sources can be created and added to the project by using the "Project->New Source" command.

Existing sources can be added on the next page.

[ <Back ][ Net> | [ Cancel |

Figure 9: New source file list.
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In the following window, you can add existing source files to the project as seen
in Figure [0l Once you are done, click Next.

EZ New Project Wizard - Add Existing Sources

Add existing sources

Source File Copy to Project Add Source

Remove

Adding existing sources is optional. Additional sources can be added after the project is created using the "Project->Add
Source" or "Project->Add Copy of Source" commands.

[ < Back ]I Next > ][ Cancel ]

Figure 10: Add existing sources.
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Once all the files are created/added, check the Project Summary as shown in Figure
[ and click Finish. When all the above steps are done, you will see the main ISE
window as shown in Figure

ES New Project Wizard - Project Summary

Project Navigator will create a new project with the following specffications:

Project:

Device:
Device:

Package:
Speed:

New Source:

Project Name: SSD_test
Project Path: C:\Documents and Settings\GSI\My Documents\eecs452\452
Top Level Source Type: HDL

Device Family: Spartan3

xc3s81000
ft256
-4

Synthesis Tool: XST (VHDL/Verilog)
Simulator: ISE Simulator (VHDL/Verilog)
Preferred Language: VHDL

Enhanced Design Summary: enabled

Message Filtering: disabled
Display Incremental Messages: disabled

VHDL Module 55D _test.vhd

[ <Back || Fnish

I [ Cancel ]

ISE WebPACK Tutorial

Figure 11: Project Summary.
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35 FPGA Design Summary &l SSD_test Project Status
Sources f Overw .
o i S e Project File: $5D_testise Curent State: [New
_te: mmary | Pt > |
= EAxc35100041256 [} 108 Propeties Bhork 45/ Nemme SSDiteat SlEaT |
()% SSD_test - Behavioral (SSD_test.vhd) [0) Module Leve! Utiiization | Target Device: xc3s1000-41256 + Wamings: [
[ Timing Constraints | Product Version SE 10.1.02- WebPACK * Routing Results: |
[ Pinout Report Design Goal Balanced « Timing Constraints: |
[ Clock Report [Design Strategy: Xiiro Default (urlocked) + Final Timing Score: |
= Emors and Wamings 5 e ]
[ Synthesis Messages
[ Trenslation Messages ‘ - __ SSD.test Partition Summary [ 5]
D) Map Messages | No partition information was found.
[Q) Place and Route Messages
[ Timing Messages | Detailed Reports [ 2]
[ Bitgen Messages Report Name Status Generated Errors ‘Wamings Infos.
[2) Al Curent Messages | Synthesis Report [
3 Sources | [y Fies | gg Snapshots | () Lbrares | @ D’““D""SR‘*;“’* . Transiation Repot |
yrihesis Repor
P () Translation Report ]| | Map Report [
Processes for: xc3s10004t256 Project Properties | Place and Route Report [
[ Add Exsting Source Enable Enhanced Design Summary | | | Static Timing Report T
O Creste New Source O Enable Message Fitering Bigen Repott i
% Design Uiities O Display Incremental Messages
Enhanced Design Summary Conterts P —
Show Partition Data =
O Show Emors
O Show Wamings
O Show Faiing Constraints
O Show Clock Report
Processes
“ [ SSD_testvhd | X Design Summary |
Started : "Launching ISE Text Editor to edit SSD_test.vhd".
Started : "Launching Design Summary”.
& i | 3
Console | @ Erors | o\ Wamings | @1 TelShell | igg Fndin Fies
[tnicolt

Figure 12: The ISE working environment.

Now we finished creating a new project. Next we can edit the source file using

the ISE build-in editor.
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The details of the design process and VHDL programming will be mentioned in
lecture and lab. Basically, you need to edit all the source files and define the constraints
file for the project. The code generated by ISE from the template when you create a
new source code in the earlier step is shown in the editor window as in Figure

W00 »dWwh e

-- Company:

-- Engineer:

-- Create Date: 19:11:35 09/16/2008
-—- Design Name:

-- Module Name: S5D_test - Behavioral

-- Project Name:
-- Target Devices:
-- Tool versions:
-- Description:

-- Dependencies:

-- Revision:
-- Revision 0.01 - File Created
—-- Additional Comments:

.STD_LOGIC_UNSIGNED.ALL;

-—--- Uncomment the following library declaration if instantiating

-—-- any Xilinx primitives in this code.
--library UNISIM;
—--use UNISIM.VComponents.all;

entity SSD_test is
Port ( mclk : in STD_LOGIC:
an : in STD _LOGIC_
ssg : out STD_LOGIC
end SSD_test;

OR (3 downto 0);

architecture Behavioral of SSD_test is

begin

end Behavioral;

Figure 13: A VHDL example code.
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CTOR (7 downto 0)):;
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When finish editing the source files, choose the main VHDL source file in the
Sources panel, and then you can click on Synthesize, Implement Design, and Gener-
ate Programming File, and Configure Target Device in the Processes panel as seen in
Figure [[4. Once you finish all the processes without any error, iMPACT will open
automatically.

Processes X

Processes for: SSD_top - Behavioral
[ Add Bdsting Source
[ Create New Source
¥,  View Design Summary
y Design Utilties
y User Constraints
€21\ Synthesize - XST
2@ Implement Design
€ 2@ Generate Programming File
€ 2@ Configure Target Device

@t Processes | Configuration Operations

Figure 14: Processes window.
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iMPACT is the tool used to load your design configuration from the ISE to the
hardware. The starting window is shown in Figure [[5l The easiest way to load the

EZ iMPACT - Welcome to iMPACT

Please select an action from the list below
(3 Configure devices using Boundary-Scan (JTAG)

[ Automatically connect to a cable and identify Boundary-Scan chain v

Prepare a PROM File
Prepare a System ACE File

(O Prepare a Boundary-Scan File

(O Configure devices

using Slave Serial mode

<Back || Finish | [ Cancel

Figure 15: iMPACT starting window.

design into the chip is using the JTAG interface. Leave the default setting in the

starting window and click Finish.

ISE WebPACK Tutorial 16
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Next, the “Assign New Configuration File” window will show up as in Figure [16
Choose the .bit file of your design and click Open.

1 File Edit View Project Source Process Operations Output Debug Window Help

CDEX

0P HE DINREX e QiIPAKX PR [N:BE DD:LR MG ViV iE@E MEAALLIQOO

e ¥ (@2 JO W
Sources x

‘35 Boundary Scan

29 SlaveSerial

29 SelectMAP

29 Desktop Corfiguration
3 Diect SPI Configuration
[2) systemaCE

[2) PROM File Fomnatter

Lookin: [-35452/452F08/Labs/Exercise3_development/SSD_test/ v| 4= [&] £ E

{3 Source!| [y Fles | g5 Srnaps| [P Lirarie | Cofiguraton 1

Processes x

File name: [ssd_top bt ] Open |
Fietype: | Al Design Files ("bit *1bt “nky “isc “bsd) | Cancel
® None
O Enable SPI Flash Device is FPGA
O Enable BP! Flash Device is FPGA |
B |

@' Processes | Corfiguration Operations

= Design Summary | @ Boundary Scan

PROGRESS_END - End Operation.
Elapsed time = 0 sec.
// *w* BATCH CMD : identifyMPM

<
2] Console

Transcript

i ]
| @Fron | i\ Wamings | @1 Tcishell | (g Findin Fles

Figure 16: Assign new configuration file to FPGA
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Then you will be asked to assign the new configuration file for the EPROM as
shown in Figure[I7 For now, since we are not using the EPROM, simply click Bypass.

[E= Xilinx - ISE - C:\Documents and Settings\GSI\My Documents\eecs452\452F 08\Labs\Exercise3_development\SSD_test\SSD_test.ise - [Boundary Scan]

% File Edit View Project Source Process Operations Output Debug Window Help

IDPEHF S IHREX e RiIPAKKPR|[ N BE DD RiNG iV iIEFE SCAXLH OO

igpX (O (@ &0 N

Sources

X

& 23 Boundary Scan
29 SlaveSerial
BB SelectMAP
"% Desktop Corfiguration
“S3Direct SPI Corfiguration
[2) SystemacE
[2) PROM File Formatter

Processes

ot S les_| g ] L oo 1|

X

xc3s1000 xcf0ds
ssd_top.bit —fie? —
TD0.

[ Assign New Configuration File

Lookin: [ 35452/452F08/Labs/Exercise3_development/SSD_test/ | 4= (2] e (B8 5

P

(=]
©_ngo
(2 xmsgs
(2)SSD _test_xdb
st
File name: | | [ oeen ]
Fietype: | Al Design Fies (“mes ~exo “isc “bsd) | Cancel
@® None
O Enable ing of SPI Flash Device is FPGA
O Enable ing of BPI Flash Device is FPGA |

B Processes | Corfiguration Operations

X Design Summary | 5 Boundary Scan

X | INFO:iMPACT:501 - '1': Added Device xc3s1000 successfully.

Transcript

@ ]
[£] Console | @FErors | i\ Wamings | 1Tl el | igg FindimFies

[[£3

3]

>

Configuration | Parallel IT | 200 KHz | LPT1

Figure 17: Assign new configuration file to EPROM

ISE WebPACK Tutorial

18

September 19, 2008



EECS 452

Digital Signal Processing Design Laboratory Fall 2008

Once you finish assigning the configuration file, you will see the following window
as shown in Figure Simply click Okay and continue without changing the setting.

= Device Programming Properties - Device 1 Programming Properties
Category

(= Boundary-Scan

Device 1 ( FPGA, xc3s1000)
Device 2 ( PROM, xcf04s )

Property Name

Verify

FPGA Device Specific Programming Properties
Pulse PROG

Value

O

l

0K

) Coes J o J [ ]

ISE WebPACK Tutorial

Figure 18: iMPACT window.
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Right-click on the chip (XC351000) and choose Program as shown in Figure [[9.

= Xilinx - ISE - C:\Documents and Settings\GSI\My Documents\eecs452\452F08\Labs\Exercise3_development\SSD_test\SSD_test.ise - [Boundary, Scan]

% File Edit View Project Source Process Operations Output Debug Window Help B X
DA ES LiXDEX D RQIPOPX PR (N:BE DD:FN MR Vi :FZE@ BEAAANL:QOO
i mie i @ &0 WN
29 SlaveSerial
B3 SelectMAP
88 Desitop Corfiguration iim! =
9 Direct SPI Corfiguration Program
[2) SystemacE # Get Device ID
[2)PROM File Fommatter ssd {  GetDevice Signature/Usercode
TDO.
Assign New Configuration File...
Set Programming Propertes. ..
Set Erase Properties...
Set Target Device
g Source] (s | g5 nope| ) e Cotipatn |
Pro
Avaiable Operations are:
= Program
= Get Device ID
=) Get Device Signature/Usercode
= Check ldcode
=) Read Status Register
Corfi [
B Erocseseel Corfiurotion Operstons | E Design Summary | @ Boundary Scan ‘
INFO:iMPACT:501 - '1': Added Device xc3s1000 successfully. A
5 g
& J &
Bl

] [£] Console | @Erors | g\ Waings | 7ol Shel | g FindinFies |

ISE WebPACK Tutorial

Figure 19: Program the FPGA.
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Next you will see the progress of loading the configuration to the FPGA as shown
in Figure 201

S Xilinx - ISE - C:\Documents and Settings\GSI\My Documents\eecs452\452F 08\Labs\Exercise3_development\SSD_test\SSD_test.ise - [Boundary Scan] EHEHX\

1% File Edit View Project Source Process Operations Output Debug Window Help LDEX
IDPHE LI DEX 0 DiPOPHKAR (N BB DDIAPNIMNE ViV iE@E MEAALLIQOO
e ¥ (@2 JO W

Sources x
23 Boundary Scan

23 SlaveSerial

23 SelectMAP

23 Desktop Configuration

29 Direct SPI Configuration

[2) systemaCE

xc3s1000 xcfods
[2) PROM File Fomnatter ssd_top.bit bypass

T00.

IS Progress Dialog [34%]
03 Source| () Fles | g S| ) i Corimtion Brocuting command..

Eiocesses X CTTTTTITT 3%

Available Operations are:

=) Program

= Get Device ID

=) Get Device Signature/Usercode —
= Check ldcode

=) Read Status Register

9! Processes | Configuration Operations  Desion Summay | B BoundoryScan

x| Boundary-scan chain validated successfully.
'1': Programming device...
PROGRESS_START - Starting Operation.

23

3

Transcript

@ )
[£] Console | @Erors | g\ Wamings | @ Tetshell | igg Fndin Fles

Configuration | Parallel T | 200 KHz | LPT1

Figure 20: Programming in progress.
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When the configuration is done and successful, you will see ” Program Successful”

in the iIMPACT window as shown in Figure 2I, and the FPGA board should start
running.

= Xilinx - ISE - C:\Documents and Settings\GSI\My Documents\eecs452\452F08\Labs\Exercise3_deyelopment\SSD_test\SSD_test.ise - [Boundary Scan]

1% File Edit View Project Source Process Operations Output Debug Window Help

LB X
iDAEHG LiXDEAX D RIPLPHEPR [ N:BEOD:FNR NG v:Q iR E SEAARK:QO
igEXiImfE: 82 HZolww
#53Boundary Scan
29 SlaveSerial
29 SelectMAP
"8 Desktop Configuration
‘23 Direct SPI Configuration
[2) SystemACE

xc3s1000 xcfods
[£) PROM File Formatter ssd_top.bit bypass.

13 Source| [ Fles | g Snape| [P Librare Configurston |

Process

Available Operations are:
= Program

=) Get Device ID

=) Get Device Signature/Usercode
=) Check ldcode

=) Read Status Register

Configuration Operations
#4;Pocesses | Configuaton Opersrs| I Design Summary | 3 Boundary Scan
'1': Programmed successfully.

Program Succeeded
PROGRESS_END - End Operation.

-~
Elapsed time = 17 sec.

] >
S [5] Console | @Eros | g\ Wamings | [ TciShell | igg Findin Fles

(=l

mps

Configuration | Parallel I | 200 KHz | LPT1

Figure 21: Programming succeeded.
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