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1 Overview

The C5515 Fingerprint Development Kit (FDK) is a complete signal chain solution that enables
manufacturers and developers, who are interested in integrating fingerprint biometrics features into their
product, to go to market faster.

The kit contains two widely used fingerprint sensor types (one swipe sensor and one optical sensor), one
core board with TI’s latest C5515 low-power digital signal processor, and one extension board for user
interaction. The kit also includes complete hardware design collateral, simplified application source code
and technical documentation including user guide, and application notes, to help users understand how to
develop a fingerprint application.

A production quality demo and its .out file are also included in the kit to enable users to experience the
final product performance. Some target applications include fingerprint-enabled physical access control
products (electronic door locks and safe boxes), USB smart keys and storage device, PC user
identification, and time and attendance monitoring systems.

The part number for the FDK is TMDXBDKFP5515.

2 FDK Content

The FDK includes:
• 1 core board (30 mm x 30 mm) based on C5515 low-power DSP
• 1 extension board (78 mm x 30 mm) for power supply, communication and user interaction
• 1 swipe fingerprint sensor (AuthenTec ATW310)
• 1 optical fingerprint sensor (Tooan OP-100N)
• 1 Type-B USB cable for updating program and user interaction
• 1 mini DVD containing:

– Code Composer Studio™ IDE
– Simplified fingerprint application source code
– Demo code .out file
– C5515 datasheet and chip support library (CSL)
– Technical documentation including user guide, application notes, quick start guide, schematics,

BOM, and gerbers
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3 FDK Software Overview

Figure 1 provides an overview of the FDK algorithm software.

Figure 1. FDK Algorithm Overview

Segmentation: The image acquired from the fingerprint sensor is first subjected to Segmentation. Image
Segmentation is the process of partitioning the image into regions based on certain metrics so that the
pixels in a given segment all have the same values for the metric. The result of this operation is a labeling
of image regions into “valid” and “invalid” areas corresponding to the presence and absence to fingerprint
information. An example of an image acquired from the fingerprint sensor and the result after
Segmentation is shown in Figure 2 and Figure 3.
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Figure 2. Original Image

Figure 3. Segmentation Result

Gray Stretch: The image after segmentation is subjected to Gray Stretch to increase the global contrast
of the image. Gray Stretch is performed by means of Histogram Equalization, resulting in an even
distribution of gray scale intensities in the image. Figure 4 shows the result of Gray Stretch for the
example image.
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Figure 4. Gray Stretch Result

Block Direction: A gradient based Block Direction algorithm is used to process the output of Gray
Stretch, resulting in a gradient map for the image. Figure 5 shows the result of Block Direction for the
example image.

Figure 5. Block Direction

Gabor Filter: The results of Gray Stretch and Block Direction for the input to Gabor Filtering. Gabor filters
are directional filters used for extracting edge oriented information. The result is enhancement of certain
frequencies and directions based on parameter settings. The parameter settings are critical to the overall
algorithm performance.

Binarization: The output of Gabor filtering is subjected to Binarization. Binarization converts an image
with multiple gray levels into an image with binary (black and white) levels. Thresholding operations are
used to binarize the input gray scale image, typically with input values at and below the threshold set to
black and those above the threshold set to white.

The result of Binarization and Block Direction are subjected to a second pass of Gabor Filtering and
Binarization.

Figure 6 and Figure 7 show the output of Gabor Filter and Binarization on the first pass.
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Figure 6. Output of First Pass of Gabor Filter

Figure 8 and Figure 9 respectively show the output of Gabor Filter and Binarization on the second pass.

Figure 7. Output of First Binarization
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Figure 8. Output of Second Pass of Gabor Filter and Binarization

Figure 9. Output of Second Pass of Binarization

Thinning: The output of the second Binarization step is subjected to Thinning. This step is used for
skeletonization, to reduce the output of the Binarization step to lines of single pixel thickness. Thinning is
done by performing the morphological operation of Erosion on the Binarization output. Figure 10 shows
the result of Thinning for the example image.
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Figure 10. Thinning Output

Feature Extraction: Minutae based features are extracted from the image after thinning. Minutiae
represent local discontinuities in the fingerprint ridge flow. A map of the minutiae is extracted from the data
and can be matched against stored minutiae maps to identify/verify an individual. Removal of false
minuate is conducted and then the features corresponding to each minutae are tagged resulting in a
feature vector of up to 45 values. Figure 11 shows the result of Feature Extraction for the example image.

Figure 11. Feature Extraction Result

Figure 12 shows the result of processing on two instance of fingerprint acquisition that were confirmed as
a match by the matching algorithm.
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Figure 12. Confirmed Match
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4 CCS4.x Setup

This section describes the procedure for configuring Code Composer Studio 4.x(CCS) to communicate
with the C5515 DSP on the FDK through the XDS100 JTAG interface.

• Install CCS4 from the Mini-DVD provided with this development kit.
• Ensure that you have installed the XDS100 drivers for CCS4

– See instructions at the hyperlink below (drivers included with CCS4.1 and newer):
http://processors.wiki.ti.com/index.php/XDS100#XDS100_Installation_Instructions

• <FDK PATH> represents the path to the disk location where the FDK CD ROM contents are located in
the Windows file system.

CCS4 can be downloaded from: http://processors.wiki.ti.com/index.php/CCSv4

4.1 Configure CCS4.x for C5515 Target Configuration
• Open CCS4.x and select a workspace

• When the welcome screen appears, click on the icon to close the welcome screen and go to the
CCS workbench

• When the workbench opens, click on Target→New Target Configuration...
• In the New Target Configuration window, enter a name for the Target Configuration and click Finish.
• In the next window that opens, under General Setup, from the Connection drop-down menu, select

Texas Instruments XDS100v1 USB Emulator.
• Type C5515 into the Device field to filter out nonrelevant devices.
• Check the box labeled EVM5515 and click Save.

Figure 13. General Setup of Code Composer Studio
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• Click the Advanced tab at the bottom of the window.
• Under All Connections click on the plus icons to fully expand the list hierarchy.

Figure 14. Plus Icon

• Click on to access the CPU properties.
• In the Initialization Script field, browse to the C5515 GEL file located at "<FDK

PATH>\Software\C5515_code_development\FDK_Demo\gel\c5515.gel"
• Click Save.

Figure 15. All Connections in Code Composer Studio

• Click on View→Target Configurations.
• Expand the User Defined folder to see the target configuration just created.
• Right click on the target configuration name and click on Launch Selected Configuration.
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Figure 16. Launch Selected Configuration

• When the target configuration is launched, the Debug perspective opens. This is indicated by the

debug selection at the top right of the CCS window.
• Click on Target→Connect Target to connect to the C5515 device.

4.2 Load Demo Code .out File onto FDK Device

Four versions of production code in binary boot image format are provided:

• atw310.bin — Fingerprints obtained with AuthenTec ATW310 Swipe Sensor
• OP-100N.bin — Fingerprints obtained with Tooan OP-100N Optical Sensor
• OP-100R.bin — Fingerprints obtained with Tooan OP-100R Optical Sensor
• fpc1101.bin — Fingerprints obtained with FPC1101 sensor (Contact Tooan)

Also provided is a User BIOS binary boot image, sensor_ck.bin, that automatically detects the attached
sensor and uses the corresponding production boot image for that sensor.

All binary files previously listed are programmed into the SPI Flash of the FDK so that the FDK can work
with any of these sensors without reflashing the SPI Flash.

Copies of the binary boot images are located under "<FDK PATH>\Software\bin_files\".

See the system guide in the C5515 FDK Window Program User Guide, included on the mini DVD for
instructions for loading the demo code onto the FDK device.

4.3 Open, Build, and Run Simplified Fingerprint Application Source Code

The FDK CDROM contains source code with a simplified fingerprint feature extraction/matching algorithm.
This section describes how to open, build, and run that project in CCS4.x.

• Change back to the C/C++ perspective by clicking on at the top right of the window
• Click on Project→Import Existing CCS/CCE Eclipse Project.
• In the Import window, browse to "<FDK PATH>\Software\C5515_code_development\FDK_Demo\".

Ensure that FDK_Demo is checked and click Finish.
• Click on Project→Build Active Project to build the FDK Demo.

Ensure no error messages were printed to the console.
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• Ignore the warning about the entry-point symbol other than _c_int00. This project uses the entry point
reset_isr, which is defined inside of vectors.asm.

WARNING:
<Linking>
warning: entry-point symbol other than "_c_int00" specified: "reset_isr"
'Finished building target: FDK_Demo.out'
' '
Build complete for project FDK_Demo

• Switch back to the Debug perspective by clicking on the icon at the top right of the window.
• Click on View→C/C++ Projects to open the project file explorer window.
• Click on the icon next to Binaries to show the FDK_Demo.out file.
• Right-click on FDK_Demo.out and click on Load Program.

Figure 17. Load Program

• When the project finishes loading, click on View→Debug to see the Debug Window.

• Click on the icon to run the demo.

The demo inputs two fingerprints through the optical sensor only. A single beep indicates when a
fingerprint is being read.

Repeated beeps indicate either that the finger prints match or they do not match.

The results are also printed on the console.

The demo will repeat infinitely.
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5 Support Resources

For additional information regarding the TMS320C5000 family of DSPs, please refer to the following page
on TI website:

http://www.ti.com/c5000

Code Composer Studio support is available via a forum at:
http://community.ti.com/forums/138.aspx

Additional development support is available via the online community/tool folder:
http://www.ti.com/c5515fdk
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IMPORTANT NOTICE

Texas Instruments Incorporated and its subsidiaries (TI) reserve the right to make corrections, modifications, enhancements, improvements,
and other changes to its products and services at any time and to discontinue any product or service without notice. Customers should
obtain the latest relevant information before placing orders and should verify that such information is current and complete. All products are
sold subject to TI’s terms and conditions of sale supplied at the time of order acknowledgment.

TI warrants performance of its hardware products to the specifications applicable at the time of sale in accordance with TI’s standard
warranty. Testing and other quality control techniques are used to the extent TI deems necessary to support this warranty. Except where
mandated by government requirements, testing of all parameters of each product is not necessarily performed.

TI assumes no liability for applications assistance or customer product design. Customers are responsible for their products and
applications using TI components. To minimize the risks associated with customer products and applications, customers should provide
adequate design and operating safeguards.

TI does not warrant or represent that any license, either express or implied, is granted under any TI patent right, copyright, mask work right,
or other TI intellectual property right relating to any combination, machine, or process in which TI products or services are used. Information
published by TI regarding third-party products or services does not constitute a license from TI to use such products or services or a
warranty or endorsement thereof. Use of such information may require a license from a third party under the patents or other intellectual
property of the third party, or a license from TI under the patents or other intellectual property of TI.

Reproduction of TI information in TI data books or data sheets is permissible only if reproduction is without alteration and is accompanied
by all associated warranties, conditions, limitations, and notices. Reproduction of this information with alteration is an unfair and deceptive
business practice. TI is not responsible or liable for such altered documentation. Information of third parties may be subject to additional
restrictions.

Resale of TI products or services with statements different from or beyond the parameters stated by TI for that product or service voids all
express and any implied warranties for the associated TI product or service and is an unfair and deceptive business practice. TI is not
responsible or liable for any such statements.

TI products are not authorized for use in safety-critical applications (such as life support) where a failure of the TI product would reasonably
be expected to cause severe personal injury or death, unless officers of the parties have executed an agreement specifically governing
such use. Buyers represent that they have all necessary expertise in the safety and regulatory ramifications of their applications, and
acknowledge and agree that they are solely responsible for all legal, regulatory and safety-related requirements concerning their products
and any use of TI products in such safety-critical applications, notwithstanding any applications-related information or support that may be
provided by TI. Further, Buyers must fully indemnify TI and its representatives against any damages arising out of the use of TI products in
such safety-critical applications.

TI products are neither designed nor intended for use in military/aerospace applications or environments unless the TI products are
specifically designated by TI as military-grade or "enhanced plastic." Only products designated by TI as military-grade meet military
specifications. Buyers acknowledge and agree that any such use of TI products which TI has not designated as military-grade is solely at
the Buyer's risk, and that they are solely responsible for compliance with all legal and regulatory requirements in connection with such use.

TI products are neither designed nor intended for use in automotive applications or environments unless the specific TI products are
designated by TI as compliant with ISO/TS 16949 requirements. Buyers acknowledge and agree that, if they use any non-designated
products in automotive applications, TI will not be responsible for any failure to meet such requirements.

Following are URLs where you can obtain information on other Texas Instruments products and application solutions:

Products Applications

Audio www.ti.com/audio Communications and Telecom www.ti.com/communications

Amplifiers amplifier.ti.com Computers and Peripherals www.ti.com/computers

Data Converters dataconverter.ti.com Consumer Electronics www.ti.com/consumer-apps

DLP® Products www.dlp.com Energy and Lighting www.ti.com/energy

DSP dsp.ti.com Industrial www.ti.com/industrial

Clocks and Timers www.ti.com/clocks Medical www.ti.com/medical

Interface interface.ti.com Security www.ti.com/security

Logic logic.ti.com Space, Avionics and Defense www.ti.com/space-avionics-defense

Power Mgmt power.ti.com Transportation and www.ti.com/automotive
Automotive

Microcontrollers microcontroller.ti.com Video and Imaging www.ti.com/video

RFID www.ti-rfid.com Wireless www.ti.com/wireless-apps

RF/IF and ZigBee® Solutions www.ti.com/lprf

TI E2E Community Home Page e2e.ti.com
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