[an error occurred while processing this directive]

Mentor Support

What does the software do?

Mentor Graphics has been widely used in courses here in the EECS department. The most popular applications in use are:

Other applications include:

Running on Unix/Linux:

Note: to run Mentor software on a non-CAEN EECS department machine, the machine must be part of the software subscription program.

Under /usr/caen/bin (which should be in your search path) are wrapper scripts for many but not all Mentor applications. These scripts set the proper environment variables for you and launch the application. Scripts include:

These wrapper scripts use the version settings you select using the CAEN application swselect. If you haven't selected a version with swselect, the wrapper script will default to the latest stable version installed on the platform.

Note: If you wish to use pre-ICFlow releases like Mentor D1, use these executables: da_d1, ic_d1, accusim_d1, dmgr_d1, dve_d1, iclink_d1 and vnet_d1. These will be available on the Solaris 9 platform but users are encouraged to migrate to the ICFlow package.

Setting up your environment to run executables NOT in /usr/caen/bin

First, identify which package it is that you're interested in and determine the install directory. Then add the following lines to your .cshrc or to a small set-up file that you intend to source prior to running the application, replacing instdir with the correct path.

All Mentor tools except Modelsim and AMS tools

setenv MGC_HOME instdir
setenv MGLS_LICENSE_FILE $MGC_HOME/license.dat
setenv MGC_PLOT_OPTIONS $MGC_HOME/printer_config
setenv PL_SCSDIR $MGC_HOME/hotplot
setenv MGC_VELOCITYLIB $MGC_HOME/shared/pkgs/stv_any.any/systest_data
set path=($MGC_HOME/bin /usr/caen/acroread-4.05/bin $path)

Setting X11DD_NAMED_COLORMAP can help preserve Mentor's color map when other applications hoard colors.

To use Modelsim-related products like Quicksim Pro or Continuum, set:

setenv MTI_HOME modelsim instdir


setenv MGLS_LICENSE_FILE instdir/license.dat
set path=(instdir/bin $path)

AMS tools (Eldo, A/MS, etc. - set these also if you wish to access Eldo, A/MS from within da_ic)

setenv anacad instdir
setenv MGLS_LICENSE_FILE $anacad/license.dat
source $anacad/com/init_anacad
setenv CYGNUS_COMPILER_PATH $anacad/cygnus
setenv DIR_SPEC H-sparc-sun-solaris2.7
set path=($COMPLETE_GCC_PATH/$DIR_SPEC/bin $path)

On-line Manuals

All on-line manuals are available via the Help menu in any Mentor application. Select Help->Open Bookcase to access the entire Mentor document set. ICFlow supports the mgcdocs executable to access the same on-line docs directly.

Similarly, the Help pulldown menu in Modelsim opens on-line Modelsim documentation. You can also bring up the pdf files directly from under the instdir/docs directory.

Mentor Graphics Printing

In da_ic, use File->Print Sheet with ICprint. In ICStation, use File->Print->Hotplot. Select the printer you would like to use along with the Setup File. If you don't have a Setup File, click "Build..." next to its field and one will be automatically generated for you. Note that you can modify the Setup File to achieve whatever fill pattern or color (if using a color plotter) you would like.

There are other ways to generate plots and print-outs as well. You can use File->Export Graphics and get a .ps file in /usr/tmp which can be printed with lp (e.g. lp -d4327eecs myfile.ps) or you can use MGC->Setup->Printer followed by File->Print->Print Cell or File->Print Sheet to also get a .ps file in /tmp. Note that these methods of printing will be phased out in the next few releases of ICFlow. Also, Linux ICStation supports only Hotplot for layout printing.

Installed Versions/Platforms

Helpful Links

Last Updated: 9/30/2004.