
Maple User Manual

Copyright © Maplesoft, a division of Waterloo Maple Inc.
1996-2009



Maple User Manual
Copyright
Maplesoft, Maple, MapleSim, Maple Application Center, Maple Student Center, Maplet, Maple T.A., and Maple-
Net are all trademarks of Waterloo Maple Inc.

© Maplesoft, a division of Waterloo Maple Inc. 1996-2009. All rights reserved. No part of this book may be re-
produced, stored in a retrieval system, or transcribed, in any form or by any means — electronic, mechanical,
photocopying, recording, or otherwise. Information in this document is subject to change without notice and does
not represent a commitment on the part of the vendor. The software described in this document is furnished under
a license agreement and may be used or copied only in accordance with the agreement. It is against the law to
copy the software on any medium except as specifically allowed in the agreement.

Adobe and Acrobat are either registered trademarks or trademarks of Adobe Systems Incorporated in the United
States and/or other countries.

Microsoft and Windows are registered trademarks of Microsoft Corporation.

Java and all Java based marks are trademarks or registered trademarks of Sun Microsystems, Inc. in the United
States and other countries. Maplesoft is independent of Sun Microsystems, Inc.

All other trademarks are the property of their respective owners.

This document was produced using a special version of Maple and DocBook.

Printed in Canada

ISBN 978-1-897310-69-4



Contents
Preface .................................................................................................... xiii
1 Getting Started ........................................................................................ 1

1.1 Introduction to Maple ...................................................................... 2
Working in Maple .............................................................................. 2
Starting the Standard Document Interface ......................................... 3
Entering 2-D Math ............................................................................ 6
Toolbar Options ............................................................................... 10
Context Menus and Copy & Drag ................................................... 46
Saving a Maple Document .............................................................. 22

1.2 Entering Expressions ..................................................................... 22
Execution Groups ............................................................................. 22
Math Mode vs. Text Mode .............................................................. 23
Palettes ............................................................................................ 25
Symbol Names ................................................................................ 33
Toolbar Icons ................................................................................... 35

1.3 Point-and-Click Interaction ............................................................ 37
Assistants ........................................................................................ 38
Tutors .............................................................................................. 44
Context Menus ................................................................................ 46
Task Templates ................................................................................. 47
Exploration Assistant ....................................................................... 50

1.4 Commands ..................................................................................... 52
The Maple Library ........................................................................... 52
Entering Commands ......................................................................... 52
Document Blocks ............................................................................. 58

1.5 The Maple Help System ................................................................. 62
Accessing the Help System ............................................................. 62
Using the Help Navigator ............................................................... 63
Viewing Help Pages as Documents ................................................. 65
Viewing Examples in 2-D Math ...................................................... 65
Copying Examples ........................................................................... 66

1.6 Available Resources ....................................................................... 66
Online Help and Examples .............................................................. 66
Maple Tour and Quick Resources .................................................... 68

iii



Web Site Resources .......................................................................... 69
2 Document Mode .................................................................................... 71

2.1 In This Chapter .............................................................................. 71
2.2 Introduction .................................................................................... 71
2.3 Entering Expressions ..................................................................... 73

Example 1 - Calculate a Partial Derivative ..................................... 75
Example 2 - Define a Mathematical Function ................................. 76

2.4 Evaluating Expressions .................................................................. 77
2.5 Editing Expressions and Updating Output .................................... 78
2.6 Performing Computations ............................................................. 79

Computing with Palettes ................................................................. 79
Context Menus ................................................................................ 80
Assistants and Tutors ....................................................................... 87

3 Worksheet Mode ................................................................................... 91
3.1 In This Chapter .............................................................................. 92
3.2 Input Prompt .................................................................................. 93

Suppressing Output .......................................................................... 94
1-D Math Input ................................................................................ 94
Input Separators ............................................................................... 95

3.3 Commands .................................................................................... 96
The Maple Library ........................................................................... 96
Top-Level Commands ...................................................................... 96
Package Commands ........................................................................ 99

3.4 Palettes ........................................................................................ 103
3.5 Context Menus ............................................................................ 105

Example 1 - Using Context Menus ................................................ 106
3.6 Assistants and Tutors .................................................................. 107

Launching an Assistant or Tutor .................................................... 107
3.7 Task Templates ............................................................................ 108
3.8 Text Regions ................................................................................ 110
3.9 Names ......................................................................................... 110

Assigning to Names ...................................................................... 111
Unassigning Names ...................................................................... 113
Valid Names .................................................................................. 113

3.10 Equation Labels ........................................................................ 114
Displaying Equation Labels ........................................................... 115

iv   •   Contents



Referring to a Previous Result ....................................................... 115
Execution Groups with Multiple Outputs ...................................... 116
Label Numbering Schemes ........................................................... 117
Features of Equation Labels .......................................................... 118

4 Basic Computations ........................................................................... 119
4.1 In This Chapter ............................................................................ 119
4.2 Symbolic and Numeric Computation .......................................... 120

Exact Computations ...................................................................... 121
Floating-Point Computations ........................................................ 122
Converting Exact Quantities to Floating-Point Values ................. 123
Sources of Error ............................................................................ 124

4.3 Integer Operations ....................................................................... 125
Non-Base 10 Numbers and Other Number Systems ...................... 128

4.4 Solving Equations ........................................................................ 131
Solving Equations and Inequations ............................................... 132
Other Specialized Solvers .............................................................. 143

4.5 Units, Scientific Constants, and Uncertainty ............................... 151
Units .............................................................................................. 151
Scientific Constants and Element Properties ................................ 160
Uncertainty Propagation ............................................................... 166

4.6 Restricting the Domain ................................................................ 170
Real Number Domain ................................................................... 170
Assumptions on Variables ............................................................. 171

5 Mathematical Problem Solving .......................................................... 177
5.1 In This Chapter ............................................................................ 177
5.2 Algebra ........................................................................................ 178

Polynomial Algebra ...................................................................... 178
5.3 Linear Algebra ............................................................................ 189

Creating Matrices and Vectors ...................................................... 189
Accessing Entries in Matrices and Vectors ................................... 198
Linear Algebra Computations ....................................................... 200
Student LinearAlgebra Package .................................................... 208

5.4 Calculus ....................................................................................... 208
Limits ............................................................................................ 209
Differentiation ............................................................................... 211
Series ............................................................................................. 217

Contents   •   v



Integration ..................................................................................... 219
Differential Equations .................................................................... 222
Calculus Packages ......................................................................... 223

5.5 Optimization ............................................................................... 225
Point-and-Click Interface .............................................................. 225
Large Optimization Problems ....................................................... 228
MPS(X) File Support .................................................................... 230
Optimization Package Commands ................................................. 230

5.6 Statistics ...................................................................................... 231
Probability Distributions and Random Variables .......................... 232
Statistical Computations ................................................................ 233
Plotting .......................................................................................... 235
Additional Information .................................................................. 238

5.7 Teaching and Learning with Maple ............................................ 238
Student Packages and Tutors ........................................................ 239
Calculus Problem Solving Examples ............................................. 246

5.8 Clickable Math Examples ............................................................ 253
Example 1 - Graph a Function and its Derivatives ........................ 254
Example 2 - Solve for x in a Quadratic Equation .......................... 261
Example 3 - Solve a Quadratic Trig Equation ............................... 267
Example 4 - Find the Inverse Function .......................................... 271
Example 5 - Methods of Integration - Trig Substitution ................ 275
Example 6 - Initial Value Problem ................................................. 279

6 Plots and Animations .......................................................................... 283
6.1 In This Chapter ............................................................................ 283
6.2 Creating Plots .............................................................................. 284

Interactive Plot Builder ................................................................. 285
Context Menu ................................................................................ 294
Dragging to a Plot Region ............................................................. 298
The plot and plot3d Commands .................................................... 299
The plots Package ......................................................................... 307
Multiple Plots in the Same Plot Region ......................................... 312

6.3 Customizing Plots ....................................................................... 314
Interactive Plot Builder Options ................................................... 315
Context Menu Options .................................................................. 315
The plot and plot3d Options ......................................................... 318

vi   •   Contents



6.4 Analyzing Plots ........................................................................... 321
Point Probe, Rotate, Pan, and Zoom Tools .................................... 321

6.5 Creating Animations ................................................................... 322
Interactive Plot Builder ................................................................. 322
The plots[animate] Command ....................................................... 323
The plot3d[viewpoint] Command .................................................. 325

6.6 Playing Animations ..................................................................... 326
Animation Context Bar .................................................................. 326

6.7 Customizing Animations ............................................................ 327
Interactive Plot Builder Animation Options ................................. 327
Context Menu Options .................................................................. 327
The animate Command Options .................................................... 328

6.8 Exporting ..................................................................................... 329
6.9 Code for Color Plates .................................................................. 331

7 Creating Mathematical Documents ..................................................... 333
7.1 In This Chapter ............................................................................ 334
7.2 Document Formatting .................................................................. 335

Copy and Paste ............................................................................... 336
Quick Character Formatting .......................................................... 337
Quick Paragraph Formatting .......................................................... 339
Character and Paragraph Styles ..................................................... 341
Sections .......................................................................................... 349
Headers and Footers ....................................................................... 351
Show or Hide Worksheet Content .................................................. 352
Indentation and the Tab Key .......................................................... 354

7.3 Commands in Documents ............................................................ 354
Document Blocks ........................................................................... 354
Typesetting ..................................................................................... 359
Auto-Execute ................................................................................. 360

7.4 Tables ........................................................................................... 362
Creating a Table ............................................................................. 362
Cell Contents .................................................................................. 362
Navigating Table Cells ................................................................... 363
Modifying the Structural Layout of a Table ................................... 364
Modifying the Physical Dimensions of a Table ............................. 367
Modifying the Appearance of a Table ............................................ 368

Contents   •   vii



Printing Options ............................................................................. 373
Execution Order Dependency ....................................................... 373
Tables and the Classic Worksheet .................................................. 373
Additional Examples ...................................................................... 374

7.5 Canvas .......................................................................................... 377
Insert a Canvas ............................................................................... 377
Drawing .......................................................................................... 378
Canvas Style ................................................................................... 379
Inserting Images ............................................................................. 381

7.6 Hyperlinks .................................................................................... 382
Inserting a Hyperlink in a Document ............................................. 383
Bookmarks ..................................................................................... 387

7.7 Embedded Components ............................................................... 389
Adding Graphical Interface Components ...................................... 389
Task Template with Embedded Components ................................. 391

7.8 Spell Checking ............................................................................. 392
How to Use the Spellcheck Utility ................................................. 393
Selecting a Suggestion ................................................................... 394
User Dictionary .............................................................................. 394

7.9 Creating Graded Assignments ..................................................... 396
Creating a Question ........................................................................ 396
Viewing Questions in Maple .......................................................... 396
Saving Test Content ....................................................................... 396

7.10 Worksheet Compatibility ........................................................... 397
8 Maple Expressions .............................................................................. 399

8.1 In This Chapter ............................................................................ 399
8.2 Creating and Using Data Structures ............................................ 399

Expression Sequences ................................................................... 400
Sets ................................................................................................ 401
Lists ............................................................................................... 402
Arrays ............................................................................................ 403
Tables ............................................................................................ 406
Matrices and Vectors ..................................................................... 406
Functional Operators ..................................................................... 407
Strings ........................................................................................... 412

8.3 Working with Maple Expressions ................................................ 413

viii   •   Contents



Low-Level Operations ................................................................... 413
Manipulating Expressions ............................................................. 419
Evaluating Expressions ................................................................. 426

9 Basic Programming ............................................................................ 439
9.1 In This Chapter ............................................................................ 439
9.2 Flow Control ................................................................................ 440

Conditional Execution (if Statement) ........................................... 440
Repetition (for Statement) ............................................................. 444

9.3 Iterative Commands .................................................................... 451
Creating a Sequence ...................................................................... 452
Adding and Multiplying Expressions ........................................... 453
Selecting Expression Operands ..................................................... 453
Mapping a Command over a Set or List ....................................... 455
Mapping a Binary Command over Two Lists or Vectors ............... 455
Additional Information .................................................................. 456

9.4 Procedures ................................................................................... 457
Defining and Running Simple Procedures .................................... 457
Procedures with Inputs .................................................................. 458
Procedure Return Values ............................................................... 458
Displaying Procedure Definitions ................................................. 459
Displaying Maple Library Procedure Definitions ......................... 459
Modules ......................................................................................... 461

9.5 Programming in Documents ........................................................ 462
Code Edit Region .......................................................................... 462
Startup Code .................................................................................. 463
Document Blocks ........................................................................... 464

10 Embedded Components and Maplets ................................................ 465
10.1 In This Chapter .......................................................................... 465
10.2 Using Embedded Components ................................................... 465

Interacting ...................................................................................... 465
Printing and Exporting a Document with Embedded Compon-
ents ................................................................................................. 469

10.3 Creating Embedded Components .............................................. 469
Inserting Components .................................................................... 469
Editing Component Properties: General Process ........................... 470
Removing Graphical Interface Components .................................. 471

Contents   •   ix



Integrating Components into a Document ..................................... 471
Example 2 - Creating Embedded Components .............................. 473

10.4 Using Maplets ........................................................................... 477
Maplet File .................................................................................... 478
Maple Document ............................................................................ 478

10.5 Authoring Maplets .................................................................... 479
Simple Maplet ................................................................................ 479
Maplet Builder .............................................................................. 480
Maplets Package ........................................................................... 485
Saving ............................................................................................ 488

11 Input, Output, and Interacting with Other Products ......................... 489
11.1 In This Chapter ........................................................................... 489
11.2 Writing to Files .......................................................................... 489

Saving Data to a File ...................................................................... 489
Saving Expressions to a File .......................................................... 491

11.3 Reading from Files .................................................................... 492
Reading Data from a File ............................................................... 492
Reading Expressions from a File ................................................... 493

11.4 Exporting to Other Formats ...................................................... 495
Exporting Documents ................................................................... 495
MapleNet ........................................................................................ 498
Maple T.A. ..................................................................................... 499

11.5 Connectivity .............................................................................. 500
Translating Maple Code To Other Programming Languages ........ 500
Accessing External Products from Maple ...................................... 500
Accessing Maple from External Products ...................................... 501

Index ...................................................................................................... 505

x   •   Contents



List of Tables
Table 1.1: Common Keystrokes for Entering Symbols and Formats ....... 7
Table 1.2: Maple Toolbar Options ........................................................... 11
Table 1.3: Tab Icon Description ............................................................... 12
Table 1.4: Toolbar Icons and their Tools .................................................. 13
Table 1.5: Toolbar Icon Availability ........................................................ 13
Table 1.6: Math Mode vs. Text Mode ...................................................... 24
Table 1.7: Palette Categories .................................................................. 27
Table 1.8: Managing Palettes ................................................................. 29
Table 1.9: Help Page Icons ...................................................................... 64
Table 3.1: Top Commands ..................................................................... 98
Table 3.2: Top Packages ....................................................................... 101
Table 4.1: Select Integer Commands ..................................................... 127
Table 4.2: Modular Arithmetic Operators .............................................. 130
Table 4.3: Overview of Solution Methods for Important Equation
Types ...................................................................................................... 132
Table 4.4: Sample Dimensions .............................................................. 152
Table 4.5: Scientific Constants ............................................................... 161
Table 5.1: Polynomial Arithmetic Operators ......................................... 179
Table 5.2: Polynomial Coefficient and Degree Commands ................... 186
Table 5.3: Select Other Polynomial Commands .................................... 187
Table 5.4: Additional Polynomial Help ................................................. 188
Table 5.5: Matrix and Vector Arithmetic Operators .............................. 201
Table 5.6: Select Matrix and Vector Operators ...................................... 203
Table 5.7: Select LinearAlgebra Package Commands ........................... 205
Table 5.8: Limits .................................................................................... 209
Table 5.9: Optimization Package Commands ........................................ 230
Table 5.10: Student and Instructor Resources ........................................ 238
Table 6.1: Windows of the Interactive Plot Builder ............................... 286
Table 6.2: The plot and plot3d Commands ............................................ 299
Table 6.3: Common Plot Options ........................................................... 318
Table 6.4: Plot Analysis Options ........................................................... 321
Table 6.5: The animate Command ......................................................... 323
Table 5.6: Animation Options ................................................................ 326
Table 9.1: Default Clause Values ........................................................... 445

xi



Table 9.2: Iterative Commands .............................................................. 452
Table 9.3: The seq Command ................................................................ 452
Table 9.4: The add and mul Commands ................................................ 453
Table 9.5: The select, remove, and selectremove Commands ............... 454
Table 9.6: The map Command ............................................................... 455
Table 9.7: The zip Command ................................................................. 456
Table 10.1: Embedded Component Descriptions ................................... 466
Table 10.1: Summary of Content Translation When Exporting to Different
Formats .................................................................................................. 497

xii   •   List of Tables



Preface
Maple Software
MapleTM software is a powerful system that you can use to solve mathemat-
ical problems from simple to complex. You can also create professional
quality documents, presentations, and custom interactive computational tools
in the Maple environment.

You can access the power of the Maple computational engine through a
variety of interfaces.

DescriptionInterface

A full-featured graphical user interface that helps you create
electronic documents to show all your calculations, assumptions,
and any margin of error in your results. You can also hide the
computations to allow your reader to focus on the problem setup
and final results. The advanced formatting features lets you create
the customized document you need. Because the documents are
live, you can edit the parameters and, with the click of a button,
compute the new results. The Standard interface has two modes:
Document mode and Worksheet mode.
An interactive version of this manual is available in the Standard
Worksheet interface. From the Help menu, select Manuals, Re-
sources, and more → Manuals → User Manual.

Standard (default)

A basic worksheet environment for older computers with limited
memory. The Classic interface does not offer all of the graphical
user interface features that are available in the Standard interface.
The Classic interface has only one mode, Worksheet mode.

Classic

A command-line interface for solving very large complex problems
or batch processing with scripts. No graphical user interface fea-
tures are available.

Command-line version
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DescriptionInterface

Graphical user interfaces containing windows, textbox regions,
and other visual interfaces, which gives you point-and-click access
to the power of Maple. You can perform calculations and plot
functions without using the worksheet.

MapletTM Applications

A graphical calculator interface to the Maple computational engine.
Using it, you can perform simple computations and create custom-
izable, zoomable graphs. This is available on Microsoft® Win-
dows® only.

MaplesoftTM Graphing
Calculator

This manual describes how to use the Standard interface. As mentioned, the
Standard interface offers two modes: Document mode and Worksheet mode.
Using either mode, you can create high quality interactive mathematical
documents. Each mode offers the same features and functionality, the only
difference is the default input region of each mode.

Shortcut Keys by Platform
This manual will frequently refer to context menus and command completion
when entering expressions. The keyboard keys used to invoke these features
differ based on the operating system you're using.

This manual will only refer to the keyboard keys needed for a Windows op-
erating system. When working through the examples, use the keyboard keys
needed for your operating system.

Context Menus
• Right-click, Windows and UNIX®

• Control-click, Macintosh®

That is, place the mouse over the input or output region and press the right
button on the mouse or press and hold the Control key and click the mouse
key for Macintosh.
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For more information on Context Menus, see Context Menus and Copy &
Drag (page 46).

Command Completion
• Ctrl + Space or Esc, Windows

• Command + Shift + Space or Esc, Macintosh

• Ctrl + Shift + Space or Esc, UNIX

Begin entering a command in a Maple document. Press and hold the Ctrl
key and then press the Space bar for Windows. Press and hold the Command
key, press and hold the Shift key, and then press the Space bar for Macintosh.
Alternatively, press the Esc key. The steps for UNIX are the same as for
Macintosh, with the exception of pressing the Ctrl key instead of the Com-
mand key.

For more information on Command Completion, see Command Comple-
tion (page 55).

In This Manual
This manual provides an introduction to the following Maple features:

• Ease-of-use when entering and solving problems

• Point-and-click interaction with various interfaces to help you solve
problems quickly

• Maple commands and standard math notation

• Clickable Calculus

• The help system

• Online resources

• Performing computations

• Creating plots and animations

• The Maple programming language
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• Using and creating custom Maplet applications

• File input and output, and using Maple with third party products

• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources,
visit the Maplesoft web site at http://www.maplesoft.com

Audience
The information in this manual is intended for first-time Maple users and
users looking for a little more information.

Conventions
This manual uses the following typographical conventions.

• bold font - Maple command, package name, option name, dialog, menu,
or text field

• italics - new or important concept

• Note - additional information relevant to the section

• Important - information that must be read and followed

Customer Feedback
Maplesoft welcomes your feedback. For suggestions and comments related
to this and other manuals, contact doc@maplesoft.com.

xvi   •   Preface
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1  Getting Started
Don't worry about your difficulties in Mathematics. I can assure you
mine are still greater.

~Albert Einstein

Mathematics touches us every day—from the simple chore of calculating
the total cost of our purchases to the complex calculations used to construct
the bridges we travel.

To harness the power of mathematics, Maplesoft provides a tool in an access-
ible and complete form. That tool is Maple.

In this chapter:
TopicsSection

• Starting the Standard Document Interface

• Entering commands and mathematical
expressions

• Toolbars

• Context menus

• Copy and Drag keys

• Saving Maple documents

Introduction to Maple - The main features
of Maple's Standard Interface

• Execution groups

• Math Mode and Text Mode

• Palettes

• Symbol names

• Toolbar icons

Entering Expressions - Methods of entering
expressions in 1-D and 2-D Math
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TopicsSection

• Assistants

• Tutors

• Context menus

• Task Templates

• Exploration Assistant

Point-and-Click Interaction - An introduc-
tion to the point-and-click features in Maple

• Using commands from the Maple library

• Entering commands

• Document blocks

Commands - An introduction to the com-
mands of the Maple language

• How to access help for Maple features

• Interacting with help pages

• Viewing and interacting with examples

The Maple Help System- Accessing help on
commands, packages, point-and-click fea-
tures, and more

• Online help

• Examples

• The Maple tour

• New user resources

• Maple web site resources

Available Resources - Both online and from
within Maple

1.1  Introduction to Maple
Working in Maple
With Maple, you can create powerful interactive documents. The Maple
environment lets you start solving problems right away by entering expres-
sions in 2-D Math and solving these expressions using point-and-click inter-
faces. You can combine text and math in the same line, add tables to organize
the content of your work, or insert images, sketch regions, and spreadsheets.
You can visualize and animate problems in two and three dimensions, format
text for academic papers or books, and insert hyperlinks to other Maple files,
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web sites, or email addresses. You can embed and program graphical user
interface components, as well as devise custom solutions using the Maple
programming language.

Figure 1.1: The Maple Environment

Starting the Standard Document Interface
To start Maple on:

From the Start menu, select All Programs → Maple 13 → Maple 13.
Alternatively:
Double-click the Maple desktop icon.

Windows
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1. From the Finder, select Applications and Maple 13.
2. Double-click Maple 13.

Macintosh

Enter the full path, for example, /usr/local/maple/bin/xmaple
Alternatively:
1. Add the Maple directory (for example, /usr/local/maple/bin) to your
command search path.
2. Enter xmaple.

UNIX

The first Maple session opens with a Startup dialog explaining the difference
between Document Mode and Worksheet Mode. Using either mode, you can
create high quality interactive mathematical documents. Each mode offers
the same features and functionality; the only difference is the default input
region of each mode.

Document Mode

Document mode uses Document Blocks as the default input region to hide
Maple syntax. A Document Block region is indicated by two triangles located
in the vertical Markers column along the left pane of the Maple Document,

. If the Markers column is not visible, open the View menu and select
Markers. This allows you to focus on the problem instead of the commands
used to solve the problem. For example, when using context menus on Maple
input in Document mode (invoked by right-clicking or Control-clicking for
Macintosh), input and output are connected using an arrow or equal sign
with self-documenting text indicating the calculation that had taken place.
The command used to solve this expression is hidden.

When starting Standard Maple, the default mode is Document mode.

Worksheet Mode

Worksheet mode uses a Maple prompt as the default input region. The Maple
input prompt is a red angle bracket where the black square bracket indicates
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the full execution region, . When using content menus on Maple input
in Worksheet mode, all commands are displayed.

To work in Worksheet mode, select File → New → Worksheet Mode.

Document and Worksheet Modes

Regardless of which mode you are working in, you have the opportunity to
show or hide your calculations. You can hide commands in Worksheet Mode
by adding a document block from the Format menu, Format → Create
Document Block (see Document Blocks (page 58)), or you can show com-
mands in Document mode by adding a Maple prompt from the Insert menu,
Insert → Execution Group → Before / After Cursor (see Input
Prompt (page 93)).

This chapter discusses features common to both modes. Specific aspects of
Document mode are explained in Document Mode (page 71), and aspects of
Worksheet mode are explained in Worksheet Mode (page 91).

The Startup dialog also contains links to items, such as various document
options, help resources including updates and other introductory help pages,
and application resources on the Maplesoft web site. Subsequent sessions
display Tip of the Day information.

To start a Maple session:

1. In the Startup dialog, select Blank Document or Blank Worksheet. A
blank document displays.

or

1. Close the Startup dialog.
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2. From the File menu, select New, and then either Document Mode or
Worksheet Mode. A blank document displays.

Every time you open a document, Maple displays a Quick Help pop-up list
of important shortcut keys. To invoke Quick Help at any time, press the F1
key.

Entering 2-D Math
In Maple, the default format for entering mathematical expressions is 2-D
Math. This results in mathematical expressions that are equivalent to the
quality of math found in textbooks. Entering 2-D Math in Maple is done
using common key strokes or palette items. For more information on palettes,
see Palettes (page 25). An example of entering an expression using common
key strokes is presented in the following section. An example of entering an
expression using palette items is presented in Example 3 - Enter an Expres-
sion Using Palettes (page 31).

Common Operations

Entering mathematical expressions, such as , , and 

is natural in 2-D Math.

To enter a fraction:

1. Enter the numerator.

2. Press the forward slash (/) key.

3. Enter the denominator.

4. To leave the denominator, press the right arrow key.

To enter a power:

1. Enter the base.

2. Press the caret (^) key.
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3. Enter the exponent, which displays in math as a superscript.

4. To leave the exponent, press the right arrow key.

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in 2-D Math as a dot, .

3. Enter the second factor.

Implied Multiplication:

In most cases, you do not need to include the multiplication operator, .
Insert a space character between two quantities to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or
a space character. For example, Maple interprets a number followed by a
variable as multiplication.

Important: Maple interprets a sequence of letters, for example, xy, as a
single variable. To specify the product of two variables, you must insert a
space character (or multiplication operator), for example, x y or . For
more information, refer to the ?2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1: Common Keystrokes for Entering Symbols and Formats

ExampleKeySymbol/Formats

Space keyimplicit multiplication

* (asterisk)explicit multiplication
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ExampleKeySymbol/Formats

/ (forward slash)fraction

^ (Shift + 6 or caret key)exponent (superscript)

_ (Shift + underscore )subscript

Arrow keysnavigating expressions

• Ctrl + Space, Windows

• Esc, Macintosh

• Ctrl + Shift + Space, UNIX

command / symbol com-

pletion

sqrt and then command completionsquare root

exp and then command completionexponential function

versus 1/4Math and Text icons in the toolbarenter / exit 2-D Math

required for products of numbers

use the right arrow key to leave a denominator, superscript, or subscript region

for more information, see Command Completion (page 55).

For a complete list of shortcut keys, refer to the 2-D Math Shortcut Keys
and Hints help page. To access this help page in the Maple software, in
Math mode enter ?MathShortcuts and then press Enter. For information
on the Maple Help System, see The Maple Help System (page 62).
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Example 1 - Enter and Evaluate an Expression Using Keystrokes

Review the following example:

In this example, we enter and evaluate the expression.

Result in DocumentAction

To enter the expression:
1. Enter x.

2. Press Shift + 6 (the ^ or caret key). The cursor moves to the
superscript position.

3. Enter 2.

4. Press the right arrow key. The cursor moves right and out of
the superscript position.

5. Enter the + symbol.

6. Enter y.

7. Press Shift + 6 to move to the superscript position.

8. Enter 2 and press the right arrow key.

9. With the mouse, select the expression that will be the numer-
ator of the fraction.
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Result in DocumentAction

10. Enter the / symbol. The cursor moves to the denominator,
with the entire expression in the numerator.

11. Enter 2.

12. Press the right arrow key to move right and out of the denom-
inator position.

=
To evaluate the expression and display the result inline:
13. Press Ctrl + = (Command + =, Macintosh).

To execute 2-D Math, you can use any of the following methods.

• Pressing Ctrl + = (Command + =, for Macintosh). That is, press and
hold the Ctrl (or Command) key, and then press the equal sign (=) key.
This evaluates and displays results inline.

• Pressing the Enter key. This evaluates and displays results on the next
line and centered.

• Right-click (Control-click for Macintosh) the input to invoke a context
menu item. From the context menu, select Evaluate and Display Inline.
See Context Menus and Copy & Drag (page 46) for more details.

• Using the context-menu item Evaluate.

Toolbar Options
The Maple toolbar offers several buttons to assist you when interacting with
Maple. See Table 1.2.
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Table 1.2: Maple Toolbar Options

Equivalent Menu Option or CommandIconBasic Usage

From the Insert menu, select Text.Inserts plain text after the current ex-
ecution group.

From the Insert menu, select Execution
Group and then After Cursor.

Inserts Maple Input after the current
execution group. For details, refer to
Execution Groups (page 22).

From the Format menu, select Indent.Encloses the selection in a subsection.
For details, refer to Sec-
tions (page 349).

From the Format menu, select Outdent.Removes any section enclosing the
selection.

From the Edit menu, select Execute and
then Worksheet.

Executes all commands in the work-
sheet or document

From the Edit menu, select Execute and
then Selection.

Executes a selected area.

Enter restart.Clears Maple's internal memory. For
details, refer to the ?restart help
page.

From the Edit menu, select Startup
Code.

Add and edit Maple code that is ex-
ecuted each time the worksheet is
opened. For details, refer to the
?startupcode help page.

From the View menu, select Zoom
Factor and then a zoom size.

Adjusts the display size of document
content. Note: plots, spreadsheets,
images, and sketches remain un-
changed.

From the Help menu, select Maple
Help.

Opens the Maple help system. For
details, refer to The Maple Help Sys-
tem (page 62).

For 1-D Math and text regions, the Tab icon in the toolbar allows you to set
the Tab key to move between placeholders (or cells in a table) or to indent
text.
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Table 1.3: Tab Icon Description

DescriptionTab Icon

Tab icon off. Allows you to move between placeholders using the Tab
key.

Tab icon on. Allows you to indent in the worksheet using the Tab key.

The Tab icon is disabled when using 2-D Math (Math mode), and as such,
the Tab key allows you to move between placeholders.

Toolbar icons are controlled by the location of the cursor in the document.
For example, place the cursor at an input region and the Text and Math
icons are accessible while the others are dimmed. See Table 1.4 for a list of
the tools available in each icon.
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Table 1.4: Toolbar Icons and their Tools

Toolbar Icon Options

Text tools

Math tools

Drawing tools

Plot tools

Animation tools

Table 1.5: Toolbar Icon Availability

Available ToolsRegion

Text and Math iconsInput region

Drawing and Plot iconsPlot region

Drawing, Plot, and Animation iconsAnimation region

Drawing iconCanvas and Image regions
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The Text and Math icons allow you to enter text and math in the same line
by choosing the appropriate input style at each stage when entering the sen-
tence.

The derivative of is .

Using the tools available in these icons, you can customize the input style
of the text and 2-D Math. For the Text and Math icons, the icon that is se-
lected remains in that state until prompted otherwise; therefore, if the Text
icon is selected and you press the Enter key, the new input region remains
a Text region.

The Text and Math icons differ while at a Maple input prompt. The Math
icon displays input as 2-D Math, whereas the Text icon displays Maple input.
For details, refer to Math Mode vs. Text Mode (page 23). For an example,
see Example 6 (page 36).

> 

x^2/2;>

To access the tools available in the Plot and Drawing icons, click a plot re-
gion. These tools allow you to manipulate the plot or draw shapes and enter
text on the plot region. By clicking an animation region, you have the same
features available for a plot region, in addition to tools for playing the anim-
ation in the Animation icon. For details on plots and animations, refer to
Plots and Animations (page 283).

For the remaining icons, hover the mouse over the icon to display the icon
description.
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Context Menus and Copy & Drag

Context Menus

Maple dynamically generates a context menu of applicable options when
you right-click an object, expression, or region. The options available in the
context menu depend on the selected input region. For example, you can
manipulate and graph expressions, enhance plots, format text, manage
palettes, structure tables, and more. When using context menus to perform
an action on an expression, the input and output are connected with a self-
documenting arrow or equal sign indicating the action that had taken place.
For more information, see Context Menus and Copy & Drag (page 46).

Copy & Drag

With Maple, you can drag input, output, or curves in a plot region into a new
input region. This is done by highlighting the input or selecting the curve
and dragging it with your mouse into a new input region. Dragging the
highlighted region will cut or delete the original input. To prevent this, use
the copy and drag feature.

• Ctrl + drag, Windows and UNIX

• Command + drag, Macintosh

That is, highlight the region you want to copy. Press and hold the Ctrl key
while you drag the input to the new region using the mouse. The steps are
the same for Macintosh with the exception of pressing the Command key.

Example 2 - Solve and Plot an Equation Using Context Menus
and Copy & Drag

Review the following example:

In this example, we will enter the equation and then solve and plot the
equation using context menus and Maple's copy & drag feature. This example
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will only refer to the keystrokes needed on a Windows operating system to
invoke the context menus and the copy & drag feature. For your operating
system, refer to section Shortcut Keys by Platform (page xiv) for the equivalent
keystrokes.
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To solve the equation:
1. Enter the equation.
2. Right-click the equation and select Move to Left.

Input:

Result:

A brief description, "move to left" is displayed above the arrow that connects the input
and output.
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3. Right-click the output from the previous action, and select Left-hand Side.

Input:

Result:
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4. Right-click the new output, and select Solve → Isolate Expression for → x.

Input:

Result:
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Now that we have solved the equation, we can plot it. To do this, we will copy the expression
to a new document block and use context menus once again.

5. From the Format menu, select Create Document Block.

6. To copy the expression , highlight only this expression from the previous result.
Press and hold the Ctrl key and drag the expression to the new document block region.

Result:
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To plot the expression:
7. Right-click the expression and select Plots → 2-D Plot.

Input:
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Result:

Saving a Maple Document
To save these examples you created, from the File menu, select Save. Maple
documents are saved as .mw files.

1.2  Entering Expressions
Execution Groups
An execution group is a grouping of Maple input with its corresponding
Maple output. It is distinguished by a large square bracket, called a group
boundary, at the left. An execution group may also contain any or all of the
following: a plot, a spreadsheet, text, embedded components, and a drawing
canvas.
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Execution groups are the fundamental computation and documentation ele-
ments in the document. If you place the cursor in an input command and
press the Enter or Return key, Maple executes all of the input commands
in the current execution group.

Math Mode vs. Text Mode
The default mode of entry in Document or Worksheet mode is Math Mode,
which displays input in 2-D Math. In earlier releases of Maple, commands
and expressions were entered using Maple Input or 1-D Math.

Important: With Maple input, you must terminate commands with a semi-
colon or colon.

cos(alpha)^2+sin(alpha)^2;>

a*int(exp(sqrt(2)*x),x);>

limit(f(x),x=infinity);>

sum(a[k]*x^k, k=0..m)=product(b[j]*x^j, j=0..n);>
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In Document Mode, to enter input using Maple Input mode, insert a Maple

prompt by clicking in the toolbar, and then click the Text button in the
toolbar. In Worksheet Mode, simply click the Text button. See Figure 1.2.

Figure 1.2: Text and Math buttons
on the Toolbar

Table 1.6: Math Mode vs. Text Mode

Text ModeMath Mode

Executable Maple notation. This is
also referred to as 1-D Math Input
or Maple Input.
> int(x^2+2*x+1, x);

Maple's default setting. Executable
standard math notation. This is also
referred to as 2-D Math Input.

> 

Access from the Insert → Maple Input
menu.

Access from the Insert → 2-D Math menu.

When entering Maple Input or text in a text
region, the Text mode icon is highlighted in
the toolbar, .

When using 2-D Math, the Math mode icon
is highlighted in the toolbar, .

In Document Mode (or a document block),
input is entered with a vertical cursor, as plain
text, .

In Document Mode (or a document block),
input is entered in a document block with a
slanted cursor, .

In Worksheet Mode, input is made at an input

prompt with a vertical cursor, .

In Worksheet Mode, input is made at an input
prompt with a slanted cursor, .
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Text ModeMath Mode

To convert a 1-D Math expression to 2-D
Math, right-click the expression (Command-
click, Macintosh) and select Convert To →
2-D Math Input.

To convert a 2-D Math expression to 1-D
Math, right-click the expression (Com-
mand-click, Macintosh) and select 2-D Math
→ Convert To → 1-D Math Input.

All input must end with a semi-colon ( ; ) or
a colon ( : ).

No termination symbol is required.

Using palettes while in 1-D Math teaches you
the related Maple command syntax.

Palettes make entering expressions in familiar
notation easier than entering foreign syntax
and reduces the possibility of introducing
typing errors.

If you prefer 1-D Math input, you can change the default math input notation.

To change math input notation for a session or globally across all docu-
ments:

1. From the Tools menu, select Options. The Options Dialog opens.

2. Click the Display tab.

3. In the Input Display drop-down list, select Maple Notation.

4. Click the Apply to Session or Apply Globally button.

Important: The new input display becomes the default setting after pressing
the Enter key.

Palettes
Palettes are collections of related items that you can insert into a document
by clicking or drag-and-dropping. The Maple environment provides access
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to over 20 palettes containing items such as symbols , layouts

mathematical operations and much more.

By default, palettes are displayed in the left pane of the Maple environment
when you launch Maple. If the palettes are not displayed,

1. From the View menu, select Palettes.

2. Select Expand Docks.

3. Right-click (Control-click, Macintosh) the palette dock. From the context
menu, select Show All Palettes.

Alternatively, from the main menu, select View → Palettes → Arrange
Palettes to display specific palettes.

You can create a Favorites palette of the expressions and entities you use
often by right-clicking (Control-click, Macintosh) the palette template you
want to add and selecting Add To Favorites Palette from the context menu.
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Table 1.7: Palette Categories

Palette DescriptionPalette Category

Expression - construct expressions such as integrals .
Matrix - enter the number of rows and columns required, des-
ignate type, such as zero-filled, and designate shape, such as
diagonal.
Layout - add math content that has specific layout, such as ex-

pressions with one or more superscripts and subscripts .
Components - embed graphical interface components such as
a button into your document or worksheet. Components can be
programmed to perform an action when selected such as execut-

ing a command when a button is clicked .
Handwriting - an easy way to find a desired symbol.
Units (SI) - insert a unit from the International System of Units

(SI), or any general unit .
Units (FPS) - insert a unit from the Foot-Pound-Second System
(FPS), or any general unit .

Accents - insert decorated names, such as an with an arrow

over it to denote a vector .
Favorites - add templates that you use most often from other
palettes.

Expression Palettes
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Palette DescriptionPalette Category

Palettes for constructing expressions

Common Symbols, Relational , Relational Round ,

Operators , Large Operators , Negated , Fenced
, Arrows , Constants and Symbols .

Punctuation - insert punctuation symbols such as the registered
trademark symbols for inserting into text regions
Miscellaneous - insert miscellaneous math and other symbols
outside the above categories .

Mathematical Palettes

Greek, Script , Fraktur , Open Face , Cyrillic ,
Diacritical Marks , Roman Extended Upper Case ,
Roman Extended Lower Case .

Alphabetical Palettes

28   •   1  Getting Started



Viewing and Arranging Palettes

By default, palettes display in palette docks at the right and left sides of the
Maple window. To view and manage palettes and palette docks, see Table
1.8.

Table 1.8: Managing Palettes

To view palette docks:
From the View menu, select Palettes, and
then Expand Docks. There are docks on
the far right and left of the window.
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To add a palette:
1. Right-click the palette dock. Maple
displays a context menu near the palette.
2. From the context menu, select Show
Palette and then select the palette.

To expand or collapse a palette in the
palette dock:
Click the triangle at the left of the palette
title.
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To move a palette in the palette dock:
Move the palette by clicking the title and
dragging the palette to the new location.

To expand or collapse the palette
docks:
Select the appropriate triangle at the top
right or top left side of the palette region.

Example 3 - Enter an Expression Using Palettes

Review the following example:

= 

In this example, we will enter and evaluate the expression.
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Result in DocumentAction

1. Place the cursor in a new document block. In the
Expression palette, click the summation template

. Maple inserts the summation symbol with
the range variable placeholder highlighted.

2. Enter i and then press Tab. The left endpoint
placeholder is selected. Notice that the color of the
range placeholder has changed to black. Each
placeholder must have an assigned value before
you execute the expression. The Tab key advances
you through the placeholders of an inserted palette
item.

3. Enter 1 and then press Tab. The right endpoint
placeholder is selected.

4. Enter 10 and then press Tab. The expression
placeholder is selected.

5. Enter For instructions on entering
this type of expression, see the previous example,
Example (page 9).

= 

6. Press Ctrl + = (Command + = for Macintosh)
to evaluate the summation.

Handwriting Palette

The Handwriting palette provides another way to find and insert desired
symbols easily.

1. Draw the symbol with your mouse in the space provided.
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2. Click the recognize button, . Maple matches your input
against symbols available in the system. See Figure 1.3.

3. To view more symbols (where indicated with a box around the result),
click the displayed symbol and choose one of the selections from the drop-
down menu.

4. To insert a symbol, click the displayed symbol.

Figure 1.3: Handwriting Palette

For more information, refer to the ?handwritingpalette help page.

Symbol Names
Each symbol has a name, and some have aliases. By entering its name (or
an alias) in Math mode, you can insert the symbol.

Note: If you hover the mouse pointer over a palette item, a tooltip displays
the symbol's name.

To enter a symbol quickly, you can enter the first few characters of its name
and then press the completion shortcut key (see Shortcut Keys by Plat-
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form (page xiv)). Symbol completion works in the same way as command
completion (see Command Completion (page 55)).

• If a unique symbol name matches the characters entered, Maple inserts
the corresponding symbol.

• If multiple symbol names match the characters entered, Maple displays
the completion list, which lists all matches, including commands. To
select an item, click its name or symbol.

Example 4 - Square Root

To find the square root of :

Result in DocumentAction

1. In a new document block, enter sqrt.

2. Press the symbol completion shortcut
key, Ctrl + Space in Windows. Maple
displays a pop-up list of exact matches.

3. In the completion list, select
. Maple inserts the

symbol with the placeholder selected.

4. Enter 

= 5. Press Ctrl + = (Command + =,
Macintosh).

Example 5 - Complex Numbers

Notice that when you type the letter i in Math mode, it is in italics. This letter

is not the same as the imaginary unit denoted by I or i in Maple.

Multiply two complex numbers, and :
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Result in DocumentAction

1. In a new document block, enter

2. Press the symbol completion
shortcut key. Maple displays a pop-
up list of partial and exact matches,
including symbols and commands.

3. Select the imaginary unit,
.

4. Close the parentheses, enter a
space (for implicit multiplication),
and type the second expression in
parentheses, using symbol comple-
tion for the second imaginary num-
ber.

= 5. Press Ctrl + = (Command + =,
Macintosh) to evaluate the product.

Toolbar Icons
In the introduction section, you learned about the toolbar icons and context
toolbars available in Maple (see Toolbar Options (page 10)). The toolbar
can be used to format your document, alter plots and animations, draw in a
canvas, write in both Math and Text modes in one line and much more. The
last of these is demonstrated in the next example.
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Example 6 - Enter Text and 2-D Math in the Same Line Using
Toolbar Icons

Enter the following sentence:

Evaluate

and write in simplest terms.

Result in DocumentAction

To enter this sentence:
1. Select the Text icon and enter Evalu-
ate.

2. Select the Math icon.
3. From the Expression palette, select

the definite integration template, .
The expression is displayed with the first
placeholder highlighted.

4. With the first placeholder highlighted,
enter 1, then press Tab.
5. Enter 5 and press Tab to highlight the
integrand region.

6. Enter (3x^2 and press the right arrow
to leave the superscript position.
7. Enter + 2.
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Result in DocumentAction

8. Press the Space bar for implicit multi-
plication. Enter sqrt and press Ctrl +
Space to show the command completion
options. Maple displays a pop-up list of
exact matches. Select the square root
symbol, . Maple inserts the symbol
with the x placeholder selected. Alternat-
ively, select the square root symbol from
the Expression palette.

9. Enter x, then press the right arrow to
leave the square root region.
10. Enter + 3, and then press the Space
bar.
11. Select the n-th root symbol from the

Expression palette, .

12. Enter 3, then press Tab.
13. Enter x), then press Tab.
14. Enter x for the integration variable.

15. Click the Text icon in the toolbar,
then enter the rest of the sentence: "and
write in simplest terms."

1.3  Point-and-Click Interaction
Maple contains many built-in features that allow you to solve problems
quickly without having to know any commands.
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Assistants
Maple offers a set of assistants in the form of graphical user interfaces to
perform many tasks without you needing to use any syntax. An example of
an assistant is shown in Figure 1.4.

Figure 1.4: Optimization Assistant

Using the Tools → Assistants menu, you can access tools to help you ac-
complish various tasks. See Figure 1.5. In some cases, you can launch an
assistant by entering an expression and selecting the assistant from the context
menu that displays.
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Figure 1.5: Accessing the Assistants from the Tools Menu

Example 7 - Curve Fitting Assistant

Enter a data sample and use the Curve Fitting Assistant to find the best
approximation of a function to fit the data.
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Result in DocumentAction

1. From the Tools
menu, select Assist-
ants → Curve Fit-
ting. The first dialog
in the Curve Fitting
Assistant appears.
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Result in DocumentAction

2. Enter data as Inde-
pendent Values and
Dependent Values.
Alternatively, you
could import a file
containing data. If
you have more data
than the space
provided, click the
Next Page button for
more space. For this
example, enter the
data as shown.

3. Once you have
entered the data,
click the Fit button.
The second dialog of
the Curve Fitting
Assistant appears.
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Result in DocumentAction

4. In this dialog, you
can plot the data and
several types of inter-
polations, including
Polynomial, Spline,
and Least Squares.
For example, click
the Plot button in the
Polynomial Interpol-
ation section. The
polynomial is plotted
with the data, and the
interpolating func-
tion is displayed be-
low.

5. You can choose to
return either the inter-
polating function or
the plot to your docu-
ment. When fin-
ished, click Done.

Descriptions of Assistants

The remaining assistants are described below. Some of the assistants are in-
terfaces to package commands. For more information on package commands,
see Package Commands (page 53).

• Back-Solver - an interface that allows you to take a mathematical for-
mula, involving multiple parameters, enter values for all but one of the
parameters and solve for the remaining value. You can also plot the be-
havior of the formula as one of the parameters change.

• Curve Fitting - an interface to commands in the CurveFitting package.
Data points can be entered as independent and dependent values, and
interpolated with polynomials, rational functions, or splines.
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• Data Analysis - an interface to the data analysis commands in the Stat-
istics package.

• Import Data - an interface to read data from an external file into Maple.

• Installer Builder - an interface to the InstallerBuilder package in which
you can create installers for your Maple toolboxes. For information on
toolboxes, go to http://www.maplesoft.com/developers/index.aspx.

• Library Browser - an interface to manipulate the libraries in a specified
directory.

• Maplet Builder - an interface to the Maplets package. The Maplets
package contains commands for creating and displaying Maplet applica-
tions (point-and-click interfaces). Using the Maplet Builder, you can
define the layout of a Maplet, drag-and-drop elements (visual and func-
tional components of Maplets), set actions associated with elements, and
directly run a Maplet application. The Maplet Builder is available in the
Standard interface only.

• ODE Analyzer - an interface to obtain numeric or symbolic solutions
to a single ordinary differential equation (ODE) or a system of ODEs
and plot a solution of the result.

• Optimization - an interface to the solver commands in the Optimization
package. The Optimization package is a collection of commands for
numerically solving optimization problems, which involves finding the
minimum or maximum of an objective function possibly subject to con-
straints.

• Plot Builder - an interface for creating two and three-dimensional plots,
animations, and interactive plots.

• Scientific Constants - an interface to over 20 000 values of physical
constants and properties of chemical elements. All of these constants
come with the corresponding unit and, if applicable, with the uncertainty
or error, that is, how precisely the value of this constant is known.

• Special Functions - an interface to the properties of over 200 special
functions, including the Hypergeometric, Bessel, Mathieu, Heun and
Legendre families of functions.

1.3  Point-and-Click Interaction   •   43

http://www.maplesoft.com/developers/index.aspx


• Units Calculator - an interface to convert between 500 units of measure-
ment.

Tutors
Maple provides over 40 interactive tutors to aid in the learning of

• Precalculus

• Calculus

• Multivariate Calculus

• Vector Calculus

• Differential Equations

• Linear Algebra

These tutors are easily accessible in the Tools menu by selecting Tutors.
See Figure 1.10.

Figure 1.10: Accessing Tutors from the Tools Menu

Some of the tutors can also be accessed through the Student package. The
Differential Equations tutor, DE Plots, is accessible through the DEtools
package. For a definition of the term package, see Package Com-
mands (page 53).
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The Student package is a collection of subpackages designed to assist with
the teaching and learning of standard undergraduate mathematics. The sub-
packages contain many commands for displaying functions, computations,
and theorems in various ways, and include support for stepping through im-
portant computations.

The interactive commands help you explore concepts and solve problems
using a point-and-click interface. These commands launch tutors that provide
a graphical interface to some of the visualization and computation commands
described above. See Figure 1.11 for an example of one of the tutors.

Figure 1.11: Calculus - Single Variable → Differentiation Methods Tutor
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Context Menus
A context menu is a dynamically generated menu of actions that are applic-
able for the region upon which it is invoked. Context menus allow you to
perform calculations and manipulations on expressions without using Maple
syntax. To display a context menu, right-click an object, expression, or region.
Context menus are available for many input regions, including:

• expressions to perform calculations, manipulations, or plotting

• plot regions to apply plot options and manipulate the plot

• tables to modify the table properties

• palette regions to add or remove palettes and palette regions

• text regions to add annotations and format text

• spreadsheets to manipulate the spreadsheet

When performing calculations or manipulations on an expression, a self-
documenting arrow or equal sign connects the input and output, indicating
the action that took place. See Figures 1.12 and 1.13 for two examples of
context menus.

46   •   1  Getting Started



Figure 1.13: Right-click the plot to see a
menu of plot options

Figure 1.12: Right-click the expression to
see a menu of applicable operations

Task Templates
Task templates help you perform specific tasks in Maple, such as:

• performing a mathematical computation such as solving an equation
symbolically or numerically, or determining the Taylor approximation
of a function of one variable

• constructing a Maple object such as a function

• creating a document such as an application
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Each task contains a description along with a collection of content that you
can insert directly into your document. Content consists of 2-D mathematics,
commands, embedded components (for example, buttons), and plots. You
specify the parameters of your problem and then execute the commands in
the document. See Figure 1.14 for an example of a Task Template.

Figure 1.14 Browse Tasks Dialog

Previewing Tasks

To preview Maple tasks,

• From the Tools menu, select Tasks, and then Browse. The Browse
Tasks dialog opens and displays the list of tasks.
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The tasks are sorted by subject to help you quickly find the desired task. In
the Browse Tasks dialog, you can view tasks without inserting them into
your document.

Inserting a Task into the Document

To insert a task into your document,

1. Select the Insert into New Worksheet check box to insert the task into
a new document.

2. Click one of the insert buttons.

• Click the Insert Default Content button. Maple inserts the default con-
tent. The default content level is set using the Options dialog. For instruc-
tions, see the ?usingtasks help page.

• Click the Insert Minimal Content button. Maple inserts only the com-
mands and embedded components, for example, a button to launch the
related assistant or tutor.

• Click the Copy Task to Clipboard button. Place the cursor where you
want to insert the task, and then paste the task. Maple inserts the default
content. Use this method to quickly insert a task multiple times.

Note: You can view the history of previously inserted tasks. From the Tools
menu, select Tasks. Previously selected task names are displayed below the
Browse menu item.

Before inserting a task, Maple checks whether the task variables have as-
signed values in your document. If any task variable is assigned, the Task
Variables dialog opens to allow you to modify the names. Maple uses the
edited variable names for all variable instances in the inserted task.

By default, the Task Variables dialog is displayed only if there is a naming
conflict. You can set it to display every time you insert a task.
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To specify that the Task Variables dialog be displayed every time you
insert a task:

1. From the Tools menu, select Options.

2. Click the Display tab.

3. In the Show task variables on insert drop-down list, select Always.

4. Click Apply to Session or Apply Globally, as necessary.

Updating Parameters and Running the Commands

In inserted Task Templates, parameters are marked as placeholders (in purple
text) or specified using sliders or other embedded components.

1. Specify values for the parameters in placeholders or using graphical inter-
face components. You can move to the next placeholder by pressing Tab.

2. Execute all commands in the task by:

• Placing the cursor in the first task command, and then pressing Enter
repeatedly to execute each command.

• Selecting all the template commands, and then clicking the execute
toolbar icon .

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the ?tasks help page.

Exploration Assistant
The Exploration Assistant allows you to interactively make parameter changes
to expressions and view the result. The assistant can be used with almost
any Maple expression or command that has at least one variable or parameter.

To launch the Exploration Assistant:

1. Enter an expression or command.
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2. Right-click (Control-click, Macintosh) the expression or command. From
the context menu, select Explore.

3. The Explore parameter selection dialog appears, where you can select the
parameters to explore and their ranges. See Figure 1.15.

If you enter integer ranges, only integer values are allowed for parameters.
To allow floating-point values, enter floating-point ranges.

Select skip for any of the parameters to leave that parameter as a variable.

Figure 1.15: Explore parameter selection dialog

4. Click Explore to continue to the Expression Explorer. The explorer
opens in a new Maple tab, with the expression and parameters filled in. You
can use the slider or sliders to change the parameters and see your changes
as the expression output is updated. See Figure 1.16.

Figure 1.16: Exploration Assistant
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5. Once you are finished interacting with the assistant, you can copy and
paste the results into your document, or save the interactive document for
later use.

Example:

Enter the following command and explore the parameters with ranges a =
0..10.0, b = -5.0..5.0.

1.4  Commands
Even though Maple comes with many features to solve problems and manip-
ulate results without entering any commands, you may find that you prefer
greater control and flexibility by using the set of commands and programming
language that Maple offers.

The Maple Library
Commands are contained in the Maple library, which is divided into two
groups: the main library and packages.

• The main library contains the most frequently used Maple commands.

• Packages contain related commands for performing tasks from disciplines
such as Student Calculus, Statistics, or Differential Geometry. For ex-
ample, the Optimization package contains commands for numerically
solving optimization problems.

For details on top-level and package commands, see Commands (page 96).

Entering Commands
If you want to interact with Maple using commands, simply enter the com-
mand using 2-D math. Notice that commands and variable names display in
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italics. Maple commands are constructed in a format similar to command(ar-
guments), based on the command you are using.

For example, to factor an expression, enter:

To differentiate an expression, enter:

To integrate an expression in the range [ enter:

To plot an expression, enter:

 

For a list of the top commands in Maple, see Top Commands (page 98).

Package Commands

There are two ways to access commands within a package, using the long
form of the package command or the short form.
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Long Form of Accessing Package Commands:

The long form specifies both the package and command names using the
syntax package[command](arguments).

Short Form of Accessing Package Commands:

The short form makes all of the commands in the package available using
the with command, with(package). If you are using a number of commands
in a package, loading the entire package is recommended. When you execute
the with command, a list of all commands in the package displays. To sup-
press the display of all command names, end the with(package) command
with a colon. Alternatively, you can load packages through the Tools menu,
by selecting Load Package, and then the package name.

(1.1)

After loading a package, you can use the short-form names, that is, the
command names, without the package name.

(1.2)

For a list of the top packages in Maple, see Top Packages (page 101).
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Command Completion

To help with syntax and reduce the amount of typing when entering Maple
commands, you can use command completion. Command completion displays
a list of all Maple packages, commands, and functions that match the entered
text. If there are multiple ways to call a command, then the command com-
pletion list contains each one, with appropriate placeholders.

To use command completion:

1. Begin entering a command or package name.

2. Select Tools → Complete Command or use the shortcut key for your
operating system (see Shortcut Keys by Platform (page xiv)). If there is a
unique completion, it is inserted. Otherwise, a list of possible matches is
displayed.

3. Select the correct completion from the list.

4. Some inserted commands have placeholders, denoted by purple text. The
first placeholder is highlighted after you insert it into the document. Replace
it with your parameter, then move to the next placeholder by pressing the
Tab key.
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Equation Labels

Equation labels help to save time entering expressions by referencing Maple
output. The label is associated with the last output within an execution group.
See Figure 1.17.

By default, equation labels are displayed. If equation labels are not displayed,

1. From the Tools menu, select Options, and click the Display tab. Ensure
that the Show equation labels check box is selected.

2. From the Format menu, select Labels. Ensure that both Execution Group
and Worksheet are selected.

Figure 1.17: Equation Label

To apply equation labels:

1. Enter an expression and press Enter. Note that the equation label is dis-
played to the right of the answer in the document.

2. In a new execution group, enter another expression that will reference the
output of the previous execution group.

3. From the Insert menu, select Label. Alternatively, press Ctrl+L (Com-
mand+L, for Macintosh) to open the Insert Label dialog. Enter the label
number in the Insert Label dialog and click OK. The item is now a label.
See Figure 1.18.
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Figure 1.18: Inserting an Equation Label

4. Press Enter to obtain the result.

To change the format of equation labels:

• Select Format → Labels → Label Display. In the Format Labels dia-
log, select one of the numbering schemes.

• Optionally, enter an appropriate numbering prefix.

Figure 1.19: Format Labels Dialog: Adding a Prefix
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The Label Reference menu item allows you to switch between the label
name and its reference content. Place the cursor on the referenced equation
label and select Format → Labels → Label Reference.

Figure 1.20: Label Reference

You cannot apply equation labels to the following:

• Error, warning, and information messages

• Tables, images, plots, sketches, or spreadsheets

Document Blocks
In Document mode, content is created as a series of document blocks. Doc-
ument blocks allow you to hide the syntax used to perform calculations,
which in turn lets you focus on the concept presented instead of the command
used to manipulate or solve the problem. You can also create document
blocks in Worksheet mode to perform the same function. Document blocks
are typically collapsed to hide the Maple code, but these regions can also be
expanded to reveal this code.

To create a document block:

From the Format menu, select Create Document Block. If text or math in
one or more execution groups is selected, then a document block is created
that contains those execution groups. If not, a new document block is created
after the current execution group. For more information, see the next example.

Document block regions are identified using markers that are located in a
vertical bar along the left pane of the document. See Figure 1.21. In addition
to document block boundaries, these markers (icons) indicate the presence
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of hidden attributes in the document such as annotations, bookmarks, and
numeric formatting.

To activate markers:

From the View menu, select Markers. See Figure 1.21.

Figure 1.21: Document Block Markers

To view code in a document block:

1. Place the cursor in a document block to be expanded.

2. From the View menu, select Expand Document Block.

Figure 1.22: Expanded Document Block

With the Document Block expanded, you can see the Maple command that
was used to perform this calculation. In Figure 1.22, the solve command was
used.

Also notice a red prompt (>) before the original expression and the solve
command. Entering commands outside of a document block region is done
at this input region. To insert an input region, click the button in the
toolbar menu.
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In Figure 1.22, an equation label was used to refer to the expression. For
more information, see Equation Labels (page 56).

To collapse a Document Block:

• With your cursor inside the document block, select View → Collapse
Document Block.

You can use this process of expanding document blocks to begin learning
Maple commands.

Changing the Display:

You can specify which parts of the input and output are displayed when the
document block is collapsed. For each execution group in the block, you can
choose to display either the input or the output.

• Place the cursor in the execution group.

• From the View menu, select Toggle Input/Output Display.

Also, you can choose to display output either inline or centered on a new
line.

• From the View menu, select Inline Document Output.

Example 8 - Creating a Document Block in Worksheet Mode

In Worksheet mode, you can create the content using commands, and then
use a document block to choose how much information to display.

Enter the following sentence using text and 2-D Math input and output:

The answer to is .
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1. At an input prompt, click the text icon, ,
to enter plain text. Enter "The answer to ". Note:
these instructions are for Worksheet mode.

2. Click the input prompt icon, , to enter

Maple commands. Enter , and then

press Enter to execute the command.

3. Again, click the text icon to insert the rest of
the text, "is", and then enter another input
prompt icon. Make sure to put spaces around
all of the text, so the sentence displays properly.

4. To display the same output again, use the
value command and an equation label. This al-
lows you to insert text between the input and
output of a single command: there are really
two commands.
Enter and execute the command, as shown.

5. To finish the sentence, click the text icon in
the last execution group and enter a period.

6. Select the entire sentence, then from the
Format menu, select, Create Document Block.
By default, only the text and output remains
visible, and output is centered on a new line.

7. To display the text and output on one line,
place the cursor in the document block. From
the View menu, select Inline Document Out-
put.

The answer to is .8. To display input instead of output for the first
expression, place the cursor in the first expres-
sion. From the View menu, select Toggle In-
put/Output Display. Only the first region dis-
plays input.
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1.5  The Maple Help System
The Maple program provides a custom help system consisting of almost
5000 reference pages. The help system is a convenient resource for determ-
ining the syntax of Maple commands and for learning about Maple features.

Accessing the Help System
There are several ways to access the Maple help system:

• From the Help menu, select Maple Help

• Click in the toolbar

• In the document, execute the command ?topic, for example, enter
?LinearAlgebra and press Enter

The Maple help system opens in a separate window with two panes. The left
pane contains the Help Navigator where you initiate searches and browse
the table of contents, and the right pane displays the final search result, such
as a specific help page.
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Figure 1.23: Example Help Page

Every help page in Maple lists the command's calling sequence, parameters,
and a description, with examples of the command at the end of the page.
Some help pages also contain hyperlinks to related help pages and hyperlinks
to dictionary definitions. Hyperlinks to help pages display in green, while
hyperlinks to dictionary definitions display in dark red.

Using the Help Navigator
The Help Navigator contains a field for topic or text-based searches. The
Table of Contents tab provides a structured list of all topics in the help
system.
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To search the help system:

1. In the left pane, enter a string in the search field.

2. By default, a topic search is performed. To perform a text search, select
the Text radio button.

3. Enter the term and click Search.

• Topic searches reveal a list of matching topics sorted by the precision
of the match.

• Text searches reveal a list of topics based on keyword frequency.

• You can search all of the help system or specific Resources such as Help
Pages, Tasks, Tutorials, and Manuals by selecting the Resources drop-
down menu.

Search results are displayed as a list in the Search Results tab of the left
pane. Click the Table of Contents tab to view a structured list of all topics
in the help system.

To display potential matches in the right pane, click a topic preceded by an
icon. Table 1.9 describes the different icons.

Table 1.9: Help Page Icons

DescriptionIcon

A folder icon in the Table of Contents tab indicates that a topic can be expan-
ded into subtopics.

Question mark icon indicates a help page and displays the associated help page
in the right pane when selected.

WS icon indicates an example worksheet. Example worksheets open in a new
tab in the Maple document.

D icon indicates a definition and displays the associated dictionary definition
in the right pane when selected.

64   •   1  Getting Started



DescriptionIcon

T icon indicates a Task template and displays the associated Task Template
in the right pane when selected.

M icon indicates a manual. Manuals open in a new tab in the Maple document.

Viewing Help Pages as Documents
In the help system, examples are not executable.

The Maple help system allows you to open help pages as documents that
you can execute.

To open a help page as a document or worksheet:

• With the help page displayed in the right pane of the help system, from
the View menu, select Open Page as Worksheet. A new worksheet tab
opens and displays the help page as an executable document.

Alternatively, in the help system toolbar, click the open current help page in
a worksheet window icon.

Viewing Examples in 2-D Math
You can choose to view the examples in most help pages in either 1-D Math
(Maple input) or 2-D Math mode. The default is 1-D Math.

To change the math mode:

In the Maple help system:

• From the View menu, check or uncheck Display Examples with 2D
math.

• Click the 2-D Math icon, .

• Note: Some input in help pages displays as 1-D Math, no matter which
option you have chosen. This is for Maple procedures and other code
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that is best input in 1-D Math. For more information, see the ?helpnav-
igator help page.

Copying Examples
Instead of opening the entire page as a document, you can copy the Examples
section only.

To copy examples:

1. With the help page displayed in the right pane of the help system, from
the Edit menu, select Copy Examples.

2. Close or minimize the Help Navigator and return to your document.

3. In your document, place the cursor at the location where you want to paste
the examples.

4. From the Edit menu, select Paste. The Examples section of the help page
is inserted as executable content in your document.

1.6  Available Resources
Your work with Maple is supported by numerous resources.

Online Help and Examples

Help Pages

The online help system helps you find information about a specific topic,
command, package, or feature. You can access help three ways:

• From the Help menu, select Maple Help.

• In the toolbar, click the Help icon .

• In the document or worksheet, execute the command ?topicname. For
example, enter ?LinearAlgebra and then press Enter.
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Dictionary

More than 5000 mathematical and engineering terms with over 300 figures
and plots.

1. From the Help menu, select Maple Help.

2. Enter a search term. Dictionary entries that match your query are displayed
in the left pane with a icon.

Applications and Example Worksheets

Applications

Sample applications demonstrate how Maple can be used to find and docu-
ment a solution to a specific problem. Some applications allow for input or
contain animations that you can run; however, their primary use is for
demonstrations. Topics include DC Motor Control Design, Digital Filter
Design, Frequency Domain System Identification, Harmonic Oscillator,
Mathematical Model to Simulation Code, Mobile Robot Modeling and
Simulation, Radiator Design with CAD Systems, and Black-Scholes Model.

Examples

Example worksheets are executable documents covering topics that demon-
strate syntax or invoke a user interface to make complex problems easy to
solve and visualize. You can copy and modify the examples as needed.
Topics include Algebra, Calculus, Connectivity, Discrete Mathematics,
General Numerics and Symbolics, and Integral Transforms.

• From the Help menu, select Manuals, Resources, and more, and then
Applications and Examples.

Online Manuals

Online manuals, including the Maple Programming Guide and this manual.
You can execute examples, copy content into other documents, and search
the contents using the Maple Help System.
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• From the Help menu, select Manuals, Resources, and more and then
Manuals.

Task Templates

Set of commands with placeholders that you can use to quickly perform a
task. For details, see Task Templates (page 47).

• From the Tools menu, select Tasks, and then Browse.

Maple Tour and Quick Resources

Maple Tour

The Maple Tour consists of interactive sessions on several of the following
topics: Ten Minute Tour, Numeric and Symbolic Computations, Matrix
Computations, Differential Equations, Statistics, Programming and Code
Generation, Units and Tolerances, and Education Assessment with Maple
T.A.

• From the Help menu, select Take a Tour of Maple.

Quick Help and Quick References

The Quick Help dialog is a list of key commands and concepts.

• From the Help menu, select Quick Help. Alternatively, press F1. For
additional information, click an item in the Quick Help.

The Quick Reference is a table of commands and information for new users
that opens in a new window. It contains hyperlinks to help pages for more
information.

• From the Help menu, select Quick Reference. Alternatively, press Ctrl
+ F2 (Command + F2, for Macintosh).
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Web Site Resources

Welcome Center

A Maple web site offering all of Maplesoft's key user resources in one
central location. In the Welcome Center, you can view sample applications,
participate in user forums, access exclusive premium content, and listen to
podcasts. You can also access our support services, view training videos,
download user manuals, and more.

(http://www.maplesoft.com/welcome)

Student Help Center

The Student Help Center offers a Maple student forum, online math Oracles,
training videos, and a math homework resource guide.

(http://www.maplesoft.com/studentcenter)

Teacher Resource Center

The Teacher Resource Center is designed to ensure you get the most out of
your Maple teaching experience. It provides sample applications, course
material, training videos, white papers, e-books, podcasts, and tips.

(http://www.maplesoft.com/teachercenter)

Application Center

Maple web site resource for free applications related to mathematics, educa-
tion, science, engineering, computer science, statistics and data analysis,
finance, communications, and graphics. Many applications are available in
translations (French, Spanish, and German).

You can also search for Education and Research PowerTools, which provide
free course curricula and are available as add-on Maple packages and courses.
PowerTools are developed by experts in their fields to help users configure
Maple for research in specific application areas.

1.6  Available Resources   •   69



(http://www.maplesoft.com/applications)

Training

Maplesoft offers a comprehensive set of complementary training materials.
From complete training videos to recorded training seminars to downloadable
documentation, you have many options to get familiar with Maplesoft
products. In addition, whether you are an expert or someone who is consid-
ering a new license purchase, a custom training session that is right for you
and/or your organization can be created.

(http://www.maplesoft.com/support/training)

MaplePrimes

A web community dedicated to sharing experiences, techniques, and opinions
about Maple and related products, as well as general interest topics in math
and computing.

(http://www.mapleprimes.com)

Technical Support

A Maple web site containing FAQs, downloads and service packs, links to
discussion groups, and a form for requesting technical support.

(http://www.maplesoft.com/support)

For a complete list of resources, refer to the ?MapleResources help page.
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2  Document Mode
Using the Maple software, you can create powerful interactive documents.
You can visualize and animate problems in two and three dimensions. You
can solve complex problems with simple point-and-click interfaces or easy-
to-modify interactive documents. You can also devise custom solutions using
the Maple programming language. While you work, you can document your
process, providing text descriptions.

2.1  In This Chapter
TopicsSection

• Comparison of document and worksheet
modes

Introduction

• Palettes

• Symbol Names

• Mathematical Functions

Entering Expressions - Overview of tools for
creating complex mathematical expressions

• Displaying the Value Inline

• Displaying the Value on the Following
Line

Evaluating Expressions - How to evaluate
expressions

• Updating a Single Computation

• Updating a Group of Computations

• Updating All Computations in a Docu-
ment

Editing Expressions and Regenerating Output
- How to update expressions and results

• Computing with Palettes

• Context Menus

• Assistants and Tutors

Performing Computations - Overview of
tools for computing and plotting

2.2  Introduction
Maple has two modes: Document mode and Worksheet mode.
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Document mode is designed for quickly performing calculations. You can
enter a mathematical expression, and then evaluate, manipulate, solve, or
plot it with a few keystrokes or mouse clicks. This chapter provides an
overview of Document mode.

Document mode sample:

Find the value of the derivative of at .

Integrate over the interval .

= 

Worksheet mode is designed for interactive use through commands and
programming using the Maple language. The Worksheet mode supports the
features available in Document mode described in this chapter. For informa-
tion on using Worksheet mode, see Chapter 3, Worksheet Mode (page 91).

Note: To enter a Maple input prompt while in Document mode, click 
in the Maple toolbar.

Important: In any Maple document, you can use Document mode and
Worksheet mode.
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Interactive document features include:

• Embedded graphical interface components, like buttons, sliders, and
check boxes

• Automatic execution of marked regions when a file is opened

• Tables

• Character and paragraph formatting styles

• Hyperlinks

These features are described in Chapter 7, Creating Mathematical Docu-
ments (page 333).

Note: This chapter and Chapter 1 were created using Document mode. All
of the other chapters were created using Worksheet mode.

2.3  Entering Expressions
Chapter 1 provided an introduction to entering simple expressions in 2-D
Math (see Entering Expressions (page 22)). It is also easy to enter mathem-
atical expressions, such as:

• Piecewise-continuous functions: 

• Limits: 

• Continued fractions: 

and more complex expressions.
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Mathematical expressions can contain the following symbols.

• Numbers: integers, rational numbers, complex numbers, floating-point
values, finite field elements, ...

• Operators: /, ...

• Constants: ...

• Mathematical functions: ...

• Names (variables): ...

• Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and
names, you can press the corresponding key, for example, 9, =, >, or x. Most
symbols are not available on the keyboard, but you can insert them easily
using two methods.
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Example 1 - Calculate a Partial Derivative
To insert a symbol, you can use palettes or symbol names.

Enter the partial derivative using palettes.

Result in DocumentAction

1. In the Expression palette, click the partial dif-

ferentiation item . Maple inserts the partial
derivative. The variable placeholder is selected.

2. Enter t, and then press Tab. The expression
placeholder is selected.

3. Enter . Note: To enter the exponential e,
use the expression palette or command comple-
tion.

To evaluate the integral and display the result inline, press Ctrl+= (Com-
mand+=, for Macintosh) or Enter. For more information, see Computing
with Palettes (page 79).

You can enter any expression using symbol names and the symbol completion
list.

Result in DocumentAction

1. Begin typing the name of the sym-
bol, diff, and press the symbol comple-
tion key (see Shortcut Keys by Plat-
form (page xiv)).
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Result in DocumentAction

2. Select the partial differentiation

item, .

3. Fill in placeholders as in the previ-
ous example.

Example 2 - Define a Mathematical Function

Define the function which doubles its input.

Result in DocumentAction

1. In the Expression palette, click the single vari-

able function definition item, .

2. Replace the placeholder f with the function
name, Press Tab to move to the next
placeholder.

3. Replace the parameter placeholder, a, with the
independent variable Press Tab.

4. Replace the output placeholder, y, with the de-
sired output, 

= 

= 

Note: To insert the right arrow symbol , you can also enter the characters
-> in Math mode. In this case, symbol completion is automatic.

Important: The expression is different from the function .

For more information on functions, see Functional Operators (page 407).
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2.4  Evaluating Expressions
To evaluate a mathematical expression, place the cursor in the expression
and press Ctrl + = (Command + =, for Macintosh). That is, press and hold
the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value
of the expression.

= 

You can replace the inserted equal sign with text or mathematical content.

To replace the equal sign:

1. Select the equal sign. Press Delete.

2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

is equal to 

In mathematical content, pressing Enter evaluates the expression and displays
it centered on the following line. The cursor moves to a new line below the
output.

(2.1)
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By default, Maple labels output that is generated by pressing Enter. For in-
formation on equation labels, see Equation Labels (page 114). In this manual,
labels are generally not displayed.

In text, pressing Enter inserts a line break.

You can use the basic algebraic operators, such as and , with most
expressions, including polynomials—see Polynomial Algebra (page 178)—and
matrices and vectors—see Linear Algebra (page 189).

= 

= 

2.5  Editing Expressions and
Updating Output
One important feature of Maple is that your documents are live. That is, you
can edit expressions and quickly recalculate results.

To update one computation:

1. Edit the expression.

2. Press Ctrl + = (Command + =, for Macintosh) or Enter.

The result is updated.

To update a group of computations:

1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.

3. Click the Execute toolbar icon .
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All selected results are updated.

To update all output in a Maple document:

• Click the Execute All toolbar icon .

All results in the document are updated.

2.6  Performing Computations
Using the Document mode, you can access the power of the advanced Maple
mathematical engine without learning Maple syntax. In addition to solving
problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

• Palettes

• Context menus

• Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also
supports Maple commands. For information on commands, see Com-
mands (page 96) in Chapter 3, Worksheet Mode (page 91).

Important: In Document mode, you can execute a statement only if you
enter it in Math mode. To use a Maple command, you must enter it in Math
mode.

Computing with Palettes
As discussed in Entering Expressions (page 73), some palettes contain
mathematical operations.

To perform a computation using a palette mathematical operation:

1. In a palette that contains operators, such as the Expression palette, click
an operator item.
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2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press Ctrl+= (Com-
mand+=, for Macintosh) or Enter.

For example, to evaluate inline:

1. Using the Expression palette, enter the partial derivative. See Example 1
- Calculate a Partial Derivative (page 75).

2. Press Ctrl+= (Command+=, for Macintosh).

= 

Context Menus
A context menu is a pop-up menu that lists the operations and actions you
can perform on a particular expression. See Figure 2.1.
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Figure 2.1: Context Menu

To display the context menu for an expression:

• Right-click (Control-click, for Macintosh) the expression.

The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus.

• The Evaluate and Display Inline operation (see Figure 2.1) is equivalent
to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an
equal sign (=) and then the value of the expression.

• The Evaluate operation (see Figure 2.1) is equivalent to pressing Enter.
That is, it evaluates the expression and displays the result centered on
the following line.

For more information on evaluation, see Evaluating Expressions (page 77).

From the context menu, you can also select operations different from evalu-
ation. To the right of the expression, Maple inserts a right arrow symbol (→)
and then the result.
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For example, use the Approximate operation to approximate a fraction:

You can perform a sequence of operations by repeatedly using context menus.

For example, to compute the derivative of use the Differentiate
operation on the expression, and then to evaluate the result at a point, use
the Evaluate at a Point operation on the output and enter 10:

The following subsections provide detailed instructions on performing a few
of the numerous operations available using context menus. Figures in the
subsections show related context menus or palettes.

Approximating the Value of an Expression

To approximate a fraction numerically:

1. Enter a fraction.

2. Display the context menu. See Figure 2.2.

3. From the context menu, select Approximate, and then the number of
significant digits to use: 5, 10, 20, 50, or 100.
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Figure 2.2: Approximating the Value of a Fraction

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow ( ):

1. Select the arrow and text. Press Delete.

2. Enter the replacement text or mathematical content.

Note: To replace the right arrow with text, you must first press F5 to switch
to Text mode.

For example, you can replace the arrow with the text "is approximately equal
to" or the symbol ≈.
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Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric)
solution of an equation. For more information on symbolic and numeric
computations, see Symbolic and Numeric Computation (page 120).

To solve an equation:

1. Enter an equation.

2. Display the context menu. See Figure 2.3.

3. From the context menu, select Solve or Numerically Solve in the Solve
menu item.
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Figure 2.3: Finding an Exact Solution to an Equation
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For more information on solving equations, including solving inequations,
differential equations, and other types of equations, see Solving Equa-
tions (page 131).

Using Units

You can create expressions with units. To specify a unit for an expression,
use the Units palettes. The Units (FPS) palette (Figure 2.4) contains import-
ant units from the foot-pound-second (FPS) system of units used in the United
States. The Units (SI) palette (Figure 2.5) contains important units from the
international system (SI) of units.

Figure 2.5: SI Units PaletteFigure 2.4: FPS Units Palette

To insert an expression with a unit:

1. Enter the expression.

2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.
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2. Right-click (Control-click, for Macintosh) the expression.

3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that con-
ducts 590 coulombs in 2.9 seconds.

For more information on using units, see Units (page 151).

Assistants and Tutors
Assistants and tutors provide point-and-click interfaces with buttons, text
input regions, and sliders. For details on assistants and tutors, see Point-and-
Click Interaction (page 37).

Assistants and tutors can be launched from the Tools menu or the context
menu for an expression. For example, you can use the Linear System
Solving tutor to solve a linear system, specified by a matrix or a set of
equations.

Example 3 - Using a Context Menu to Open the Linear System
Solving Tutor

Use the Linear System Solving tutor to solve the following system of linear
equations, written in matrix form:
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Result in DocumentAction

1. In a new document block, create
the matrix or set of linear equations
to be solved.

Loading Student:-LinearAlgebra2. Load the Student[LinearAl-
gebra] package. From the Tools
menu, select Load Package → Stu-
dent Linear Algebra. This makes
the tutors in that package available.
For details, see Package Com-
mands (page 53).

3. Right-click the matrix and select
Tutors → Linear Algebra → Lin-
ear System Solving.... The Linear
System Solving dialog appears,
where you can choose the solving
method. Gaussian Elimination re-
duces the matrix to row-echelon
form, then performs back-substitu-
tion to solve the system. Gauss
Jordan Elimination reduces the
matrix to reduced row-echelon form,
where the equations are already
solved. For this example, choose
Gaussian Elimination.
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Result in DocumentAction

4. The Gaussian Elimination dialog
opens. You can specify the Gaussian
elimination step-by-step, or you can
use the Next Step or All Steps but-
tons to have Maple perform the steps
for you.
5. Once the matrix is in row-echelon
(upper-triangular) form, click the
Solve System button to move to the
next step.

6. The Solve the system of equa-
tions in Row-Echelon Form dialog
appears. Click the buttons on the
right to calculate the solution: first
find the Equations, then solve for
each variable. Click the Solution
button to display the solution in the
tutor.
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Result in DocumentAction

7. Click the Close button to return
the solution to your document.

For more information on linear systems and matrices, see Plots and Anima-
tions (page 283).
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3  Worksheet Mode
The Worksheet mode of the Standard Worksheet interface is designed for:

• Interactive use through Maple commands, which may offer advanced
functionality or customized control not available using context menus
or other syntax-free methods

• Programming using the powerful Maple language

Using Worksheet mode, you have access to all of the Maple features described
in Chapter 1, and most of those described in Chapter 2, including:

• Math and Text modes

• Palettes

• Context menus

• Assistants and tutors

For information on these features, see Chapter 1, Getting Started (page 1)
and Chapter 2, Document Mode (page 71).

Note: Using a document block, you can use all Document mode features in
Worksheet mode. For information on document blocks, see Document
Blocks (page 58).

Note: This chapter and the following chapters were created using Worksheet
mode.
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3.1  In This Chapter
TopicsSection

• The Input Prompt (>)

• Suppressing Output

• 2-D and 1-D Math Input

• Input Separators

Input Prompt - Where you enter input

• The Maple Library

• Top-Level Commands

• Package Commands

• Lists of Common Commands and Pack-
ages

Commands - Thousands of routines for per-
forming computations and other operations

• Using PalettesPalettes - Items that you can insert by click-
ing or dragging

• Using Context MenusContext Menus - Pop-up menus of common
operations

• Launching Assistants and TutorsAssistants and Tutors - Graphical interfaces
with buttons and sliders

• Viewing Task Templates

• Inserting a Task Template

• Performing the Task

Task Templates - Sets of commands with
placeholders that you can insert and use to
perform a task

• Inserting a Text Region

• Formatting Text

Text Regions - Areas in the document in
which you can enter text

• Assigning to Names

• Unassigning Names

• Valid Names

Names - References to the expressions you
assign to them
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TopicsSection

• Displaying Equation Labels

• Referring to a Previous Result

• Execution Groups with Multiple Outputs

• Label Numbering Schemes

• Features of Equation Labels

Equation Labels - Automatically generated
labels that you can use to refer to expressions

3.2  Input Prompt
In Worksheet mode, you enter input at the Maple input prompt ( ). The
default mode for input is Math mode (2-D Math).

To evaluate input:

• Press Enter.

Maple displays the result (output) below the input.

For example, to find the value of , enter the expression, and then

press Enter.

> 

(3.1)

For example, compute the sum of two fractions.
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> 

(3.2)

Suppressing Output
To suppress the output, enter a colon (:) at the end of the input.

> 

A set of Maple input and its output are referred to as an execution group.

1-D Math Input
You can also insert input using Text mode (1-D Math). The input is entered
as a one-dimensional sequence of characters. 1-D Math input is red.

To enter input using 1-D Math:

• At the input prompt, press F5 or click the Text button in the toolbar,
, to switch from 2-D Math to 1-D Math.

123^2 - 29857/120;>

Important: 1-D Math input must end with a semicolon or colon. If you use
a semicolon, Maple displays the output; if you use a colon, Maple suppresses
the output.

123^2 - 29857/120:>
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To set the default input mode to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.

2. On the Display tab, in the Input display drop-down list, select Maple
Notation.

3. Click Apply to Session (to set for only the current session) or Apply
Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:

1. Select the 2-D Math input.

2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you
enter it in Math mode.

Input Separators
In 1-D and 2-D Math input, you can use a semicolon or colon to separate
multiple inputs in the same input line.

> 

If you do not specify a semicolon or colon, Maple interprets it as a single
input. This can either give unexpected results, as below, or an error.

> 
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3.3  Commands
Maple contains a large set of commands and a powerful programming lan-
guage. Most Maple commands are written using the Maple programming
language.

You can enter commands using 1-D or 2-D Math. You must use 1-D Math
input when programming in Maple. Basic Programming (page 439) provides
an introduction to Maple programming.

To learn how to use Maple commands, see the appropriate help page, or use
task templates. For more information, see The Maple Help System (page 62)
and Task Templates (page 108).

The Maple Library
Commands are contained in the Maple library, which is divided into two
groups: the top-level commands and packages.

• The top-level commands are the most frequently used Maple commands.

• Packages contain related specialized commands in areas such as student
calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the index help pages.
To access the index overview help page, enter ?index, and then press Enter.
For information on the Maple Help System, see The Maple Help Sys-
tem (page 62).

Top-Level Commands
To use a top-level command, enter its name followed by parentheses (( ))
containing any parameters. This is referred to as a calling sequence for the
command.
command(arguments)
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Note: In 1-D Math input, include a semicolon or colon at the end of the
calling sequence.

For example, to differentiate an expression, use the diff command. The re-
quired parameters are the expression to differentiate, which must be specified
first, and the independent variable.

> 

For a complete list of functions (commands that implement mathematical
functions), such as BesselI and AiryAi, available in the library, refer to the
?initialfunctions help page.

> 

For detailed information on the properties of a function, use the Function-
Advisor command.

> 

For detailed information on how to use a function in Maple, refer to its help
page.
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For example:

> 

Note: In 1-D and 2-D Math input, when accessing a help page using ?, you
do not need to include a trailing semicolon or colon.

Top Commands

Here are a few of the most frequently used Maple commands. A complete
list of top-level commands is available at Help → Manuals, Resources,
and more → List of Commands.

Table 3.1: Top Commands

DescriptionCommand Name

Create a two-dimensional and three-dimensional plot of functions.plot and plot3d

Solve one or more equations or inequalities for their unknowns.solve

Solve one or more equations using floating-point arithmetic.fsolve

Evaluate an expression at a given point.eval

Numerically evaluate expressions.evalf

Solve ordinary differential equations (ODEs).dsolve

Compute an indefinite or definite integral.int

Compute an ordinary or partial derivative, as the context dictates.diff

Calculate the limiting value of a function.limit

For symbolic summation. It is used to compute a closed form for an
indefinite or definite sum.

sum

Set variable properties and relationships between variables. Similar
functionality is provided by the assuming command.

assume/is

Compute the value of an expression under assumptions.assuming

Apply simplification rules to an expression.simplify

98   •   3  Worksheet Mode



DescriptionCommand Name

Distribute products over sums.expand

Normalize a rational expression.normal

Convert an expression to a different type or form.convert

Type-checking command. In many contexts, it is not necessary to
know the exact value of an expression; it suffices to know that an
expression belongs to a broad class, or group, of expressions that share
some common properties. These classes or groups are known as types.

type

Generalized series expansion.series

Apply a procedure to each operand of an expression.map

Package Commands
To use a package command, the calling sequence must include the package
name, and the command name enclosed in square brackets ([ ]).
package[command](arguments)

If you are frequently using the commands in a package, load the package.

To load a package:

• Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless
you suppress the output by entering a colon at the end of the calling se-
quence).

After loading a package, you can use its commands as top-level commands,
that is, without specifying the package name.

For example, use the NLPSolve command from the Optimization package
to find a local minimum of an expression and the value of the independent
variable at which the minimum occurs.
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> 

> 

> 

For more information on optimization, see Optimization (page 225).

To unload a package:

• Use the unwith command, specifying the package as an argument.

> 

To execute the examples in this manual, you may be required to use the un-
with command between examples.

Some packages contain commands that have the same name as a top-level
command. When you load one of these packages, Maple returns a warning.

For example, the plots package contains a changecoords command. Maple
also contains a top-level changecoords command.

> 

In general, this manual does not include the warning messages Maple returns.

To use the top-level command, unload the package. (For alternative methods
of accessing the top-level command, see the ?with help page.)
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Top Packages

Here are a few of the most frequently used Maple packages. A complete list
of packages is available in the Maple help system at Help → Manuals, Re-
sources, and more → List of Packages.

Table 3.2: Top Packages

DescriptionPackage Name

The Code Generation package is a collection of commands and
subpackages that enable the translation of Maple code to other
programming languages, such as C, Fortran, MATLAB®, Visual

Basic®, and

CodeGeneration

The Linear Algebra package contains commands to construct and
manipulate Matrices and Vectors, and solve linear algebra problems.
LinearAlgebra routines operate on three principal data structures:
Matrices, Vectors, and scalars.

LinearAlgebra

The Optimization package is a collection of commands for numer-
ically solving optimization problems, which involve finding the
minimum or maximum of an objective function possibly subject
to constraints.

Optimization

The Physics package implements computational representations
and related operations for most of the objects used in mathematical
physics computations.

Physics

The Real Domain package provides an environment in which
Maple assumes that the basic underlying number system is the field
of real numbers instead of the complex number field.

RealDomain

The Scientific Constants package provides access to the values
of various physical constants, for example, the velocity of light and
the atomic weight of sodium. This package provides the units for
each of the constant values, allowing for greater understanding of
an equation. The package also provides units-matching for error
checking of the solution.

ScientificConstants
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DescriptionPackage Name

The Scientific Error Analysis package provides representation
and construction of numerical quantities that have a central value
and an associated uncertainty (or error), which is a measure of the
degree of precision to which the quantity's value is known. Various
first-order calculations of error analysis can be performed with
these quantities.

ScientificErrorAna-
lysis

The Statistics package is a collection of tools for mathematical
statistics and data analysis. The package supports a wide range of
common statistical tasks such as quantitative and graphical data
analysis, simulation, and curve fitting.

Statistics

The Student package is a collection of subpackages designed to
assist with teaching and learning standard undergraduate mathem-
atics. The many commands display functions, computations, and
theorems in various ways, including stepping through important
computations.

The Student package contains the following subpackages:
• Calculus1 - single-variable calculus

• LinearAlgebra - linear algebra

• MultivariateCalculus - multivariate calculus

• NumericalAnalysis - numerical analysis

• Precalculus - precalculus

• VectorCalculus - multivariate vector calculus

Student

The Units package contains commands for unit conversion and
provides environments for performing calculations with units. It
accepts approximately 300 distinct unit names (for example, meters
and grams) and over 550 units with various contexts (for example,
standard miles and U.S. survey miles). Maple also contains two
Units palettes that allow you to enter the unit for an expression
quickly.

Units
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DescriptionPackage Name

The Vector Calculus package is a collection of commands that
perform multivariate and vector calculus operations. A large set of
predefined orthogonal coordinate systems is available. All compu-
tations in the package can be performed in any of these coordinate
systems. It contains a facility for adding a custom but orthogonal
coordinate system and using that new coordinate system for your
computations.

VectorCalculus

3.4  Palettes
Palettes are collections of related items that you can insert by clicking or
dragging. For example, see Figure 3.1.

Figure 3.1: Expression Palette

You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item

in the Expression palette.
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In 2-D Math, clicking the definite integration item inserts:

> 

1. Enter values in the placeholders. To move to the next placeholder, press
Tab. Note: If pressing the Tab key inserts a tab, click the Tab icon in
the toolbar.

2. To evaluate the integral, press Enter.

> 

In 1-D Math, clicking the definite integration item inserts the corresponding
command calling sequence.

int(f,x=a..b);>

Specify the problem values (using the Tab to move to the next placeholder),
and then press Enter.

int(tanh(x), x = 0..1);>

Note: Some palette items cannot be inserted into 1-D Math because they are
not defined in the Maple language. When the cursor is in 1-D Math input,
unavailable palette items are dimmed.

For more information on viewing and using palettes, see Palettes (page 25)
in Chapter 1.
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3.5  Context Menus
A context menu is a pop-up menu that lists the operations and actions you
can perform on a particular expression. See Figure 3.2.

Figure 3.2: Integer Context Menu

In Worksheet mode, you can use context menus to perform operations on 2-
D Math and output.

To use a context menu:

1. Right-click (Control-click, for Macintosh) the expression. The context
menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:

• The calling sequence that performs the operation

• The result of the operation
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Example 1 - Using Context Menus
Determine the rational expression (fraction) that approximates the floating-
point number .

Result in DocumentAction

> 1. Enter and execute the expression.

2. Right-click (Control-click, for Macintosh)
the output floating-point number.

> 3. From the context menu, select Conver-
sions → Rational. The inserted calling se-
quence includes an equation label reference
to the number you are converting.

Notice that an equation label reference has been used. For information on
equation labels and equation label references, see Equation Labels (page 114).

For more information on context menus, see Context Menus (page 80) in
Chapter 1.
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3.6  Assistants and Tutors
Assistants and tutors provide point-and-click interfaces with buttons, text
input regions, and sliders. See Figure 3.3.

Figure 3.3: ODE Analyzer Assistant

Launching an Assistant or Tutor
To launch an assistant or tutor:

1. Open the Tools menu.

2. Select Assistants or Tutors.

3. Navigate to and select one of the assistants or tutors.

For more information on assistants and tutors, see Assistants (page 38) in
Chapter 1.
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3.7  Task Templates
Maple can solve a diverse set of problems. The task template facility helps
you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in
the placeholders, and then execute the commands, or click a button.

The Task Browser (Figure 3.4) organizes task templates by subject.

To launch the Task Browser:

• From the Tools menu, select Tasks, and then Browse.

You can also browse the task templates in the Table of Contents of the Maple
Help System.
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Figure 3.4: Task Browser

For details on inserting and using task templates, see Task Tem-
plates (page 47). You can also create your own task templates for performing
common tasks. For details, refer to the ?creatingtasks help page.
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3.8  Text Regions
To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

• In the toolbar, click the Text region icon .

The default mode in a text region is Text mode.

In a text region, you can:

• Enter text with inline mathematical content by switching between Text
and Math modes. To toggle between Text mode and Math mode, press
F5 or click the Math and Text toolbar icons, . Note: The
mathematical content in a text region is not evaluated. To enter mathem-
atical content that is evaluated, enter it at an Input Prompt (page 93).

• Insert any palette item. Palette items are inserted in Math mode (2-D
Math). Note: After you insert a palette item, you must press F5 or click
the toolbar icon to return to Text mode.

You can format text in a text region. Features include:

• Character styles

• Paragraph styles

• Sections and subsections

• Tables

For more information on formatting documents, see Creating Mathematical
Documents (page 333).

3.9  Names
Instead of re-entering an expression every time you need it, you can assign
it to a name or add an equation label to it. Then you can quickly refer to the
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expression using the name or an equation label reference. For information
on labels, see the following section, Equation Labels (page 114).

Assigning to Names
You can assign any Maple expression to a name: numeric values, data
structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

> 

The assignment operator (:=) associates an expression with a name.

> 

Recall that you can enter using the following two methods.

• Use the Common Symbols palette

• In 2-D Math enter pi, and then press the symbol completion short cut
key. See Shortcuts for Entering Mathematical Expressions (page 7).

When Maple evaluates an expression that contains a name, it replaces the
name with its value. For example:

> 

For information on Maple evaluation rules, see Evaluating Expres-
sions (page 426).
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Mathematical Functions

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

> 

For information on creating functions, see Define a Mathematical Func-
tion (page 76).

> 

Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple
replaces -> with the right arrow symbol In 1-D Math, the characters
are not replaced.

For example, define a function that squares its argument.
square := x -> x^2:>

square(32);>

For more information on functions, see Functional Operators (page 407).

Protected Names

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.
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> 

Error, attempting to assign to `sin` which is 
protected

For more information, refer to the ?type/protected and ?protect help pages.

Unassigning Names
The unassign command resets the value of a name to itself. Note: You must
enclose the name in right single quotes (' ').

> 

> 

Right single quotes (unevaluation quotes) prevent Maple from evaluating
the name. For more information on unevaluation quotes, see Delaying
Evaluation (page 435) or refer to the ?uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 437).

Unassigning all names:

The restart command clears the Maple internal memory. The effects include
unassigning all names and unloading all packages. For more information,
refer to the ?restart help page.

Note: To execute the examples in this manual, you may be required to use
the unassign or restart command between examples.

Valid Names
A Maple name must be one of the following.

• A sequence of alphanumeric and underscore (_) characters that begins
with an alphabetical character. Note: To enter an underscore character
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in 2-D Math, enter a backslash character followed by an underscore
character, that is, \_.

• A sequence of characters enclosed in left single quotes (` `).

Important: Do not begin a name with an underscore character. Maple re-
serves names that begin with an underscore for use by the Maple library.

Examples of valid names:

• a

• a1

• polynomial

• polynomial1_divided_by_polynomial2

• `2a`

• `x y`

3.10  Equation Labels
Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.

> 

(3.3)

Using equation labels, you can refer to the result in other computations.

> 

(3.4)
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Displaying Equation Labels
Important: By default, equation labels are displayed. If equation label display
is turned off, complete both of the following operations.

• From the Format menu, select Labels, and then ensure that Worksheet
is selected.

• In the Options dialog (Tools→Options), on the Display tab, ensure that
Show equation labels is selected.

Referring to a Previous Result
Instead of re-entering previous results in computations, you can use equation
label references. Each time you need to refer to a previous result, insert an
equation label reference.

To insert an equation label reference:

• From the Insert menu, select Label. (Alternatively, press Ctrl+L;
Command+L, Macintosh.)

• In the Insert Label dialog (see Figure 3.5), enter the label value, and
then click OK.

Figure 3.5: Insert Label Dialog

Maple inserts the reference.
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For example:

To integrate the product of (3.3) and (3.4):
Result in DocumentAction

1. In the Expression palette, click the indefinite

integration item . The item is inserted and
the integrand placeholder is highlighted.

2. Press Ctrl+L (Command+L, for Macintosh).
3. In the Insert Label dialog, enter 3.3. Click
OK.

4. Press *.
5. Press Ctrl+L (Command+L, for Macintosh).
6. In the Insert Label dialog, enter 3.4. Click
OK.

> 

(3.5)

7. To move to the variable of integration place-
holder, press Tab.
8. Enter x.
9. To evaluate the integral, press Enter.

Execution Groups with Multiple Outputs
An equation label is associated with the last output within an execution
group.

> 
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(3.6)

> 

(3.7)

Label Numbering Schemes
You can number equation labels in two ways:

• Flat - Each label is a single number, for example, 1, 2, or 3.

• Sections - Each label is numbered according to the section in which it
occurs. For example, 2.1 is the first equation in the second section, and
1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

• From the Format menu, select Labels → Label Display. In the Format
Labels dialog (Figure 3.6), select one of the formats.

• Optionally, enter a prefix.
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Figure 3.6: Format Labels Dialog: Adding a Prefix

Features of Equation Labels
Although equation labels are not descriptive names, labels offer other import-
ant features.

• Each label is unique, whereas a name may be inadvertently assigned
more than once for different purposes.

• Maple labels the output values sequentially. If you remove or insert an
output, Maple automatically re-numbers all equation labels and updates
the label references.

• If you change the equation label format (see Label Numbering
Schemes (page 117)), Maple automatically updates all equation labels and
label references.

For information on assigning to, using, and unassigning names, see
Names (page 110).

For more information on equation labels, refer to the ?equationlabels help
page.

The following chapters describe how to use Maple to perform tasks such as
solving differential (and other types of) equations, producing plots and anim-
ations, and creating mathematical documents. The chapters were created
using Worksheet mode. Except where noted, all features are available in
both Worksheet mode and Document mode.
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4  Basic Computations
This chapter discusses key concepts related to performing basic computations
with Maple. It discusses important features that are relevant to all Maple
users. After learning about these concepts, you will learn how to use Maple
to solve problems in specific mathematical disciplines in the following
chapter.

4.1  In This Chapter
TopicsSection

• Exact Computations

• Floating-Point Computations

• Converting Exact Quantities to Floating-
Point Values

• Sources of Error

Symbolic and Numeric Computation - An
overview of exact and floating-point compu-
tation

• Important Integer Commands

• Non-Base 10 Numbers

• Finite Rings and Fields

• Gaussian Integers

Integer Operations - How to perform integer
computations

• Equations and Inequations

• Ordinary Differential Equations

• Partial Differential Equations

• Integer Equations

• Integer Equations in a Finite Field

• Linear Systems

• Recurrence Relations

Solving - How to solve standard mathematic-
al equations
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TopicsSection

Units
• Conversions

• Applying Units to an Expression

• Performing Computations with Units

• Changing the Current System of Units

• Extensibility

Scientific Constants
• Scientific Constants

• Element and Isotope Properties

• Value, Units, and Uncertainty

• Performing Computations

• Modification and Extensibility

Uncertainty Propagation
• Quantities with Uncertainty

• Performing Computations with Quantities
with Uncertainty

Units, Scientific Constants, and Uncertainty
- How to construct and compute with expres-
sions that have units, scientific constants, or
uncertainty

• Real Number Domain

• Assumptions on Variables

Restricting the Domain - How to restrict the
domain for computations

4.2  Symbolic and Numeric
Computation
Symbolic computation is the mathematical manipulation of expressions in-
volving symbolic or abstract quantities, such as variables, functions, and

operators; and exact numbers, such as integers, rationals, π, and The
goal of such manipulations may be to transform an expression to a simpler
form or to relate the expression to other, better understood formulas.
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Numeric computation is the manipulation of expressions in the context of
finite-precision arithmetic. Expressions involving exact numbers, for example,

are replaced by close approximations using floating-point numbers,
for example 1.41421. These computations generally involve some error.
Understanding and controlling this error is often of as much importance as
the computed result.

In Maple, numeric computation is normally performed if you use floating-
point numbers (numbers containing a decimal point) or the evalf command.
The plot command (see Plots and Animations (page 283)) uses numeric
computation, while commands such as int, limit, and gcd (see Integer Oper-
ations (page 125) and Mathematical Problem Solving (page 177)) generally
use only symbolic computation to achieve their results.

Exact Computations
In Maple, integers, rational numbers, mathematical constants such as π and
∞, and mathematical structures such as matrices with these as entries are
treated as exact quantities. Names, such as and

mathematical functions, such as and are sym-
bolic objects. Names can be assigned exact quantities as their values, and
functions can be evaluated at symbolic or exact arguments.

> 

Important: Unless requested to do otherwise (see the following section),
Maple evaluates expressions containing exact quantities to exact results, as
you would do if you were performing the calculation by hand, and not to
numeric approximations, as you normally obtain from a standard hand-held
calculator.
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> 

> 

> 

Floating-Point Computations
In some situations, a numeric approximation of an exact quantity is required.
For example, the plot command requires the expression it is plotting to
evaluate to numeric values that can be rendered on the screen: π cannot be
so rendered, but can be. Maple distinguishes approximate from

exact quantities by the presence or absence of a decimal point: is ap-

proximate, while is exact.

Note: An alternative representation of floating-point numbers, called e-
notation, may not include an explicit decimal point: 1e5 , 3e-

2 .

In the presence of a floating-point (approximate) quantity in an expression,
Maple generally computes using numeric approximations. Arithmetic in-
volving mixed exact and floating-point quantities results in a floating-point
result.
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> 

If a mathematical function is passed a floating-point argument, it normally
attempts to produce a floating-point approximation to the result.

> 

Converting Exact Quantities to Floating-Point
Values
To convert an exact quantity to a numeric approximation of that quantity,
use the evalf command or the Approximate context menu operation (see
Approximating the Value of an Expression (page 82)).

> 

By default, Maple computes such approximations using 10 digit arithmetic.
You can modify this in one of two ways:

• Locally, you can pass the precision as an index to the evalf call.

> 
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• Globally, you can set the value of the Digits environment variable.

> 

> 

For more information, see the ?evalf and ?Digits help pages.

Note: When appropriate, Maple performs floating-point computations directly
using your computer's underlying hardware.

Sources of Error
By its nature, floating-point computation normally involves some error.
Controlling the effect of this error is the subject of active research in Numer-
ical Analysis. Some sources of error are:

• An exact quantity may not be exactly representable in decimal form:

and are examples.

• Small errors can accumulate after many arithmetic operations.

• Subtraction of nearly equal quantities can result in essentially no useful
information. For example, consider the computation for

> 
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No correct digits remain. If, however, you use Maple to analyze this expres-
sion, and replace this form with a representation that is more accurate for
small values of a fully accurate 10-digit result can be obtained.

> 

> 

For information on evaluating an expression at a point, see Substituting a
Value for a Subexpression (page 426). For information on creating a series
approximation, see Series (page 217). For more information on floating-point
numbers, refer to the ?float and ?type/float help pages.

4.3  Integer Operations
In addition to the basic arithmetic operators, Maple has many specialized
commands for performing more complicated integer computations, such as
factoring an integer, testing whether an integer is a prime number, and de-
termining the greatest common divisor (GCD) of a pair of integers.

Note: Many integer operations are available as task templates
(Tools→Tasks→Browse, under Integer Operations).

You can quickly perform many integer operations using context menus. Se-
lecting an integer, and then right-clicking (for Macintosh, Control-clicking)
displays a context menu with integer commands, for example, Integer
Factors, which applies the ifactor command to compute the prime factoriz-
ation of the given integer. See Figure 4.1.
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Figure 4.1: Context Menu for an Integer

In Worksheet mode, Maple uses an equation label reference in the ifactor
calling sequence.

> 

(4.1)

> 

(4.2)

For more information on equation labels, see Equation Labels (page 114).

For more information on using context menus in Worksheet mode, see
Context Menus (page 105). For information on using context menus in Docu-
ment mode, see Context Menus (page 80).

You can also enter the ifactor command and specify the integer to factor as
an argument.
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> 

Maple has many other integer commands, including those listed in Table
4.1.

Table 4.1: Select Integer Commands

DescriptionCommand

absolute value (displays in 2-D math as )abs

factorial (displays in 2-D math as )factorial

prime factorizationifactor

greatest common divisorigcd

quotient of integer divisioniquo

remainder of integer divisionirem

integer approximation of nth rootiroot

test primalityisprime

integer approximation of square rootisqrt

maximum and minimum of a setmax, min

modular arithmetic (See Finite Rings and
Fields (page 129).)

mod

set of positive divisorsnumtheory[divisors]

> 

> 
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> 

> 

For information on finding integer solutions to equations, see Integer Equa-
tions (page 149).

Non-Base 10 Numbers and Other Number Systems
Maple supports:

• Non-base 10 numbers

• Finite ring and field arithmetic

• Gaussian integers

Non-Base 10 Numbers

To represent an expression in another base, use the convert command.

> 

> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 435).
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You can also use the convert/base command.

> 

Note: The convert/base command returns a list of digit values in order of
increasing significance.

Finite Rings and Fields

Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.

> 

By default, the mod operator uses positive representation (modp command).
Symmetric representation is available using the mods command.

> 

> 

For information on setting symmetric representation as the default, refer to
the ?mod help page.

The modular arithmetic operators are listed in Table 4.2.
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Table 4.2: Modular Arithmetic Operators

ExampleOperatorOperation

> +Addition

> -Subtraction

> *Multiplication (displays in 2-D Math as )

> ^(-1)Multiplicative inverse (displays in 2-D Math as
a superscript)

> /Division (displays in 2-D Math as )

> &^Exponentiation1

1To enter a caret (^) in 2-D Math, enter a backslash character followed by a caret, that is,
\^.

For information on solving an equation modulo an integer, see Integer
Equations in a Finite Field (page 149).

The mod operator also supports polynomial and matrix arithmetic over finite
rings and fields. For more information, refer to the ?mod help page.
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Gaussian Integers

Gaussian integers are complex numbers in which the real and imaginary
parts are integers.

The GaussInt package contains commands that perform Gaussian integer
operations.

The GIfactor command returns the Gaussian integer factorization.

> 

You can enter the imaginary unit using the following two methods.

• In the Common Symbols palette, click the i or j item. See
Palettes (page 25).

• Enter i or j, and then press the symbol completion key. See Symbol
Names (page 33).

Note: In 1-D Math input, enter the imaginary unit as an uppercase i (I).

The GIsqrt command approximates the square root in the Gaussian integers.

> 

For more information on Gaussian integers including a list of GaussInt
package commands, refer to the ?GaussInt help page.

4.4  Solving Equations
You can solve a variety of equation types, including those described in Table
4.3.
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Table 4.3: Overview of Solution Methods for Important Equation Types

Solution MethodEquation Type

solve and fsolve commandsEquations and inequations

ODE Analyzer Assistant (and dsolve command)Ordinary differential equations

pdsolve commandPartial differential equations

isolve commandInteger equations

msolve commandInteger equations in a finite field

intsolve commandLinear integral equations

LinearAlgebra[LinearSolve] commandLinear systems

rsolve commandRecurrence relations

Note: Many solve operations are available as task templates
(Tools→Tasks→Browse) and in context menus. Most of this section focuses
on other methods.

Solving Equations and Inequations
Using Maple, you can symbolically solve equations and inequations. You
can also solve equations numerically.

To solve an equation or set of equations using context menus:

1. Right-click (for Macintosh, Control-click) the equations.

2. From the context menu, select Solve (or Solve Numerically). See Figure
4.2.
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Figure 4.2: Context Menu for an Equation

In Worksheet mode, Maple inserts a calling sequence that solves the equation
followed by the solutions.

If you select Solve, Maple computes exact solutions.

> 

(4.3)
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> 

(4.4)

If you select Solve Numerically, Maple computes floating-point solutions.

> 

(4.5)

> 

(4.6)

For information on solving equations and inequations symbolically using
the solve command, see the following section. For information on solving
equations numerically using the fsolve command, see Numerically Solving
Equations (page 138).

Symbolically Solving Equations and Inequations

The solve command is a general solver that determines exact symbolic
solutions to equations or inequations. The solutions to a single equation or
inequation are returned as an expression sequence. If Maple does not find
any solutions, the solve command returns the empty expression sequence.

> 

It is recommended that you verify the solutions returned by the solve com-
mand. For details, see Working with Solutions (page 140).
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To return the solutions as a list, enclose the calling sequence in brackets ([
]).

> 

Expressions: You can specify expressions instead of equations. The solve
command automatically equates them to zero.

> 

Multiple Equations: To solve multiple equations or inequations, specify
them as a set or list.

> 

> 

Solving for Specific Unknowns: By default, the solve command returns
solutions for all unknowns. You can specify the unknowns for which to
solve.
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> 

To solve for multiple unknowns, specify them as a list.

> 

Transcendental Equations: In general, the solve command returns one
solution to transcendental equations.

> 

> 

To produce all solutions, set the _EnvAllSolutions environment variable to
true.

Note: To enter an underscore character (_) in 2-D Math, enter \_.

> 

> 
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Maple uses variables of the form _ZN~, where N is a positive integer, to
represent arbitrary integers. The tilde (~) indicates that it is a quantity with
an assumption. For information about names with assumptions, see Assump-
tions on Variables (page 171).

RootOf Structure: The solve command may return solutions, for example,
to higher order polynomial equations, in an implicit form using RootOf
structures.

> 

(4.7)

These RootOf structures are placeholders for the roots of the equation

The index parameter numbers and orders the
four solutions.

Like any symbolic expression, you can convert RootOf structures to a
floating-point value using the evalf command.

> 

(4.8)

Some equations are difficult to solve symbolically. For example, polynomial
equations of order five and greater do not in general have a solution in terms
of radicals. If the solve command does not find any solutions, it is recommen-
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ded that you use the Maple numerical solver, fsolve. For information, see
the following section, Numerically Solving Equations.

For more information on the solve command, including how to solve equa-
tions defined as procedures and how to find parametric solutions, refer to
the ?solve/details help page.

For information on verifying and using solutions returned by the solve
command, see Working with Solutions (page 140).

Numerically Solving Equations

The fsolve command solves equations numerically. The behavior of the
fsolve command is similar to that of the solve command.

> 

> 

(4.9)

Note: You can also numerically solve equations using the context menus.
See Solving Equations and Inequations (page 132).

It is recommended that you verify the solutions returned by the fsolve com-
mand. For details, see Working with Solutions (page 140).

Multiple Equations: To solve multiple equations, specify them as a set. The
fsolve command solves for all unknowns.

> 

Univariate Polynomial Equations: In general, the fsolve command finds
one solution. However, for a univariate polynomial equation, the fsolve
command returns all real roots.

138   •   4  Basic Computations



> 

> 

Controlling the Number of Solutions: To limit the number of roots returned,
specify the maxsols option.

> 

To find additional solutions to a general equation, use the avoid option to
ignore known solutions.

> 

(4.10)

Complex Solutions: To search for a complex solution, or find all complex
and real roots for a univariate polynomial, specify the complex option.

> 

If the fsolve command does not find any solutions, it is recommended that
you specify a range in which to search for solutions, or specify an initial
value.

Range: To search for a solution in a range, specify the range in the calling
sequence. The range can be real or complex.
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> 

The syntax for specifying a region in the complex plane is lower-left
point..upper-right point.

> 

Initial Values: You can specify a value for each unknown. The fsolve
command uses these as initial values for the unknowns in the numerical
method.

> 

(4.11)

For more information and examples, refer to the ?fsolve/details help page.

For information on verifying and using solutions returned by the fsolve
command, see the following section, Working with Solutions.

Working with Solutions

Verifying: It is recommended that you always verify solutions (that the solve
and fsolve commands return) using the eval command.

> 

> 

(4.12)
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> 

(4.13)

> 

> 

(4.14)

> 

(4.15)

For more information, see Substituting a Value for a Subexpression (page 426).

Assigning the Value of a Solution to a Variable: To assign the value of a
solution to the corresponding variable as an expression, use the assign
command.

For example, consider the numeric solution to equation2,
(4.11), found using the starting value .

> 

> 

(4.16)

Creating a Function from a Solution: The assign command assigns a value
as an expression to a name. It does not define a function. To convert a solu-
tion to a function, use the unapply command.
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Consider one of the solutions for q to the equation .

> 

> 

You can evaluate this function at symbolic or numeric values.

> 

> 

> 

For more information on defining and using functions, see Functional Oper-
ators (page 407).
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Other Specialized Solvers
In addition to equations and inequations, Maple can solve other equations
including:

• Ordinary differential equations (ODEs)

• Partial differential equations (PDEs)

• Integer equations

• Integer equations in a finite field

• Linear systems

• Recurrence relations

Ordinary Differential Equations (ODEs)

Maple can solve ODEs and ODE systems, including initial value and
boundary value problems, symbolically and numerically.

ODE Analyzer Assistant The ODE Analyzer Assistant is a point-and-click
interface to the Maple ODE solving routines.

To open the ODE Analyzer:

• From the Tools menu, select Assistants, and then ODE Analyzer.

Maple inserts the dsolve[interactive]() calling sequence in the document.
The ODE Analyzer Assistant (Figure 4.3) is displayed.
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Figure 4.3: ODE Analyzer Assistant

In the main ODE Analyzer Assistant window, you can define ODEs, initial
or boundary value conditions, and parameters. To define derivatives, use the

diff command. For example, diff(x(t), t) corresponds to and

diff(x(t), t, t) corresponds to For more information on the diff

command, see The diff Command (page 212).

After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:

1. Ensure that the conditions guarantee uniqueness of the solution.

2. Ensure that all parameters have fixed values.

3. Click the Solve Numerically button.
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4. In the Solve Numerically window (Figure 4.4), you can specify the nu-
meric method and relevant parameters and error tolerances to use for solving
the problem.

5. To compute solution values at a point, click the Solve button.

Figure 4.4: ODE Analyzer Assistant: Solve Numerically Dialog

To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the Solve Symbolically button.

2. In the Solve Symbolically window (Figure 4.5), you can specify the
method and relevant method-specific options to use for solving the problem.
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3. To compute the solution, click the Solve button.

Figure 4.5: ODE Analyzer Assistant: Solve Symbolically Dialog

When solving numerically or symbolically, you can view a plot of the solution
by clicking the Plot button.

• To plot the solution to a symbolic problem, all conditions and parameters
must be set.

• To customize the plot, click the Plot Options button to open the Plot
Options window.

To view the corresponding Maple commands as you solve the problem or
plot the solution, select the Show Maple commands check box.
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You can control the return value of the ODE Analyzer using the On Quit,
Return drop-down list. You can select to return nothing, the displayed plot,
the computed numeric procedure (for numeric solutions), the solution (for
symbolic solutions), or the Maple commands needed to produce the solution
values and the displayed plot.

For more information, refer to the ?ODEAnalyzer help page.

The dsolve Command

The ODE Analyzer provides a point-and-click interface to the Maple dsolve
command.

For ODEs or systems of ODEs, the dsolve command can find:

• Closed form solutions

• Numerical solutions

• Series solutions

In addition, the dsolve command can find:

• Formal power series solutions to linear ODEs with polynomial coeffi-
cients

• Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the dsolve command directly. For
more information, refer to the ?dsolve help page.

Partial Differential Equations (PDEs)

To solve a PDE or PDE system symbolically or numerically, use the pdsolve
command. PDE systems can contain ODEs, algebraic equations, and inequa-
tions.
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For example, solve the following PDE symbolically.

> 

(4.17)

> 

(4.18)

The solution is an arbitrary univariate function applied to .

Maple generally prints only the return value, errors, and warnings during a
computation. To print information about the techniques Maple uses, increase
the infolevel setting for the command.

To return all information, set infolevel to 5.

> 

> 

(4.19)

For more information on solving PDEs, including numeric solutions and
solving PDE systems, refer to the ?pdsolve help page.
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Integer Equations

To find only integer solutions to an equation, use the isolve command. The
isolve command finds solutions for all variables. For more information, refer
to the ?isolve help page.

> 

Integer Equations in a Finite Field

To solve an equation modulo an integer, use the msolve command. The
msolve command finds solutions for all variables. For more information,
refer to the ?msolve help page.

> 

Solving Linear Systems

To solve a linear system, use the LinearAlgebra[LinearSolve] command.
The LinearSolve command returns the vector x that satisfies A . x = B. For
more information, refer to the ?LinearAlgebra[LinearSolve] help page.

For example, construct an augmented matrix using the Matrix palette (see
Creating Matrices and Vectors (page 189)) in which the first four columns
contain the entries of A and the final column contains the entries of B.
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> 

> 

For more information on using Maple to solve linear algebra problems, see
Linear Algebra (page 189).

Solving Recurrence Relations

To solve a recurrence relation, use the rsolve command. The rsolve command
finds the general term of the function. For more information, refer to the
?rsolve help page.

> 
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4.5  Units, Scientific Constants, and
Uncertainty
In addition to manipulating exact symbolic and numeric quantities, Maple
can perform computations with units and uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars,
and provides facilities for adding custom units.

Maple has a library of hundreds of scientific constants with units, including
element and isotope properties.

To support computations with uncertainties, Maple propagates errors through
computations.

Units
The Units package in Maple provides a library of units, and facilities for
using units in computations. It is fully extensible so that you can add units
and unit systems as required.

Note: Some unit operations are available as task templates (see
Tools→Tasks→Browse) and through context menus.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set
of dimensions that are fundamental and independent are known as base di-
mensions.
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In Maple, the base dimensions include length, mass, time, electric current,
thermodynamic temperature, amount of substance, luminous intensity, in-
formation, and currency. For a complete list, enter and execute Units[GetDi-
mensions]().

Complex dimensions (or composite dimensions) measure other quantities in
terms of a combination of base dimensions. For example, the complex dimen-

sion force is a measurement of 

Each dimension, base or complex, has associated units. (Base units measure
a base dimension. Complex units measure a complex dimension.) Maple
supports over 40 units of length, including feet, miles, meters, angstroms,
microns, and astronomical units. A length must be measured in terms of a
unit, for example, a length of 2 parsecs.

Table 4.4 lists some dimensions, their corresponding base dimensions, and
example units.

Table 4.4: Sample Dimensions

Example UnitsBase DimensionsDimension

second, minute, hour, day, week,
month, year, millennium, blink,
lune

timeTime

joule, electron volt, erg, watt
hour, calorie, Calorie, British
thermal unit

Energy

volt, abvolt, statvoltElectric poten-
tial

For the complete list of units (and their contexts and symbols) available for
a dimension, refer to the corresponding help page, for example, the
?Units/length help page for the units of length.

152   •   4  Basic Computations



Each unit has a context. The context differentiates between different defini-
tions of the unit. For example, the standard and US survey miles are different
units of length, and the second is a unit of time and of angle. You can specify
the context for a unit by appending the context as an index to the unit, for
example, mile[US_survey]. If you do not specify a context, Maple uses the
default context.

Units are collected into systems, for example, the foot-pound-second (FPS)
system and international system, or système international, (SI). Each system
has a default set of units used for measurements. In the FPS system, the foot,
pound, and second are used to measure the dimensions of length, mass, and
time. The unit of speed is the foot/second. In SI, the meter, kilogram, and
second are used to measure the dimensions of length, mass, and time. The
units of speed, magnetic flux, and power are the meter/second, weber, and
watt, respectively.

Conversions

To convert a value measured in a unit to the corresponding value in a different
unit, use the Units Calculator.

• In the worksheet, enter ?UnitsCalculator.

The Units Calculator application (Figure 4.6) opens.
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Figure 4.6: Unit Converter Assistant

To perform a conversion:

1. In the Convert text field, enter the numeric value to convert.

2. In the Dimension drop-down list, select the dimensions of the unit.

3. In the From and To drop-down lists, select the original unit and the unit
to which to convert.

4. Click Perform Unit Conversion.

Maple inserts the corresponding convert/units command into the document.
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> 

Using the Units Calculator, you can convert temperatures and temperature
changes.

• To perform a temperature conversion, in the Dimension drop-down list,
select temperature(absolute).

• To perform a temperature change conversion, in the Dimension drop-
down list, select temperature(relative).

To convert temperature changes, the Units Calculator uses the convert/units
command. For example, an increase of 32 degrees Fahrenheit corresponds
to an increase of almost 18 degrees Celsius.

> 

To convert absolute temperatures, the Unit Converter uses the convert/tem-
perature command. For example, 32 degrees Fahrenheit corresponds to 0
degrees Celsius.

> 

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 4.7)
contains important units from the foot-pound-second system of units. The
Units (SI) palette (Figure 4.8) contains important units from the international
system of units.
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Figure 4.8: Units (SI) PaletteFigure 4.7: Units (FPS) Palette

To insert a unit:

• In a Units palette, click a unit symbol.

> 

To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol . Maple inserts a Unit
object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).

For example, to enter standard (the default context) miles, you can
specify the unit name, mile, or symbol, mi.

> 

The context of a unit is displayed only if it is not the default context.

156   •   4  Basic Computations



Important: In 1-D Math input, the quantity and unit (entered using the top-
level Unit command) are a product, not a single entity. The following calling
sequences define different expressions.

> 1*Unit(m)/2*Unit(s);> 1*Unit(m)/(2*Unit(s));

Some units support prefixes. For example, SI units support prefixes to names
and symbols. You can specify 1000 meters using kilometer or km. For more
information, refer to the ?Units/prefixes help page.

> 

Performing Computations with Units

In the default Maple environment, you cannot perform computations with
quantities that have units. You can perform only unit conversions. For more
information about the default environment, refer to the ?Units/default help
page.

To compute with expressions that have units, you must load a Units envir-
onment, Natural or Standard. It is recommended that you use the Standard
environment.

> 

In the Standard Units environment, commands that support expressions
with units return results with the correct units.

4.5  Units, Scientific Constants, and Uncertainty   •   157



> 

> 

(4.20)

> 

(4.21)

> 

(4.22)

For information on differentiation and integration, see Calculus (page 208).

Changing the Current System of Units

If a computation includes multiple units, all units are expressed using units
from the current system of units.

> 

(4.23)

By default, Maple uses the SI system of units, in which length is measured
in meters and time is measured in seconds.
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> 

(4.24)

To view the name of the default system of units, use the Units[UsingSystem]
command.

> 

> 

To change the system of units, use the Units[UseSystem] command.

> 

> 

(4.25)

Extensibility

You can extend the set of:

• Base dimensions and units

• Complex dimensions

• Complex units

• Systems of units

For more information, refer to the ?Units[AddBaseUnit], ?Units[AddDi-
mension], ?Units[AddUnit], and ?Units[AddSystem] help pages.
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For more information about units, refer to the ?Units help page.

Scientific Constants and Element Properties
Computations often require not only units (see Units (page 151)), but also the
values of scientific constants, including properties of elements and their
isotopes. Maple supports computations with scientific constants. You can
use the built-in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical
quantities, for example, the velocity of light and the atomic weight of sodium.
The ScientificConstants package also provides the units for the constant
values, allowing for greater understanding of the equation as well as unit-
matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into
two distinct categories.

• Physical constants

• Chemical element (and isotope) properties

Scientific Constants

List of Scientific Constants

You have access to scientific constants important in engineering, physics,
chemistry, and other fields. Table 4.5 lists some of the supported constants.
For a complete list of scientific constants, refer to the ?ScientificCon-
stants/PhysicalConstants help page.
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Table 4.5: Scientific Constants

SymbolName

GNewtonian_constant_of_gravitation

hPlanck_constant

eelementary_charge

a[0]Bohr_radius

mu[d]deuteron_magnetic_moment

N[A]Avogadro_constant

FFaraday_constant

You can specify a constant using either its name or symbol.

Accessing Constant Definition

The GetConstant command in the ScientificConstants package returns the
complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the
symbol G (or its name) in a call to the GetConstant command.

> 

> 

For information on accessing a constant's value, units, or uncertainty, see
Value, Units, and Uncertainty (page 163).

Element Properties

Maple also contains element properties and isotope properties.
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Elements

Maple supports all 117 elements of the periodic table. Each element has a
unique name, atomic number, and chemical symbol. You can specify an
element using any of these labels. For a complete list of supported elements,
refer to the ?ScientificConstants/elements help page.

Maple supports key element properties, including atomic weight (atomic-
weight), electron affinity (electronaffinity), and density. For a complete list
of element properties, refer to the ?ScientificConstants/properties help
page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons
but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes
command.

> 

Maple supports isotopes and has a distinct set of properties for isotopes, in-
cluding abundance, binding energy (bindingenergy), and mass excess
(massexcess). For a complete list of isotope properties, refer to the ?Scien-
tificConstants/properties help page.

Accessing an Element or Isotope Property Definition

The GetElement command in the ScientificConstants package returns the
complete definition of an element or isotope.
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> 

> 

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a Scientific-
Constants object.

To construct a scientific constant, use the Constant command.

> 

To construct an element (or isotope) property, use the Element command.

> 
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Value

To obtain the value of a ScientificConstants object, use the evalf command.

> 

> 

Note: The value returned depends on the current system of units.

Units

To obtain the units for a ScientificConstants object, use the GetUnit com-
mand.

> 

> 

For information on changing the default system of units, for example, from
SI to foot-pound-second, see Changing the Current System of Units (page 158).
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Value and Units

If you are performing computations with units, you can access the value and
units for a ScientificConstants object by specifying the units option when
constructing the object, and then evaluating the object.

> 

> 

Uncertainty

The value of a constant is often determined by direct measurement or derived
from measured values. Hence, it has an associated uncertainty. To obtain
the uncertainty in the value of a ScientificConstants object, use the GetError
command.

> 

> 

Performing Computations

You can use constant values in any computation. To use constant values with
units, use a Units environment as described in Performing Computations
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with Units (page 157). For information on computing with quantities that have
an uncertainty, see the following section.

Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope)
property.

For more information, refer to the ?ScientificConstants[ModifyConstant]
and ?ScientificConstants[ModifyElement] help pages.

You can extend the set of:

• Constants

• Elements (and isotopes)

• Element (or isotope) properties

For more information, refer to the ?ScientificConstants[AddConstant],
?ScientificConstants[AddElement], and ?ScientificConstants[AddProp-
erty] help pages.

For more information about constants, refer to the ?ScientificConstants
help page.

Uncertainty Propagation
Some computations involve uncertainties (or errors). Using the ScientificEr-
rorAnalysis package, you can propagate the uncertainty in these values
through the computation to indicate the possible error in the final result.

The ScientificErrorAnalysis package does not perform interval arithmetic.
That is, the error of an object does not represent an interval in which possible
values must be contained. (To perform interval arithmetic, use the Tolerances
package. For more information, refer to the ?Tolerances help page.) The
quantities represent unknown values with a central tendency. For more in-
formation on central tendency, refer to any text on error analysis for the
physical sciences or engineering.
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Quantities with Uncertainty

Creating: To construct quantities with uncertainty, use the Quantity com-
mand. You must specify the value and uncertainty. The uncertainty can be
defined absolutely, relatively, or in units of the last digit. For more informa-
tion on uncertainty specification, refer to the ?ScientificErrorAnalys-
is[Quantity] help page.

The output displays the value and uncertainty of the quantity.

> 

> 

> 

(4.26)

To specify the error in units of the last digit, the value must be of floating-
point type.

> 

(4.27)

To access the value and uncertainty of a quantity with uncertainty, use the
evalf and ScientificErrorAnalysis[GetError] commands.

> 

(4.28)
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> 

(4.29)

Rounding: To round the error of a quantity with uncertainty, use the Ap-
plyRule command. For a description of the predefined rounding rules, refer
to the ?ScientificErrorAnalysis/rules help page.

> 

(4.30)

Units: Quantities with errors can have units. For example, the scientific
constants and element (and isotope) properties in the ScientificConstants
packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in
the Quantity calling sequence.

For an absolute error, you must specify the units in both the value and error.

> 

> 

For a relative error, you can specify the units in only the value.

> 

For information on the correlation between, variance of, and covariance
between quantities with uncertainty, refer to the ?ScientificErrorAnalysis
help page.
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Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.

> 

> 

Compute the value of the derivative of at

> 

> 

To convert the solution to a single quantity with uncertainty, use the com-
bine/errors command.

> 

The value of the result is:

> 
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The uncertainty of the result is:

> 

Additional Information

For information on topics including:

• Creating new rounding rules,

• Setting the default rounding rule, and

• Creating a new interface to quantities with uncertainty,

refer to the ?ScientificErrorAnalysis help page.

4.6  Restricting the Domain
By default, Maple computes in the complex number system. Most computa-
tions are performed without any restrictions or assumptions on the variables.
Maple often returns results that are extraneous or unsimplified when comput-
ing in the field of complex numbers. Using restrictions, you can more easily
and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system
and for applying assumptions to variables.

Real Number Domain
To force Maple to perform computations in the field of real numbers, use
the RealDomain package.

The RealDomain package contains a small subset of Maple commands re-
lated to basic precalculus and calculus mathematics, for example, arccos,
limit, and log, and the symbolic manipulation of expressions and formulae,
for example, expand, eval, and solve. For a complete list of commands, refer
to the ?RealDomain help page.
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After you load the RealDomain package, Maple assumes that all variables
are real. Commands return simplified results appropriate to the field of real
numbers.

> 

> 

> 

Some commands that generally return NULL instead return a numeric result
when you use the RealDomain package.

> 

Complex return values are excluded or replaced by undefined.

> 

> 

Assumptions on Variables
To simplify problem solving, it is recommended that you always apply any
known assumptions to variables. You can impose assumptions using the
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assume command. To apply assumptions for a single computation, use the
assuming command.

Note: The assume and assuming commands are not supported by the
RealDomain package.

The assume Command

You can use the assume command to set variable properties, for example,
x::real, and relationships between variables, for example, x < 0 or x < y.
For information on valid properties, refer to the ?assume help page. For in-
formation on the double colon (::) operator, refer to the ?type help page.

The assume command allows improved simplification of symbolic expres-
sions, especially multiple-valued functions, for example, computing the
square root.

To assume that x is a positive real number, use the following calling sequence.

Then compute the square root of .

> 

The trailing tilde (~) on the name x indicates that it carries assumptions.

When you use the assume command to place another assumption on x, all
previous assumptions are removed.

> 

Displaying Assumptions: To view the assumptions on an expression, use
the about command.
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> 

(4.31)

(4.31)

Imposing Multiple Assumptions: To simultaneously impose multiple
conditions on an expression, specify multiple arguments in the assume
calling sequence.

> 

To specify additional assumptions without replacing previous assumptions,
use the additionally command. The syntax of the additionally calling se-
quence is the same as that of the assume command.

> 

(4.32)

(4.32)

The only integer in the open interval (0, 2) is 1.

Testing Properties: To test whether an expression always satisfies a condi-
tion, use the is command.

> 
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The following test returns false because there are values of x and y (x = 0,
y = 10) that satisfy the assumptions, but do not satisfy the relation in the is
calling sequence.

> 

To test whether an expression can satisfy a condition, use the coulditbe
command.

> 

Removing Assumptions: To remove all assumptions on a variable, unassign
its name.

> 

For more information, see Unassigning Names (page 113).

For more information on the assume command, refer to the ?assume help
page.

The assuming Command

To perform a single evaluation under assumptions on the names in an expres-
sion, use the assuming command.

The syntax of the assuming command is <expression> assuming <property
or relation>. Properties and relations are introduced in The assume Com-
mand (page 172).

The frac command returns the fractional part of an expression.

> 
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Using the assuming command is equivalent to imposing assumptions with
the assume command, evaluating the expression, and then removing the as-
sumptions.

> 

(4.33)

(4.33)

If you do not specify the names to which to apply a property, it is applied to
all names.

> 

Assumptions placed on names using the assume command are ignored by
the assuming command, unless you include the additionally option.

> 

> 

> 
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The assuming command does not affect variables inside procedures. (For
information on procedures, see Procedures (page 457).) You must use the
assume command.

f := proc(x) sqrt(a^2) + x end proc;>

> 

> 

For more information on the assuming command, refer to the ?assuming
help page.
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5  Mathematical Problem
Solving
This chapter focuses on solving problems in specific mathematical disciplines.
The areas described below are not all that Maple provides, but represent the
most commonly used packages. Examples are provided to teach you how to
use the different methods of calculation available in Maple, including tutors,
assistants, commands, task templates, plotting, and context menus.

The examples in this chapter assume knowledge of entering commands and
mathematical symbols. For information, see Entering Expressions (page 22).
For information on basic computations, including integer operations and
solving equations, see Basic Computations (page 119).

5.1  In This Chapter
TopicsSection

• Polynomial AlgebraAlgebra - Performing algebra computations

• Creating Matrices and Vectors

• Accessing Entries in Matrices and Vec-
tors

• Linear Algebra Computations

• Student LinearAlgebra Package

Linear Algebra - Performing linear algebra
computations

• Limits

• Differentiation

• Series

• Integration

• Differential Equations

• Calculus Packages

Calculus - Performing calculus computations
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TopicsSection

• Point-and-Click Interface

• Efficient Computation

• MPS(X) File Support

Optimization - Performing optimization
computations using the Optimization pack-
age

• Probability Distributions and Random
Variables

• Statistical Computations

• Plotting

Statistics - Performing statistics computations
using the Statistics package

• Table of Student and Instructor Resources

• Student Packages and Tutors

Teaching and Learning with Maple - Student
and Instructor resources for using Maple in
an academic setting

5.2  Algebra
Maple contains a variety of commands that perform integer operations, such
as factoring and modular arithmetic, as described in Integer Opera-
tions (page 125). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 189).

Polynomial Algebra
A Maple polynomial is an expression in powers of an unknown. Univariate

polynomials are polynomials in one unknown, for example, 
Multivariate polynomials are polynomials in multiple unknowns, such as

The coefficients can be integers, rational numbers, irrational numbers,
floating-point numbers, complex numbers, variables, or a combination of
these types.
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> 

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic oper-
ators excluding the division operator (/). (The division operator accepts
polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands
find the quotient and remainder of a polynomial division. See Table 5.1.
(The iquo and irem commands find the quotient and remainder of an integer
division. For more information, see Integer Operations (page 125).)

Table 5.1: Polynomial Arithmetic Operators

ExampleOperatorOperation

> Addition

> Subtraction

> *Multiplication1
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ExampleOperatorOperation

> 

> 

quo
rem

Division: Quotient
and Remainder

> ^Exponentiation2

1You can specify multiplication explicitly by entering *, which displays in 2-D Math as
. In 2-D Math, you can also implicitly multiply by placing a space character between

two expressions. In some cases, the space character is optional. For example, Maple inter-
prets a number followed by a name as an implicit multiplication.
2In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the expand command.

> 

If you need to determine whether one polynomial divides another, but do
not need the quotient, use the divide command. The divide command tests
for exact polynomial division.

> 
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Important: You must insert a space character or a multiplication operator
( ) between adjacent variables names. Otherwise, they are interpreted as
a single variable.

For example, does not divide the single variable 

> 

But, divides the product of and 

> 

For information on polynomial arithmetic over finite rings and fields, refer
to the ?mod help page.

Sorting Terms

To sort the terms of a polynomial, use the sort command.

> 

> 
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Note: The sort command returns the sorted polynomial, and updates the
order of the terms in the polynomial.

The terms of p1 are sorted.

> 

To specify the unknowns of the polynomial and their ordering, include a list
of names.

> 

> 

By default, the sort command sorts a polynomial by decreasing total degree
of the terms.

> 

> 

The first term has total degree 4. The other two terms have total degree 3.
The order of the final two terms is determined by the order of their names
in the list.
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To sort the terms by pure lexicographic order, that is, first by decreasing
order of the first unknown in the list option, and then by decreasing order of
the next unknown in the list option, specify the 'plex' option.

> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 435).

The first term contains to the power 3; the second, to the power 2; and

the third, to the power 0.

Using context menus, you can perform operations, such as sorting, for
polynomials and many other Maple objects.

To sort a polynomial:

1. Right-click (Control-click, for Macintosh) the polynomial.

2. The context menu displays. From the Sorts menu, select:

• Single-variable, and then the unknown

• Two-variable (or Three-variable), Pure Lexical or Total Degree, and
then the sort priority of the unknowns.

See Figure 5.1.

5.2  Algebra   •   183



Figure 5.1: Sorting a Polynomial Using a Context Menu

Maple sorts the polynomial.
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In Worksheet mode, Maple inserts the calling sequence that performs the
sort followed by the sorted polynomial.

> 

> 

You can use context menus to perform operations on 2-D Math content in-
cluding output. For more information, see Context Menus (page 80) (for
Document mode) or Context Menus (page 105) (for Worksheet mode).

Collecting Terms

To collect the terms of polynomial, use the collect command.

> 

Coefficients and Degrees

Maple has several commands that return coefficient and degree values for a
polynomial. See Table 5.2.

5.2  Algebra   •   185



Table 5.2: Polynomial Coefficient and Degree Commands

ExampleDescriptionCommand

> Coefficient of specified degree termcoeff

> Leading coefficientlcoeff

> Trailing coefficienttcoeff

> Sequence of all coefficients, in one-to-
one correspondence with the terms
Note: It does not return zero coefficients

coeffs

> (Highest) degreedegree

> Lowest degree term with a non-zero
coefficient

ldegree
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Factorization

To express a polynomial in fully factored form, use the factor command.

> 

The factor command factors the polynomial over the ring implied by the
coefficients, for example, integers. You can specify an algebraic number
field over which to factor the polynomial. For more information, refer to the
?factor help page. (The ifactor command factors an integer. For more in-
formation, see Integer Operations (page 125).)

To solve for the roots of a polynomial, use the solve command. For inform-
ation on the solve command, see Solving Equations and Inequa-
tions (page 132). (The isolve command solves an equation for integer solutions.
For more information, see Integer Equations (page 149).)

Other Commands

Table 5.3 lists other commands available for polynomial operations.

Table 5.3: Select Other Polynomial Commands

DescriptionCommand

Content (multivariate polynomial)content

Decompositioncompoly

Discriminantdiscrim

Greatest common divisor (of two polynomials)gcd

Extended Euclidean algorithm (for two polyno-
mials)

gcdex
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DescriptionCommand

Interpolating polynomial (for list of points)CurveFitting[PolynomialInterpolation]
See also the CurveFitting Assistant
(Tools → Assistants → Curve Fitting)

Least common multiple (of two polynomials)lcm

Normnorm

Pseudo-remainder (of two multivariate polyno-
mials)

prem

Primitive part (multivariate polynomial)primpart

Random polynomialrandpoly

Determine whether self-reciprocalPolynomialTools[IsSelfReciprocal]

Resultant (of two polynomials)resultant

Exact roots (over algebraic number field)roots

Square free factorization (multivariate polyno-
mial)

sqrfree

Additional Information

Table 5.4: Additional Polynomial Help

ResourceTopic

?polynom help pageGeneral polynomial information

?PolynomialTools package overview help pagePolynomialTools package

?SNAP (Symbolic-Numeric Algorithms for
Polynomials) package overview help page

Algebraic manipulation of numeric poly-
nomials

?SDMPolynom (Sparse Distributed Multivari-
ate Polynomial data structure) help page

Efficient arithmetic for sparse polynomials

Maple Help System Table of Contents: Math-
ematics→Algebra→Polynomials section

Polynomial information and commands
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5.3  Linear Algebra
Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the
Task Browser (Tools → Tasks → Browse), expand the Linear Algebra
folder.

Creating Matrices and Vectors

Creating Matrices

To create a matrix, use either the Matrix command, or the Matrix palette
(see Figure 5.2).

There are several input formats available to create a Matrix using the Matrix
command. For example, enter a list of lists. The dimensions of the matrix
are inferred from the number of entries given.

> 

Alternatively, use the angle bracket shortcut, <>. Separate items in a column
with commas, and separate columns with vertical bars, |.

> 
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For information on the Matrix command options, see Creating Matrices and
Vectors for Large Problems (page 195).

Use the Matrix palette to interactively create a matrix without commands:

Figure 5.2: Matrix Palette

In the Matrix palette, you can specify the matrix size (see Figure 5.3) and
properties. To insert a matrix, click the Insert Matrix button.
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Figure 5.3: Matrix Palette: Choosing the Size

After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder,
press Tab.

2. After specifying all entries, press Enter.

> 
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Creating Vectors

To create a vector, use angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, <a, b, c>.
The number of elements is inferred from the number of expressions.

> 

To create a row vector, specify a vertical-bar-delimited (|) sequence, <a | b
| c>. The number of elements is inferred from the number of expressions.

> 

For information on the Vector command options, refer to the ?Vector help
page.

You can also create vectors using the Matrix palette. If either the number
of rows or number of columns specified is 1, then you have the option of
inserting a matrix, or inserting a vector of the appropriate type. See Figure
5.4.
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Figure 5.4: Insert Matrix or Insert Vector

Editing and Viewing Large Matrices and Vectors

Matrices and smaller, and vectors with 10 or fewer elements,
display in the document. Larger objects are displayed as a placeholder.

For example, insert a matrix.

In the Matrix palette:

1. Specify the dimensions: 15 rows and 15 columns.

2. In the Type drop-down list, select a matrix type, for example, Custom
values.

3. Click Insert Matrix. Maple inserts a placeholder.

> 
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To edit or view a large matrix or vector, double-click the placeholder. This
launches the Matrix Browser. See Figure 5.5.

Figure 5.5: Matrix Browser

To specify the value of entries using the Matrix Browser:

1. Select the Table tab.

2. Double-click an entry, and then edit its value. Press Enter.

3. Repeat for each entry to edit.

4. When you have finished updating entries, click Done.
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You can view the matrix or vector as a table or as an image, which can be
inserted into the document. For more information, refer to the ?Mat-
rixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:

• Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the ?interface help page.

Creating Matrices and Vectors for Large Problems

By default, matrices and vectors can store any values. To increase the effi-
ciency of linear algebra computations, create matrices and vectors with
properties. You must specify the properties, for example, the matrix or vector
type or the data type, when defining the object.

The Matrix palette (Figure 5.2) supports several properties.

To specify the matrix type:

• Use the Shape and Type drop-down lists.

To specify the data type:

• Use the Data type drop-down list.

For example, define a diagonal matrix with small integer coefficients.

In the Matrix palette:

1. Specify the size of the matrix, for example, .

2. In the Shapes drop-down list, select Diagonal.

3. In the Data type drop-down list, select integer[1].

4. Click the Insert Matrix button.
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5. Enter the values in the diagonal entries.

> 

Note: To create a matrix with randomly generated entries, select the Random
Type.

You cannot specify properties when defining vectors using the angle-bracket
notation. You must use the Vector constructor.

To define a column vector using the Vector constructor, specify:

• The number of elements. If you explicitly specify all element values, this
argument is not required.

• A list of expressions that define the element values.

• Parameters such as shape, datatype, and fill that set properties of the
vector.

The following two calling sequences are equivalent.

> 

> 
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To create a row vector using the Vector constructor, include row as an index.

> 

> 

The Matrix palette does not support some properties. To set all properties,
use the Matrix constructor.

To define a matrix using the Matrix constructor, specify:

• The number of rows and columns. If you explicitly specify all element
values, these arguments are not required.

• A list of lists that define the element values row-wise.

• Parameters such as shape, datatype, and fill that set properties of the
matrix.

For example:

> 
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The Matrix palette cannot fill the matrix with an arbitrary value. Use the
fill parameter.

> 

For more information on the constructors, including other calling sequence
syntaxes and parameters, refer to the ?storage, ?Matrix, and ?Vector help
pages.

See also Numeric Computations (page 207).

Accessing Entries in Matrices and Vectors

Matrices

To select an entry in a Matrix, enter the matrix name with a sequence of two
non-zero integer indices, row first.

> 

> 

To select an entire row, enter a single index; to select an entire column, enter
first the entire range of rows, then the column index.
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> 

> 

Similarly, you can access submatrices. Enter the indices as a list or range.

> 

Vectors

To select an entry in a vector, enter the vector name with a non-zero integer
index.

> 

> 
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Negative integers select entries from the end of the vector.

> 

To create a Vector consisting of multiple entries, specify a list or range of
integers in the index. For more information, refer to the ?list and ?range
help pages.

> 

> 

Linear Algebra Computations
You can perform matrix and vector computations using context menus and
the LinearAlgebra package.

Matrix Arithmetic

The matrix and vector arithmetic operators are the standard Maple arithmetic
operators up to the following two differences.
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• The scalar multiplication operator is the asterisk (*), which displays in
2-D Math as . The noncommutative matrix and vector multiplication
operator is the period (.).

• There is no division operator (/) for matrix algebra. (You can construct
the inverse of a matrix using the exponent )

See Table 5.5.

> 

Table 5.5: Matrix and Vector Arithmetic Operators

ExampleOperatorOperation

> Addition

> Subtraction

> .Multiplication
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ExampleOperatorOperation

> 

> 

*Scalar Multiplication1

> 

> 

^Exponentiation2

1You can specify scalar multiplication explicitly by entering *, which displays in 2-D Math

as . In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector by
placing a space character between them. In some cases, the space character is optional.
For example, Maple interprets a number followed by a name as an implicit multiplication.
2In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 5.6.

Define two column vectors.

> 
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Table 5.6: Select Matrix and Vector Operators

ExampleOperatorOperation

> ^%T1Transpose

> 
^%H1Hermitian Transpose

> 

> 

&x2Cross Product
(3-D vectors only)

1Exponential operators display in 2-D Math as superscripts.
2 After loading the LinearAlgebra package, the cross product operator is available as the
infix operator &x . Otherwise, it is available as the LinearAlgebra[CrossProduct] com-
mand.

For information on matrix arithmetic over finite rings and fields, refer to the
?mod help page.

Point-and-Click Interaction

Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.
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• Perform standard operations: determinant, inverse, norm (1, Euclidean,
infinity, or Frobenius), transpose, and trace

• Compute eigenvalues, eigenvectors, and singular values

• Compute the dimension or rank

• Convert to the Jordan form, or other forms

• Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 5.6.

Figure 5.6: Computing the Infinity Norm of a Matrix
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In Document mode, Maple inserts a right arrow and the name of the compu-
tation performed, followed by the norm.

Vector operations available in the context menu include the following.

• Compute the dimension

• Compute the norm (1, Euclidean, and infinity)

• Compute the transpose

• Select an element

For more information on context menus, see Context Menus (page 80) (for
Document mode) or Context Menus (page 105) (for Worksheet mode).

LinearAlgebra Package Commands

The LinearAlgebra package contains commands that construct and manip-
ulate matrices and vectors, compute standard operations, perform queries,
and solve linear algebra problems.

Table 5.7 lists some LinearAlgebra package commands. For a complete
list, refer to the ?LinearAlgebra/Details help page.

Table 5.7: Select LinearAlgebra Package Commands

DescriptionCommand

Return a basis for a vector spaceBasis

Compute the cross product of two vectorsCrossProduct

Delete a row or rows of a matrixDeleteRow

Determine the dimension of a matrix or a vectorDimension

Compute the eigenvalues of a matrixEigenvalues

5.3  Linear Algebra   •   205



DescriptionCommand

Compute the eigenvectors of a matrixEigenvectors

Reduce a matrix to Frobenius formFrobeniusForm

Perform Gaussian elimination on a matrixGaussianElimination

Reduce a square matrix to Hessenberg formHessenbergForm

Construct a generalized Hilbert matrixHilbertMatrix

Test if a matrix is orthogonalIsOrthogonal

Compute the least-squares approximation to A . x = bLeastSquares

Solve the linear system A . x = bLinearSolve

Compute the inverse of a square matrix or pseudo-inverse of a non-
square matrix

MatrixInverse

Compute the QR factorization of a matrixQRDecomposition

Construct a random matrixRandomMatrix

Construct the Sylvester matrix of two polynomialsSylvesterMatrix

For information on arithmetic operations, see Matrix Arithmetic (page 200).

For information on selecting entries, subvectors, and submatrices, see Access-
ing Entries in Matrices and Vectors (page 198).

Example: Determine a basis for the space spanned by the set of vectors {(2,
13, -15), (7, -2, 13), (5, -4, 9)}. Express the vector (25, -4, 9) with respect to
this basis.

> 

> 

Find a basis for the vector space spanned by these vectors, and then construct
a matrix from the basis vectors.
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> 

To express (25, -4, 9) in this basis, use the LinearSolve command.

> 

Numeric Computations

You can very efficiently perform computations on large matrices and vectors
that contain floating-point data using the built-in library of numeric linear
algebra routines. Some of these routines are provided by the Numerical Al-
gorithms Group (NAG®). Maple also contains portions of the CLAPACK
and optimized ATLAS libraries.

For information on performing efficient numeric computations using the
LinearAlgebra package, refer to the ?EfficientLinearAlgebra help page.

See also Creating Matrices and Vectors for Large Problems (page 195) and
Reading from Files (page 492).
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Student LinearAlgebra Package
The Student package contains subpackages that help instructors teach con-
cepts and allow students to visualize and explore ideas. These subpackages
also contain computational commands.

In the Student[LinearAlgebra] subpackage, the environment differs from
that of the LinearAlgebra package in that floating-point computations are
generally performed using software precision, instead of hardware precision,
and symbols are generally assumed to represent real, rather than complex,
quantities. These defaults, and others, can be controlled using the SetDefault
command. For more information, refer to the ?Student[LinearAlgebra][Set-
Default] help page.

For information on using Maple as a teaching and learning tool, see Teaching
and Learning with Maple (page 238).

5.4  Calculus
The Task Browser (Tools→Tasks→Browse) contains numerous calculus
task templates. For a list of tasks, navigate to one of the related folders, such
as Calculus, Differential Equations, Multivariate Calculus, or Vector
Calculus.

This section describes the key Maple calculus commands, many of which
are used in task templates or available in the context menus.

For a complete list of calculus commands, refer to the Mathematics (includ-
ing Calculus, Differential Equations, Power Series, and Vector Calculus
subfolders) and Student Package sections of the Maple Help System Table
of Contents.
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Limits
To compute the limit of an expression as the independent variable ap-
proaches a value:

1. In the Expression palette, click the limit item .

2. Specify the independent variable, limit point, and expression, and then
evaluate it. Press Tab to move to the next placeholder.

For example:

> 

The limit Command

By default, Maple searches for the real bidirectional limit (unless the limit
point is ∞ or -∞). To specify a direction, include one of the options left,
right, real, or complex in a call to the limit command. See Table 5.8.

Table 5.8: Limits

OutputCommand SyntaxLimit

undefined> 

(5.1)
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> 

(5.2)

> 

(5.3)

Using the limit command, you can also compute multidimensional limits.

> 

For more information on multidimensional limits, refer to the ?limit/multi
help page.

Numerically Computing a Limit

To numerically compute a limit:

• Use the evalf(Limit(arguments)) calling sequence.

Important: Use the inert Limit command, not the limit command. For more
information, refer to the ?limit help page.
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The Limit command accepts the same arguments as the limit command.

For example:

> 

For information on the evalf command, see Numerical Approxima-
tion (page 428).

The Limit command does not compute the limit. It returns an unevaluated
limit.

> 

For more information on the Limit command, refer to the ?Limit help page.

Differentiation
Maple can perform symbolic and numeric differentiation.

To differentiate an expression:

1. In the Expression palette, click the differentiation item or the

partial differentiation item .

2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate with respect to :
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> 

You can also differentiate using context menus. For more information, see
Context Menus and Copy & Drag (page 46).

To calculate a higher order or partial derivative, edit the derivative symbol

inserted. For example, to calculate the second derivative of 

with respect to :

> 

To calculate the mixed partial derivative of :

> 

Note: To enter another symbol, you can copy and paste the existing
symbol, or enter d and use symbol completion.

The diff Command

Maple computes derivatives using the diff command. To directly use the
diff command, specify the expression to differentiate and the variable.

> 
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(5.4)

> 

(5.5)

For information on equation labels such as (5.4), see Equation La-
bels (page 114).

To calculate a higher order derivative, specify a sequence of differentiation
variables. Maple recursively calls the diff command.

> 

(5.6)

To calculate a partial derivative, use the same syntax. Maple assumes that
the derivatives commute.

> 

To enter higher order derivatives, it is convenient to use the sequence oper-
ator ($). For more information, refer to the ?$ help page.

To compute the nth derivative of an expression f in the independent variable
t, you can use the syntax 

For example:

> 
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Differentiating an Operator

You can also specify a mathematical function as a functional operator (a
mapping). For a comparison of operators and other expressions, see Distinc-
tion between Functional Operators and Other Expressions (page 408).

To find the derivative of a functional operator:

• Use the D operator.

The D operator returns a functional operator.

For example, find the derivative of an operator that represents the mathem-
atical function 

First, define the mathematical function as the operator F.

1. In the Expression palette, click the single-variable function definition

item .

2. Enter placeholder values.

• To move to the next placeholder, press the Tab key. Note: If pressing
the Tab key inserts a tab, click the Tab icon in the toolbar.

> 

Now, define the operator, G, that maps to the derivative of 

> 
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F and G evaluated at return the expected values.

> 

For more information on the D operator, refer to the ?D help page. For a
comparison of the diff command and D operator, refer to the ?diffVersusD
help page.

Directional Derivative

To compute and plot a directional derivative, use the Directional Derivative
Tutor. The tutor computes a floating-point value for the directional derivat-
ive.

To launch the tutor:

From the Tools menu, select Tutors, Calculus - Multi-Variable, and then
Directional Derivatives. Maple launches the Directional Derivative Tutor.
See Figure 5.7.
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Figure 5.7: Directional Derivative Tutor

To compute a symbolic value for the directional derivative, use the Stu-
dent[MultivariateCalculus][DirectionalDerivative] command. The first
list of numbers specifies the point at which to compute the derivative. The
second list of numbers specifies the direction in which to compute the deriv-
ative.

For example, at the point the gradient of points in the

direction which is the direction of greatest increase. The directional

derivative in the orthogonal direction is zero.
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> 

> 

> 

Series
To generate the Taylor series expansion of a function about a point, use the
taylor command.

> 

Note: If a Taylor series does not exist, use the series command to find a
general series expansion.

For example, the cosine integral function does not have a taylor series expan-
sion about 0. For more information, refer to the ?Ci help page.

> 

Error, does not have a taylor expansion, try 
series()

To generate a truncated series expansion of a function about a point, use the
series command.

> 
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By default, Maple performs series calculations up to order 6. To use a differ-
ent order, specify a non-negative integer third argument.

> 

To set the order for all computations, use the Order environment variable.

For information about the Order variable and the term, refer to the
?Order help page.

The expansion is of type series. Some commands, for example, plot, do not
accept arguments of type series. To use the expansion, you must convert it
to a polynomial using the convert/polynom command.

> 
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For information on Maple types and type conversions, see Maple Expres-
sions (page 399).

For information on plotting, see Plots and Animations (page 283).

Integration
Maple can perform symbolic and numeric integration.

To compute the indefinite integral of an expression:

1. In the Expression palette, click the indefinite integration item .

2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate with respect to x:

> 
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Recall that you can also enter symbols, including and using symbol

completion.

• Enter the symbol name (or part of the name), for example, int or d, and
then press the completion shortcut key.

For more information, see Symbol Names (page 33).

You can also compute an indefinite integral using context menus. For more
information, see Context Menus and Copy & Drag (page 46).

To compute the definite integral of an expression:

1. In the Expression palette, click the definite integration item .

2. Specify the endpoints of the interval of integration, integrand expression,
and variable of integration, and then evaluate it.

For example, to integrate over the interval (0, ∞):

> 

Maple treats the parameter a as a complex number. As described in Assump-
tions on Variables (page 171), you can compute under the assumption that a
is a positive, real number using the assuming command.
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> 

To compute iterated integrals, line integrals, and surface integrals, use the
task templates (Tools → Tasks → Browse) in the Multivariate and Vector
Calculus folders.

The int Command

and use the int command. To use the int command directly,

specify the following arguments.

• Expression to integrate

• Variable of integration

> 

(5.7)

> 

(5.8)

For a definite integration, set the variable of integration equal to the interval
of integration.

> 
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(5.9)

Numeric Integration

To perform numeric integration:

• Use the evalf(Int(arguments)) calling sequence.

Important: Use the inert Int command, not the int command. For more in-
formation, refer to the ?int help page.

In addition to the arguments accepted by the int command, you can include
optional arguments such as method, which specifies the numeric integration
method.

> 

Note: To enter an underscore character (_) in 2-D Math, enter \_.

For information on the evalf command, see Numerical Approxima-
tion (page 428).

For information on numeric integration, including iterated integration and
controlling the algorithm, refer to the ?evalf/Int help page.

Differential Equations
Maple has a powerful set of solvers for ordinary differential equations (ODEs)
and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see Other Specialized Solv-
ers (page 143).
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Calculus Packages
In addition to top-level calculus commands, Maple contains calculus pack-
ages.

VectorCalculus Package

The VectorCalculus package contains commands that perform multivariate
and vector calculus operations on VectorCalculus vectors (vectors with an
additional coordinate system attribute) and vector fields (vectors with addi-
tional coordinate system and vectorfield attributes), for example, Curl, Flux,
and Torsion.

> 

> 

> 

Note: For information on changing the display format in the VectorCalculus
package, see the ?VectorCalculus[BasisFormat] help page.

Find the curl of VectorField1.

> 

Find the flux of VectorField1 through a sphere of radius r at the origin.
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> 

Compute the torsion of a space curve. The curve must be a vector with
parametric function components.

> 

For information on the assuming command, see The assuming Com-
mand (page 174).

For more information on the VectorCalculus package, including a complete
list of commands, refer to the ?VectorCalculus help page.

To find other calculus packages, such as VariationalCalculus, refer to the
?index/package help page.

Student Calculus Packages

The Student package contains subpackages that help instructors teach con-
cepts and allow students to visualize and explore ideas. These subpackages
also contain computational commands. The Student calculus subpackages
include Calculus1, MultivariateCalculus, and VectorCalculus. The Stu-
dent[VectorCalculus] package provides a simple interface to a limited
subset of the functionality available in the VectorCalculus package.

For information on using Maple as a teaching and learning tool, and some
computational examples, see Teaching and Learning with Maple (page 238).
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5.5  Optimization
Using the Optimization package, you can numerically solve optimization
problems. The package uses fast Numerical Algorithms Group (NAG) al-
gorithms to minimize or maximize an objective function.

The Optimization package solves constrained and unconstrained problems.

• Linear programs

• Quadratic programs

• Nonlinear programs

• Linear and nonlinear least-squares problems

The Optimization package contains local solvers. In addition, for univariate
finitely-bounded nonlinear programs with no other constraints, you can
compute global solutions using the NLPSolve command. To find global
solutions generally, purchase the Global Optimization Toolbox. For more
information, visit http://www.maplesoft.com/products/toolboxes.

Point-and-Click Interface
The primary method for solving optimization problems is the Optimization
Assistant.

To launch the Optimization Assistant:

• From the Tools menu, select Assistants, and then Optimization.

Maple inserts the Optimization[Interactive]() calling sequence (in Worksheet
mode), and launches the Optimization Assistant. See Figure 5.8.
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Figure 5.8: Optimization Assistant
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To solve a problem:

1. Enter the objective function, constraints, and bounds.

2. Select the Minimize or Maximize radio button.

3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds)
in the calling sequence.

For example, find the maximum value of subject to the constraints

.

> 

After finding a solution, you can plot it. To plot a solution:

In the Optimization Assistant window, click the Plot button. The Optimiz-
ation Plotter window is displayed. See Figure 5.9.

Note: When you close the Optimization Assistant, you can choose to return
the solution, problem, command used, plot, or nothing, using the drop-down
in the bottom right corner of the assistant window.
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Figure 5.9: Optimization Assistant Plotter Window

For information on the algorithms used to solve optimization problems, refer
to the ?Optimization/Methods help page.

Large Optimization Problems
The Optimization Assistant accepts input in an algebraic form. You can
specify input in other forms, described in the ?Optimization/InputForms
help page, in command calling sequences.
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The Matrix form, described in the ?Optimization/MatrixForm help page,
is more complex but offers greater flexibility and efficiency.

For example, solve the linear program:

maximize subject to , where is the vector of problem vari-
ables.

Define the column vector, c, of the linear objective function.

> 

> 

Define the matrix A, the coefficient matrix for the linear inequality con-
straints.

> 

Define the column vector b, the linear inequality constraints.

> 

The QPSolve command solves quadratic programs.

> 
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This example uses a random data set to demonstrate the problem. You could
also read data from an external file as Matrices, and use that data. For details
and an example, see Reading from Files (page 492).

Note: For information on creating matrices and vectors (including how to
use the Matrix palette to easily create matrices), see Linear Al-
gebra (page 189).

For additional information on performing efficient computations, refer to
the ?Optimization/Computation help page.

MPS(X) File Support
To import linear programs from a standard MPS(X) data file, use the Import-
MPS command.

Optimization Package Commands
Each Optimization package command solves the problem using a different
optimization method. These are described in Table 5.9, along with the gen-
eral input form for each command.

Table 5.9: Optimization Package Commands

DescriptionCommand

Solve a linear program (LP), which involves computing the min-
imum (or maximum) of a linear objective function subject to linear
constraints; input is in equation or Matrix form

LPSolve
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DescriptionCommand

Solve a least-squares (LS) problem, which involves computing the
minimum of a real-valued objective function having the form

where is a vector of problem

variables, possibly subject to constraints; input is in equation or
Matrix form

LSSolve

Compute a local maximum of an objective function, possibly
subject to constraints

Maximize

Compute a local minimum of an objective function, possibly subject
to constraints

Minimize

Solve a non-linear program (NLP), which involves computing the
minimum (or maximum) of a real-valued objective function, pos-
sibly subject to constraints; input is in equation or Matrix form

NLPSolve

Solve a quadratic program (QP), which involves computing the
minimum (or maximum) or a quadratic objective function, possibly
subject to linear constraints; input is in equation or Matrix form

QPSolve

For a complete list of commands and other Optimization package informa-
tion, refer to the ?Optimization help page.

5.6  Statistics
The Statistics package is a collection of commands and the point-and-click
Data Analysis Assistant—refer to the ?Statistics[InteractiveDataAnalysis]
help page—for performing computations in mathematical statistics and data
analysis. The package supports a wide range of common statistical tasks in-
cluding quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides
a wide range of symbolic and numeric tools for computing with random
variables. The package supports over 35 major probability distributions and
can be extended to include new distributions.
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Probability Distributions and Random Variables
The Statistics package supports:

• Continuous distributions, which are defined along the real line by prob-
ability density functions. Maple supports many continuous distributions,
including the normal, Student-t, Laplace, and logistic distributions.

• Discrete distributions, which have nonzero probability only at discrete
points. A discrete distribution is defined by a probability function. Maple
supports many discrete distributions, including the Bernoulli, geometric,
and Poisson distributions.

For a complete list of distributions, refer to the ?Statistics/Distributions
help page.

You can define random variables by specifying a distribution in a call to the
RandomVariable command.

> 

> 

Find the probability distribution function for X. (For information on statistics
computations, see Statistical Computations (page 233).)

> 

Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the
Distribution command.
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> 

To construct a piecewise-continuous function in 1-D Math, use the piecewise
command, for example, t -> piecewise(t < 0, 0, t < 3, 1/3, 0).

Define a new random variable with this distribution.

> 

Calculate the mean value of the random variable.

> 

Statistical Computations
In addition to basic functions, like mean, median, standard deviation, and
percentile, the Statistics package contains commands that compute, for ex-
ample, the interquartile range and hazard rate.

Example 1 - Interquartile Range

Compute the average absolute range from the interquartile of the Rayleigh
distribution with scale parameter 3.
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> 

To compute the result numerically:

• Specify the 'numeric' option.

> 

Example 2 - Hazard Rate

Compute the hazard rate of the Cauchy distribution with location and scale
parameters a and b at an arbitrary point t.

> 

You can specify a value for the point t.

> 
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You can also specify that Maple compute the result numerically.

> 

(5.10)

For more information, refer to the ?Statistics/DescriptiveStatistics help
page.

Plotting
You can generate statistical plots using the visualization commands in the
Statistics package. Available plots include:

• Bar chart

• Frequency plot

• Histogram

• Pie chart

• Scatter plot

For example, create a scatter plot for a distribution of points that vary from

by a small value determined by a normally distributed sample.

> 
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> 

> 

> 

> 

To fit a curve to the data points, include the optional fit equation parameter.

Using the plots[display] command, create a plot that contains the:

• Scatter plot of the data points

• Quartic polynomial fitted to the data points:
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• Function 

> 

> 

> 

For more information on statistical plots, refer to the ?Statistics/Visualization
help page.

For an overview of plotting, see Plots and Animations (page 283).
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Additional Information
For more information on the Statistics package, including regression analysis,
estimation, data manipulation, and data smoothing, refer to the ?Statistics
help page.

5.7  Teaching and Learning with
Maple
Table 5.10 lists the available resources for instructors and students. For ad-
ditional resources, see Available Resources (page 66).

Table 5.10: Student and Instructor Resources

DescriptionResource

The Student package contains computational and visual-
ization (plotting and animation) functionality, and
point-and-click interfaces for explaining and exploring
concepts (Tools→Tutors). For more information, refer
to the ?Student help page.

Student Packages and Tutors

The Maple Help System has an integrated dictionary of
over 5000 mathematics and engineering terms. You can
search the dictionary by entering a term in the Help Sys-
tem search field.

Mathematics and Engineering
Dictionary

The Maple Application Center contains tutorials and ap-
plications that help instructors begin using Maple and use
Maple in the classroom. Browse the many resources in
the Education and Education PowerTools categories.
(http://www.maplesoft.com/applications)

Maple Application Center
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DescriptionResource

The Maple Student Help Center contains tutorials and
applications that help students learn how to use Maple,
explore mathematical concepts, and solve problems.
Available resources include:
• Study guides - Complete lessons with examples for

academic courses, including precalculus and calculus.
For example, the Interactive Precalculus Study Guide
contains worked problems, each solved as in a stand-
ard textbook, using Maple commands and custom
Maplet graphical interfaces.

• Free course lessons for many subjects including pre-
calculus to vector calculus; high school, abstract, and
linear algebra; engineering; physics; differential
equations; cryptography; and classical mechanics.

• Applications for students, written by students,
providing examples in many subject areas.

• Student FAQs with answers from experts.

(http://www.maplesoft.com/academic/students)

Student Help Center

The Maple Teacher Resource Center contains resources
and tips for teachers using Maplesoft products to help in
the classroom. Available resources include:
• Training videos

• E-books

(http://www.maplesoft.com/teachercenter)

Teacher Resource Center

Student Packages and Tutors
The Student package is a collection of subpackages for teaching and learning
mathematics and related subjects. The Student package contains packages
for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:

• Teach concepts without being distracted by the mechanics of the compu-
tations.
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• Create examples and quickly update them during a lesson to demonstrate
different cases or show the effect of the variation of a parameter.

• Create plots and animations to visually explain concepts, for example,
the geometric relationship between a mathematical function and its de-
rivatives (Tools→Tutors→Calculus - Single Variable→Derivatives).
See Figure 5.10.

Figure 5.10: Student[Calculus1] Derivatives Tutor

Students can:

• Perform step-by-step computations, for example, compute a derivative
by applying differentiation rules using commands or a tutor
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(Tools→Tutors→Calculus - Single Variable→Differentiation
Methods). See Figure 5.11.

• Perform computations.

• Visually explore concepts.

Figure 5.11: Student[Calculus1] Differentiation Methods Tutor

Tutors provide point-and-click interfaces to the Student package functional-
ity.

To launch a tutor:
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1. From the Tools menu, select Tutors.

2. Select a subject, for example, Calculus - Multi-Variable.

3. Select a tutor, for example, Gradients.

Maple inserts the Student[MultivariateCalculus][GradientTutor]() calling
sequence (in Worksheet mode), and launches the Multivariate Calculus
Gradient Tutor.

By rotating the three-dimensional plot, you can show that the gradient points
in the direction of greatest increase of the surface (see Figure 5.12) and show
the direction of the gradient vector in the x-y plane by rotating the plot (see
Figure 5.13).

Figure 5.12: Multivariate Calculus Gradient Tutor
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Figure 5.13: Multivariate Calculus Gradient Tutor Showing x-y Plane

When you close the tutor, Maple inserts the 3-D plot.

> 
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Many Student package commands can return a value, mathematical expres-
sion, plot, or animation. This allows you to compute the final answer, see
the general formula applied to a specific problem, or visualize the underlying
concepts.

For example, the Student[VectorCalculus][LineInt] (line integral) command
can return the following.

• Plot that visually indicates the vector field, path of integration, and tangent
vectors to the path

• Unevaluated line integral

• Numeric value of the line integral

> 
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> 

> 

(5.11)

To evaluate the integral returned by the output = integral calling sequence,
use the value command.

> 

(5.12)

By default, the LineInt command returns the value of the integral.
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> 

For more information on the Student package, refer to the ?Student help
page.

Calculus Problem Solving Examples
Maple is a powerful application with many resources to guide you. The fol-
lowing examples provide you with scenarios to learn about using Maple re-
sources and the Maple program.

When using Maple to solve a problem, consider the following process.

1. Formulate your problem.

2. Obtain Maple resources that allow you to solve it.

Problem
Scenario A:
Your company is designing a bottle for its new spring
water product. The bottle must contain 18 ounces of
water and the height is fixed. The design includes an
undulating curved surface. You know the amplitude and
equation of the curve, but you must find the radius. You
require the Volume of Revolution.

Scenario B:
You want to teach your students the concept of a
Volume of Revolution. Specifically, you want to plot
and compute the volume of a solid generated by rotating

, about an axis or a line parallel to an
axis.
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Figure 5.14: Flowchart of solving a problem

Check for Existing Tools: Tutor

Begin by examining the Tools menu for a Tutor to a Volume of Revolution
problem.

To access a Tutor for the Volume of Revolution:

1. From the Tools menu, select Tutors, and then Calculus-Single Variable.
Notice that a Volume of Revolution tutor exists.

2. Click the Volume of Revolution menu item. The following Maple com-
mand is entered in your document.

> 
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The Volume of Revolution Tutor is displayed. See Figure 5.15. Use this
tutor to enter a function and an interval, view and manipulate the correspond-
ing plot, and view the full Maple command associated with your entries and
selections.
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Figure 5.15: Volume of Revolution Tutor

After you Close the tutor, the plot is inserted into your worksheet.

Check for Existing Tools: Task Template

1. From the Tools menu, select Tasks, and then Browse. The Browse Tasks
dialog opens, displaying a list of tasks in the left pane. The tasks are sorted
by subject to help you quickly find the desired task.

2. Expand the Calculus → Integration → Surface of Revolution folder.

3. From the displayed list, select Volume. The Volume of Revolution task
is displayed in the right pane of the Browse Tasks dialog.

4. Select the Insert into New Worksheet check box.
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5. Click Insert Default Content. Before inserting a task, Maple checks
whether the task variables have assigned values in your worksheet. If any
task variable is assigned, the Task Variables dialog opens allowing you to
modify the names. Maple uses the edited variable names for all variable in-
stances in the inserted task. The content is inserted into your document. See
Figure 5.16.

Figure 5.16: Inserted Task Template

6. When a Task Template is inserted, parameters are marked as placeholders,
denoted by purple font. To navigate between placeholders, press the Tab
key. After updating any parameters, execute the command by pressing Enter.

Check for Instructions: Help Page and Example Worksheet

The help system provides command syntax information.

To access a help page:

1. From the Help menu, select Maple Help.

2. In the search field, enter volume of revolution and click Search. The
search results include the command help page, the dictionary definition, and
the associated tutor help page.
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3. Review the calling sequence, parameters, and description in the Stu-
dent[Calculus1][VolumeOfRevolution] help page.

4. Copy the examples into your worksheet: from the help system Edit menu,
select Copy Examples.

5. Close the Help Navigator.

6. In your document, from the Edit menu, select Paste. The examples are
pasted into your document.

7. Execute the examples and examine the results.

To access an example worksheet:

1. In the worksheet, enter ?index/examples. The Example Worksheet Index
opens.

2. Expand the Calculus topic.

3. Click the examples/Calculus1IntApps link. The Calculus1: Applications
of Integration worksheet opens. See Figure 5.17.

4. Expand the Volume of Revolution topic.

5. Examine and execute the examples.
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Figure 5.17: Example Worksheet

Check for Other Ready-To-Use Resources: Application Center

The Maple Application Center contains free user-contributed applications
related to mathematics, education, science, engineering, computer science,
statistics and data analysis, finance, communications, graphics, and more.

To access a free application for volume of revolution:

1. Go to the Maplesoft web site, http://www.maplesoft.com.

2. In the menu of the main web page, click User Community, and then
Application Center.

3. In the Application Search section, enter Calculus 2 in the Keyword or
phrase field and select Education PowerTool from the Application type
drop-down menu.
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4. Click Go.

5. From the search results page, click the CalculusII: Complete Set of
Lessons link.

6. From the Options area, click Download Maple Worksheet.

7. Log in as a guest or Maplesoft Member.

8. Download the .zip file.

9. Extract the L2-volumeRevolution.mws file.

10. Execute the worksheet and examine the results.

5.8  Clickable Math Examples
Maple has incorporated several features that eliminate the learning curve for
new users. With drag-and-drop functionality, context menus, built-in tutors,
command completion, and over 20 palettes, using Maple has never been so
easy. This chapter is designed to show several ways to solve the same problem
in Maple. Throughout these examples, you will need to insert new document
block regions. This is done through the Format menu, by selecting Create
Document Block. Also, these examples only use the keyboard keys needed
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for a Windows operating system. Refer to Shortcut Keys by Plat-
form (page xiv) for the keys needed for your operating system.

Example 1 - Graph a Function and its Derivatives

On the interval graph and for 

We solve this problem using the following methods:

• Solution by Context Menus (page 254)

• Solution by Tutor (page 256)

• Access the Tutor from a Task Template (page 258)

Solution by Context Menus
Result in DocumentAction

1. Enter the expression 

Make a copy of the expression and calcu-
late the derivative:
2. Insert a new document block region by
selecting from the Format menu Create
Document Block.
3. Highlight the original expression. Ctrl +
drag the expression to the new document
block.
4. Right-click the expression and select
Differentiate → x.

Make a copy of the derivative and calcu-
late the second derivative:
5. Insert a new document block, and Ctrl
+ drag the derivative to the document block.
6. Right-click the derivative and select Dif-
ferentiate → x.
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Result in DocumentAction

Plot the expression:
7. Insert a new document block, and Ctrl
+ drag the original expression to the new
block.
8. Right-click the expression and select
Plots → Plot Builder.
9. In the Interactive Plot Builder: Select
Plot Type dialog, change the x Axis range
to -Pi to Pi.

Add the first and second derivatives to
the plot:
11. Select and then Ctrl + drag the derivat-
ive of the expression onto the plot region.
Do the same for the second derivative.

5.8  Clickable Math Examples   •   255



Result in DocumentAction

Enhance the plot by adding a legend us-
ing context menus:
12. Right-click in the plot region and select
Legend → Show Legend.
13. In the legend, double-click Curve 1.
Notice that the Text icon is selected in the
toolbar, . Delete the text and select
the Math icon in the toolbar, . This
allows you to enter 2-D Math in a text re-
gion. Enter the original expression,

14. Repeat for Curve 2 and Curve 3.

Add a title:
15. To enter a title, click the Drawing icon

in the toolbar, . If the Drawing
icon is not accessible, click in the plot re-
gion.

16. Click T in the Drawing toolbar, .
17. Click the plot region and a text region
appear. Notice that the toolbar has changed
once again with the Text icon selected.
Enter "Plot the expression". Click the
Math icon, and enter the expression

Click the Text icon once again
and enter "and its derivatives".
18. Click the text region and the border be-
comes highlighted. You can now reshape
the text region and move it around the plot
region using the mouse.

Solution by Tutor

The Student Calculus 1 package contains a tutor called Derivatives, which
displays a plot of the expression along with its derivatives. In this example,
we solve the same problem as previously, using this tutor
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Result in DocumentAction

Loading Student:-Calculus11. Load the Student Calculus 1 pack-
age. From the Tools menu, select Load
Package → Student Calculus 1.

2. Ctrl + drag the expression 
to a blank document block region.

3. Right-click the expression and select
Tutors → Calculus - Single Variable
→ Derivatives. Note: The Tutors
menu is now available in the context
menu because we loaded the Student
Calculus 1 package in step 1.
In the Derivative Tutor, the color
swatch shown beside the original ex-
pression is the color used for the curve
in the plot region. Similarly for 

and 

4. Select the check box to display
in the plot. Click Display to

make this change take effect.
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Result in DocumentAction

5. You can change the expression,
ranges, or plot options from within this
tutor. For each change made, click
Display to view the altered plot. When
complete, click Close to display the
resulting plot in the document. The title
and legend are automatically added.

Access the Tutor from a Task Template

Maple also comes with a Task Template to solve this problem without using
any commands.
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Result in DocumentAction

1. Launch the Task Template Browser by
selecting Tools → Tasks → Browse.
2. In the table of contents of the Task
Browser dialog, select Calculus → Derivat-
ives → Graph and its Derivatives.

3. Click Insert Minimal Content at the top
of the dialog to insert the task template into
the current document.

4. Enter the new expression in
the f(x) region.

5. Enter the interval To insert the
symbol for pi, you can use command comple-
tion or select from the Common Symbols
palette.
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Result in DocumentAction

6. Click Launch Differentiation Tutor to
launch the same tutor as in the previous
solution.
7. When complete, click Close. A plot of the
expression and its derivatives displays in the
plot region of the inserted task template.
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Example 2 - Solve for x in a Quadratic Equation

Solve for in the equation

We solve this problem using the following methods:

• Solution through Equation Manipulator (page 261)

• Instant Solution (page 263)

• Step-by-step Interactive Solution (page 263)

• Graphical Solution (page 265)

Solution through Equation Manipulator

Maple provides a dialog that allows you to single-step through the process
of manipulating an expression. This manipulator is available from the context
menu.

Result in DocumentAction

1. Enter the equation
in a new

document block region.

2. Right-click this equation and select
Manipulate Equation. The Manipulate
Equation dialog displays.
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Result in DocumentAction

Group all of the terms to the left:
3. In the Addition region, the Group
terms row allows you to group terms on
a specified side. With the left side already
selected, click Do.

Expand the left side of the equation:
4. In the Miscellaneous Operations re-
gion, we can manipulate the equation by
applying a command from the drop-down
menus. Since we want to expand the left
side of the equation only, click the first
drop-down menu in the second row and
select expand. Click Do.

Factor the equation:
5. From the same drop-down menu, select
factor and click Do.

6. Click Return Steps to close the dialog
and return all of the steps to the Maple
document.

7. Ctrl + drag the factored form of the
original equation to a new document
block region.
8. Right-click and select Solve → Solve
for Variable → x.
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Instant Solution

To apply an instant solution to this problem, use context menus.
Result in DocumentAction

1. Ctrl + drag the equation
to a new

document block region.

2. Right-click the expression and select
Solve → Solve for Variable → x.

Step-by-step Interactive Solution

By making use of equation labels, we can refer to each successive equation
and add, subtract, multiply, and divide as appropriate, one step at a time.

Result in DocumentAction

(5.13)

1. Ctrl + drag the equation
to a blank

document block region and press the Enter
key.
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(5.14)

(5.15)

To group all terms on the right, subtract

and from both sides
of the equation:
2. Press Ctrl + L to launch the Equation La-
bel dialog and refer to the previous output.
In the dialog, enter 5.10 (or the appropriate
label) and click OK.
3. With the equation label inserted, enter

Press Enter.

4. Using equation labels again, enter 5.11 in
the Equation Label dialog and click OK.

Enter Press Enter.

(5.16)

Use Maple's expand, factor, and solve
commands to complete the problem:
5. Enter expand(.
6. Press Ctrl + L and enter the label for the
previous result.
7. Enter a closing parenthesis, ), then press
Enter.

(5.17)

(5.18)

8. Repeat steps 5 → 7 with factor and solve
to complete the solution.
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Graphical Solution

Now that we have seen several methods to solve this problem, we can check
the answer by plotting the expression.

Result in DocumentAction

1. Ctrl + drag the equation
to a new

document block region and press Enter.

(5.19)

First, manipulate the equation to become
an expression:
2. Right-click the output and select Move to
Left.
Note the difference in the alignment when
using context menus on output rather than
input. The result is centered in the document
with the self-documenting arrow positioned
at the left.

(5.20)

3. Right-click the output and select Left-
hand Side.

(5.21)

4. Right-click the output and select Expand.
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Now that the equation is in its simplest
form, plot the result:
5. Ctrl + drag the output to a new document
block.
6. Right-click the expression and select Plots
→ 2-D Plot.

Change the and axis ranges using
context menus:
7. By default, plots generated using the con-
text menus have an -axis range of -10 to
10. To change the range, right-click the plot
and select Axes → Properties. In the Hori-
zontal tab of the Axes Properties dialog, de-
select Use data extents and change the
Range min and `Range max to 0 and 5, re-
spectively.
Click the Vertical tab and de-select Use data
extents. Change the Range min and Range
max to -5 and 10, respectively.
8. Click OK to apply the changes and return
to the plot.
The interception points of this graph with the

-axis are 1 and 3, the same solutions that
we found previously.
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Example 3 - Solve a Quadratic Trig Equation

Find all of the solutions to the equation in

the interval 

We solve this problem using the following methods:

• Graphical Solution (page 267)

• Solution by Task Template (page 269)

• Analytic Solution (page 270)

Graphical Solution
Result in DocumentAction

1. Ctrl + drag the equation

to a blank
document block and press Enter.

2. Right-click the output and select Left-
hand Side.
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Result in DocumentAction

3. Right-click the output and select Plots →
Plot Builder.

4. Modify the plot range to to 
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Result in DocumentAction

5. Click Plot to display the plot in the docu-
ment.
6. From the graph, we can see all of the
solutions within the interval To
approximate the values, click on the plot,
then use the Point Probe tool to view the
coordinates of the cursor in the toolbar.

Solution by Task Template
Result in DocumentAction

1. From the Format menu, select Tasks
→ Browse. Expand the Algebra folder
and select Solve Analytically in a
Specified Interval.

2. Click Insert Minimal Content.
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Result in DocumentAction

3. Replace the current equation with the
one from this example,

and then

execute the commands. Notice that
equation labels are used to reference
the results.

Analytic Solution
Result in DocumentAction

1. Ctrl + drag the equation

to a blank
document block region.

2. Right-click the expression and select Left-
hand Side.

3. Right-click the output and select Factor.

4. Ctrl + drag the first factor to a blank doc-
ument block region.
5. Right-click and select Solve → Solve.

6. Ctrl + drag the second factor to a blank
document block region.
7. Right-click and select Solve → Solve.
Notice that you have not found all of the
solutions, as with the above methods. These
are all of the solutions in the interval
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Example 4 - Find the Inverse Function

If find and graph the rule for its functional
inverse.

We solve this problem using the following methods:

• Implement the Definition Graphically (page 271)

• Solution by Tutor (page 274)

Implement the Definition Graphically

The graph of the inverse function is the set of ordered pairs formed by inter-
changing the ordinates and abscissas.

Result in DocumentAction

1. In a blank document block, enter

and press Enter.

2. Right-click the output and select Plots
→ Plot Builder.
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Result in DocumentAction

3. In the Plot Builder : Select Plot Type
dialog, ensure that 2-D parametric plot
is selected in the Select Plot region.

4. Adjust the domain for to the interval

5. Click Plot to return the plot to the doc-
ument.

6. Ctrl + drag the expression onto
this graph.
Notice that the axis ranges alter.
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Result in DocumentAction

7. Ctrl + drag the expression onto this
graph. The resulting graph shows

and the line 

Adjust the and axis ranges:

8. Right-click the plot and select Axes →
Properties.
9. In the Axis Properties dialog, de-select
Use data extents and change the range to
0 to 2.
10. Click the Vertical tab and repeat step
9. Click OK to apply these settings and
close the dialog.

5.8  Clickable Math Examples   •   273



Solution by Tutor
Result in DocumentAction

Loading Student:-Calculus11. Load the Student Calculus 1 package.
From the Tools menu, select Load
Package → Student Calculus 1.

2. Ctrl + drag the expression to
a blank document block.

3. Right-click and select Tutors → Cal-
culus - Single Variable → Function
Inverse. The Function Inverse Tutor
displays.

4. Adjust the domain to 

5. When you are finished, click Close.
The plot of the function, its inverse, and
the line is returned to the docu-
ment.
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Example 5 - Methods of Integration - Trig
Substitution

Evaluate the integral by making the substitution

We solve this problem using the following methods:

• Immediate Evaluation of the Integral (page 275)

• Solution by Integration Methods Tutor (page 275)

• Solution by First Principles (page 277)

Immediate Evaluation of the Integral
Result in DocumentAction

1. Enter the integral in a

blank document block region.

= 
2. Right-click the expression and select
Evaluate and Display Inline.

Solution by Integration Methods Tutor
Result in DocumentAction

Loading Student:-Calculus11. Load the Student Calculus 1 package.
From the Tools menu, select Load Package
→ Student Calculus 1.

2. Ctrl + drag the integrand to

a blank document block region.
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Result in DocumentAction

3. Right-click the expression and select
Tutors → Calculus Single Variable →
Integration Methods. The Integration
Methods Tutor displays.

4. Perform a change of variables by select-
ing Change and entering x = 2*sin(u).

5. Apply the constant rule by clicking Con-
stant.
6. To revert back to the original variable,
click Revert.
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Result in DocumentAction

7. Now that the integral has been evaluated,
click Close to close the tutor and return the
evaluated integral to the document.

Solution by First Principles
Result in DocumentAction

1. Ctrl + drag the integrand to

a blank document block region and press
Enter.

Perform trig substitution:
2. Right-click the output and select Evaluate
at a point. In the dialog that displays, enter
2*sin(u).

(5.22)

3. Right-click the output and select Simplify
→ Symbolic.
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Result in DocumentAction

(5.23)

Calculate :

4. In a blank document block, enter the sub-
stitution equation: and press
Enter.
5. Right-click the output and select Differen-
tiate Implicitly. In the dialog that displays,
change the Independent Variable to u.

(5.24)

Calculate the integral in terms of :

6. Referencing the results by their equation
labels, multiply the original simplified expres-
sion by this derivative.

(5.25)

7. Integrate the resulting expression.

Revert the substitution:

8. Place the equation in a blank

document block. Delete and insert the
equation label for the previous result, the
value of the integral in terms of Press
Enter.
9. Right-click the output and select Solve →
Solve for Variable → u.

The solution is 
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Example 6 - Initial Value Problem
Solve and plot the solution of the initial value problem

Solution by ODE Analyzer Assistant

The ODE Analyzer Assistant lets you solve ODEs numerically or symbolic-
ally and displays a plot of the solution.

Result in DocumentAction

1. Enter the ODE in a blank docu-
ment block region.

2. Right-click the equation and select
Solve DE Interactively. The ODE
Analyzer Assistant displays with the
ODE automatically inserted.
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Result in DocumentAction

To insert the initial conditions:
3. In the Conditions region, click
Edit. The Edit Conditions dialog
opens.

4. In the Add Condition region, with
y selected in the drop-down menu,
enter 0 in the first text field to the
right and 2 in the second text field.
Click Add. Your entry should match
the one shown to the right.

5. To enter the initial condition for
select y' from the drop-down

menu. In the text fields, enter 0 and
-1. Click Add.
Click Done to close this dialog and
return to the main dialog. Notice that
the initial conditions are in the Con-
ditions section.
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Result in DocumentAction

6. Click Solve Numerically. A new
dialog appears.

7. Click Solve to solve the initial
value problem.
8. Click Plot to plot the solution of
the DE.

9. Click the Plot Options button to
modify the default graph, if desired.
10. Click Quit to close the ODE
Analyzer and return a plot of the
solution to the document.
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6  Plots and Animations
Maple can generate many forms of plots, allowing you to visualize a problem
and further understand concepts.

• Maple accepts explicit, implicit, and parametric forms to display 2-D
and 3-D plots and animations.

• Maple recognizes many coordinate systems.

• All plot regions in Maple are active; therefore, you can drag expressions
to and from a plot region.

• Maple offers numerous plot options, such as axis styles, title, colors,
shading options, surface styles, and axis ranges, which give you complete
control to customize your plots.

For a reference to the types of plots available in Maple, see the ?Plotting
Guide.

6.1  In This Chapter
TopicsSection

• Interactive Plot Builder

• Context Menu

• Dragging to a Plot Region

• The plot and plot3d Commands

• The plots Package

• Multiple Plots in the Same Plot Re-
gion

Creating Plots - Interactive and command-driven
methods to display 2-D and 3-D plots
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TopicsSection

• Interactive Plot Builder Options

• Context Menu Options

• The plot and plot3d Command Op-
tions

Customizing Plots - Methods for applying plot
options before and after a plot displays

• Point Probe

• Rotate

• Pan

• Zoom

Analyzing Plots - Plot analyzing tools

• Interactive Plot Builder

• The plots[animate] Command

• The plot3d[viewpoint] Command

Creating Animations - Interactive and command-
driven methods to display animations

• Animation Context BarPlaying Animations - Tools to run animations

• Interactive Plot Builder Animation
Options

• Context Menu Options

• The animate Command Options

Customizing Animations - Methods for applying
plot options before and after an animation dis-
plays

• Saving Plots to File FormatsExporting - Methods for exporting plots

• Accessing Code for the Color PlatesCode for Color Plates - Information on color
plates

6.2  Creating Plots
Maple offers several methods to easily plot an expression. These methods
include:

• The Interactive Plot Builder

• Context menus

• Dragging to a plot region
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• Commands

Each method offers a unique set of advantages. The method you use depends
on the type of plot to display, as well as your personal preferences.

Interactive Plot Builder
The Interactive Plot Builder is a point-and-click interface to the Maple
plotting functionality. The interface displays plot types based on the expres-
sion you specify. The available plot types include plots, interactive plots,
animations, or interactive animations. Depending on the plot type you select,
you can create a:

• 2-D / 3-D plot

• 2-D polar plot

• 2-D / 3-D conformal plot of a complex-valued function

• 2-D / 3-D complex plot

• 2-D density plot

• 2-D gradient vector-field plot

• 2-D implicit plot

Using the Interactive Plot Builder, you can:

1. Specify the plotting domain before you display the graph

2. Specify the endpoints of the graph as symbolic, such as Pi or sqrt(2)

3. Select different kinds of graphs, such as animations or interactive plots
with slider control of a parameter; that is, customize and display a plot by
selecting from the numerous plot types and applying plot options without
any knowledge of plotting command syntax

4. Apply the discont=true option for a discontinuous graph

The output from the Interactive Plot Builder is a plot of the expression or
the command used to generate the plot in the document.
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To launch the Interactive Plot Builder:

• From the Tools menu, select Assistants, and then Plot Builder. Note:
The Tools menu also offers tutors to easily generate plots in several
academic subjects. For more information, see Teaching and Learning
with Maple (page 238).

Table 6.1: Windows of the Interactive Plot Builder

2. Select Plot Type window1. Specify Expressions window

1. Specify Expressions window - Add, edit, or remove expressions and
variables. Once finished, you can advance to the Select Plot Type window.

2. Select Plot Type window - Select the plot type and corresponding plot,
and edit the ranges. Once finished, you can display the plot or advance to
the Plot Options window.
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3. Plot Options window

3. Plot Options window - Apply plot options. Once finished, you can display
the plot or return the command that generates the plot to the document.
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Example 1 - Display a plot of a single variable expression

Maple can display two-dimensional graphs and offers numerous plot options
such as color, title, and axis styles to customize the plot.
Launch the Interactive Plot Builder:
1. Make sure that the cursor is in a Maple input region.

2. From the Tools menu, select Assistants, and then Plot Builder.

Notes: 1. In worksheet mode, Maple inserts plots[interactive](); in the Maple document.

Entering this command at the Maple prompt also opens the Plot Builder.

2. Interaction with the document is disabled while the Plot Builder is running.

Enter an expression:
3. In the Specify Expressions window:

a. Add the expression, sin(x)/x.

b. Click Done to proceed to the Select Plot Type window.

Plot the expression:
4. In the Select Plot Type window, notice the default setting of a 2-D plot type and an x

axis range, -10 .. 10. Notice also the various plot types available for this expression.

5. Click Plot. 

To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 299)

Example 2 - Display a plot of multiple expressions in 1 variable

Maple can display multiple expressions in the same plot region to compare
and contrast. The Interactive Plot Builder accepts multiple expressions.
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Launch the Interactive Plot Builder and enter the expressions:
1. Launch the Interactive Plot Builder. The Plot Builder accepts expressions in 1-D 

Math and performs basic calculations on expressions. For example, entering

diff(sin(x^2), x) in the Specify Expression window performs the calculation and

displays the expression as 2*cos(x^2)*x in the Expression group box. 

2. In the Specify Expressions window: 

a. In three separate steps, add the expressions sin(x^2), diff(sin(x^2),x), and

int(sin(x^2), x).

Change the x-axis range:
3. In the Select Plot Type window:

a. Change the x Axis range to -3 .. 3.

b. Click Options to proceed to the Plot Options window.

Launch the Plot Options window and return the plot command syntax to the docu-
ment:
4. Click Command.

Display the actual plot:
5. Execute the inserted command to display the plot by using the context menu item Execute.

> 

By default, Maple displays each plot in a plot region using a different color.
You can also apply a line style such as solid, dashed, or dotted for each ex-
pression in the graph. For more information, refer to the ?plot/options help
page. To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 299)
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Example 3 - Display a plot of a multi-variate expression

Maple can display three-dimensional plots and offers numerous plot options
such as light models, surface styles, and shadings to allow you to customize
the plot.
Launch the Interactive Plot Builder and enter an expression:
1. Add the expression (1+sin(x*y))/(x^2+y^2).

In the Select Plot Type window:
2. Notice the available plot types for an expression with 2 variables, as well as the plot

objects for each type.

3. Click Options.

In the Plot Options window:
4. From the Variables column at the top of the dialog, change the Range from field to

0 .. 0.05.

5. From the Label column, enter z.

6. From the Style group box, select surface.

7. From the Color group box, in the Light Model drop-down menu, select green-red.

8. From the Color group box, in the Shading, drop-down menu, select z (grayscale).

9. From the Miscellaneous group box, in the Grid Size drop-down menu, select 40, 40.

Plot the expression:
10. Click Plot.

To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 299)
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Example 4 - Display a conformal plot

Maple can display a conformal plot of a complex expression mapped onto
a two-dimensional grid or plotted on the Riemann sphere in 3-D.
Launch the Interactive Plot Builder and enter an expression:
1. Add the expression z^3.

In the Select Plot Type window: 

2. From the Select Plot group box, select 2-D conformal plot of a complex-valued function.

3. Change the range of the z parameter to 0 .. 2+2*I.

In the Plot Options window: 

4. From the Axes group box, select normal.

5. From the Miscellaneous group box, select the Grid Size drop-down menu option 30, 30.

Plot the expression:
6. Click Plot.

Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports
numerous other coordinate systems, including hyperbolic, inverse elliptic,
logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cyl-
indrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic
cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-
dimensional plots. For a complete list of supported coordinate systems, refer
to the ?coords help page.
Launch the Interactive Plot Builder and enter an expression:
1. Add the expression 1+4*cos(4*theta).
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Change the x-axis range:
2. In the Select Plot Type window:

a. With 2-D polar plot selected, change the Angle of theta to 0 .. 8*Pi.

In the Plot Options window: 

3. From the Color group box, select Magenta.

Plot the expression:
4. Click Plot.

To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 299)

Example 6 - Interactive Plotting

Using the Interactive Plot Builder, you can plot an expression with several
of its variables set to numeric values. The Interactive Parameter window
allows you to interactively adjust these numeric values within specified
ranges to observe their effect. To access this window, enter an expression
with two or more variables and select Interactive Plot with x parameter
from the Select Plot Type and Functions drop-down menu.
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Figure 6.1: Interactive Parameter Window

Launch the Interactive Plot Builder and enter an expression:
1. Add the expression x+3*sin(x*t).
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In the Select Plot Type window: 

2. From the Select Plot group box, select Interactive Plot with 1 parameter.

3. Change the range of the x-axis to 0 .. 5.

4. Change the t range to 0 .. 10.

5. Click Plot to open the Interactive Parameter window.

Note: To apply plot options before interactively adjusting the plot, click Options to open

the Plot Options window. After setting the plot options, click Plot to display the

Interactive Parameter window.

6. To adjust the numeric values, use the slider.
7. Click Done to place the plot in the Maple document.

To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 299)

For information on customizing plots using the Interactive Plot Builder,
refer to Customizing Plots: Interactive Plot Builder Options (page 315).

Context Menu
A context menu in Maple displays a list of commands to manipulate, display,
or calculate using a Maple expression. The commands in the menu depend
on the type of the expression. To display the context menu for a Maple ex-
pression, right-click (Control-click for Macintosh) the expression.

For expressions, the context menu lists:

• 2-D or 3-D plot

• 2-D or 3-D implicit plot

• Interactive Plot Builder
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based on the expression selected.

When you invoke the Interactive Plot Builder through the context menu,
the expression automatically passes to the builder, and Maple does not display
the Specify Expression window.

One advantage of using the context menu is the simplicity of creating an
expression using menus. By using this method, you do not need any know-
ledge of plot command syntax.

1. Enter and evaluate an expression, for example, 

2. Right-click (Control-click for Macintosh) the expression.

3. From the context menu, select Plots → 3-D Plot → x,y.
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> 

(6.1)
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For information on customizing plots using the context menu, see Context
Menu Options (page 315).
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Dragging to a Plot Region
To use the drag-and-drop method, use the plot region created by one of the
other methods or insert an empty plot region into the document. Empty plot
regions can be two-dimensional or three-dimensional.

Advantages of the drag-and-drop method include the ease of adding and re-
moving plots and the independence from plotting command syntax.

Example:
1. From the Insert menu, select Plot → 2-D.

2. Enter the expression in an input region.

3. When dragging an expression to a plot region, you can either make a copy of the expres-
sion from the input region or you can cut the expression, thereby removing it from the input
region. To make a copy of the expression, select the full expression in the input region and
press Ctrl (Command, Macintosh) while you drag the expression to the plot region. To
cut the expression and paste it in the plot region, highlight the expression and drag it to
the plot region.

4. Repeat steps 2 and 3 using the following expressions: and 

5. To remove an expression from the plot region, drag-and-drop the expression plot from
the plot region to a Maple input region.
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The plot and plot3d Commands
The final method for creating plots is entering plotting commands.

The main advantages of using plotting commands are the availability of all
Maple plot structures and the greater control over the plot output. Plot options
are discussed in Customizing Plots (page 314).

Table 6.2: The plot and plot3d Commands

plot(plotexpression, x=a..b, ...)
plot3d(plotexpression, x=a..b, y=a..b, ...)
• plotexpression - expression to be plotted

• x=a..b - name and horizontal range

• y=a..b - name and vertical range

Maple commands from Creating Plots: Interactive Plot Builder

The following examples show the plotting commands returned by the ex-
amples in Interactive Plot Builder (page 285).

Example 1 - Display a plot of a single variable expression

> 
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Example 2 - Display a plot of multiple expressions in 1 variable

To display multiple expressions in a plot, include the expressions in a list.

To enter and use the Expression palette. For

more information, see Palettes (page 25).

> 

300   •   6  Plots and Animations



Example 3 - Display a plot of a multi-variable expression

> 
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Example 4 - Display a conformal plot

A collection of specialized plotting routines is available in the plots package.
For access to a single command in a package, use the long form of the
command.

> 
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Example 5 - Display a plot in polar coordinates

> 
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Example 6 - Interactive Plotting

> 
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For more information on the plot options used in this section, refer to the
?plot/options and ?plot3d/options help pages.

Display a Parametric Plot

Some graphs cannot be specified explicitly. In other words, you cannot write
the dependent variable as a function of the independent variable, 
One solution is to make both the x-coordinate and the y-coordinate depend
upon a parameter.

> 
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Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimen-
sional space. To customize the plot, include plot3d options in the calling
sequence. For a list of plot options, see The plot and plot3d Options (page 318).
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> 

The plots Package
The plots package contains numerous plot commands for specialized plotting.
This package includes: animate, contourplot, densityplot, fieldplot, ode-
plot, matrixplot, spacecurve, textplot, tubeplot, and more. For details
about this package, refer to the ?plots help page.

> 
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The pointplot Command

To plot numeric data, use the pointplot command in the plots package with
the data organized in a list of lists structure of the form

By default, Maple does not connect the

points. To draw a line through the points, use the style = line option. For
further analysis of data points, use the Curve Fitting Assistant
(Tools→Assistants→CurveFitting), which fits and plots a curve through
the points. For more information, refer to the ?CurveFitting[Interactive]
help page.
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> 

The matrixplot Command

The matrixplot command plots the values of a plot object of type Matrix.
The matrixplot command accepts options such as heights and gap to control
the appearance of the plot. For more information on Matrices, see Linear
Algebra (page 189).

> 

> 
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> 
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> 

The contourplot Command

The contourplot command generates a topographical map for an expression
or function. To create a smoother and more precise plot, increase the number
of points using the numpoints option.

> 
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Multiple Plots in the Same Plot Region

List of Expressions

To display multiple expressions in the same plot region, enter the expressions
in a list data structure. To distinguish the surfaces, apply different shading
options, styles, or colors to each surface.

> 
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The display Command

To display different types of plots in the same plot region, use the display
command in the plots package.

This example plots a curve over a hill with the shadow of the curve projected
onto the hill.

> 

> 

> 

> 
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Maple can draw curves in three-dimensional space.

> 

> 

> 

> 

6.3  Customizing Plots
Maple provides many plot options to display the most aesthetically pleasing,
illustrative results. Plot options include line styles, colors, shadings, axis
styles, and titles where applicable. Plot options are applied using the Inter-
active Plot Builder, the context menus, or as options in the command syntax.
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Interactive Plot Builder Options
The Interactive Plot Builder offers most of the plot options available in
Maple in an easy-to-use interface.

Example:
Launch the Interactive Plot Builder and enter the expression:
1. Add the expression 2*x^5-10*x^3+6*x-1. For information on interacting with the In-
teractive Plot Builder, see Example 1 - Display a plot of a single variable expres-
sion (page 288).

Set the x-axis range:
2. In the Select Plot Type window, change the x-axis range to -2 .. 2.

In the Plot Options window:
3. From the Line group box, select dot from the left drop-down menu.
4. From the Color group box, select Blue.
5. From the Axes group box, select frame.
6. From the Title group box, enter My Plot in the text field.

Plot the expression:
7. Click Plot.

Context Menu Options
Using the context menu, you can alter a plot by right-clicking (Control-click
for Macintosh) the plot output. You can also access a large subset of plot
options using the Plot toolbar and Plot menu options. These menus display
when a plot region is selected. Regardless of the method used to insert a plot
into Maple, you can use the context menu to apply different plot options.
For a list of options available when plotting in two and three dimensions,
see The plot and plot3d Options (page 318).

2-D Plot Options

Some plots do not display as you would expect using default option values.
A expression with a singularity is one such example.
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> 

In the previous plot, all interesting details of the plot are lost because there
is a singularity at x = 1. The solution is to view a narrower range, for example,
from y = 0 to 7.
Alter the y-axis range:
1. Right-click the plot region. Select Axes, and then Properties.
2. In the Axes Properties dialog, click the Vertical tab.
3. De-select the Use data extents check box and enter 0 and 7 in the
Range min and Range max text regions accordingly.
4. Click Apply to view the changes, or OK to return to the document.

Change the color:
5. Place the mouse pointer on the curve and right-click (Control-click,
Macintosh). Note: The curve is selected when it becomes highlighted.
Select Color, and then Green.
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Change the line style:
6. Select Style, and then Point.

3-D Plot Options

By default, Maple displays the graph as a shaded surface with a wireframe
and scales the plot to fit the window. To change these options, use the context
menu.

> 

Maple has many preselected light source configurations.
Change the style:
1. Right-click the plot region. Select Style → Surface.

Apply a light scheme:
2. Select Lighting → Light 1.
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Change the color:
3. Select Color → Z (Grayscale).

Change the axes style:
4. Select Axes → Boxed.

Alter the glossiness:
5. Select Glossiness and then select Set.... Using the slider, adjust the level of glossiness.

The plot and plot3d Options
If you are using commands to insert a plot, you can specify plot options as
arguments at the end of the calling sequence. You can specify the options
in any order. Applying plot options in the command syntax offers a few more
options and greater control than what is available in the Interactive Plot
Builder and context menus.

Table 6.3: Common Plot Options

DescriptionOption

Defines the type of axes, one of: boxed, frame, none, or normalaxes

Defines the caption for the plotcaption

Defines a color for the curves to be plottedcolor

Defines the font for text objects in the plotfont

Controls the amount of light reflected from the surfaceglossiness (3-D)

Defines gridlines in the plotgridlines (2-D)

Controls the light model to illuminate the plot, one of: none, light1,
light2, light3, or light4

lightmodel (3-D)

Defines the dash pattern used to render lines in the plot, one of: dot,
dash, dashdot, longdash, solid, spacedash, and spacedot

linestyle

Defines a legend for the plotlegend (2-D)

Controls the minimum total number of points generatednumpoints
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DescriptionOption

Controls the scaling of the graph, one of: constrained or uncon-
strained

scaling

Defines how the surface is colored, one of: xyz, xy, z, zgrayscale,
zhue, or none

shading (3-D)

Defines how the surface is to be drawn, one of: line, point, polygon,
or polygonoutline for 2-D plots; contour, point, surface, surfacecon-
tour, surfacewireframe, wireframe, or wireframeopaque for 3-D
plots

style

Defines the symbol for points in the plot, one of: asterisk, box, circle,
cross, diagonalcross, diamond, point, solidbox, solidcircle, or
soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonal-
cross, diamond, point, solidsphere, or sphere for 3-D plots

symbol

Defines a title for the plottitle

Defines the thickness of lines in the plotthickness

Controls the transparency of the plot surfacetransparency (3-D)

Defines the minimum and maximum coordinate values of the axes
displayed on the screen

view

For a complete list of plot options, refer to the ?plot/options and
?plot3d/options help pages.
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> 

To create a smoother or more precise plot, calculate more points using the
numpoints option.

> 
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6.4  Analyzing Plots
Point Probe, Rotate, Pan, and Zoom Tools
To gain further insight into a plot, Maple offers various tools to analyze plot
regions. These tools are available in the Plot menu menu, Context Bar, and
in the context menu under Transform when the plot region is selected.

Table 6.4: Plot Analysis Options

DescriptionIconName

Display the coordinates corresponding to the cursor position on a
two-dimensional plot in the context bar (upper left-hand corner).

Point probe
(2-D)

Rotate a three-dimensional plot to see it from a different point of
view.

Rotate
(3-D)
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DescriptionIconName

Pan the plot by changing the view ranges for 2-D plots; smartplots
re-sample to reflect the new view. Change the position of the plot
in the plot region for 3-D plots.

Pan

Zoom into or out of the plot by changing the view ranges for 2-D
plots; smartplots re-sample to reflect the new view. Make the plot
larger or smaller in the plot window for 3-D plots.

Zoom

6.5  Creating Animations
Animations allow you to emphasize certain graphical behavior, such as the
deformation of a bouncing ball, more clearly than in a static plot. A Maple
animation is a number of plot frames displayed in sequence, similar to the
action of movie frames. To create an animation, use the Interactive Plot
Builder or commands.

Interactive Plot Builder
Creating Animations Using the Interactive Plot Builder:
Launch the Interactive Plot Builder and enter the expression:
1. Add the expression sin(i*sqrt(x^2+y^2)/10).
For information on interacting with the Interactive Plot Builder, see Example 1 - Display
a plot of a single variable expression (page 288).

In the Select Plot Type window: 

2. From the Select Plot Type drop-down menu, select Animation.

3. Change the x Axis range to -6 .. 6.

4. Change the y Axis range to -6 .. 6.

5. Change the Animation Parameter (i) range to 1 .. 30.
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In the Plot Options window:

3. From the Style group box, select surface.

4. From the Color group box, in the Light Model drop-down menu, select red-turquoise.

5. From the Color group box, in the Shading drop-down menu, select z (grayscale).

6. In the View group box, select the Constrained Scaling check box.

Plot the expression:
7. Click Plot.

> 

For information on playing the animation, see Playing Animations (page 326).
To see the Maple syntax used to generate this plot, see Maple Syntax for
Creating Animations: Interactive Plot Builder Example (page 324).

The plots[animate] Command
You can also use the animate command, in the plots package, to generate
animations.

Table 6.5: The animate Command

animate(plotcommand, plotarguments, t=a..b, ...)
animate(plotcommand, plotarguments, t=L, ...)
• plotcommand - Maple procedure that generates a 2-D or 3-D plot

• plotarguments - arguments to the plot command

• t=a..b - name and range of the animation parameter

• t=L - name and list of real or complex constants

To access the command, use the short form name after invoking the
with(plots) command.
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> 

Maple Syntax for Creating Animations: Interactive Plot Builder
Example

The following example shows the plotting command returned by the example
in Interactive Plot Builder (page 322).

> 

Animate a 2-D plot

> 
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For more information on the animate command, refer to the ?plots[animate]
help page.

The plot3d[viewpoint] Command
You can use the viewpoint command to create an animation in which the
position from which you view a 3-D plot moves in all directions and in
various angles around the plot surface based on coordinates and parameters
you specify. This type of animation creates the effect of flying through,
around, beside, towards, and away from a plot surface in three-dimensional
space.

The moveable position from which you view the surface is called the camera.
You can specify the orientation of the camera to view different sides of a
surface, the path along which the camera moves throughout and around a
surface, and the location of the camera in 3-D space in each animation frame.
For example, you can specify coordinates to move the camera to specific
points beside a surface; a pre-defined camera path to move the camera in a
circle around the surface; and the range of view to move the camera close
to or away from the surface. Refer to the ?viewpoint help page for informa-
tion on the available options.

To animate the following examples, click the plot object and then click the

play button ( ) in the Animation context bar.

Example 1: Moving the Camera Around a 3-D Plot

In the following example, a pre-defined path circleleft moves the camera in
a counter-clockwise circle around the plot surface.

> 

Example 2: Specifying a Path to Move the Camera Towards and Around a
3-D Plot
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In the following example, a camera path is specified to zoom into and view
different sides of the plot surface.

> 

6.6  Playing Animations
Animation Context Bar
To run the animation, click the plot to display the Animate context bar.

Table 5.6: Animation Options

DescriptionIconName

View the previous frame in the
animation.

Previous
Frame

Stop the animation.Stop

Play the selected animation.Play

View the next frame in the anima-
tion.

Next Frame

Slider control for viewing individu-
al frames of an animated plot.

Current
Frame

Forward - Play the animation for-
ward.
Oscillate - Play the animation for-
ward and backward.
Backward - Play the animation
backward.

Forward
Oscillate
Backward
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DescriptionIconName

Single - Run the animation in
single cycle mode. The animation
is displayed only once.
Continuous - Run the animation
in continuous mode. The anima-
tion repeats until you stop it.

Single
Continuous

Set the animation to play at a
faster or slower speed.

Frames per
second

Determine the coordinates of a 2-
D plot at the position of the cursor.

Point probe

Zoom into or out of the plot by
changing the view ranges.

Zoom

Pan the plot by changing the view
ranges.

Pan

You can also run the animation using the context menu or the Plot menu.

6.7  Customizing Animations
The display options that are available for static plots are also available for
Maple animations.

Interactive Plot Builder Animation Options
Using the Interactive Plot Builder, you can apply various plot options
within the Plot Options window. See Interactive Plot Builder (page 322).

Context Menu Options
As with static plots, you can apply plot options to the animation by right-
clicking (Control-click for Macintosh) the animation output.

Customize the animation using the context menu:
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1. To change the line style, right-click the plot region. Select Style → Point.

2. To remove the axes, select Axes → None.

The animate Command Options
The animate command offers a few options that are not available for static
plots. Refer to the ?animate help page for information on these additional
options. By default, a two-dimensional animation consists of sixteen plots
(frames) and a three-dimensional animation consists of eight plots (frames).
To create a smoother animation, increase the number of frames using the
frames option.

Note: Computing more frames increases time and memory requirements.

> 
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> 

6.8  Exporting
You can export a generated plot or animation to an image in various file
formats, including DXF and X3D (for 3-D plots), EPS, GIF, JPEG/JPG,
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POV, Windows BMP, and WMF. Exporting an animation to GIF produces
an animated image file. The exported images can be included in presentations,
web pages, Microsoft Word, or other software.

To export an image:

1. Right-click the plot region (Control-click for Macintosh).

2. Select Export and the file format.

Alternatively:

1. Click the plot.

2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be
automatically created without returning the image to the document. For more
information, refer to the ?plot,device help page.
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6.9  Code for Color Plates
Generating impressive graphics in Maple can require only a few lines of
code, as shown by the examples in this chapter. However, other graphics
require many lines of code. Code for the color plates is available at the Maple
Application Center.

From the Help menu, select On the Web, User Resources, and then Applic-
ation Center.

To access the color plate code:

1. Go to the Maple Application Center.

2. In the Keyword or phrase region, enter Color Plate.
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7  Creating Mathematical
Documents
Maple allows you to create powerful documents as business and education
tools, technical reports, presentations, assignments, and handouts.

You can:

• Copy, cut, and paste information

• Format text for reports or course material

• Add headers and footers

• Insert images, tables, and symbols

• Generate two- and three-dimensional plots and animations

• Sketch in the document

• Insert hyperlinks to other Maple files, web sites, or email addresses

• Place instructions and equations side by side

• Bookmark specific areas

• Easily update, revise, and distribute your documents

In this chapter, we will create a document that demonstrates many of Maple's
documentation features. For further examples, note that this guide was
written using Maple.
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7.1  In This Chapter
TopicsSection

• Copy and Paste

• Quick Character Formatting

• Quick Paragraph Formatting

• Character and Paragraph Styles

• Sections

• Headers and Footers

• Displaying Hidden Formatting Attributes

• Show or Hide Document Content

• Indentation and the Tab Key

Document Formatting - Add various
text formatting elements

• Document Blocks

• Typesetting

• Autoexecute

Commands in Documents - Format
and display or hide commands in a
document

• Creating a table

• Cell contents

• Navigating table cells

• Modifying Structural Layout

• Modifying Physical Dimensions

• Modifying Appearance

• Printing Options

• Execution Order

• Tables in the Classic Worksheet

Tables - Create tables and modify
their attributes
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TopicsSection

• Insert a Canvas

• Drawing

• Canvas Style

• Inserting Images

Canvas- Sketch an idea in the docu-
ment by inserting a canvas

• Inserting a Hyperlink in the Document

• Linking to an Email Address, Dictionary Topic,
Help Page, Maplet Application, Web Page, or
Document

• Bookmarks

Hyperlinks and Bookmarks - Add
hyperlinks to various sources

• How to Use the Spellcheck Utility

• Selecting a Suggestion

• User Dictionary

Spell Checking - Verify text with
the Maple spell checking utility

• Overview of available components

• Example using a task template

Embedded Components - Insert
buttons, sliders, and more in your
document

• Creating a Question

• Viewing Questions in Maple

• Saving Test Content

Creating Graded Assignments -
Create documents for automated
testing and assessment

• Classic Worksheet interface does not support all
Standard Worksheet interface features

Worksheet Compatibility - Compat-
ibility Issues

7.2  Document Formatting
To begin, create a new Maple document. From the File menu, select New
→ Document Mode. For this example, you can copy and paste text from
any file. The example text below is from a Maple help page, ?plot, but the
formatting has been removed for demonstration purposes.
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Copy and Paste
You can cut, copy, and paste content within Maple documents, and from
other sources.

To copy an expression, or part of an expression, to another location on
the document:

1. Select the expression, or part of the expression, to copy.

2. From the Edit menu, select Copy.

3. Place the cursor at the insertion point.

4. From the Edit menu, select Paste.
Result:

If you paste into a math input region, Maple interprets all the pasted content
as input. If you paste into a text region, Maple interprets all the pasted content
as text. However, note that 2-D Math retains its format in both input and text
regions.

When you copy and paste to another application, in general, Maple retains
the original structure.
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Quick Character Formatting
The Format→Character menu provides access to the following quick
formatting features: Bold, Italic, Underline, Superscript, Subscript, font
Color, and Highlight Color.

To modify text:

1. In the document, select the text to modify.

2. From the Format menu, select Character, and then the appropriate feature.

For example, in the pasted text, select "Calling Sequences" and apply Bold
character formatting.

Alternatively, use the context bar icons. For example, to apply a color to the
parameters "f, x=x0..x1":

• Font Color Context Bar Icon 

• Highlight Color Context Icon 

For font and highlight colors, you can select from Swatches, a color wheel,
RGB values, or choose a color using the eye dropper tool. See Figure 7.1.

Figure 7.1: Select Color Dialog

In this example, choose a dark purple color, as in the help pages.

To format this text as bold, click the Bold toolbar icon, . Also, select the
text "Calling Sequence" and format as bold.

7.2  Document Formatting   •   337



Result:

Attributes Submenu: Setting Fonts, Character Size, and Attributes

You can also change various character attributes such as font, character size,
style, and color in one dialog.

To modify text:

1. In the document, select text to modify.

2. From the Format menu, select Character, and then Attributes. The
Character Style dialog opens. See Figure 7.2.
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Figure 7.2: Character Style Dialog

Quick Paragraph Formatting
The Format→Paragraph menu provides access to the following quick
alignment features: Align Left, Center, Align Right, and Justify.

To modify a paragraph:

1. In the document, select the paragraph to modify.

2. From the Format menu, select Paragraph, and then the appropriate fea-
ture.
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Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line
Break, and Page Break

You can change various paragraph attributes in one dialog.

• From the Format menu, select Paragraph, and then Attributes. The
Paragraph Style dialog opens. See Figure 7.3.

• When changing spacing, you must indicate units (inches, centimeters,
or points) in the Units drop-down list.

Figure 7.3: Paragraph Style Dialog

For example, in the pasted text, select all of the items under "Parameters",
then open the Paragraph Style dialog. Notice that the spacing has already
been set.

In the Indent section, change the Left Margin indent to 10.0 pt.

In the Bullets and Numbering section, click the Style drop-down and select
Dash. Click OK to close the dialog and apply the styles.
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Result:

For more information, refer to the ?paragraphmenu help page.

Character and Paragraph Styles
Maple has predefined styles for characters and paragraphs. A style is a set
of formatting characteristics that you can apply to text in your document to
change the appearance of that text. When you apply a style, you apply a
group of formats in one action.

• A character style controls text font, size, color, and attributes such as
bold and italic. To override the character style within a paragraph style,
you must apply a character style or character formatting.

• A paragraph style controls all aspects of a paragraph's appearance, such
as text alignment, line spacing, and indentation. In Maple, each paragraph
style includes a character style.
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Figure 7.4: Style Management Dialog

Applying Character Styles

By using the drop-down list in the document context bar, you can apply:

• Existing Maple character styles.

• New styles that you have created through the Style Management (Figure
7.4) and Character Style (Figure 7.5) dialogs.

To apply a character style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select an
appropriate character style. All character styles are preceded by the letter C.
The selected text now reflects the attributes of the character style you have
chosen.
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3. (Optional) If necessary, you can remove this style. From the Edit menu,
select Undo.

Creating and Modifying Character Styles

You can create custom character styles to apply to text, or change existing
character styles. New styles are automatically added to the styles drop-down
list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 7.4.

To create a character style:

• Click Create Character Style. The Character Style dialog opens. See
Figure 7.5.

• In the first row of the dialog, enter a style name in the blank text region.

To modify a character style:

• From the style list, select the character style to modify. Recall that all
character styles are preceded by the letter C, while paragraph styles are
preceded by the letter P.

• Click Modify. The Character Style dialog opens with the current attrib-
utes displayed. See Figure 7.5.

For either action, continue:

2. Select the properties for the new character style, such as font, size, attrib-
utes, and color. In the font attributes, the Superscript and Subscript check
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boxes are mutually exclusive. When you select one of the two check boxes,
the other is disabled. You must clear one before selecting the other.

Note: A preview of the style is displayed in the last row of the Character
Style dialog.

3. To save the style, click OK or to abandon, click Cancel. If you have
modified a style, all text in your document that uses the altered style is up-
dated to reflect the changes.

Figure 7.5: Character Style Dialog

For example, in the pasted text, suppose we want to create a character style
for the bold, purple parameter.

• From the Format menu, select Styles, then click Create Character
Style.

• Enter the style name, "Placeholder", and then select the character attrib-
utes. In this case, click the Bold check box. Then click the Color button
and choose a dark purple. Click OK to create the character style.
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Now you can apply the style to any text. Under Calling Sequences, select
each list of parameters inside the command. To apply the style, from the
Styles drop-down menu in the toolbar, select Parameter.

Result:

Applying Paragraph Styles

By using the drop-down list in the document context bar, you can apply:

• Existing Maple paragraph styles.

• New styles that you have created through the Style Management (Figure
7.4) and Paragraph Style (Figure 7.6) dialogs.

To apply a Maple paragraph style to text in your document:

1. Select the text to modify.
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2. In the styles drop-down list in the context bar of your document, select an
appropriate paragraph style. All Maple paragraph styles are preceded by the
letter P. The selected text now reflects the attributes of the paragraph style
you have chosen.

For example, to format the title of the pasted text as a title, first select the
line: "plot - create a two-dimensional plot". In the Styles drop-down, select
Title.
Result:

3. (Optional) If necessary, you can remove this style. From the Edit menu,
select Undo.
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Creating and Modifying Paragraph Styles

You can create custom paragraph styles to apply to text, or change existing
paragraph styles. New styles are automatically added to the styles drop-down
list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 7.4.

To create a paragraph style:

• Click Create Paragraph Style. The Paragraph Style dialog opens. See
Figure 7.6.

• In the first row of the dialog, enter a style name in the blank text field.

To modify a paragraph style:

• Select a paragraph style to modify. Recall that all paragraph styles are
preceded by the letter P.

• Click Modify. The Paragraph Style dialog opens with the current attrib-
utes displayed.

For either action, continue:

4. In the Units drop-down menu, select the units used to determine spacing
and indentation. Select from inches (in), centimeters (cm), or points (pt).

5. Select the properties to use for this paragraph style, such as Spacing, In-
dent, Alignment, Bullets and Numbering, Page Break Before, and
Linebreak.

6. To add or modify a font style, click Font. The Character Style dialog
opens. For detailed instructions, see Creating and Modifying Character
Styles (page 343).

7. To save the style, click OK, or to abandon, click Cancel. If you are
modifying an existing style, all text in your document that uses the altered
style is updated to reflect the changes.
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Figure 7.6: Paragraph Style Dialog

Style Set Management: Saving Styles for Future Use

You can use the style set of a particular document as the default style for all
documents.
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Figure 7.7: Style Set Management Dialog

For information on creating and managing style sets, see the ?worksheet/doc-
umenting/styles help page.

Sections
You can organize your document into sections, either before or after the text
has been entered.

Using the Insert Menu to Add Sections

1. Place the cursor in the paragraph or execution group above the location
at which you want to insert a new section.
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• If the cursor is inside a section, Maple inserts the new section after the
current section.

• If the cursor is in an execution group, Maple inserts the new section after
the execution group.

2. From the Insert menu, select Section. An arrow marks the start of the
section.

3. Enter the section heading.

4. Press the Enter key.

5. Enter the body of the section.

Tips for Adding Subsections

The insert location of subsections is the same as for sections, with a few ex-
ceptions.

• Subsections are inserted at the current cursor location when in a subsec-
tion.

• To insert a subsection immediately after the current subsection, collapse
the subsection and place the cursor in the subsection title.

Using the Indent and Outdent Toolbar Icons

You can shift sections to create or remove subsections.
Enclose the selection in a section or subsection

Outdent the selection to the next section level, if pos-
sible.

For example, to create two sections containing the two categories of inform-
ation in the pasted text:

1. Select "Parameters" and all of the items under it.
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2. Click the Indent toolbar item.

3. Cut and paste "Parameters" from inside the section to its title.

4. Similarly, create a section with the title "Calling Sequence", containing
the items under that heading.
Result:

Note: the section titles are automatically formatted as section titles, but you
can change the formatting through the Paragraph Style dialog.

Headers and Footers
You can add headers and footers to your document that will appear at the
top and bottom of each page when you print the document.

To add or edit headers and footers:

From the View menu, select Header Footer. The Header Footer dialog
appears. See Figure 7.8.

7.2  Document Formatting   •   351



Figure 7.8: Header and Footer Dialog - Custom Header

The available elements include the current date, page number, number of
pages, an image, the filename, or any plain text. These elements can be placed
in the left or right corner or the center of the page.

You can choose one of the predefined header or footer styles in the Pre-
defined Header and Footer tab, or create your own by clicking the Custom
Header or Custom Footer tab.

For more information on header and footer options, refer to the ?headerfooter
help page.

Show or Hide Worksheet Content
You can hide document elements of a specific type so that they are not visible.
This does not delete them, but hides them from view. Hidden elements are
not printed or exported, but they can be copied and pasted.

In a document, use the Show Contents dialog to hide all spreadsheets, input,
output, or graphics, plus markers for section boundaries, execution group
boundaries, hidden table borders on mouse pointer roll over, and annotations.
The dialog is accessed from the View→Show/Hide Contents menu.

Using the Show Contents Dialog

A check mark beside the item indicates that all document elements of that
type are displayed for the current document. See Figure 7.9.
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Figure 7.9: Show Contents Dialog

1. From the View menu, select Show/Hide Contents. The Show Contents
dialog opens with all items selected for display.

2. Clear the check box associated with the document components or markers
to hide them.

Note: By clearing the Input check box, only Maple Input and 2-D Math in-
put, that is, 2-D Math content that has been evaluated, are hidden. Clearing
the Graphics check box ensures that a plot, an image, or the Canvas inserted
in the document by using the Insert menu option is also hidden.

Command Output Versus Inserted Content

Output is considered an element that results from executing a command.
Inserted components are not considered output.

Consider the following examples.

The plot resulting from executing the plot(sin) command is considered output.

• To show a plot from the plot(sin) command, select both the Output and
Graphics check boxes in the Show Contents dialog.
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If you insert a plot by using the Insert menu option, that plot is not considered
output. Therefore, if you clear the Output check box in the Show Contents
dialog, that plot will be visible in the document.

• To hide an inserted plot, clear the Graphics check box in the Show
Contents dialog.

Inserted images and the Canvas are not considered output. As such, they
are not hidden if you clear the Output check box.

• To hide an inserted image or canvas, clear the Graphics check box in
the Show Contents dialog.

Indentation and the Tab Key
The Tab icon allows you to set the Tab key either to move between place-
holders or to indent. For example, with the Tab icon off, click the exponent
button in the Expression palette. The expression is inserted with the first
placeholder highlighted. To move to the next placeholder, use the Tab key.

Tab icon off. Allows you to move between placeholders using the Tab key.

The Tab icon is disabled when using 2-D Math (Math mode), and as such,
the Tab key allows you to move between placeholders.

Tab icon on. Allows you to indent in the document using the Tab key.

7.3  Commands in Documents
Document Blocks
With document blocks, you can create documents that present text and math
in formats similar to those found in business and education documents.

In a document block, an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create
a document with better presentation flow. Before using document blocks, it
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is recommended that you display Markers. A vertical bar is displayed along
the left pane of the document. Icons representing document blocks are dis-
played in this vertical bar next to associated content.

To activate Markers:

• From the View menu, select Markers.

For further details on document blocks, see Document Blocks (page 58) in
Chapter 1.

Working with Document Blocks

In document mode, each time you press Enter, a new document block ap-
pears. Documents consist of a series of document blocks.

1. Create a new document block after the last section of the pasted example,
either by pressing Enter, or by selecting, from the Format menu, Create
Document Block.

2. Enter text and an expression to evaluate. For example, enter "Plot the ex-

pression and its derivative, ". For detailed instructions

on entering this phrase, see Example 6 (page 36) in Chapter 1.

3. Select the expression

and right-click (Control-click, for Macintosh) to display the context menu.

4. Click the Evaluate and Display Inline menu item. The expression is
evaluated.

5. Check that the input mode is Text, then enter the rest of the sentence: ",
in the same plot."
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Before

After

Figure 6.9: Working with Document Blocks
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Result:

Inline Document Output

Document blocks can display content inline, that is, text, input, and output
in one line as presented in business and education documents. In document
mode, content is displayed inline by default.

To display content inline:

1. Place the cursor in the document block.

2. From the View menu, select Inline Document Output.
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View Document Code

To view the contents, that is, all code and expanded execution groups within
a document block, you must expand the document block.

1. Place the cursor in the document block region.

2. From the View menu, select Expand Document Block.

3. To hide code again, select View and then Collapse Document Block.

Expand an Execution Group within a Document Block

An execution group is a grouping of Maple input with its corresponding
Maple output. It is distinguished by a large square bracket at the left called
a group boundary.

As document blocks can contain many execution groups, you can select to
expand an execution group within a document block.

1. Place the cursor near the end of the document block region.

2. From the View menu, select Expand Execution Group.

3. To hide the group, select View and then Collapse Execution Group.
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Switch between Input and Output

1. Place the cursor in the document block region.

2. From the View menu, select Toggle Input-Output Display.

Input from any executable math or commands is displayed in one instance,
or only output is displayed.

Typesetting
You can control typesetting and 2-D Math equation parsing options in the
Standard Worksheet interface. Extended typesetting uses a customizable set
of rules for displaying expressions.

The rule-based typesetting functionality is available when Typesettinglevel
is set to Extended (Tools→Options→Display tab). This parsing function-
ality applies to 2-D Math editing (Math mode) only.

For example, you can change the display of derivatives to suit the content
and audience of your document.

Tools→Options→Display tab: Typesetting level
= Maple Standard.

> 

Tools→Options→Display tab: Typesetting level
= Extended.

> 

To specify rules, use the Typesetting Rule Assistant.

• From the View menu, select Typesetting Rules. The Typesetting Rule
Assistant dialog opens.
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For more information, see the ?Typesetting, ?TypesettingRuleAssist, and
?OptionsDialogDisplay help pages.

Auto-Execute
The Autoexecute feature allows you to designate regions of a document for
automatic execution. These regions are executed when the document opens
or when the command is executed. This is useful when sharing documents.
Important commands can be executed as soon as the user opens your docu-
ment. The user is not required to execute all commands.

Setting the Auto-Execute Feature

1. Select the region to be automatically executed when the document opens.

2. From the Format menu, select Autoexecute, and then Set.

Regions set to Autoexecute are denoted by exclamation mark symbols in

the Markers region (View → Markers), .

For example, to display a plot in your document without saving the plot,
making your document use less memory, you can set a plot command to
autoexecute.

1. After the plot instruction, enter a Maple prompt (Insert → Execution
Group → After Cursor).

2. Enter the plot command: and press Enter

to execute.

3. Select the plot, then select Edit → Remove Output → From Selection.

4. Place the cursor in the plot command, the select Format → Autoexecute
→ Set.

5. Save and close the document; on reopening, the command is re-executed.
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Result:

Removing the Auto-Execute Setting

To remove the setting in a region:

1. Select the region.

2. From the Format menu, select Autoexecute, and then Clear.

To remove all autoexecuted regions from a document:

• From the Format menu, select Autoexecute, and then Clear All.

Repeating Auto-Execution

To execute all marked groups:

• From the Edit menu, select Execute, and then Repeat Autoexecution.

Security Levels
By default, Maple prompts the user before automatically executing the doc-
ument.
To set security levels for the autoexecute feature, use the Security tab in the
Options dialog. For details, refer to the ?OptionsDialogSecurity help page.
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7.4  Tables
Tables allow you to organize content in a document.

Creating a Table
To create a table:

1. From the Insert menu, select Table.

2. Specify the number of rows and columns in the table creation dialog.

3. Click OK.

The default properties for the table include visible borders and auto-adjust-
ment to 100% of the document width. These options, as well as the table
dimensions, can be modified after table creation.

Create a table with 4 rows and 2 columns at the end of your document. In
document mode, the input mode is set to Math by default; in worksheet
mode, the default is Text mode.

Cell Contents
Any content that can be placed into a document can also be placed into a
table cell, including other sections and tables. Table cells can contain a mix
of:

• Input commands

• 2-D Math
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• Embedded components: buttons, sliders, check boxes, and more

• Plots

• Images

Enter a heading in both columns of the first row, in 2-D Math. You can use
any text formatting features within each cell; for example, bold and center
the headings.

Navigating Table Cells
Use the Tab key to move to the next cell. Ensure that the Tab toolbar icon
is off.

Tab icon off. Allows you to move between cells using the Tab key.

Tab icon on. Allows you to indent in the table using the Tab key.

Tab between the cells of the table and enter the following expressions in the
first column. For each function, from the context menu, select Differentiate
→ x. Cut and paste the resulting expression into the second column.
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Modifying the Structural Layout of a Table
The number of rows and columns in a table are modified using the Insert
and Delete submenus in the Table menu or by using the Cut and Copy/Paste
tools.

Inserting Rows and Columns

Row and column insertion is relative to the table cell that currently contains
the cursor. If the document has an active selection, insertion is relative to
the selection boundaries.

• Column insertion can be to the left or right of the document position
marker or selection.

• Row insertion can be above or below the marker or selection.

In your table, add a third column on the right to display the plots of these
expressions. Add the heading, and insert a blank plot region in each cell below
it, by selecting Insert → Plot → 2-D (or 3-D for the second expression).
Then Ctrl-drag (Control-drag for Macintosh) each expression in the row
into its plot region to display it. For details on this procedure, see Chapter
6: Plots and Animations.

Resize the plots and table as desired.
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Plot of and

Deleting Rows and Columns

With deleting operations using the Delete key, the Delete Table Contents
dialog opens allowing you to specify the desired behavior. For example, you
can delete the selected rows, or delete the contents of the selected cells. See
Figure 7.10.
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Figure 7.10: Delete Table Contents Verification Dialog

Pasting

Pasting a table subselection into a table may result in the creation of additional
rows or columns, overwriting existing cell content, or the insertion of a
subtable within the active table cell. When there is a choice, the Table Paste
Mode dialog opens, allowing you to choose. See Figure 7.11.

Figure 7.11: Table Paste Mode Selection Dialog

Merging Cells

You can merge cells across row or column borders. See Figure 7.12. The
resulting cell must be rectangular. The contents of the individual cells in the
merge operation are concatenated in execution order. See Figure 7.13. For
details on cell execution order, see Execution Order Dependency (page 373).
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> 

> 

> > 

Figure 7.13: Merged CellsFigure 7.12: Two cells

Modifying the Physical Dimensions of a Table
The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button,
for Macintosh) while hovering over the left or right table boundary and
dragging the mouse left or right. Upon release of the mouse button, the table
boundary is updated. This approach can also be used to resize the relative
width of table columns.

Alternatively, the size of the table can be controlled from the Table Proper-
ties dialog. Select the Table menu and then Properties. Two sizing modes
are supported.

(1) Fixed percentage of page width. Using this option, the table width ad-
justs whenever the width of the document changes. This option is useful for
ensuring that the entire content of the table fits in the screen or printed page.

(2) Scale with zoom factor. This option is used to preserve the size and
layout of the table regardless of the size of the document window or the
zoom factor. If the table exceeds the width of the document window, the
horizontal scroll bar can be used to view the rightmost columns. Note: Using
this option, tables may be incomplete when printed.
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Modifying the Appearance of a Table

Table Borders

The style of exterior and interior borders is set using the Table Properties
dialog. From the Table menu, select Properties.

• You can set all, none, or only some of the borders to be visible in a table.
Exterior borders are controlled separately.

• You can control the visibility of interior borders by using the Group
submenu of the Table menu; grouping rows or columns suppresses interior
borders, provided that the interior border style is set by row and column
group.

For example, group the columns together, and group rows 2 to 4 together.
Then in the Table Properties dialog, select Exterior Borders: Top and
bottom, and Interior Borders: By row and column group.
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• Hidden borders are visible when the mouse hovers over a table. Note:
You can hide the visibility of lines on mouse pointer roll over by using
the View→Show/Hide Contents dialog, and clearing the Hidden Table
Borders check box.

Alignment Options

The table alignment tools control the horizontal alignment of columns and
vertical alignment of rows.
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For column alignment, the current selection is expanded to encompass all
rows in the selected columns. The alignment choice applies to all cells
within the expanded selection. If the document does not contain a selection,
the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected
rows for vertical alignment options. The following table illustrates the ver-
tical alignment options. The baseline option is useful for aligning equations
across multiple cells within a row of a table.

For example, set the Row alignment to Baseline for all rows, and set the
Column alignment to Center for all columns.
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Cell Color

You can set the background color of any cell or collection of cells to be any
color. This coloring is independent of any highlighting or text color that may
also be applied.

To change the color of a cell, place the cursor in the cell, then from the Table
menu, select Cell Color.... In the Select A Color dialog, choose a color from
the swatches, the color wheel, or RGB. See the ?DrawingTools help page
for details on color selection.
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For example, select the first row of the table and apply a light blue color.
This sets the header off from the content below.

Controlling the Visibility of Cell Content

The Table Properties dialog includes two options to control the visibility
of cell content. These options allow control over the visibility of Maple input
and execution group boundaries. Thus, these elements can be hidden in a
table even if they are set to visible for the document in the View→Show/Hide
Contents dialog.
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Printing Options
The Table Properties dialog contains options to control the placement of
page breaks when printing. You can fit a table on a single page, allow page
breaks between rows, or allow page breaks within a row.

Execution Order Dependency
The order in which cells are executed is set in the Table Properties dialog.
The following tables illustrate the effect of execution order.
Row-wise execution order

> x:=x+1;

(7.2)

> x:=1;

(7.1)

> x:=x+1;

(7.4)

> x:=x+1;

(7.3)

Column-wise execution order

> x:=x+1;

(7.6)

> x:=1;

(7.5)

> x:=x+1;

(7.8)

> x:=x+1;

(7.7)

Tables and the Classic Worksheet
Tables are flattened on export to the Classic Worksheet interface. For ex-
ample, the following table in the Standard Worksheet appears as one column
in the Classic Worksheet interface.
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Table in Classic WorksheetTable in Standard Worksheet

Additional Examples
For more practice creating and manipulating tables, try creating the following
tables at the end of your document.

Table of Values

This example illustrates how to set the visibility options for cell contents to
display a table of values.

> 

Create a table with 2 rows and 7 columns. Enter the values as below, and
then select all table cells. In the Table → Alignment menu, select Columns,
and then Center.

6543210t [s]

> > > > > > > y(t) [m]

Table settings:

In the Properties dialog (Table → Properties menu):
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1. Set Table Size Mode to Scale with zoom factor.

2. Hide Maple input and execution group boundaries: Clear the Show input
and Show execution group boundaries check boxes.

6543210t [s]

y(t) [m]

Formatting Table Headers

The following table uses cell merging for formatting row and column headers,
and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over.
You can hide the visibility of lines on mouse pointer roll over by using the
View→Show/Hide Contents dialog, and clearing the Hidden Table Borders
check box.

Parameter 2

HighLow

2413LowParameter 1

2918High

Table settings:

1. Insert a table with 4 rows and 4 columns and enter the information shown
above.

Using the Table menu:

2. Merge the following sets of (Row,Column) cells: (R1,C1) to (R2,C2),
(R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).

3. Group columns 1 and 2, and columns 3 and 4.

4. Group rows 1 and 2, and rows 3 and 4.
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In the Properties dialog (Table→Properties menu):

5. Set Exterior Borders to None.

6. (Optional) Change Table Size Mode size option to Scale with zoom
factor.

Using the Table menu:

7. Set Alignment of columns 3 and 4 to Center.

2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and
plots side by side.

Approximating exp(-x) as a rational polyno-

mial using a order Padé approximation.

Insert a table with 1 row and 2 columns. Enter the information in text and
executable 2-D Math to create the calculation and plot, as shown.

Table Settings:

In the Properties dialog (Table→Properties menu):

1. Set Exterior and Interior Borders to None.

2. Hide Maple input and execution group boundaries: Clear the Show input
and Show execution group boundaries check boxes.
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Using the Table menu:

3. Change row Alignment to Center.

7.5  Canvas
Using the drawing tools, you can sketch an idea in a canvas, draw on plots,
and draw on images. See Figure 7.14. For details about the drawing feature,
refer to the ?DrawingTools help page.

Figure 7.14: Drawing Tools and Canvas

Insert a Canvas
To insert a canvas:

1. Place the cursor where the canvas is to be inserted.
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2. From the Insert menu, select Canvas. A canvas with grid lines appears
in the document at the insertion point. The Drawing icon is available and
associated context bar icons are displayed.

The tools include the following: selection tool, pencil (free style drawing),
eraser, text insert, straight line, rectangle, rounded rectangle, oval, diamond,
alignment, drawing outline, drawing fill, drawing linestyle, and drawing
canvas properties.

Drawing
To draw with the pencil tool in the canvas:

1. From the Drawing icons, select the pencil icon.

2. Click and drag your mouse in the canvas to draw lines. Release the mouse
to complete the drawing.

To adjust the color of drawing tools:

1. From the Drawing icons, select the Drawing Outline icon. See Figure
7.15.

2. Select one of the color swatches available or select the color wheel, RGB
ranges, or eye dropper icon at the bottom of the dialog and customize the
color to your preference.

3. After selecting a new color, draw on the canvas using the pencil icon and
notice the new color.
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Figure 7.15: Drawing Outline Color
Icon

In your document, there are three plots, two of which are 2-D plots that can
be drawn on. All of the information in the table you made in the previous
section could be drawn onto the plot, putting the information in a more
concise layout.

Consider one of the plots from the table:

Click on the plot, and notice that the Plot toolbar is open. However, the
Drawing toolbar is also available. Click on Drawing to see the toolbar.

Select the Text icon, , and click on the plot. Enter the expression 
in one text area, and its integral in another, as shown. You can move the text
areas around on the plot so that they indicate the correct lines.

For details on the rest of the drawing features, refer to the ?DrawingTools
help page.

Canvas Style
You can alter the Canvas in the following ways:
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• Add a grid of horizontal and/or vertical lines. By default, the canvas
opens with a grid of horizontal and vertical lines.

• Change the grid line color.

• Change the spacing between grid lines.

• Change the background color.

These options can be changed in the Drawing Properties Canvas Icon. See
Figure 7.16.

Figure 7.16: Drawing Properties Canvas Icon - Change the Gridline Color

380   •   7  Creating Mathematical Documents



Inserting Images
You can insert images in these file formats
into your document.
• Graphics Interchange Format - gif

• Joint Photographic Experts Group -
jpe, jpeg, jpg

• Portable Network Graphics - png

• Bitmap Graphics - bmp

• Tagged Image File Format - tif, tiff,
jfx

• Portable aNyMap - pnm

• Kodak FlashPix - fpx

To insert an image into the document at the cursor location:

1. From the Insert menu, select Image. The Load Image dialog opens.

2. Specify a path or folder name.

3. Select a filename.

4. Click Open. The image is displayed in the document.

If the source file is altered, the embedded image does not change because
the original object is pasted into the document.

To resize an inserted image:

1. Click the image. Resizing anchors appear at the sides and corners of the
image.

2. Move the mouse over the resize anchor. Resizing arrows appear.

3. Click and drag the image to the desired size.

Note: To constrain the proportions of the image as it is resized, press and
hold the Shift key as you drag.
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You can also draw on images in the same way as the drawing canvas For
more information, refer to the ?worksheet/documenting/drawingtools help
page..

ImageTools Package

You can manipulate image data using the ImageTools package. This package
is a collection of utilities for reading and writing common image file formats,
and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-bit
hardware floating-point numbers. Grayscale images are 2-D, whereas color
images are 3-D (the third dimension representing the color channels).

In addition to the commands in the ImageTools package, many ordinary
Array and Matrix operations are useful for image processing.

For details about this feature, refer to the ?ImageTools help page.

7.6  Hyperlinks
Use a hyperlink in your document to access any of the following.

• Web Page (URL)

• Email

• Worksheet

• Help Topic

• Task

• Dictionary Topic

• Maplet
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Figure 7.17: Hyperlink Properties Dialog

Inserting a Hyperlink in a Document
To create a hyperlink from existing text in the document:

1. Highlight the text that you want to make a hyperlink. For example, high-
light the text "horizontal range" in the Parameters section of your document.

2. From the Format menu, select Convert To and then Hyperlink.

3. In the Hyperlink Properties dialog box, the Link Text field is grayed
out since the text region you highlighted is used as the link text. See Figure
7.17.

4. Specify the hyperlink Type and Target as described in the appropriate
following section.

To insert a text or image hyperlink into the document:

1. From the Insert menu, select Hyperlink.

2. In the Hyperlink Properties dialog box, enter the Link Text.

Optionally, use an image as the link. Select the Image check box and click
Choose Image for the file. In .mw files, the image appears as the link. You
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can resize the image as necessary. Click and drag from the corners of the
image to resize.

3. Specify the hyperlink Type and Target as described in the appropriate
following section.

Linking to a Web Page

To link to a Web page:

1. In the Type drop-down list, select URL.

2. In the Target field, enter the full URL, for example, ht-
tp://www.maplesoft.com.

3. Click OK.

Linking to an Email Address

To link to an email address:

1. In the Type drop-down list, select Email.

2. In the Target field, enter the email address.

3. Click OK.

Note: For information about email hyperlinks in the Classic Worksheet in-
terface, see Worksheet Compatibility (page 397).

Linking to a Worksheet

To link to a Maple worksheet or document:

1. In the Type drop-down list, select Worksheet.

2. In the Target field, enter the path and filename of the document or click
Browse to locate the file. (Optional) In the Bookmark drop-down list, enter
or select a bookmark.
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Note: To link within a single Maple document, leave the Target field blank
and choose the bookmark from the Bookmark drop-down list.

Note: When linking to a custom document, the path is absolute. When
sharing documents that contain hyperlinks, ensure that target documents are
in the same directory.

3. Click OK.

Linking to a Help Page

To link to a help page:

1. In the Type drop-down list, select Help Topic.

2. In the Target field, enter the topic of the help page. (Optional) In the
Bookmark drop-down list, enter or select a bookmark.

3. Click OK.

Linking to A Task

To link to a task:

1. In the Type drop-down list, select Task.
2. In the Target field, enter the topic name of the task template (see the status
bar at the bottom of the Task Browser window).
3. Click OK.

Linking to a Dictionary Topic

To link to a Dictionary topic:

1. In the Type drop-down list, select Dictionary Topic.

2. In the Target field, enter a topic name. Dictionary topics begin with the
prefix Definition/, for example, Definition/dimension.

3. Click OK.
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Linking to a Maplet Application

To link to a Maplet application:

1. In the Type drop-down list, select Maplet.

2. In the Target field, enter the local path to a file with the .maplet extension.
Optionally, click Browse to locate the file.

If the Maplet application exists, clicking the link launches the Maplet applic-
ation. If the Maplet application contains syntax errors, then error messages
are displayed in a pop-up window.

When linking to a custom Maplet application, the path is absolute. When
sharing documents that contain links to Maplet applications, ensure that target
Maplet applications are in the same directory.

3. Click OK.

Note: To link to a Maplet application available on a MapleNet Web page,
use the URL hyperlink type to link to the Web page. For information on
MapleNet, see Embedded Components and Maplets (page 465).

Example

For this example, link the text "horizontal range" to the dictionary page for
domain. As indicated in the section for Linking to a Dictionary Topic, select
Dictionary Topic in the Type drop-down list, and then enter Definition/do-
main in the Target field.

Links to dictionary topics appear underlined and in red.
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Result:

Bookmarks
Use a bookmark to designate a location in an active document. This bookmark
can then be accessed from other regions in your document or by using hyper-
links in other documents.

To display bookmark formatting icons, activate the Marker feature.

• From the View menu, select Markers.

Figure 7.18: Bookmark Indicator

Note: You can display bookmark properties by holding the pointer over a
bookmark indicator. See Figure 7.18.

Inserting, Renaming, and Deleting a Bookmark

To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark. For ex-
ample, place the cursor in the Parameters section title.
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2. From the Format menu, select Bookmarks. The Bookmark dialog opens,
listing existing bookmarks in the document.

3. Click New. The Create Bookmark dialog opens. See Figure 7.19. Enter
a bookmark name, "parameters", and click Create.

Figure 7.19: Create Bookmark Dialog

4. The new bookmark appears in the Bookmark dialog list. Click OK.

Note: You can also rename and delete bookmarks using the Bookmark
dialog.
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Result:

Go to a Bookmark

You can automatically move the cursor to the location of the bookmark in
the active document.

1. From the Edit menu, select Go To Bookmark. The Go To Bookmark
dialog opens with the current bookmarks listed.

2. Select the bookmark "parameters" and click OK. The cursor moves to the
bookmark, at the beginning of the Parameters section.

For more information, refer to the ?bookmarks help page.

7.7  Embedded Components
You can embed simple graphical interface components, such as a button, in
your document. These components can then be associated with actions that
are to be executed. For example, the value of a slider component can be as-
signed to a document variable, or a text field can be used to input an equation.

Adding Graphical Interface Components
The graphical interface components can be inserted by using the Components
palette (Figure 7.20) or by cutting/copying and pasting existing components
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to another area of the document. Although copied components have most of
the same characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are not
visible, use the following procedure.

1. From the View menu, select Palettes.

2. Select Expand Docks.

3. If the Components palette is not displayed, right-click (Control-click,
for Macintosh) the palette dock. From the context menu, select Show Palette,
and then Components.

For more information, see Palettes (page 25).

You can embed the following items.

• Button, Toggle Button

• Combo Box, Check Box, List Box, Radio Button

• Text Area, Label

• Slider, Plot, Mathematical Expression

• Dial, Meter, Rotary Gauge, Volume Gauge

390   •   7  Creating Mathematical Documents



Figure 7.20: Components Palette

Task Template with Embedded Components
In your document, you can add components that have already been configured
to work together, by using a task template. Here, we use the template. For
details on how to create and modify components, see Creating Embedded
Components (page 469).

To insert the task template, from the Tools menu, select Tasks → Browse.
In the table of contents, expand Document Templates, and select Interactive
Application. Click Insert Minimal Content. The following is inserted into
your document.
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Figure 6.13: Interactive Application Task Template

This configuration of components plots a linear function with inputs given
by two dials, and displays the inverse slope of the function on a gauge. For
details on how these components work together, see Embedded Components
and Maplets (page 465).

7.8  Spell Checking
The Spellcheck utility examines all designated text regions of your document
for potential spelling mistakes, including regions that are in collapsed sec-
tions. It does not check input, output, text in execution groups, or math in
text regions. See Figure 7.21.

Note: The Spellcheck utility uses American spelling.
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Figure 7.21: Spellcheck Dialog

How to Use the Spellcheck Utility
1. From the Tools menu, select Spellcheck. Alternatively, press F7. The
Spellcheck dialog appears. It automatically begins checking the document
for potential spelling mistakes.

2. If the Spellcheck utility finds a word that it does not recognize, that word
is displayed in the Not Found text box.

You have six choices:

• To ignore the word, click Ignore.

• To ignore all instances of the word, click Ignore All.

• To change the word, that is, accept the suggested spelling that is in the
Change To text box, click Change.

• To change all instances of the word, that is, accept the suggested spelling
to replace all instances of the word, click Change All.
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• To add the word to your dictionary, click Add. For details, see the fol-
lowing User Dictionary section.

• To close the Spellcheck dialog and stop the spelling check, click Cancel.

3. When the Spellcheck is complete, a dialog containing the message "The
spelling check is complete" appears. Click OK to close this dialog.

Note: when using the Spellcheck utility, you can fix spelling errors in the
dialog, but you cannot change the text in document. The Spellcheck utility
does not check grammar.

Selecting a Suggestion
To select one of the suggestions as the correct spelling, click the appropriate
word from the list in the Suggestions text box.

If none of the suggestions are correct, highlight the word in the Change To
text box and enter the correct spelling. Click Change to accept this new
spelling.

User Dictionary
You can create and maintain a custom dictionary that works with the Maple
Spellcheck utility.

Properties of the Custom Dictionary File

• It must be a text file, that is, have the file extension .txt. For example,
mydictionary.txt.

• It is a list of words, one word per line.

• It is case sensitive. This means that integer and Integer require individual
entries in the dictionary file.

• It does not require manual maintenance. You build your dictionary file
by using the Add functionality of the Spellcheck. However, you can
manually edit the file.
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To specify a custom dictionary to be used with the Maple Spellcheck
utility:

1. Create a .txt file in a directory/folder of your choice.

2. In Maple, open the Options dialog, Tools → Options, and select the
General tab.

3. In the User Dictionary field, enter the path and name of the .txt file you
created, or click Browse to select the location and filename.

4. To ignore Maple words that are command and function names, select the
Use Maple Words in spellchecker check box.

5. Click Apply to Session or Apply Globally to save the settings, or Cancel
to discard.

Adding a Word to Your Dictionary

When running the spellcheck, if the word in the Not Found text box is cor-
rect, you can add the word to your dictionary.

1. Click the Add button. If this is the first time you are adding a word, the
Select User Dictionary dialog opens.

2. Enter or select the custom dictionary (.txt file) you created. See User
Dictionary (page 394).

3. Click Select. The word is automatically added to your custom dictionary
file.

Note: Specifications in the Options dialog determine whether this word is
recognized in your next Maple session. If you set your custom dictionary
and clicked Apply to Session, then this word will not be recognized in a
new Maple session. If you set your custom dictionary and clicked Apply
Globally, then this new word will be recognized.
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7.9  Creating Graded Assignments
You can use Maple to create graded assignments. Question types include
multiple choice, essay, true-or-false, fill-in-the-blanks, and Maple-graded.

Note: This feature can be used to create questions for Maple T.A.—an online
automated testing and assessment system. For details about Maple T.A., see
Maple T.A. (page 499).

Creating a Question
To create a question:

1. Open the Task browser (Tools→Tasks→Browser).
2. From the Maple T.A. folder, select the appropriate question type.
3. Insert the question template into a document.
4. Enter the question content as described in the template.
5. Repeat steps 1 to 4 for each question to add to the document.

Viewing Questions in Maple
To view and test your questions in Maple:

• From the View menu, select Assignment. This view displays all of the
questions in your assignment with access to hints, plotting, and grading.

After answering your questions, you can test the grading function by clicking
the Grade button. A Maplet dialog is displayed indicating if the question
was answered correctly. If hints were provided in the question, these are also
displayed.

Saving Test Content
When you save a document with test content, the authoring and assignment
modes determine what the user sees when opening your document.
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• If you save the document in authoring mode (task template contents
visible), the user sees this content when opening the document.

• If you save the document in assignment mode, the user sees only the as-
signment layout.

In both cases the View→Assignment menu is accessible. As such, users
(students) can switch between the original document contents and the dis-
played assignment.

7.10  Worksheet Compatibility
Maple provides users with two worksheet interfaces: the Standard Worksheet
and the Classic Worksheet. Both have access to the full mathematical engine
of Maple and take advantage of the new functionality in Maple. The Classic
Worksheet has the traditional Maple worksheet look and uses less memory.

If you create a document in the Standard Worksheet interface of Maple and
then open it in the Classic Worksheet interface, you should note possible
changes to your file. For example, a bulleted list in the Standard Worksheet
will not be displayed with bullets in the Classic Worksheet. Many of the
graphical features in this manual, especially those in this chapter, are not
available in the Classic Worksheet interface.

If you are creating documents for distribution, refer to the ?Compatibility
help page.
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8  Maple Expressions
This chapter provides basic information on using Maple expressions, includ-
ing an overview of the basic data structures. Many of the commands described
in this chapter are useful for programming. For information on additional
Maple programming concepts, such as looping, conditional execution, and
procedures, see Basic Programming (page 439).

8.1  In This Chapter
TopicsSection

• Expression Sequences

• Sets

• Lists

• Tables

• Arrays

• Matrices and Vectors

• Functional Operators

• Strings

Creating and Using Data Structures - How
to define and use basic data structures

• Low-Level Operations

• Manipulating Expressions

• Evaluating Expressions

Working with Maple Expressions - Tools for
manipulating and controlling the evaluation
of expressions

8.2  Creating and Using Data
Structures
Constants, data structures, mathematical expressions, and other objects are
Maple expressions. For more information on expressions, refer to the Maple
Help System.
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This section describes the key data structures:

• Expression sequences

• Sets

• Lists

• Tables

• Arrays

• Matrices and Vectors

• Functional operators

• Strings

Expression Sequences
The fundamental Maple data structure is the expression sequence. It is a
group of expressions separated by commas.

> 

Accessing Elements

To access one of the expressions:

• Enter the sequence name followed by the position of the expression en-
closed in brackets([ ]).

For example:

> 

Using negative integers, you can select an expression from the end of a se-
quence.
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> 

You can select multiple expressions by specifying a range using the range
operator (..).

> 

Note: This syntax is valid for most data structures.

Sets
A set is an expression sequence enclosed in curly braces ({ }).

> 

A Maple set has the basic properties of a mathematical set.

• Each element is unique. Repeated elements are stored only once.

• The order of elements is not stored.

For example:

> 

Using Sets

To perform mathematical set operations, use the set data structure.
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> 

Note: The union operator is available in 1-D Math input as union. For more
information, refer to the ?union help page.

For more information on sets, refer to the ?set help page.

Lists
A list is an expression sequence enclosed in brackets ([ ]).

> 

Note: Lists preserve both the order and repetition of elements.

Accessing Entries

To refer to an element in a list:

• Use square brackets.

For example:

> 

For more information, see Accessing Elements (page 400).

Using Lists

Some commands accept a list (or set) of expressions.
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For example, you can solve a list (or set) of equations using a context menu
or the solve command.

> 

For more information, see Solving Equations and Inequations (page 132).

For more information on sets and lists, refer to the ?set help page.

Arrays
Conceptually, the Array data structure is a generalized list. Each element
has an index that you can use to access it.

The two important differences are:

• The indices can be any integers.

• The dimension can be greater than one.

Creating and Using Arrays

To define an Array, use the Array constructor.

Standard Array constructor arguments are:

• Expression sequences of ranges - Specify the indices for each dimension

• Nested lists - Specify the contents

For example:

> 
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> 

To access entries in an Array, use either square bracket or round bracket
notation.

Square bracket notation respects the actual index of an Array, even when
the index does not start at 1.

> 

> 

> 

> 

Error, Array index out of range
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Round bracket indexing normalizes the dimensions to begin at 1. Since this
method is relative, you can access the end of the array by entering 

> 

> 

The Array constructor supports other syntaxes. It also supports many options.
For more information on the Array constructor and the Array data structure,
refer to the ?Array help page. For more information on indexing methods,
refer to the ?rtable_indexing help page.

Large Arrays

Only one- and two-dimensional Arrays (with at most 10 indices in each di-
mension) display in the document. Larger Arrays display as a placeholder.

> 

To view large Arrays:

• Double-click the placeholder.

The Matrix Browser displays the Array. For more information, see Editing
and Viewing Large Matrices and Vectors (page 193).
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Tables
Tables are conceptually an extension of the Array data structure, but the
table data structure is implemented using hash tables. Tables can be indexed
by any values, not only integers.

Defining Tables and Accessing Entries

> 

> 

You can also assign anything, for example, a list, to each element.

> 

> 

For more information on tables, refer to the ?table help page.

Matrices and Vectors
Matrices and Vectors are specialized data structures used in linear algebra
and vector calculus computations.

> 

For information on defining Matrices and Vectors, see Creating Matrices
and Vectors (page 189).
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> 

> 

> 

For more information on these data structures, including how to access entries
and perform linear algebra computations, see Linear Algebra (page 189).

Functional Operators

A functional operator is a mapping The value of is the

result of evaluating 

Using functional operators, you can define mathematical functions.

Defining a Function

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items. See
Figure 8.1. Maple inserts the function definition.
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2. Replace the placeholders, using Tab to move to the next placeholder.
Note: If pressing the Tab key indents the text, click the Tab icon in the
toolbar. This allows you to move between placeholders.

3. Press Enter.

Figure 8.1: Function Definition Palette Items

For example, define a function that adds 1 to its input.

> 

Note: To insert the right arrow, you can enter the characters ->. In 2-D Math,
Maple replaces -> with the right arrow symbol . In 1-D Math, the
characters are not replaced.

You can evaluate the function add1 with symbolic or numeric arguments.

> 

Distinction between Functional Operators and Other Expressions

The expression is different from the functional operator 

Assign the functional operator to f.

> 

Assign the expression to g.
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> 

To evaluate the functional operator f at a value of x:

• Specify the value as an argument to f.

> 

To evaluate the expression g at a value of x:

• You must use the eval command.

> 

> 

For more information on the eval command, and on using palettes and context
menus to evaluate an expression at a point, see Substituting a Value for a
Subexpression (page 426).

Multivariate and Vector Functions

To define a multivariate or vector function:

• Enclose coordinates or coordinate functions in parentheses (( )).

For example, a multivariate function:

> 

8.2  Creating and Using Data Structures   •   409



> 

A vector function:

> 

> 

Using Operators

To perform an operation on a functional operator, specify arguments to the
operator. For example, for the operator f, specify f(x), which Maple evaluates
as an expression. See the following examples.

Plotting:

Plot a three-dimensional operator as an expression using the plot3d command.

> 

> 
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For information on plotting, see Plots and Animations (page 283).

Integration:

Integrate a function using the int command.

> 

> 

For information on integration and other calculus operations, see Calcu-
lus (page 208).
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Strings
A string is a sequence of characters enclosed in double quotes (" ").

> 

Accessing Characters

You can access characters in a string using brackets.

> 

Using Strings

The StringTools package is an advanced set of tools for manipulating and
using strings.

> 

> 

> 

> 

412   •   8  Maple Expressions



8.3  Working with Maple Expressions
This section describes how to manipulate expressions using commands.
Topics covered include testing the expression type, accessing operands of
an expression, and evaluating an expression.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties.
Maple contains over 200 types, including:

• `+`

• boolean

• constant

• integer

• Matrix

• trig

• truefalse

For more information and a complete list of Maple types, refer to the ?type
help page.

The type commands return true if the expression satisfies the type check.
Otherwise, they return false.

Testing the Type of an Expression

To test whether an expression is of a specified type:

• Use the type command.

> 
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> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 435).

Maple types are not mutually exclusive. An expression can be of more than
one type.

> 

> 

For information on converting an expression to a different type, see Convert-
ing (page 423).

Testing the Type of Subexpressions

To test whether an expression has a subexpression of a specified type:

• Use the hastype command.

414   •   8  Maple Expressions



> 

Testing for a Subexpression

To test whether an expression contains an instance of a specified
subexpression:

• Use the has command.

> 

> 

> 

The has command searches the structure of the expression for an exactly
matching subexpression.

For example, the following calling sequence returns false.

> 

To return all subexpressions of a particular type, use the indets command.
For more information, see Indeterminates (page 418).
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Accessing Expression Components

Left and Right-Hand Side

To extract the left-hand side of an equation, inequality, or range:

• Use the lhs command.

To extract the right-hand side of an equation, inequality, or range:

• Use the rhs command.

For example:

> 

(8.1)

> 

(8.2)

> 

(8.3)

For the following equation, the left endpoint of the range is the left-hand
side of the right-hand side of the equation.

> 

(8.4)
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> 

(8.5)

Numerator and Denominator

To extract the numerator of an expression:

• Use the numer command.

To extract the denominator of an expression:

• Use the denom command.

> 

If the expression is not in normal form, Maple normalizes the expression
before selecting the numerator or denominator. (For more information on
normal form, refer to the ?normal help page.)

> 

> 

> 

The expression can be any algebraic expression. For information on the be-
havior for non-rational expressions, refer to the ?numer help page.
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Components of an Expression

The components of an expression are called its operands.

To count the number of operands in an expression:

• Use the nops command.

For example, construct a list of solutions to an equation.

> 

Using the nops command, count the number of solutions.

> 

For more information on the nops command and operands, refer to the ?nops
help page.

Indeterminates

To find the indeterminates of an expression:

• Use the indets command.

The indets command returns the indeterminates as a set. Because the expres-
sion is expected to be rational, functions such as sin(x), f(x), and sqrt(x) are
considered to be indeterminate.

> 
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To return all subexpressions of a particular type, specify the type as the
second argument. For information on types, see Testing the Type of an Ex-
pression (page 413).

> 

To test whether an expressions has subexpressions of a specific type (without
returning them), use the has command. For more information, see Testing
for a Subexpression (page 415).

Manipulating Expressions
This section introduces the most commonly used manipulation commands.
For additional manipulation commands, see Iterative Commands (page 451).

Simplifying

To simplify an expression:

• Use the simplify command.

The simplify command applies simplification rules to an expression. Maple
has simplification rules for various types of expressions and forms, including
trigonometric functions, radicals, logarithmic functions, exponential functions,
powers, and various special functions. You can also specify custom simpli-
fication rules using a set of side relations.

> 
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> 

To limit the simplification, specify the type of simplification to be performed.

> 

> 

You can also use the simplify command with side relations. See Substituting
a Value for a Subexpression (page 426).

Factoring

To factor a polynomial:

• Use the factor command.

> 

> 
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Maple can factor polynomials over the domain specified by the coefficients.
You can also factor polynomials over algebraic extensions. For details, refer
to the ?factor help page.

For more information on polynomials, see Polynomial Algebra (page 178).

To factor an integer:

• Use the ifactor command.

> 

For more information on integers, see Integer Operations (page 125).

Expanding

To expand an expression:

• Use the expand command.

The expand command distributes products over sums and expands expres-
sions within functions.

> 

> 

Combining

To combine subexpressions in an expression:

• Use the combine command.
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The combine command applies transformations that combine terms in sums,
products, and powers into a single term.

> 

Recall that was previously assigned to represent a two-dimensional array
(see Creating and Using Arrays (page 403)).

> 

The combine command applies only transformations that are valid for all
possible values of names in the expression.

> 

To perform the operation under assumptions on the names, use the assuming
command. For more information about assumptions, see Assumptions on
Variables (page 171).

> 
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Converting

To convert an expression:

• Use the convert command.

The convert command converts expressions to a new form, type (see Expres-
sion Types (page 413)), or in terms of a function. For a complete list of con-
versions, refer to the ?convert help page.

Convert a measurement in radians to degrees:

> 

To convert measurements that use units, use the Unit Converter or the con-
vert/units command.

> 

For information on the Unit Converter and using units, see Units (page 151).

Convert a list to a set:

> 

Maple has extensive support for converting mathematical expressions to a
new function or function class.

> 

8.3  Working with Maple Expressions   •   423



Find an expression equivalent to the inverse hyperbolic cotangent function
in terms of Legendre functions.

> 

For more information on converting to a class of functions, refer to the
?convert/to_special_function help page.

Normalizing

To normalize an expression:

• Use the normal command.

The normal command converts expressions into factored normal form.

> 

You can also use the normal command for zero recognition.

> 

To expand the numerator and denominator, use the expanded option.
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> 

> 

Sorting

To sort the elements of an expression:

• Use the sort command.

The sort command orders a list of values or terms of a polynomial.

> 

> 

> 

For information on sorting polynomials, see Sorting Terms (page 181).

For more information on sorting, refer to the ?sort help page.
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Evaluating Expressions

Substituting a Value for a Subexpression

To evaluate an expression at a point, you must substitute a value for a vari-
able.

To substitute a value for a variable using context menus:

1. Right-click (Control-click, for Macintosh) the expression. Maple displays
a context menu.

2. From the context menu, select Evaluate at a Point. The Evaluate at a
Point dialog is displayed. See figure 8.2.

Figure 8.2: Evaluate at a Point

3. In the drop-down list, select the variable to substitute.

4. In the text field, enter the value to substitute for the variable. Click OK.

In Worksheet mode, Maple inserts the eval command calling sequence that
performs the substitution. This is the most common use of the eval command.

For example, substitute in the following polynomial.

> 

> 
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To substitute a value for a variable using palettes:

1. In the Expression palette, click the evaluation at a point item .

2. Specify the expression, variable, and value to be substituted.

For example:

> 

Substitutions performed by the eval function are syntactical, not the more
powerful algebraic form of substitution.

If the left-hand side of the substitution is a name, Maple performs the substi-
tution.

> 

If the left-hand side of the substitution is not a name, Maple performs the
substitution only if the left-hand side of the substitution is an operand of the
expression.

> 
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> 

Maple did not perform the evaluation because is not an operand of

For information on operands, refer to the ?op help page.

For algebraic substitution, use the algsubs command, or the simplify com-
mand with side relations.

> 

> 

Numerical Approximation

To compute an approximate numerical value of an expression:

• Use the evalf command.

The evalf command returns a floating-point (or complex floating-point)
number or expression.
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> 

> 

> 

By default, Maple calculates the result to ten digits of accuracy, but you can
specify any number of digits as an index, that is, in brackets ([ ]).

> 

For more information, refer to the ?evalf help page.

See also Numerically Computing a Limit (page 210) and Numeric Integra-
tion (page 222).

Evaluating Complex Expressions

To evaluate a complex expression:

• Use the evalc command.

If possible, the evalc command returns the output in the canonical form expr1
+ i expr2.
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In 2-D Math input, you can enter the imaginary unit using the following two
methods.

• In the Common Symbols palette, click the i or j item. See
Palettes (page 25).

• Enter i or j, and then press the symbol completion key. See Symbol
Names (page 33).

> 

> 

In 1-D Math input, enter the imaginary unit as an uppercase i (I).
evalc(2^(1 + I));>

Evaluating Boolean Expressions

To evaluate an expression involving relational operators
( and ):

• Use the evalb command.

Note: In 1-D Math input, enter and using the <>, <=, and >=
operators.

The evalb command uses a three-valued logic system. The return values are
true, false, and FAIL. If evaluation is not possible, an unevaluated expression
is returned.
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> 

> 

> 

Important: The evalb command does not perform arithmetic for inequalities
involving or and does not simplify expressions. Ensure
that you perform these operations before using the evalb command.

> 

> 

Applying an Operation or Function to All Elements in a List, Set,
Table, Array, Matrix, or Vector

You can use the tilde character (~) to apply an operation or function to all
of the elements in a list, set, table, Array, Matrix, or Vector.

In the following example, each element in the Matrix M is multiplied by 2
by adding a tilde character after the multiplication operator( .

8.3  Working with Maple Expressions   •   431



> 

(8.6)

> 

(8.7)

In the following example, the function sin is applied to each element in the
Matrix M.

> 

(8.8)

The tilde character can also be used to apply a function to multiple data sets,
for example,

> 

(8.9)
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You can use values in one data structure type to compute values in another
data structure type, as long as both data structures are dimensional and contain
the same number of elements. In the following example, the values in an
Array are compared to the values in a Matrix that contains the same number
of elements.

> 

(8.10)

For more information, refer to the ?elementwise help page.

Levels of Evaluation

In a symbolic mathematics program such as Maple, you encounter the issue
of levels of evaluation. If you assign y to x, z to y, and then 5 to z, what is
the value of x?

At the top-level, Maple fully evaluates names. That is, Maple checks if the
name or symbol has an assigned value. If it has a value, Maple substitutes
the value for the name. If this value has an assigned value, Maple performs
a substitution, recursively, until no more substitutions are possible.
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For example:

> 

> 

> 

Maple fully evaluates the name x, and returns the value 5.

> 

To control the level of evaluation of an expression:

• Use the eval command with an integer second argument.

If passed a single argument, the eval command fully evaluates that expression.
If you specify an integer second argument, Maple evaluates the expression
to that level.

> 

> 

> 

> 
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For more details on levels of evaluation, refer to the ?lastnameevaluation,
?assigned, and ?evaln help pages.

Delaying Evaluation

To prevent Maple from immediately evaluating an expression:

• Enclose the expression in right single quotes (' ').

Because right single quotes delay evaluation, they are referred to as unevalu-
ation quotes.

> 

> 

> 

Using an Assigned Name as a Variable or Keyword

If you use an assigned name as a variable, Maple evaluates the name to its
value, and passes the value to the command.

> 

Note: In general, it is recommended that you unassign a name to use it as a
variable. See Unassigning a Name Using Unevaluation Quotes (page 437).

To use an assigned name as a variable:
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• Enclose the name in unevaluation quotes. Maple passes the name to the
command.

> 

Important: It is recommended that you enclose keywords in unevaluation
quotes.

For example, if you enclose the keyword left in unevaluation quotes, Maple
uses the name, not its assigned value.

> 

> 

Full Evaluation of an Expression in Quotes

Full evaluation of a quoted expression removes one set of right single quotes.

> 

> 

(8.11)

> 

(8.12)
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> 

(8.13)

For information on equation labels and equation label references, see Equation
Labels (page 114).

Enclosing an expression in unevaluation quotes delays evaluation, but does
not prevent automatic simplification.

> 

(8.14)

Unassigning a Name Using Unevaluation Quotes

To unassign a name:

• Assign the name enclosed in unevaluation quotes to itself.

> 

> 

You can also unassign a name using the unassign command. For more in-
formation, see Unassigning Names (page 113).
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9  Basic Programming
You have used Maple interactively in the previous chapters, sequentially
performing operations such as executing a single command. Because Maple
has a complete programming language, you can also use sophisticated pro-
gramming constructs.

In Maple, you can write programs called procedures, and save them in
modules. These modules can be used and distributed in the same way as
Maple packages.

Important: It is strongly recommended that you use the Worksheet mode
and 1-D Math input when programming or using programming commands.
Hence, all input in this chapter is entered as 1-D Math.

9.1  In This Chapter
TopicsSection

• Conditional Execution (if Statement)

• Repetition (for Statement)

Flow Control - Basic programming con-
structs

• Creating a sequence

• Adding and Multiplying Expressions

• Selecting Expression Operands

• Mapping a Command over a Set or List

• Mapping a Binary Command over Two Lists
or Vectors

Iterative Commands - Specialized, effi-
cient iterative commands
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• Defining and Running Simple Procedures

• Procedures with Inputs

• Procedure Return Values

• Displaying Procedure Definitions

• Displaying Maple Library Procedure
Definitions

• Modules

Procedures - Maple programs

• Code Edit Region

• Startup Code

• Document Blocks

Programming in a Document - Display
methods for Maple code

9.2  Flow Control
Two basic programming constructs in Maple are the if statement, which
controls the conditional execution of statement sequences, and the for
statement, which controls the repeated execution of a statement sequence.

Conditional Execution (if Statement)
You can specify that Maple perform an action only if a condition holds. You
can also perform an action, from a set of many, depending on which condi-
tions hold.

Using the if statement, you can execute one statement from a series of
statements based on a boolean (true, false, or FAIL) condition. Maple tests
each condition in order. When a condition is satisfied, Maple executes the
corresponding statement, and then exits the if statement.

Syntax

The if statement has the following syntax.
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The conditional expressions (conditional_expression1, conditional_expres-
sion2, ...) can be any boolean expression. You can construct boolean expres-
sions using:

• Relational operators - <, <=, =, >=, >, <>

• Logical operators - and, or, xor, implies, not

• Logical names - true, false, FAIL

The statement sequences (statement_sequence1, statement_sequence2, ...,
statement_sequenceN) can be any sequence of Maple statements, including
if statements.

The elif clauses are optional. You can specify any number of elif clauses.

The else clause is optional.

Simple if Statements

The simplest if statement has only one conditional expression.
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If the conditional expression evaluates to true, the sequence of statements
is executed. Otherwise, Maple immediately exits the if statement.

For example:
x := 1173:>

if not isprime(x) then
ifactor(x);

end if;

>

else Clause

In a simple if statement with an else clause, if the evaluation of the conditional
expressions returns false or FAIL, Maple executes the statement sequence
in the else clause.

For example:
if false then

"if statement";
else

"else statement";
end if;

>

elif Clauses

In an if statement with elif clauses, Maple evaluates the conditional expres-
sions in order until one returns true. Maple executes the corresponding
statement sequence, and then exits the if statement. If no evaluation returns
true, Maple exits the if statement.
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x := 11:>

if not type(x, integer) then
printf("%a is not an integer.", x);

elif x >= 10 then
printf("%a is an integer with more than one digit.", x);

elif x >= 0 then
printf("%a is an integer with one digit.", x);

end if;

>

Order of elif Clauses: An elif clause's statement sequence is executed only
if the evaluation of all previous conditional expressions returns false or
FAIL, and the evaluation of its conditional expression returns true. This
means that changing the order of elif clauses may change the behavior of
the if statement.

In the following if statement, the elif clauses are in the wrong order.
if not(type(x, integer)) then

printf("%a is not an integer.", x);
elif x >= 0 then

printf("%a is an integer with one digit.", x);
elif x >= 10 then

printf("%a is an integer with more than one digit.", x);
end if;

>

elif and else Clauses

In an if statement with elif and else clauses, Maple evaluates the conditional
expressions in order until one returns true. Maple executes the corresponding
statement sequence, and then exits the if statement. If no evaluation returns
true, Maple executes the statement sequence in the else clause.
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x := -12:>

if not type(x, integer) then
printf("%a is not an integer.", x);

elif x >= 10 then
printf("%a is an integer with more than one digit.", x);

elif x >= 0 then
printf("%a is an integer with one digit.", x);

else
printf("%a is a negative integer.", x);

end if;

>

For more information on the if statement, refer to the ?if help page.

Repetition (for Statement)
Using repetition statements, you can repeatedly execute a statement se-
quence. You can repeat the statements in three ways.

• Until a counter variable value exceeds a limit (for/from loop)

• For each operand of an expression (for/in loop)

• Until a boolean condition does not hold (while loop)

for/from Loop

The for/from loop statement repeats a statement sequence until a counter
variable value exceeds a limit.

Syntax

The for/from loop has the following syntax.
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The behavior of the for/from loop is:

1. Assign the initial value to the name counter.

2. Compare the value of counter to the value of final. If the counter value
exceeds the final value, exit the loop. (This is the loop bound test.)

3. Execute the statement_sequence.

4. Increment the counter value by the value of increment.

5. Repeat steps 2 to 4, until Maple exits the loop.

The from, by, and to clauses are optional and can be in any order between
the for clause and the do keyword. Table 9.1 lists the default clause values.

Table 9.1: Default Clause Values

Default ValueClause

1from initial

1by increment

infinity (∞)to final

Examples

The following loop returns the square root of the integers 1 to 5 (inclusive).
for n to 5 do

evalf(sqrt(n));
end do;

>
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When the value of the counter variable n is strictly greater than 5, Maple
exits the loop.

n;>

The previous loop is equivalent to the following for/from statement.
for n from 1 by 1 to 5 do

evalf(sqrt(n));
end do;

>

The by value can be negative. The loop repeats until the value of the counter
variable is strictly less than the final value.
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for n from 10 by -1 to 3 do
if isprime(n) then

print(n);
end if;

end do;

>

n;>

for/in Loop

The for/in loop statement repeats a statement sequence for each component
(operand) of an expression, for example, the elements of a list.

Syntax

The for/in loop has the following syntax.

The for clause must appear first.

The behavior of the for/in loop is:

1. Assign the first operand of expression to the name variable.

2. Execute the statement_sequence.
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3. Assign the next operand of expression to variable.

4. Repeat steps 2 and 3 for each operand in expression. If there are no more
operands, exit the loop. (This is the loop bound test.)

Example

The following loop returns a floating-point approximation to the sin function
at the angles (measured in degree) in the list L.

L := [23.4, 87.2, 43.0, 99.7]:>

for i in L do 
evalf(sin(i*Pi/180));

end do;

>

while Loop

The while loop repeats a statement sequence until a boolean expression does
not hold.

Syntax

The while loop has the following syntax.
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A while loops repeats until its boolean expression conditional_expression
evaluates to false or FAIL. For more information on boolean expressions,
see Conditional Execution (if Statement) (page 440).

Example

The following loop computes the digits of 872,349 in base 7 (in order of in-
creasing significance).

x := 872349:>

while x > 0 do 
irem(x, 7);
x := iquo(x, 7);

end do;

>
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To perform such conversions efficiently, use the convert/base command.
convert(872349, base, 7);>

For information on non-base 10 numbers, see Non-Base 10 Num-
bers (page 128).

General Loop Statements

You can include a while statement in a for/from or for/in loop.

The general for/from loop has the following syntax.

The general for/in loop has the following syntax.
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After testing the loop bound condition at the beginning of each iteration of
the for loop, Maple evaluates conditional_expression.

• If conditional_expression evaluates to false or FAIL, Maple exits the
loop.

• If conditional_expression evaluates to true, Maple executes statement_se-
quence.

Infinite Loops

You can construct a loop for which there is no exit condition, for example,
a while loop in which the conditional_expression always evaluates to true.
This is called an infinite loop. Maple indefinitely executes an infinite loop
unless it executes a break, quit, or return statement or you interrupt the
computation. For more information, refer to the ?break, ?quit, ?return,
and ?interrupt help pages.

Additional Information

For more information on the for statement and looping, refer to the ?do help
page.

9.3  Iterative Commands
Maple has commands that perform common selection and repetition opera-
tions. These commands are more efficient than similar algorithms implemen-
ted using library commands. Table 9.2 lists the iterative commands.
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Table 9.2: Iterative Commands

DescriptionCommand

Create sequenceseq

Compute numeric sumadd

Compute numeric productmul

Return operands that satisfy a conditionselect

Return operands that do not satisfy a conditionremove

Return operands that satisfy a condition and separately return operands
that do not satisfy a condition

selectremove

Apply command to the operands of an expressionmap

Apply binary command to the operands of two lists or vectorszip

Creating a Sequence
The seq command creates a sequence of values by evaluating a specified
expression over a range of index values or the operands of an expression.
See Table 9.3.

Table 9.3: The seq Command

ExamplesCalling Sequence Syntax

> seq(exp(x), x=-2..0);seq(expression, name = initial .. final);

> seq(u, u in [Pi/4, Pi^2/2, 1/Pi]);seq(expression, name in expression);
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Adding and Multiplying Expressions
The add and mul commands add and multiply sequences of expressions
over a range of index values or the operands of an expression. See Table 9.4.

Table 9.4: The add and mul Commands

ExamplesCalling Sequence Syntax

> add(exp(x), x = 2..4);

> mul(2*x, x = 1 .. 10);

add(expression, name = initial .. final);

mul(expression, name = initial .. final);

> add(u, u in [Pi/4, Pi/2, Pi]);

> mul(u, u in [Pi/4, Pi/2, Pi]);

add(expression, name in expression);

mul(expression, name in expression);

The endpoints of the index range (initial and final) in the add and mul
calling sequence must evaluate to numeric constants. For information on
symbolic sums and products, refer to the ?sum and ?product help pages.

Selecting Expression Operands
The select, remove, and selectremove commands apply a boolean-valued
procedure or command to the operands of an expression. For information
on operands, refer to the ?op help page.
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• The select command returns the operands for which the procedure or
command returns true.

• The remove command returns the operands for which the procedure or
command returns false or FAIL.

• The selectremove command returns two expressions of the same type
as the input expression. - The first consists of the operands for which the
procedure or command returns true. - The second consists of the operands
for which the procedure or command returns false or FAIL.

The structure of the output is the same as the structure of the input. See Table
9.5.

For information on Maple procedures, see Procedures (page 457).

Table 9.5: The select, remove, and selectremove Commands

ExamplesCalling Sequence Syntax

> select(issqr, {198331, 889249, 11751184,
9857934});

select(proc_cmd, expression);

> remove(var -> degree(var) > 3, 2*x^3*y
- y^3*x + z );

remove(proc_cmd, expression);

> selectremove(x -> evalb(x > round(x)),
[sin(0.), sin(1.), sin(3.)]);

selectremove(proc_cmd, expres-
sion);

For information on optional arguments to the selection commands, refer to
the ?select help page.
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Mapping a Command over a Set or List
The map command applies a name, procedure, or command to each element
in a set or list. See Table 9.6.

Table 9.6: The map Command

ExamplesCalling Sequence Syntax

> map(f, {a, b, c});

> map(u -> int(cos(x), x = 0 .. u), [Pi/4, Pi/7,
Pi/3.0]);

map(name_proc_cmd, expression);

For information on mapping over the operands of other expressions, optional
arguments to the map command, and other mapping commands, refer to the
?map help page.

Mapping a Binary Command over Two Lists or
Vectors
The zip command applies a name or binary procedure or command compon-
ent-wise to two lists or vectors.

By default, the length of the returned object is that of the shorter list or vector.
If you specify a value as the (optional) fourth argument, it is used as the
value of the missing elements of the shorter list or vector. In this case, the
length of the return value is that of the longer list or vector. See Table 9.7.
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Table 9.7: The zip Command

ExamplesCalling Sequence Syntax

> zip(f, [i, j], [k, l]);

> zip(AiryAi, [1, 2], [0], 1);

zip(proc_cmd, a, b);
zip(proc_cmd, a, b, fill);

For more information on the zip command, refer to the ?zip help page.

Additional Information
For more information on looping commands, refer to the corresponding
command help page.
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9.4  Procedures
A Maple procedure is a program consisting of Maple statements. Using
procedures, you can quickly execute the contained sequence of statements.

Defining and Running Simple Procedures
To define a procedure, enclose a sequence of statements between proc(...)
and end proc statements. In general, you assign a procedure definition to a
name.

The following procedure returns the square root of 2.
p := proc() sqrt(2); end proc;>

Note: Maple returns the procedure definition.

To improve readability of procedures, it is recommended that you define a
procedure using multiple lines, and indent the lines using space characters.
To begin a new line (without evaluating the incomplete procedure definition),
press Shift+Enter. When you have finished entering the procedure, press
Enter to create the procedure.

For example:
p := proc()

sqrt(2);
end proc:

>

To run the procedure p, enter its name followed by parentheses (( )).
p();>
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Procedures with Inputs
You can define a procedure that accepts user input. In the parentheses of the
proc statement, specify the parameter names. For multiple parameters, sep-
arate the names with commas.

geometric_mean := proc(x, y)
sqrt(x*y);

end proc:

>

When the user runs the procedure, the parameter names are replaced by the
argument values.

geometric_mean(13, 17);>

geometric_mean(13.5, 17.1);>

For more information on writing procedures, including options and local
and global variables, refer to the ?procedure help page.

Procedure Return Values
When you run a procedure, Maple returns only the last statement result value
computed. Maple does not return the output for each statement in the proced-
ure. It is irrelevant whether you use semicolons or colons as statement separ-
ators.
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p := proc(a, b)
a + b;
a - b:

end proc:

>

p(1, 2);>

Displaying Procedure Definitions
Unlike simple Maple objects, you cannot display the value of a procedure
by entering its name.

geometric_mean;>

You must evaluate the name of the procedure using the print (or eval)
command.

print(geometric_mean);>

Displaying Maple Library Procedure Definitions
Maple procedure definitions are a valuable learning tool. To learn how to
program in Maple, it is recommended that you examine the procedures
available in the Maple library.

By default, the print command returns only the proc and end proc statements
and (if present) the description fields of a Maple procedure.
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print(assign);>

To display a Maple library procedure definition, first set the value of the
interface verboseproc option to 2. Then re-execute the print calling se-
quence.

interface('verboseproc' = 2):>
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Modules
Maple procedures associate a sequence of commands with a single command.
The module, a more complex programming structure, allows you to associate
related procedures and data.

A key feature of modules is that they export variables. This means that the
variables are available outside the module in which they are created. Most
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Maple packages are implemented as modules. The package commands are
exports of the module.

For more information on modules, refer to the ?module help page.

9.5  Programming in Documents
To write Maple code, you could simply open a Maple worksheet and start
typing. However, if you want to create a readable document with the code
interspersed or hidden, there are several options available.

Code Edit Region
The code edit region allows you to program in one contained region, in a
natural way. Features include the ability to press Enter for line breaking and
indentation preservation. Figure 9.1 shows the expanded code edit region.

To insert a new code edit region into your worksheet:

• From the Insert menu, select Code Edit Region.

Figure 9.1: Code Edit Region

To execute the code within this region, right-click in the region and select
Execute Code.

You can hide the code in a code edit region by minimizing the region. To
minimize, right-click in the region and select Collapse Code Edit Region.
When the region is minimized, an icon appears with the first line of the code
written next to it. It is recommended that you make the first line a comment
describing the program or programs contained in the region. See Figure 9.2.
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Figure 9.2: Collapsed Code Edit Region

To re-execute the code in the region while it is collapsed, click this icon.

For more information, refer to the ?CodeEditRegion help page.

Startup Code
Startup code allows you to define commands and procedures that are executed
each time the document is opened and after restart is called. This code is
completely hidden to others reading the document. For example, use this
region to define procedures that will be used throughout the document code
but that would take up space and distract readers from the message of the
document.

To enter startup code for a document:

1. From the Edit menu, select Startup Code. Alternatively, click the startup
code icon in the toolbar, .

2. Enter commands to be run each time the worksheet is opened or restart is
called.

3. Click Syntax to check the syntax of the entered code before closing.

4. Click Save to save the contents and close the dialog.
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Figure 9.3: Startup Code Editor

For more information, refer to the ?startupcode help page.

Document Blocks
Document blocks allow you to display the output from commands without
showing the commands used. You can intersperse text, 2-D math, and Maple
commands in a readable way. For more information, see Document
Blocks (page 58) in Chapter 1.
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10  Embedded Components
and Maplets
These graphical components help you to create documents to use and share
with colleagues or students, that interact with Maple code within the docu-
ment without needing the reader to understand that Maple code. Other
methods of interaction with Maple are described throughout this guide.

10.1  In This Chapter
TopicsSection

• Interacting with Components

• Printing and Exporting

Using Embedded Components - Basic interacting
with Maple documents containing embedded com-
ponents

• Inserting Components

• Editing Components

• Removing Components

• Integrating into a Document

Creating Embedded Components - Methods for
creating embedded components that work together
and with your document

• Maplet File

• Maple Document

Using Maplets - Methods for launching a Maplet

• Maplet Builder

• Maplets Package

• Saving

Authoring Maplets - Methods for authoring and
saving a Maplet

10.2  Using Embedded Components
Interacting
Embedded components allow readers to interact with Maple code through
graphical components, rather than commands. They can be used alone, as
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with a button that you click to execute code, or together, such as a drop-down
menu where you select an item, and a change takes place in a plot component.

Component Descriptions

Table 10.1: Embedded Component Descriptions

Inserted ImageComponent Name and Description

Button - Click to perform an action; that is, execute
code.

Check Box - Select or de-select. Change the caption,
and enter code to execute when the value changes.

Combo Box - Select one of the listed options from
the drop-down menu. Change the items listed, and
enter code to execute when the value changes.

Dial - Select or display an integer or floating-point
value. Change the display, and enter code to execute
when the value changes.

Label - Display a label. The value can be updated
based on code in the document or another embedded
component.

List Box - Display a list of items. Change the items
listed, and enter code to execute when an item is se-
lected.

Math Expression - Enter or display a mathematical
expression. The value can be updated based on code
in the document or another embedded component.

Meter - Select or display an integer or floating-point
value. Change the display, and enter code to execute
when the value changes.
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Inserted ImageComponent Name and Description

Plot - Display a 2-D or 3-D plot or animation. This
plot or animation can be interacted with in the same
way as other plots (see Plots and Anima-
tions (page 283)). The value can be updated based on
code in the document or another embedded compon-
ent. You can also enter code to be executed when
the execute code pointer is used to click or drag in
the plot region.

Radio Button - Use with other radio buttons to select
one in a group. Enter code to execute when the value
changes.

Rotary Gauge - Select or display an integer or
floating-point value. Change the display, and enter
code to execute when the value changes.

Slider - Select or display an integer or floating-point
value. Change the display, and enter code to execute
when the value changes.

Text Area - Enter or display plain text. The value
can be updated based on code in the document or
another embedded component, and you can enter
code to execute when the value changes.

Toggle Button - Select or display one of two options.
Change the images displayed, and enter to code to
execute when the value changes.
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Inserted ImageComponent Name and Description

Volume Gauge - Select or display an integer or
floating-point value. Change the display, and enter
code to execute when the value changes.

Example 1 - Using Embedded Components

This example demonstrates several components working together to perform
a task. The user inputs an expression, which is plotted when the button is
clicked. Plot options are controlled by text areas, a combo box, a math ex-
pression, and radio buttons.

For an interactive version of this example, see the .mw version of this
manual. In Maple, from the Help menu, select Manuals, Resources, and
More... → Manuals → User Manual.
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Printing and Exporting a Document with
Embedded Components
Printing: When printing a document, embedded components are rendered
as they appear on screen.

Exporting: Exporting a document with embedded components to other
formats produces the following results.

• HTML format - components are exported as .gif files.

• RTF format - components are rendered as bitmap images in the .rtf
document.

• LaTeX - components are exported as .eps files.

10.3  Creating Embedded
Components
Embedded Components are graphical components that you can add to your
document. They provide interactive access to Maple code without requiring
the user to know Maple commands, and include buttons, sliders, math and
text input areas, and plot display.

Inserting Components
The graphical interface components can be inserted by using the Components
palette (Figure 10.1) or by cutting/copying and pasting existing components
to another area of the document. Although copied components have most of
the same characteristics, they are distinct.

If the Components palette is not visible, see Palettes (page 25) for instruc-
tions on viewing palettes.
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Figure 10.1: Components Palette

Editing Component Properties: General Process
To edit properties of components embedded in the document:

1. Right-click (Control-click, for Macintosh) the component to display the
context menu.

2. If available, select Component Properties...; otherwise, select Compon-
ents → Component Properties.... The related dialog opens.

3. Enter values and contents in the fields as necessary.

4. For actions, such as Action When Value Changes in the Slider component
dialog, click Edit. A blank dialog opens allowing you to enter Maple code
that is executed when the event occurs. For details, refer to the ?Document-
Tools help page.
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Removing Graphical Interface Components
You can remove an embedded component by:

• Using the Delete key

• Using the Backspace key

• Placing the cursor at the component and selecting from the document
menu, Edit→Delete Element

Integrating Components into a Document
Use embedded components to display information from calculations, obtain
input from a reader, or perform calculations at the click of a button, all
without your readers having an understanding of Maple commands. They
can be entered in any part of a Maple document, including a document block
or table. For details on each component, see its help page.

This simple example inserts a slider with a label that indicates the current
value of the slider.

1. Place the cursor in the location where the embedded component is to be
inserted.

2. In the Components palette, click the Slider item. A slider is inserted into
the document.

3. In the Components palette, click the Label item. A label is inserted next
to the slider.

4. Right-click (Control-click, for Macintosh) the label component. Select
Component Properties. The Label Properties dialog opens. See Figure
10.2.
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Figure 10.3: Slider Properties DialogFigure 10.2: Label Properties Dialog

5. Name the component SliderLabel and click Ok.

6. Right-click (Control-click, Macintosh) the slider component. Select
Component Properties. The Slider Properties dialog opens. See Figure
10.3.

7. Name the component Slider1.

8. Enter the value at the lowest position as 0 and the highest as 100.

9. Enter major tick marks at 20 and minor tick marks at 10.

10. To define an action, click the Edit button for the Action When Value
Changes. The dialog that opens allows you to program the action of display-
ing the slider value in the label component. The dialog includes instructions
on how to program embedded components. The use...in/end use; statement
allows you to specify routines using the short form of accessing a package
command without invoking the package. For details on this command, refer
to the ?use help page.
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11. Before the end use; statement at the bottom of the dialog, enter the fol-
lowing command.

Do(%SliderLabel(caption)=%Slider1(value));

12. Click OK.

13. Make sure that the Update Continuously while Dragging check box is
selected.

The value from the slider as you move the arrow indicator populates the
Label caption field.

For details on this command, refer to the ?DocumentTools/Do help page.

Example 2 - Creating Embedded Components
In chapter 7 (see Embedded Components (page 389)), you created a document
that included embedded components, imported from a task template. Here,
we re-create that configuration of components. This example takes two
parameters, and as inputs, then plots the function and

calculates .

1. Create the components.

The table layout is best done after the components are finished, in case the
configuration of the components changes as you are working.

Create two DialComponents to set the parameters, one GaugeComponent
to display the slope result, one PlotComponent to display the plot, and one
MathContainerComponent to display the function. Note that you do not
need to use the dial and gauge components here, there are others, such as
the slider, that could also be used.
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Figure 10.4: The Inserted Components

2. Edit the display of the components.

Open the Component Properties dialog for the first DialComponent, and
notice that it already has a name. This name is used to reference the compon-
ent from other components, and is unique. Change the display of each of the
components as follows:

• Dial0: no changes.

• Dial1: change the Value at Highest Position to 10, the Spacing of
Major Tick Marks to 1, and the Spacing of Minor Tick Marks to 1.
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• RotaryGauge0: change the Value at Highest Position to 40, the Spacing
of Major Tick Marks to 5, and the Spacing of Minor Tick Marks to
1.

• Plot0: no changes.

• MathContainer0: change the Width in Pixels to 200, and the Height
in Pixels to 45.

Note the names of all of the components, and close each dialog before
moving on.

3. Create actions for the components.

Components can perform actions when their values are changed, so the code
to execute needs to be in the dials. That way, whenever one of them is
changed, the other components are updated to reflect that change.

The following Maple commands retrieve the values of the parameters and
display them in the other three components:
> parameter1:=Do(%Dial0):
> parameter2:=Do(%Dial1):
> Do(%RotaryGauge0=-parameter1/parameter2);
> Do(%Plot0=plot((parameter2*x+parameter1), x=-50..50, y=-
50..50));
> Do(%MathContainer0=(y=parameter2*x+parameter1));

4. Test the actions.

To test these commands, first load the DocumentTools package with the
following command.

> 

Execute the commands in the document, and verify that the components you
inserted are updated: the gauge should change to the computed value, a plot
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should appear in the plot component, and the function should display in the
math container.

5. Troubleshooting.

The first Do command gives an error, because the second parameter is 0.
One way to avoid this problem is to change the range of the second dial. In
the Component Properties dialog for the second DialComponent, change
the Value at Lowest Position from 0 to 1. Alternatively, you could change
the code to compensate, with an if statement.

6. Copy the actions to the components.

Once the commands work as expected, you can copy them into the compon-
ents.

• Open the Component Properties dialog for the first DialComponent
and click the Edit button for Action When Value Changes. Copy and
paste the commands into the space between the use statements.

Figure 10.5: DialComponent Action dialog

• Do the same for the second DialComponent.

7. Create the layout for the components.
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Create a table, and then cut and paste the components into it, along with ex-
planatory text. Important: you must cut, not copy, the components, or their
names will be changed to avoid duplication. For information on creating and
modifying tables, refer to Tables (page 362).

10.4  Using Maplets
A Maplet is a graphical user interface that provides interactive access to the
Maple engine through buttons, text regions, slider bars, and other visual in-
terfaces. You can create your own Maplets, and you can take advantage of
the built-in Maplets that cover numerous academic and specialized topics.
For information on some of the built-in Maplets, see Assistants (page 38),
Teaching and Learning with Maple (page 238), or Ordinary Differential
Equations (ODEs) (page 143).

Maplet applications are launched by executing Maplet code. Maplet code
can be saved in a Maplet (.maplet) file or Maple document (.mw).
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Maplet File
To launch a Maplet application saved as a Maplet file:

• In Windows, double-click the file from a Windows file browser.

• In UNIX and on Macintosh, use the command-line interface. At the
command-line, enter maple -q <maplet_filename>.

To view and edit the Maplet code contained within the .maplet file:

1. Start Maple.
2. From the File menu, select Open. Maple displays the Open dialog.
3. In the Files of Type drop-down list, select .maplet.
4. Navigate to the location of the .maplet file and select the file.
5. Click Open.

Maple Document
To launch a Maplet application for which the Maple code is contained in a
Maple document, you need to execute the Maplet code. To display the Maplet
application, you must use the Maplets[Display] command. Note: The Maplet
code may be quite large if the Maplet application is complex. In this case,
execute the document to ensure user-defined procedures that are referenced
in the Maplet application are also defined.

Typical procedure:

1. If present, evaluate user-defined procedures.

Myproc:=proc...

2. Load the Maplets[Elements] package.

with( Maplets[Elements] );

3. Evaluate the Maplet definition.
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Maplet_name:=Maplet( Maplet_definition );

4. Display the Maplet application.

Maplets[Display]( Maplet_name );

Important: When a Maplet application is running, you cannot interact with
the Maple document.

10.5  Authoring Maplets
To author Maplets, you can use the Maplet Builder (GUI-based) or the
Maplets package (syntax-based). The Maplet Builder allows you to drag
and drop buttons, sliders, text regions, and other elements to define the Maplet
application and set the element properties to perform an action upon selection
or update of the element. The Maplet Builder is designed to create simple
Maplets. The Maplets package offers more capabilities, control, and options
when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When
building a house, you first construct the skeletal structure (that is, foundation,
floors, and walls) and then proceed to add the windows and doors. Construct-
ing a Maplet is no different. First define the rows and columns of the Maplet
application and then proceed to add the body elements (such as buttons, text
fields, and plot regions).

Simple Maplet
A Maplet application can be defined using the commands in the
Maplets[Elements] package and then launched using the Maplets[Display]
command. The following commands define and run a very simple Maplet
application that contains the text string "Hello World".

with(Maplets[Elements]):>
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MySimpleMaplet:= Maplet([["Hello World"]]):>

Maplets[Display](MySimpleMaplet):>

Figure 10.6: A Simple Maplet

Maplet Builder
To start the Maplet Builder:

• From the Tools menu, select Assistants → Maplet Builder.

480   •   10  Embedded Components and Maplets



Figure 10.7: Maplet Builder Interface

The Maplet Builder is divided into four different panes.

• The Palette pane displays palettes, which contain Maplet elements, or-
ganized by category. For a description of the elements, see the
?MapletBuilder/Palette help page. The Body palette contains the most
popular elements.

• The Layout pane displays the visual elements of the Maplet.

• The Command pane displays the commands and corresponding actions
defined in the Maplet.

• The Properties pane displays the properties of an instance of a defined
element in the Maplet.
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Example 3 - Design a Maplet Using the Maplet Builder

In this example, shown in Figure 10.9, the Maplet user enters a function and
plots the result.

Figure 10.8: Image of the Maplet

Button element

Label element

Plot element

TextField element

Figure 10.9: Body Elements Used to Define This Maplet

482   •   10  Embedded Components and Maplets



Result in MapletBuilderAction

Define the number of rows in the
Maplet:
1. In the Properties pane:
a. In the drop-down list, select Box-
Column1.
b. Change the numrows field to 2.

Add a plot region to row 1:
2. From the Body palette, drag the
Plotter element to the first row in the
Layout pane.

Add columns to row 2:
3. In the Properties pane:
a. In the drop-down list, select
BoxRow2.
b. Change the numcolumns field to
3.
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Add a label to row 2:
4. From the Body palette, drag the
Label element to the left column in
the Layout pane.
5. In the Properties pane:
a. In the drop-down list, select La-
bel1.
b. Change the caption field to Enter
a function of x.

Add a text region to row 2:
6. From the Body palette, drag the
TextField element to the middle
column. The TextField element al-
lows the Maplet user to enter input
that can be retrieved in an action.
7. If necessary, resize the Maplet
Builder to display the entire Layout
pane.

Add a button to row 2:
8. From the Body palette, drag the
Button element to the right column
in the Layout pane.
9. In the Properties pane:
a. In the drop-down list, select But-
ton1.
b. Change the caption field to Plot.
c. In the onclick property drop-down
list, select <Evaluate>.
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10. In the Evaluate Expression dialog
that displays, the Target drop-down
list contains the defined elements to
which you can send information, in
this case, Plotter1 and TextField1.
The List group box, located below
the Expression group box, displays
the defined elements to which you
can retrieve information, in this case,
TextField1.
a. In the Target drop-down list, select
Plotter1.
b. In the Command Form tab, enter
plot(TextField1, x=-10..10) in the
Expression group box. (Note: Do not
include a semicolon (;) at the end of
the plot command.) You can also
double-click TextField1 in the List
group box to insert this element in the
command syntax.
c. Click Ok.

Run the Maplet:
11. From the File menu, select Run. You are prompted to save the Maplet. Maplets created
with the Maplet Builder are saved as .maplet files.
12. Click Yes and navigate to a location to save this Maplet.

For further information on the Maplet Builder, see the ?MapletBuilder
help page. For more examples of designing Maplets using the Maplet
Builder, see ?MapletBuilder/examples.

Maplets Package
When designing a complicated Maplet, the Maplets package offers greater
control. The Maplets[Elements] subpackage contains the elements available
when designing a Maplet application. After you define the Maplet, use the
Maplets[Display] command to launch the Maplet.

10.5  Authoring Maplets   •   485



For more information on the Maplets package, refer to the ?MapletsPackage
help page. For more examples of designing Maplets using the Maplets
package, see the ?Maplets/Roadmap help page.

Example 4 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package,
this example illustrates the equivalent syntax for the Design a Maplet Using
the Maplet Builder (page 482).

Load the Maplets[Elements] package.
with(Maplets[Elements]):>

Define the Maplet application. To suppress the display of the data structure
associated with the Maplet application, end the definition with a colon.
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PlottingMaplet:=Maplet(
BoxLayout(
BoxColumn(
# First Box Row

BoxRow(
# Define a Plot region

Plotter('reference' = Plotter1)
# End of first Box Row

),
# Second Box Row

BoxRow(
# Define a Label

Label("Enter a function of x "), 
# Define a Text Field

TextField('reference' = TextField1),
# Define a Button

Button(caption="Plot", Evaluate(value = 'plot(TextField1, 
x = -10..10)', 'target' = Plotter1))

# End of second Box Row 
)

# End of BoxColumn
)

# End of BoxLayout
)

# End of Maplet
):

>

Launch the Maplet.
Maplets[Display](PlottingMaplet); >
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For further examples using both the MapletBuilder and Maplets package
commands, see the Maplets example worksheets. For a listing, refer to the
?examples/index help page.

Saving
When saving a Maplet, you can save the document as an .mw file or you
can export the document as a .maplet file.

Maple Document

To save the Maplet code as an .mw file:

1. From the File menu, select Save. 

2. Navigate to the save location. 

3. Enter a filename.

4. Click Save.

If the document contains only Maplet code, it is recommended that you export
the document as a .maplet file.

Maplet File

To export the Maplet code as a .maplet file:

1. From the File menu, select Export As.

2. In the Files of Type drop-down list, select Maplet. 

3. Navigate to the export location.

4. Enter the filename.

5. Click Save.
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11  Input, Output, and
Interacting with Other Products
11.1  In This Chapter

TopicsSection

• Saving Data to a File

• Saving Expressions to a File

Writing to Files - Saving to Maple file
formats

• Reading Data from a File

• Reading Expressions from a File

Reading from Files - Opening Maple files

• Exporting Documents

• MapleNet

• Maple T.A.

Exporting to Other Formats - Exporting
documents in file formats supported by
other software

• Translating Maple Code to Other Program-
ming Languages

• Accessing External Products from Maple

• Accessing Maple from External Products

Connectivity - Using Maple with other
programming languages and software

11.2  Writing to Files
Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a
file for later processing with Maple or another program.

Saving Data to a File
If the result of a Maple calculation is a long list or a large array of numbers,
you can convert it to Matrix form and write the numbers to a file using the
ExportMatrix command. This command writes columns of numerical data
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to a file, allowing you to import the numbers into another program. To convert
a list or a list of lists to a Matrix, use the Matrix constructor. For more in-
formation, refer to the ?Matrix help page.

> 

> 

If the data is a Vector or any object that can be converted to type Vector, use
the ExportVector command. To convert lists to Vectors, use the Vector
constructor. For more information, refer to the ?Vector help page.

> 

(11.1)

> 

(11.2)

> 

You can extend these routines to write more complicated data, such as
complex numbers or symbolic expressions. For more information, refer to
the ?ExportMatrix and ?ExportVector help pages.

490   •   11  Input, Output, and Interacting with Other Products



For more information on matrices and vectors, see Linear Algebra (page 189).

Saving Expressions to a File
If you construct a complicated expression or procedure, you can save them
for future use in Maple. If you save the expression or procedure in the Maple
internal format, Maple can retrieve it more efficiently than from a document.
Use the save command to write the expression to a .m file. For more inform-
ation on Maple internal file formats, refer to the ?file help page.

> 

In this example, small expressions are used. In practice, Maple supports ex-
pressions with thousands of terms.

> 

(11.3)

> 

(11.4)

You can save these expressions to the file qbinom.m.

> 

Clear the memory using the restart command and retrieve the expressions
using the read command.
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> 

> 

> 

(11.5)

For more information on writing to files, refer to the ?save help page.

11.3  Reading from Files
The most common reason for reading files is to load data, for example, data
generated in an experiment. You can store data in a text file, and then read
it into Maple.

Reading Data from a File

Import Data Assistant

If you generate data outside Maple, you can read it into Maple for further
manipulation. This data can be an image, a sound file, or columns of numbers
in a text file. You can easily import this external data into Maple using the
Import Data Assistant, where the supported file formats include files of
type Excel, Matlab (R), Image, Audio, Matrix Market, and Delimited.

To launch the Import Data Assistant:

• From the Tools menu, select Assistants, and then Import Data.

• A dialog window appears where you can navigate to your data file. Select
the file that you want to import data from, and then select the file type
before clicking Next.
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• From the main window, you can preview the selected file and choose
from the applicable options based on the format of the file read in before
importing the data into Maple. See Figure 10.1 for an example.

Figure 10.1: Import Data Assistant

ImportMatrix Command

The Import Data Assistant provides a graphical interface to the Import-
Matrix command. For more information, including options not available in
the assistant, refer to the ?ImportMatrix help page.

Reading Expressions from a File
You can write Maple programs in a text file using a text editor, and then
import the file into Maple. You can paste the commands from the text file
into your document or you can use the read command.

When you read a file with the read command, Maple treats each line in the
file as a command. Maple executes the commands and displays the results
in your document but it does not, by default, insert the commands from the
file in your document.

11.3  Reading from Files   •   493



For example, the file ks.txt contains the following Maple commands.

S:= n -> sum( binomial( n, beta ) * ( ( 2*beta )! / 2^beta - beta!*beta ),
beta=1..n );

S(19);

When you read the file, Maple displays the results but not the commands.

> 

> 

(11.6)

If you set the interface echo option to 2, Maple inserts the commands from
the file into your document.

> 

> S:=n->sum(binomial(n, beta)*((2*beta)!/2^beta-
beta!*beta), beta=1..n);

> S(19);ÿ

(11.7)ÿ
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For more information, refer to the ?read and ?interface help pages.

11.4  Exporting to Other Formats
Exporting Documents
You can save your documents by selecting Save or Save As from the File
menu. By selecting Export As from the File menu, you can also export a
document in the following formats: HTML, LaTeX, Maple input, Maplet
application, Maple text, plain text, PDF, and Rich Text Format. This allows
you to access your work outside Maple.

HTML

The .html file that Maple generates can be loaded into any HTML browser.
Exported mathematical content can be displayed in one of the following
formats: GIF, MathML 2.0 Presentation, MathML 2.0 Content, or Maple
Viewer, and is saved in a separate folder. MathML is the Internet standard,
sanctioned by the World Wide Web Consortium (W3C), for the communic-
ation of structured mathematical formulae between applications. For more
information about MathML, refer to the ?MathML help page.

Maple documents that are exported to HTML translate into multiple docu-
ments when using frames. If the frames feature is not selected, Maple creates
only one page that contains the document contents.

LaTeX

The .tex file generated by Maple is ready for processing by LaTeX. All dis-
tributions of Maple include the necessary style files. By default, the LaTeX
style files are set for printing the .tex file using the dvips printer driver. You
can change this behavior by specifying an option to the \usepackage LaTeX
command in the preamble of your .tex file. For more information, refer to
the ?exporttoLaTeX help page.
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Maple Input

You can export a Maple document as Maple input so that it can be loaded
using the Maple Command-line version.

Important: When exporting a document as Maple input for use in Command-
line Maple, your document must contain explicit semicolons in 1-D Math
input. If not, the exported .mpl file does not contain semicolons, and Com-
mand-line Maple generates errors.

Maplet Application

The Export as Maplet facility saves a Maple document as a .maplet file,
so that you can run it using the command-line interface or the
MapletViewer. The MapletViewer is an executable program that can launch
saved Maplet applications. It displays and runs Maplet applications independ-
ently of the Maple Worksheet interface.

Important: When exporting a document as a Maplet Application for use in
Command-line Maple or the MapletViewer, your document must contain
explicit semicolons. If not, the exported .maplet file does not contain semi-
colons, and Command-line Maple and the MapletViewer generates errors.

Maple Text

Maple text is marked text that retains the distinction between text, Maple
input, and Maple output. Thus, you can export a document as Maple text,
send the text file by email, and the recipient can import the Maple text into
a Maple session and regenerate the computations in the original document.

PDF

Export a Maple document to a Portable Document Format (PDF) file so that
you can open the file in a reader such as Adobe® Acrobat®. The PDF docu-
ment is formatted as it would appear when the Maple worksheet is printed
using the active printer settings.

Note: Images, plots, and embedded components may be resized in the PDF
file.
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Plain Text

Export a Maple document as plain text so that you can open the text file in
a word processor.

Rich Text Format (RTF)

Export a Maple document to a rich text format file so that you can open and
edit the file in a word processor.

Note: The generated .rtf format is compatible with Microsoft® Word and
Microsoft® WordPad only.

Summary of Translation

Table 10.1: Summary of Content Translation When Exporting to Different
Formats

Rich
Text
Format

Plain
Text

Maple
Text

Maplet
Applica-
tion

Maple
Input

LaTeXHTMLContent

Main-
tained

Main-
tained

Preceded
by #

Preceded
by #

Preceded
by #

MaintainedMaintainedText

Static im-
age

Preceded
by >

Preceded
by >

Main-
tained

Main-
tained

MaintainedMaintained1-D Math

Static im-
age

1-D
Math or
charac-
ter-based
typeset-
ting

1-D
Math or
charac-
ter-based
typeset-
ting

1-D
Math (if
possible)

1-D
Math (if
possible)

1-D Math
or LaTeX
2e

GIF or Math-
ML

2-D Math

Static im-
age

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Postscript
file

GIFPlot

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

Animated
GIF

Animation
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Rich
Text
Format

Plain
Text

Maple
Text

Maplet
Applica-
tion

Maple
Input

LaTeXHTMLContent

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

Not exportedHidden
content

RTF
page
break ob-
ject

Not sup-
ported

Not sup-
ported

Not sup-
ported

Not sup-
ported

Not suppor-
ted

Not suppor-
ted

Manually
inserted
page break

Plain textPlain textPlain textPlain
text

Plain
text

Plain textLinks to help
pages be-
come plain
text. Links to
documents
are renamed
and conver-
ted to
HTML links

Hyperlink

Static im-
age

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

GIFEmbedded
image or
sketch out-
put

RTF
table

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

LaTeX
tables

HTML tableSpread-
sheet

RTF
style

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

LaTeX en-
vironments
and sec-
tions,
LaTeX 2e
macro calls

Approxim-
ated by
HTML style
attributes

Document
style

MapleNet

Overview of MapleNet

Using MapleNet, you can deploy Maple content on the web. Powered by the
Maple computation engine, MapleNet allows you to embed dynamic formulas,
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models, and diagrams as live content in web pages. The MapleNet software
is not included with the Maple software. For more information on MapleNet,
visit http://www.maplesoft.com/maplenet.

MapleNet Documents and Maplets

After you upload your Maple document to the MapleNet server, it can be
accessed by anyone in the world using a Web browser. Even if viewers do
not have a copy of Maple installed, they can view documents and Maplets,
manipulate 3-D plots, and execute code at the click of a button.

Custom Java Applets and JavaServer PagesTM Technology

MapleNet provides a programming interface to the Maple math engine so
commands can be executed from a Java applet or using JavaServer PagesTM

technology. Embed MapleNet into your web application, and let Maple
handle the math and visualization.

Maple T.A.

Overview of Maple T.A.

Maple T.A. is a web-based automated testing system, based on the Maple
engine. Instructors can use pre-written questions or create custom question
banks and then choose from these questions to form quizzes and assignments.
Maple T.A. automatically grades responses as students complete assignments
and tests. For more information, visit http://www.maplesoft.com/mapleta.

Exporting Assignments to Maple T.A.

You can use Maple to create graded questions for use in Maple T.A. For in-
formation on creating and testing questions, see Creating Graded Assign-
ments (page 396). Using the Maple T.A. export feature, you can create and
test Maple T.A. content.

To export the document:

1. From the File menu, select Export As.
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2. In the Export As dialog, specify a filename and the Maple T.A. (.zip)
file type. The .zip file containing your questions and assignment can be up-
loaded to Maple T.A. as a course module.

Any document content outside Maple T.A. sections (indicated by green
section markers) is ignored by the export process.

For more details, refer to the ?exporttoMapleTA help page.

11.5  Connectivity
Translating Maple Code To Other Programming
Languages

Code Generation

The CodeGeneration package is a collection of commands and subpackages
that enable the translation of Maple code to other programming languages.
Languages currently supported include C, Fortran 77, Java, MATLAB, and
Visual Basic.

For details on Code Generation, refer to the ?CodeGeneration help page.

Accessing External Products from Maple

External Calling

External calling allows you to use compiled C, Fortran 77, or Java code in
Maple. Functions written in these languages can be linked and used as if
they were Maple procedures. With external calling you can use pre-written
optimized algorithms without the need to translate them into Maple com-
mands. Access to the NAG library routines and other numerical algorithms
is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical al-
gorithms. Routines exist that accomplish a variety of non-mathematical tasks.
You can use these routines in Maple to extend its functionality. For example,
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you can link to controlled hardware via a serial port or interface with another
program. The Database package uses external calling to allow you to query,
create, and update databases in Maple. For more information, refer to the
?Database help page.

For more information on using external calling, refer to the ?ExternalCalling
help page.

Mathematica Translator

The MmaTranslator package provides translation tools for converting
Mathematica® expressions, command operations, and notebooks to Maple.
The package can translate Mathematica input to Maple input and Mathematica
notebooks to Maple documents. The Mma subpackage contains commands
that provide translation for Mathematica commands when no equivalent
Maple command exists. In most cases, the command achieves the translation
through minor manipulations of the input and output of similar Maple com-
mands.

Note: The MmaTranslator package does not convert Mathematica programs.

There is a Maplet interface to the MmaTranslator package. For more in-
formation, refer to the ?MmaToMaple help page.

Matlab Package

The Matlab package enables you to translate MATLAB code to Maple, as
well as call selected MATLAB functions from a Maple session, provided
you have MATLAB installed on your system.

For more information, refer to the ?Matlab help page.

Accessing Maple from External Products

Microsoft Excel Add-In

Maple is available as an add-in to Microsoft Excel 2000, Excel 2003, Excel
XP, and Excel 2007 for Windows, and provides the following features.
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• Access to Maple commands from Excel

• Ability to copy and paste between Maple and Excel

• Access to a subset of the Maple help pages

• Maple Function Wizard to step you through the creation of a Maple
function call

To enable the Maple Excel Add-in in Excel 2000, Excel 2003, or Excel
XP:

1. From the Tools menu, choose Add-Ins.
2. If the Maple Excel Add-in is not listed:

• Click Browse and navigate to the directory in which Maple is installed.

• In the Excel directory, select the WMIMPLEX.xla file.

• Click OK.

3. Select the Maple Excel Add-in check box.
4. Click OK.

To enable the Maple Excel Add-in in Excel 2007:

1. Click the Microsoft Office Button and select Excel Options.

2. Click Add-ins.

3. In the Manage box select Excel Add-ins, and then Go.

4. Navigate to the Excel subdirectory of your Maple installation, select
WMIMPLEX.xla, and click OK.

5. Select the Maple Excel Add-in check box.

6. Click OK.

More information is available in the Using Maple in Excel online help file
within Excel.
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To view this help file:

1. Enable the add-in.
2. From the View menu, select Toolbars, and then Maple.
3. On the Maple toolbar, click the Maple help icon .

OpenMaple

OpenMaple is a suite of functions that allows you to access Maple algorithms
and data structures in your compiled C, Java, or Visual Basic programs. (This
is the reverse of external calling, which allows access to compiled C, Fortran
77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your
application to any licensed Maple user. For additional terms and conditions
on the use of OpenMaple, refer to the extern/OpenMapleLicensing.txt file
in your Maple installation.

For more details on using OpenMaple functions, refer to the ?OpenMaple
help page.

MapleSim

MapleSimTM is a complete environment for modeling and simulating multi-
domain engineering systems. During a simulation, MapleSim uses the sym-
bolic Maple computation engine to generate the mathematical models that
represent the system behavior.

Because both products are tightly integrated, you can use Maple commands
and technical document features to edit, manipulate, and analyze a MapleSim
model. For example, you can use Maple commands and tools to manipulate
your model equations, develop custom components based on a mathematical
model, and visualize simulation results.

MapleSim software is not included with the Maple software. For more in-
formation on MapleSim, visit http://www.maplesoft.com/maplesim.
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Index
Symbols
! toolbar icon, 78
!!! toolbar icon, 79
"", 412
%H, 203
%T, 203
&x, 203
', 113, 435
(), 457
->, 112
., 201
1-D Math, 94

switching to 2-D, 94
2-D Math, 93

converting to 1-D, 95
entering, 6
shortcuts, 7
switching to 1-D, 94

:, 94–95
::, 172
:=, 111
;, 94–95
<>, 189, 192
<default>, 96, 435
>, 93
?

help topic, 66
[], 199, 400, 402
^, 6, 130

entering, 130
_, 113

entering, 113

_EnvAllSolutions environment vari-
able, 136
_ZN~, 137
`, 114
{}, 401
|, 192
~, 137, 172

A
about command, 172
abs command, 127
absolute value, 127
add

word to your dictionary, 395
add command, 453
additionally command, 173
algebra, 178

linear, 189
polynomial, 178

algsubs command, 428
alignment format, 340
American spelling

spellcheck, 392
and operator, 441
angle brackets, 189, 192, 246
angles, 423
animations

creating, 322
customizing, 327

Application Center, 69
Applications

Units Calculator, 153
apply

character styles, 342
paragraph styles, 345

approximation, 122
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least-squares, 206
numeric, 428

arguments, 458
arithmetic, 78

finite-precision, 121
interval, 166
matrix and vector, 200
modular, 127, 129
polynomial, 179

Arrays, 403
indexing, 404
large, 405

arrow operator, 112
assign command, 141
assigned command, 435
assignment operator (:=), 111
Assistants

Back-Solver, 42
Curve Fitting, 42, 188
Data Analysis, 43, 231
Import Data, 43, 492
Installer Builder, 43
Library Browser, 43
Maplet Builder, 43
ODE Analyzer, 43, 143
Optimization, 43, 225
overview, 38
Plot Builder, 43, 285
Scientific Constants , 43
Special Functions, 43
Tools menu, 38
Unit Converter, 423
Units Calculator, 44

assume command, 171
adding assumptions, 173
and procedure variables, 176

imposing multiple assumptions,
173
removing assumptions, 174
setting relationships between vari-
ables, 172
setting variable properties, 172
testing property, 173
using with assuming command,
175
viewing assumptions, 172

assuming command, 172, 174, 220, 
422

additionally option, 175
and procedure variables, 176
applying to all names, 175
using with assume command, 175

Attributes submenu
character, 338
paragraph, 340

auto-execute, 360
repeating, 361
security levels, 361

Avogadro constant, 161

B
Back-Solver Assistant, 42
bar chart, 235
basis, 206

vector space, 205
binary numbers, 128
Bohr radius, 161
bold format, 337
bookmarks

using, 387
boolean expressions, 430, 441, 449
brackets
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angle, 189, 192
break statement, 451
browser

Matrix, 194, 405
Task, 108

bullets
format, 340

button
embedding, 389

Button component, 466
by clause, 445

excluding, 445
negative, 446

C
calculus, 208

multivariate, 223
Student package, 224

of variations, 224
packages, 223
study guides, 239
teaching, 224, 239
vector, 223

Student package, 224
canvas

inserting, 377
canvas style

sketch pad, 379
caret

entering, 130
central tendency, 166
character styles

creating, 343
description, 341

Check Box component, 466
Cholesky decomposition, 204

Classic Worksheet
tables, 373

Classic Worksheet Interface, xiii
Code Edit Region, 462
CodeGeneration

package description, 101
coeff command, 186
coefficients

polynomials, 185
coeffs command, 186
collect command, 185
colon, 94–95
color

of plots, 318
combine command, 421

errors option, 169
Combo Box component, 466
command completion, 8, 55
Command-line Interface, xiii
commands, 96

and task templates, 108
displaying procedures, 459
entering, 52
help, 62
hiding, 462–463
iterative, 451
mapping over set or list, 455
package, 99
top, 98
top-level, 96

compatibility
worksheet, 397

complex expressions, 429
compoly command, 187
components

adding GUI elements, 389
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palette, 389
computations

assistants, 107
commands, 96
context menus, 105
errors, 124

avoiding, 125
integers, 125
interrupting, 451
linear algebra, 200
mathematics, 177
numeric, 120
palettes, 103
performing, 119, 177
Real number system, 170
symbolic, 120
syntax-free, 79
task templates, 108
tutors, 107
under assumptions, 171

single evaluation, 174
updating, 78
with uncertainty, 169
with units, 157

conditional execution, 440
constants, 74
content command, 187
context

of unit, 153
context menus, 80, 105, 203

customizing animations, 327
equation, 132
integer, 105, 125
overview, 46
tutors, 87
using, 46

convert command, 423
base option, 129, 450
degrees option, 423
mathematical functions, 423
polynom option, 218
set option, 423
temperature option, 155
units option, 154, 423

copy, 336
examples, 66

copy expressions, 15
correlation, 168
coulditbe command, 174
covariance, 168
cross product, 203
Curl command, 223
Curve Fitting

Assistant, 188
package

PolynomialInterpolation com-
mand, 188

Curve Fitting Assistant, 42
cut and paste

in tables, 365

D
D operator, 214
Data Analysis Assistant, 43, 231
data structures, 74, 399

creating, 399
Database Integration, 501
datatype option, 196
degree

command, 186
polynomials, 185

denom command, 417
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derivatives, 211
directional, 215
partial, 212
Tutor, 240

Dial component, 466
dictionary, 67, 238
dictionary topic

adding hyperlink to, 385
diff command, 144, 212
differential equations

ordinary, 143
partial, 147

differentiation, 211
with uncertainty, 169
with units, 158

Differentiation Methods Tutor, 241
Digits environment variable, 124
dimension, 151, 204

base, 151
Directional Derivative Tutor, 215
discrim command, 187
display

bookmark, 387
distribution

probability, 232
divide command, 180
divisors, 127
document blocks, 58, 354
Document mode, 71
documents

running, 11
DocumentTools, 475
double colon operator, 172
dsolve command, 147

E
e-notation, 122
Edit menu

in help system, 66
eigenvalues, 204
eigenvectors, 204
element-wise operators, 431
elementary charge, 161
elements, 160

definition, 162
isotopes, 162

definition, 162
properties, 162

list, 162
properties

list, 162
uncertainty, 165
units, 164
using, 161
value, 164
value and units, 165

elif clauses, 442
order, 443

else clause, 442
email

adding hyperlink to, 384
embedded components, 389, 465

inserting, 469
properties, 470

end do keywords, 444, 447–448
end if keywords, 440
end proc keywords, 457
environment variables

_EnvAllSolutions, 136
Digits, 124
Order, 218
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equation labels, 114
displaying, 115
features, 118
formatting, 57
inserting, 57
numbering schemes, 117
overview, 56
references to, 115
versus names, 118
with multiple outputs, 116

equations
solving, 132

for real solutions, 170
numerically, 138
symbolically, 134
transcendental, 136

errors
quantities with, 166

Euclidean algorithm, 187
eval command, 426, 459
evalb command, 430
evalc command, 429
evalf command, 123, 137, 164, 167, 
428

with Int command, 222
with Limit command, 210

evaln command, 435
evaluation

boolean expressions, 430
complex expressions, 429
delaying, 435
levels of, 433
Maple expressions, 426
of expression at a point, 426
output below, 77, 81
output inline, 77, 81

updated computations, 78
exact

computation, 121
numbers, 120
quantities

converting to floating-point, 123
example worksheets

copy, 66
execution group, 94
execution groups, 22
expand

command, 421
document block, 358
execution group, 358
series, 217

Exploration assistant, 50
exponents

entering, 6
export, 461

to HTML, 495
to LaTeX, 495
to Maple input, 496
to Maple T.A., 499
to Maple text, 496
to Maplet application, 496
to other formats, 495
to PDF, 496
to plain text, 497
to Rich Text Format, 497
worksheets, 495

exporting
embedded components, 469

expression sequences, 134, 400
creating, 452

expressions, 74, 399
adding, 453
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evaluating, 426
manipulating, 419
multiplying, 453
right-click, 47
versus functional operators, 408

F
factor

integers, 125
polynomials, 187
QR factorization, 206

factor command, 187, 420
factored normal form, 424
factorial command, 127
FAIL, 441, 449
false, 441, 449
Faraday constant, 161
Favorites palette, 26
files

image formats, 381
reading from, 492
writing to, 489

fill option, 196
finite fields, 129

solving equations, 149
finite rings, 129
floating-point

computation, 122
accuracy, 124
hardware, 124
significant digits, 123

numbers, 121
rational approximation, 106

Flux command, 223
font color, 337

foot-pound-second (FPS) system, 86, 
153
footers, 351
for/from loops, 444
for/in loops, 447
formal power series solutions, 147
format labels, 57
Format menu

bookmarks, 388
quick formatting, 337

frac command, 174
fractions

approximating, 82
entering, 6

frequency plot, 235
Frobenius form

matrix, 206
from clause, 445

excluding, 445
fsolve command, 138
full evaluation, 433, 436
FunctionAdvisor command, 97
functional operators, 407

differentiating, 214
plotting, 410
versus expressions, 408

functions
converting between, 423
defining as functional operators,
407

G
Gaussian elimination, 206
Gaussian integers, 131
GaussInt package, 131
gcd command, 187

Index   •   511



gcdex command, 187
Global Optimization Toolbox, 225
global variables, 458
glossiness

of 3-D plots, 318
go to

bookmark, 389
gradient, 242
Gradient Tutor, 242
Graphing Calculator, xiv
greatest common divisor, 127, 187

H
Handwriting palette, 32
has command, 415
hastype command, 414
HazardRate command, 234
headers, 351
Help Navigator

Using, 63
help page

adding hyperlink to, 385
help system

accessing, 62
description, 66
Edit menu, 66
Help Navigator, 62
manuals, 64
search, 64
table of contents, 63–64
tasks, 64
topic search, 64
tutorials, 64
View menu, 65

Hermitian transpose
matrix and vector, 203

Hessenberg form, 206
hexadecimal numbers, 129
hide

worksheet content, 352
highlight color, 337
Hilbert Matrix, 206
histogram, 235
hyperlinks

in worksheet, 382

I
i

entering, 131
icons

open as example worksheet, 65
if statement, 440
ifactor command, 125, 127, 421
igcd command, 127
images

adding hyperlink to, 383
file format, 381
inserting, 381

imaginary unit
entering, 131

implied multiplication, 7
implies operator, 441
Import Data Assistant, 43, 492
indent

format, 340
indeterminates, 418
indets command, 418
indices, 96, 199
inequations

solving, 132
for real solutions, 170
symbolically, 134
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infinite loops, 451
infolevel command, 148
input

1-D Math, 94
2-D Math, 93
prompt, 93
separating, 95
setting default mode, 95

insert
bookmark, 387
hyperlink, 383
images, 381
section, 350
sketch pad, 377
table, 362

Installer Builder Assistant, 43
instructor resources, 238
Int command, 222
int command, 221
integers

commands, 127
computations, 125
context menu, 105
factoring, 125
Gaussian, 131
modulo m, 129
solving equations, 149
solving modular equations, 149

integration, 80, 103, 219
definite, 220
functional operators, 411
indefinite, 219
iterated, 221
line, 221, 244
numeric, 222
surface, 221

with units, 158
interactive commands

Student, 45
Interactive Linear System Solving
tutor, 87
Interactive Plot Builder Assistant

creating animations, 322
creating plots, 285
customizing animations, 327
customizing plots, 315

interface command
rtablesize option, 195
verboseproc option, 460

international system (SI), 153
InterquartileRange command, 233
interval arithmetic, 166
iquo command, 127
iroot command, 127
is command, 173
isprime command, 127
isqrt command, 127
italic format, 337

J
j

entering, 131
Jordan form, 204

K
keyboard keys

Command Completion, xv
Context Menu, xiv

keystrokes, 7

L
Label component, 466
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labels, 114
last name evaluation, 435
lcm command, 188
lcoeff command, 186
ldegree command, 186
least-squares, 206
left single quotes, 114
left-hand side, 416
levels of evaluation, 433
lexicographic order, 183
lhs command, 416
Library Browser

description, 43
Limit command, 210
limit command, 209
limits, 209

multidimensional, 210
line break, 340
line integrals, 244
linear algebra, 189

computations, 200
efficiency, 195, 207
LinearAlgebra package, 205
teaching, 208, 239

Linear System Solving tutor, 87
linear systems

solving, 149, 206
interactive, 87

LinearAlgebra
package description, 101

LinearAlgebra package, 203
commands, 205
numeric computations, 207

LinearSolve command, 149
List Box component, 466
lists, 200, 402

returning solutions as, 135
local variables, 458
logical operators, 441
loops, 444

general, 450
infinite, 451

M
Macintosh

command complete, 8
context menus, 46

map command, 455
Maple Application Center, 238
Maple library, 52
Maple Student Help Center, 239
MaplePrimes, 70
Maplet Builder

description, 43
launching, 480
Maplet authoring, 480

Maplets
adding hyperlink to, 386
authoring, 479

Maplet Builder, 480
Maplets package, 485

launching
Maple worksheet, 478
Maplet file type, 478

Maplets package
Display command, 485
Elements subpackage, 485
Maplet authoring, 485

saving
Maple worksheet, 488
maplet file, 488

using, 477
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markers
bookmarks, 387
displaying, 58
for document blocks, 355

math dictionary
description, 67

Math Expression component, 466
Math mode, 23

shortcuts, 7
mathematical functions

list, 97
mathematics

computations, 177
teaching and learning, 238

matrices, 406
arithmetic, 200
context menus, 203
data type, 195, 197
defining, 189
efficiency, 195
filling, 197
Hermitian transpose, 203
image, 195
large, 194
multiplication, 201
operations, 203
random, 196
scalar multiplication, 202
selecting submatrices, 199
shape, 195, 197
transpose, 203
type, 195

Matrix
Browser, 193–194, 405
constructor, 197
data structure, 189

palette, 149, 189, 195
Matrix command, 189
max command, 127
maximize, 225
maximum, 127
Mean command, 233
Meter component, 466
min command, 127
minimize, 225
minimum, 127
mod command, 127
mod operator, 129
modes

Document, 71
Worksheet, 71

modify
table, 364

modp command, 129
mods command, 129
modular arithmetic, 127, 129
modules, 461
MPS(X) files, 230
msolve command, 149
mul command, 453
multiplication

implied, 7

N
names, 74, 110

adding assumptions, 172
and symbols, 33
assigned, 435
assigning values to, 111
logical, 441
previously assigned, 435
protected, 112
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removing assumptions, 174
reserved, 112
unassigning, 113, 174, 437
valid, 113
versus equation labels, 118
with assumptions, 172

nops command, 418
norm command, 188, 204
normal command, 424
normal form, 424
not operator, 441
numbers, 74

exact, 120
floating-point, 121
non-base 10, 128

numer command, 417
numeric

approximation, 428
computation, 121

numtheory[divisors] command, 127

O
ODE Analyzer Assistant, 43, 143
operands, 418

selecting, 453
operators, 74

functional, 407
logical, 441
relational, 441

Optimization
Assistant image, 38
package description, 101

optimization, 225
efficiency, 228
plotting, 227
point-and-click interface, 225

Optimization Assistant, 43, 225
Plotter, 227

Options dialog, 25
or operator, 441
Order environment variable, 218
ordinary differential equations

plotting solution, 146
solving, 143

orthogonal matrix, 206
output

suppressing, 94

P
packages, 96

accessing commands, 53
definition, 52, 66
help, 62
loading, 99
top, 101
unloading, 100, 113
warnings, 100

page break, 340
page headers and footers, 351
palettes, 75, 79, 103, 427

categories, 27
Components, 469
favorites, 26
managing, 29
Matrix, 189, 195
overview, 25
symbol recognition, 32
Units, 86, 155

paragraph styles
creating, 347
description, 341

parameters, 458
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parametric solutions, 138
partial differential equations

solving, 147
paste, 336

examples, 66
PDEs, 147
pdsolve command, 147
pencil

sketch pad, 378
Physics

package description, 101
pie chart, 235
piecewise command, 233
Planck constant, 161
Plot Builder

description, 43
plot command, 218
Plot component, 467
plot3d command, 410
plots

analyzing, 321
pan, 321
point probe, 321
rotate, 321
scale, 321

code for color plates, 331
creating, 284

context menu, 294
displaying multiple plots, 312
insert plot, 298
Interactive Plot Builder, 285
plot command, 299
plot3d command, 299
plots package, 307

creating animations
animate command, 323

Interactive Plot Builder, 322
plot3d[viewpoint] command,
325

customizing, 314
context menu, 315
Interactive Plot Builder, 315
plot options, 318
plot3d options, 318

customizing animations, 327
command-line options, 328
context menu, 327
Interactive Plot Builder, 327

exporting, 329
functional operators, 410
gradient, 243
line integral, 244
ODEs

numeric solution, 145
symbolic solution, 146

optimization problem, 227
playing animations, 326
plots package

animate command, 323
contourplot command, 311
display command, 313
matrixplot command, 309
pointplot command, 308

series, 218
statistics, 235
viewing animations

animate context bar, 326
point-and-click, 37
polynomial equations

solving, 137
numerically, 138

polynomials
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algebra, 178
arithmetic, 179
coefficients, 185
collecting terms, 185
degree, 185
division, 179–180
efficient arithmetic, 188
expanding, 180
factoring, 187
implied multiplication, 181
numeric

algebraic manipulation, 188
operations, 187
sorting, 181

pure lexicographic, 183
total degree, 182

PolynomialTools package, 188
IsSelfReciprocal command, 188

powers
entering, 6

precalculus
teaching, 239

precision, 123
prem command, 188
previously assigned, 435
primality testing, 127
primpart command, 188
print
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